Стартовая страница

Полезные советы для Windows 7 от Nizaury v.2.08.

Полезные советы для Windows 7 - это сборник советов, в котором содержится полезная информация для простого решения ошибок и вопросов, возникающих при работе с Windows 7. Основная цель сборника: Помочь большему количеству пользователей перейти к работе с Windows 7 и уверенно ориентироваться в её среде.

Постоянная ссылка, на обновляющиеся версии сборников. Используйте её для скачивания новых версий.
Альтернативная постоянная ссылка (используйте, если у вас не скачивается по предыдущей).
Информацию о ссылках Вы также можете найти на оффициальном блоге(сайте) сборника.

Инструкция использования данного справочника

Общий список советов

Перейти к разделу:

Установка

Настройки

Администрирование

Интерфейс

Сети (Интернет и Локальная)

Тонкие настройки

Виртуализация

Твики Реестра

Устранение неполадок

Разное

История версий

Оффициальный блог(сайт) сборника: http://nizaury.blogspot.com
Гостевая книга на сайте: http://nizaury.blogspot.com/2009/12/blog-post_07.html

E-mail автора сборника: psdw7@delfi.lv


Инструкция использования данного справочника

1) Для полноценной работы со сборником, рекомендуется развернуть его на полный экран.

2) При нажатии на наименование совета в общем списке, вы перейдете на отдельную страницу данного совета.

3) При нажатии на наименование совета в содержании, вы перейдете на отдельную страницу данного совета.

4) При нажатии на наименование раздела в содержании, вы перейдете на отдельную страницу данного раздела.

5) При нажатии на миниобраз изображения, он увеличится.

6) При нажатии на значок [image], а также при нажатии на увеличенное изображение или вне его, оно закроется.

7) Если в совете несколько изображений, вы можете переключиться на следующее нажав на [image] или [image], находящиеся слева или справа на изображении.

8) При нажатии на кнопку "Показать" текст совета откроется на текущей странице.

Пример

Назад на главную.


Главная страница

Полезные советы для Windows 7 от Nizaury v.2.08.

Установка

1. Как добавить новое устройство(драйвер) вручную?

1) Нажимаем Windows + R
2) В открывшемся окне набираем hdwwiz, жмём OK
3) В открывшемся окне, жмем Далее(Next)
4) В следующем окне выбираем Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list), жмём Далее(Next)
5) Выбираем в списке самую верхнюю строчку Показать все устройства(Show all devices), жмём Далее(Next)
6) В следующем окне нажимаем на кнопку Установить с диска(Install From Disk), в нижнем правом углу
7) В открывшемся окне нажимаем кнопку Обзор(Browse) и указываем путь к файлу драйвера (inf-файл), нажимаем Ok, а затем Далее(Next)
8) Подтверждаем желание установить нажатием Далее(Next)

2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

Все обновления, которые Вы скачиваете или устанавливаете через внутреннюю службу Windows Центр обновления Windows (Windows Update) хранятся в папке: C:\Windows\SoftwareDistribution\Download, а также в подпапках внутри неё. После установки обновлений, Вы можете сохранить их себе на компьютер просто скопировав из папки нужный Вам файл. Файлы содержащие в своем названии -express, могут повторно не установиться. Следовательно Вы можете их и не копировать.

3. Как определить неизвестное устройство?

Узнаем VendorID(VEN) или HardwareID(DEV) устройства. В диспетчере устройств нажимаем у неизвестного устройства Свойства. Далее Сведения-Проматываем до ID оборудования.
Теперь идем на http://www.pcidatabase.com/. И вводим одно из найденных значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:
Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные
там тоже это указывается.

4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

6. Установка Windows 7 с USB флеш-накопителя (флешки).

Вариант 1

1) Вставьте Ваш флеш-диск в USB-порт.
2) Откройте ISO-образ Windows программой UltraISO

Так:

Щелкните на ISO-файле правой кнопкой мыши и выберите пункт Открыть, используя UltraISO

Или так:

В программе UltraISO в меню Файл нажмите на пункт Открыть, выберите нужный Вам образ Windows 7 и нажмите Открыть.

3) Убедившись, что образ открыт - выберите в меню Самозагрузка пункт Записать образ Жесткого диска
4) В списке Disk Drive:, выберите Ваш флеш-накопитель, в пункте Метод записи: USB-HDD+ и нажмите Записать.
5) В появившемся окне об уничтожении информации Подсказка, нажмите кнопку Да. Дождитесь, когда завершится запись (от 5 до 20 минут).
6) Не вынимая флеш-диска из USB-порта перезагрузите компьтер.
7) Сразу после начала перезапуска нажмите на клавиатуре Delete (Del), чтобы попасть в BIOS.
8) В BIOS установите загрузку в первую очередь с USB-HDD.
9) Сохраните настройки и выйдите из BIOS. Компьютер перезапуститься и начнет загрузку с флеш-накопителя.
10) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флеш-диска.

Вариант 2

Подготовка USB флеш-накопителя (флешки) для будущей загрузки и установки Windows 7:

1) Подключаете USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
2) В строке поиска меню Пуск вводите cmd.exe, щелкаете на найденном правой кнопкой мыши и нажимаете Запуск от имени администратора
3) Запускате утилиту управления дисками diskpart, дожидаетесь приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них Ваш диск USB, в моём примере это Disk 2
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 2. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаете выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируете раздел в файловую систему NTFS
12) Выполняете команду assign – активируете процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходите из diskpart в командную строку.

Рисунок 1 из 2

14) Вставляете имеющийся у Вас дистрибутив Windows 7 в дисковод, или монтируете образ в виртуальный диск.
15) Допустим, что он у Вас установлен в дисковод H:, тогда в командной строке (не в diskpart !!!) выполняете команду:
H:\Boot\bootsect.exe /nt60 I:
где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
16) Копируете все файлы с Вашего дистрибутива на Ваш USB флеш-накопитель (флешку). Используйте для этого либо Windows Explorer, либо команду:
xcopy H: I: /s /e /h /k

Рисунок 2 из 2

Всё, USB-драйв готов. Загружаете ПК с полученного USB флеш-накопителя.

Для ускорения процесса копирования опытные пользователи могут воспользоваться программой RichCopy, она является графической оболочкой команды robocopy, и включает всебя большое количество настроек. В число многочисленных параметров входят сортировка файлов по атрибутам и папкам, предотвращение ошибок, смена атрибутов, тайминг копирования, редактирование отметки о времени, установка количества потоков и размера используемого кэша.

7. Интеграция языковых пакетов и обновлений в дистрибутив Windows 7.

Вариант 1 вручную с помощью DISM.

Для работы нам потребуются WAIK, GimageX

1) Скачайте и установите Windows® Automated Installation Kit (AIK) for Windows® 7
2) Перезагрузите компьютер.

Русификация установщика install.Wim
1) Создаёте на диске D: папки Lip, Mount и mWim
2) Копируете lp.cab и все обновления (MSU и CAB) в папку Lip и создаёте в ней подпапку uLip
3) При помощи GimageX экспортируете из папки \Sources\install.wim в папку D:\mWim образ Ultimate (индекс 5 для 32-битных версий или Индекс 4 для 64-битных версий) как install.wim
4) Выполняете перезагрузку вашего ПК.
5) Запускаете командную строку от имени администратора (Win+R -> cmd -> Ok) и монтируете файл D:\mWim\install.wim в папку D:\Mount выполнив в консоли команду:
(команды копируете, и вставляете в консоль по правому клику)
dism /Mount-Wim /WimFile:D:\mWim\install.wim /index:1 /MountDir:D:\Mount
6) Интегрируете языковой пакет и обновления:
Для интеграции языкового пакета введите команду:
dism /image:D:\Mount /Add-Package /PackagePath:D:\Lip\lp.cab
Для интеграции обновления, используйте команду аналогичную предыдущей, подставляя вместо lp.cab, наименование интегрируемого обновления. Вот пример интеграции произвольного обновления:
dism /image:D:\Mount /Add-Package /PackagePath:D:\Lip\Windows6.1-KB123456-x64.msu
7) Применяем все настройки для русского языка командой:
dism /image:D:\Mount /Set-AllIntl:ru-RU
Примеры запуска команд DISM:
dism /image:D:\Mount /Set-UILang:ru-RU (язык интерфейса системы)
dism /image:D:\Mount /Set-SysLocale:ru-RU (язык системной локали для не Unicode)
dism /image:D:\Mount /Set-UserLocale:ru-RU (денежный формат, формат времени)
dism /image:D:\Mount /Set-InputLocale:0419:00000419 (настройки ввода с клавиатуры)
dism /image:D:\Mount /Set-TimeZone:"Russian Standard Time" (временная зона)
8) Демонтируете образ с сохранением изменений:
dism /Unmount-Wim /MountDir:D:\Mount /commit
Демонтаж без сохранения:
dism /Unmount-Wim /MountDir:D:\Mount /discard
9) Заменяете файл sources\install.wim в дистрибутиве, файлом D:\mWim\install.wim 10) Там же правите текст файла sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
Русификация установщика Boot.Wim
1) Распаковываете lp.cab в папку D:\Lip\uLip
expand D:\Lip\lp.cab -f:* D:\Lip\uLip
2) Очищаете папку D:\Mount
3) При помощи GimageX экспортируем из файла \Sources\boot.wim (индекс 2 !!!) в папку D:\mWim\ как boot.wim.
4) Монтируете файл boot.wim в папку D:\Mount
dism /Mount-Wim /WimFile:D:\mWim\boot.wim /index:1 /MountDir:D:\Mount
5) Добавляете в boot.wim русский язык:
xcopy D:\Lip\uLip\setup\* D:\Mount\ /cheryki
6) Добавляете в boot.wim файлы лицензий:
xcopy D:\Lip\uLip\sources\license\* D:\Mount\sources\license\ /cheryki
7) Правите текст файла D:\Mount\sources\lang.ini так же, как описано выше. 8) Демонтируете с сохранением файл boot.wim, папку uLip можно удалить.
dism /Unmount-Wim /MountDir:D:\Mount /commit
9) Заменяете файл sources\boot.wim в дистрибутиве, файлом D:\mWim\boot.wim

Вариант 2 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дождитесь успешного выполнения и увидите результат.

Вариант 3 с помощью командного файла скрипта.

1) Скачайте LPIntegrator.zip
2) Распакуйте скачанный архив в папку
3) Нажмите правой кнопкой мыши на файле LPIntegrator.bat и щелкните на пункте меню Изменить
4) Измените значение параметра set LANG=ru-RU, на язык интегрируемого языкового пакета, где en-US - для английского языка, de-DE - для немецкого языка и т.д.
5) Сохраните изменения и закройте редактирование.
6) Запустите LPIntegrator.bat
7) Выберите версию Вашего образа Windows 7
8) Распакуйте ISO-образ в папку C:\7Work\DVD или скопируйте туда все файлы Вашего инсталяционного диска.
9) Скопируйте языковой пакет, который Вы хотите интегрировать в папку C:\7Work\LP
10) Скопируйте обновления, которые Вы хотите интегрировать в папку C:\7Work\CABS
11) Нажмите любую клавишу(например, Enter) для продолжения.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

8. Добавление новых языков интерфейса в Windows.

Для добавления языков интерфейса необходимо установить дополнительные языковые файлы. После установки языковых файлов можно просматривать текст мастеров, диалоговых окон, меню, разделов справки и прочих элементов Windows на другом языке. Существуют 2 варианта добавления новых языков интерфейса: первый - через Центр обновления Windows(Windows Update), а второй - скачав и установив файл языкового пакета вручную. Перед началом работы измените в Панели Управления (Control Panel) способ просмотра(View by), вместо Категория(Category) на Крупные (Large icons) или Мелкие значки(Small icons).

Вариант1. Через Центр обновления Windows(Windows Update)

1) Откройте Центр обновления Windows

Пуск -> Все программы -> Центр обновления Windows (Start -> All Programs -> Windows Update)
или
Панель управления\Все элементы панели управления\Центр обновления Windows (Control Panel\All Control Panel Items\Windows Update)

1a) Также вы можете нажать Win+R, в поле Выполнить ввести указанную ниже команду и нажать Ok
Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
2) Выберите пункт Необязательных обновлений XX шт. доступны (XX options updates are available)
3) Поставьте флажок напротив нужного Вам языкового пакета (Language Pack) и нажмите Ok

Вариант 2. При наличии файла языка интерфейса lp.cab

1) Заходите в Панель Управления(Control Panel)
2) Открываете Язык и региональные стандарты (Regional and Language)
3) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
4) Нажимаете Установить или удалить язык (Install/uninstall languages...)
4a) Также вы можете нажать Win+R, в поле Выполнить ввести lpksetup и нажать Ok
5) Нажимаете Установить языки интерфейса (Install display languages)
6) Нажимаете кнопку Обзор...(Browse...)
7) Указываете путь к папке с lp.cab и нажимаете Ok
8) Выбираете необходимый Вам язык и нажимаете Далее(Next)

Вариант 3. Установка файла скачанного с сервера Windows Update

Вы можете установить необходимый Вам язык интерфейса, скачав exe-файл по прямой ссылке с сервера Windows Update и просто запустив его.

Оффициальные языковые пакеты для 32-bit (x86) Windows 7 RTM:

Арабский (Arabic):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ar-sa_210ccc96338a1ff683803eb4034e5f53d6d54c97.exe

Болгарский (Bulgarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-bg-bg_2e5d91b00775e0f974d4ec213fc20d470ff6850e.exe

Китайский (упрощенное письмо) (Chinese (Simplified)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-zh-cn_ab024143b556395e6638e26712b1e0f3bc031fcf.exe

Китайский (традиционное письмо) (Chinese (Traditional)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-zh-hk_90617b75cfaab716a43e7c082b00490a6d475376.exe

Хорватский (Croatian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-hr-hr_d8a4131aee5d5de039a3a0dc517ca0c07ebc3472.exe

Чешский (Czech):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-cs-cz_2759680ec6e2f4a7629c7d02b1fbce0a0d410a4e.exe

Датский (Danish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-da-dk_e1c57a4dcbd336ac73e349a9bb9d30de17ac093f.exe

Нидерландский (Dutch):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-nl-nl_194a2ca7b589e77b0be73b822f77760823183c51.exe

Английский (English):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe

Эстонский (Estonia):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-et-ee_3a99769fac5d6a11e6616297f842a9074c045699.exe

Финский (Finnish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-fi-fi_dd1973cc63ab7dea0e5d660af06869a8beefe36a.exe

Французский (French):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-fr-fr_1878fd391b990054787a14b0db4a5db00b793bf1.exe

Немецкий (German):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-de-de_1b86ff9b8f4c517dd341d76f24c74399278b05fc.exe

Греческий (Greek):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-el-gr_1f366d5e4fbde7df89b106821236fc1d3b3c9230.exe

Иврит (Hebrew):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-he-il_a3d6a6ae858f33ffa11a14c2a966e6603c134ef9.exe

Венгерский (Hungarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-hu-hu_12feb47da4bb28f60b6a30d379044356581c20f8.exe

Итальянский (Italian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-it-it_079a3afeb88f14d24a3b4204812225e78c2e0bb8.exe

Японский (Japanese):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ja-jp_08758c23cc64a53949072d53dd7bf6bbc8b45420.exe

Корейский (Korean):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ko-kr_bb2de1652c37394be4de87438661b129f8b56908.exe

Латышский (Latvian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-lv-lv_8b7a0b361dd37f7cd3926f798a79a90d378b18b2.exe

Литовский (Lithuanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-lt-lt_7aee9ce232cb46701f479fafdb0aea369ce1ad6a.exe

Норвежский (Norwegian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-nb-no_d65ea89195cf5f7d3170ccb1db7bae3c157f5b24.exe

Польский (Polish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe

Португальский (Бразилия) (Portuguese (Brazil)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pt-br_0a3fe79820d6d199dd43495d4efa5c40f270e45a.exe

Португальский (Португалия) (Portuguese (Portugal)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pt-pt_4165bd9cd083abd8ddd81986e18b1fd86aab5ce9.exe

Румынский (Romanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ro-ro_e1c324236046eb608e478570cf4396776ff02a72.exe

Русский (Russian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ru-ru_f4df4bcb8d3194323f17a086a17f46dd0c9c492a.exe

Сербский ()латиница (Serbian (Latin)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sr-latn-cs_6e049bae4d75b82405b28455e2def0a0d0055a9c.exe

Словацкий (Slovak):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sk-sk_dd2ce36a7e94fceff650cb892b8c954b8af6025a.exe

Словенский (Slovenian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sl-si_17786270766d556ba9bf3693762cb98805df9f50.exe

Испанский (Spanish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-es-es_1943a073d8f00e387301deb22cd177bf77319ee8.exe

Шведский (Swedish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sv-se_687085e8bbdf9c17a668b801f28f7f9c74e7a86a.exe

Тайский (Thai):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-th-th_780885dd42c039d9926ac004c76ba3ba9c30c6d0.exe

Турецкий (Turkish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-tr-tr_13015cb75811f874c83fdd679beb4c22c930a57c.exe

Украинский (Ukrainian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-uk-ua_0a467bf14bc4f524c18877f570a20c58e91ceba9.exe

Оффициальные языковые пакеты для 64-bit (x64) Windows 7 RTM:

Арабский (Arabic):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ar-sa_aaac936bd625c12b607dffea19fab8be9cfa28f6.exe

Болгарский (Bulgarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-bg-bg_155634f17868659db4b65cfeff57059b2436515f.exe

Китайский (упрощенное письмо) (Chinese (Simplified)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-zh-cn_a649e9af1e28514d48bdc51f7956be08060e54bc.exe

Китайский (традиционное письмо) (Chinese (Traditional)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-zh-hk_d428bc1cca4aea20163936e6687221c0e6b99ec4.exe

Хорватский (Croatian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-hr-hr_06468f799a1c1f295bc3abbc85c14116e2645122.exe

Чешский (Czech):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-cs-cz_f136df3188c54ff234ca77253fee2cf3e91966b7.exe

Датский (Danish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-da-dk_2b7590d389ca96af6f367408150cb6bc9aa8f4b4.exe

Нидерландский (Dutch):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-nl-nl_2ac14543f6e46c61ae226d7f0f5aee7f4d500e9f.exe

Английский (English):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe

Эстонский (Estonian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-et-ee_3c0479d7049109bcb42fd9ec59d1c65449704687.exe

Финский (Finnish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-fi-fi_4378f72d1233b00e2bdfc680a13f62ae11ab0fcb.exe

Французский (French):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-fr-fr_0e50cd2ea794e4cdfac861b194d2e996b7bbc8d8.exe

Немецкий (German):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-de-de_399ac15b2d55fd5dea0770d98825d7e75f4ad533.exe

Греческий (Greek):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-el-gr_9ae588ba70896f9100a10cb8ed68a79678d6fc32.exe

Иврит (Hebrew):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-he-il_86c22105bb32269c9c0deaf2710fcb1531a29817.exe

Венгерский (Hungarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-hu-hu_e5c47bffe398b9ace42d4326de2646a6172d39b5.exe

Итальянский (Italian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-it-it_3f0f5d78202e074e17a495beec821e1d326a8e2a.exe

Японский (Japanese):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ja-jp_9d73b1c1270deacbe7a2329559476a94daddb848.exe

Корейский (Korean):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ko-kr_e6b3322c3865cfd328d84376e192c4f9d41aa0e6.exe

Латышский (Latvian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe

Литовский(Lithuanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lt-lt_ede5a878aae2b0d64e81ff739e950b6f105df580.exe

Норвежский (Norwegian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-nb-no_1b7f93a0906a62eecd6b200979f8df986a7556f1.exe

Польский (Polish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe

Португальский (Бразилия) (Portuguese (Brazil)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pt-br_276b65f3b6b2657c8fe936f9841dc1243e02dc7b.exe

Португальский (Португалия) (Portuguese (Portugal)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pt-pt_f8310aa4a73841aec29b3f4e74ecaece56b695e9.exe

Румынский (Romanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ro-ro_810f2d590dd5aac92561eea5884ed1c70f34dbd9.exe

Русский (Russian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ru-ru_f0acfc688d609ee45d43cc60c6412a3071a665bd.exe

Сербский ()латиница (Serbian (Latin)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sr-latn-cs_275e0a17cbec543aa1bd7eebc883a1d21c11b514.exe

Словацкий (Slovak):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sk-sk_15f397de2ceaaff8dbfe670bcc6c013791a297c3.exe

Словенский (Slovenian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sl-si_8cfc82e0d15ed94634d3da69674008dc56755b93.exe

Испанский (Spanish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-es-es_2e593c26d9e23ad8176224a53c68a04f996ee014.exe

Шведский (Swedish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sv-se_1f4c415e0f4ca77064d597975f6ac7a9e0b8af63.exe

Тайский (Thai):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-th-th_080c8631d44a53c34ffdab8fd73820572dd87be4.exe

Турецкий (Turkish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-tr-tr_6bd6660158289e0b5d4b5a7f7fded6e3528a9a04.exe

Украинский (Ukrainian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-uk-ua_c6c4e44c9d903049a4c60fed9d42effa18f345bd.exe

Смена Вашего языка интерфейса на новый:

1) Заходите в Панель Управления(Control Panel)
1.1) Открываете Язык и региональные стандарты (Regional and Language)
1.1a) Также вы можете нажать Win+R, в поле Выполнить ввести intl.cpl и нажать Ok
1.2) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
2) Выбираете в пункте Выберите язык интерфейса (Choose a display language:) нужный Вам язык и нажимаете Ok
3) Нажимаете кнопку Выйти из системы сейчас (Log off now)
4) В появившемся экране выбираете своего пользователя.
5) В случае необходимости вводите свой пароль и попадаете в Windows на выбранном Вами языке

9. Как не вводить ключ при инсталляции Windows?

Вариант 1

по материалам technet.microsoft.com:
EI.cfg is a Windows Setup-specific configuration file used to determine what edition and license will be used during installation. This file replaces PID.txt and is located on the product media under the \sources folder.
Добавьте в файл EI.cfg находящийся в папке \sources строку:
[PID]
Value="xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

Вариант 2

Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>MyName</FullName>
<Organization>Microsoft</Organization>
<ProductKey>
<Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
</component>
</settings>
</unattend>

10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузиться в специальный режим Windows.
1) Сразу после включения компьютера нажмите F8. Далее вы попадете либо в меню выбора режимов загрузки Windows, либо в меню выбора диска для загрузки.
2) Нам нужен меню выбора режимов загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter, а затем быстро нажмите F8 до начала запуска Windows и окажитесь там, где нам нужно.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов. Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобиться программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С оффициального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи используйте рекомендации из совета 6 в "Тонких настройках".
Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriverPlus она добавит небольшое изменение в загрузчик, которое автоматизмрует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriverPlus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriverPlus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник -> Компьютер -> Локальный диск (C:)
1.2) В Панели меню выберите Сервис -> Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом местенахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву(Например: Z) и нажите OK
2.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriverPlus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом местенахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriverPlus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriverPlus перезагрузитесь. В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

11. Где можно скачать последние обновления для Windows 7?

Компания Microsoft периодически выпускает обновления для Windows 7. Но не все из них включены в Центр обновления Windows (Windows Update). Все последние версии обновлений, Вы можете скачать без регистрации на форуме My Digital Life:

http://forums.mydigitallife.info/threads/10571-Windows-7-RTM-Updates-Packs-x86-x64

Для того, чтобы не устанавливать каждое обновление по-отдельности, Вы можете воспользоваться предложенной там программой Windows 7 Update Pack Tool, для установки всех обновлений сразу.

12. Повышение оценки производительности жесткого диска.
Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

13. Автоматическая установка OEM-информации.

Представляем вашему вниманию небольшой скрипт, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
Не забудьте заменить серийный ключ (product key) на ваш и назовите файл autounattend.xml.
<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0409:00000409</InputLocale>
<SystemLocale>en-US</SystemLocale>
<UILanguage>en-US</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>en-US</UserLocale>
</component>
<component name=”Microsoft-Windows-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<DiskConfiguration>
<Disk wcm:action=”add”>
<CreatePartitions>
<CreatePartition wcm:action=”add”>
<Extend>false</Extend>
<Type>Primary</Type>
<Order>1</Order>
<Size>40000</Size>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action=”add”>
<Order>1</Order>
<PartitionID>1</PartitionID>
<Format>NTFS</Format>
<Letter>C</Letter>
<Extend>true</Extend>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass=”oobeSystem”>
<component name=”Microsoft-Windows-Shell-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<OEMInformation>
<Logo>E:\oemlogo.bmp</Logo>
<Manufacturer>Fabrikam</Manufacturer>
<Model>Superfast1000</Model>
<SupportHours>Anytime, day or night</SupportHours>
<SupportPhone>1-800-SUPPORT</SupportPhone>
<SupportURL>www.fabrikam.com</SupportURL>
</OEMInformation>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
<AutoLogon>
<Password>
<Value>Password</Value>
<PlainText>true</PlainText>
</Password>
<Username>Administrator</Username>
<Enabled>true</Enabled>
<LogonCount>5</LogonCount>
</AutoLogon>
<UserAccounts>
<AdministratorPassword>
<Value>Password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
<cpi:offlineImage cpi:source=”wim:c:/documents%20and%20settings/vmux/desktop/sourceos/install.wim#Windows 7 ULTIMATE” xmlns:cpi=”urn:schemas-microsoft-com:cpi” />
</unattend>

Внимание!!!
Не используйте данный метод, если имеете важную информацию на жестком диске или же сделайте резервную копию системы. Дело в том, что файл ответов в данном совете стирает все разделы и логические диски при установке.
Если же вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

14. Автоматическая установка OEM-Logo.

Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass=”windowsPE”>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OEMInformation>
<HelpCustomized>false</HelpCustomized>
<Manufacturer>Hewlett-Packard</Manufacturer>
<Model>Compaq Presario SR1610IL</Model>
<Logo>C:\Windows\Sytem32\oemlogo.bmp</Logo>
<SupportHours>9 AM to 9 PM (Mon-Sat)</SupportHours>
<SupportPhone>1-600-114772 (Toll free), 0124-2346992 (Toll Number)</SupportPhone>
<SupportURL>http://www.hp.com/in/support</SupportURL>
</OEMInformation>
</component>
</settings>
</unattend>
oemlogo.bmp
положите ваше лого в папку " \Sources\$OEM$\$$\System32\oemlogo.bmp"

15. Как установить LocalPack-RU?

Нужно в командной строке от имени Администратора выполнить команду: DISM /Online /Add-Package /PackagePath:<полный_путь_к_локал-паку>.CAB
Если не сработает - значит, нужно проделать почти то же самое, но загрузившись с установочного носителя.
Тогда /Online нужно будет заменить на /image:<буква_диска_с_установленной_системой>:.
Этим способом, кстати, MVE, можно установить лангпак на любую редакцию Windows 7
После установки нужно зайти в C:\Windows\Globalization\MCT\MCT-...\Theme

16. Автоматическая установка обновлений Windows.

Вариант 1. Использование Bat-файла (для MSU и CAB обновлений).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Update.bat")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
@Echo Off
Title Installing Windows7 Updates
For %%F In (MSU\*.msu) Do Call :msin %%F
For %%A In (CAB\*.cab) Do Call :kbin %%A
Exit
:msin
Start /Wait %1 /quiet /norestart
:kbin
Start /Wait pkgmgr /ip /m:%1 /quiet /norestart
GoTo :EOF
Exit
5) Рядом с bat-файлом cоздайте папки CAB и MSU.
6) Поместите обновления .msu в папку MSU и .cab в папку CAB.
7) Запустите Update.bat и дождитесь закрытия окна командной строки.

Для правильности работы скрипта проверьте у себя соблюдение следующих пунктов:

1) Проверьте разрядность обновлений (х86\х64)
2) В имени файла не должно быть слова EXPRESS, такое обновление копировать бесполезно, оно не установится.
3) Файл Update.bat должен находиться в папке на один уровень выше папок CAB и MSU.

Скачать готовый Update.bat

Вариант 2. Использование программы Windows 7 Update Pack Tool.

Наиболее простым решением для автоматической установки обновлений является программа Windows 7 Update Pack Tool.

Инструкция:

1) Скачайте Windows 7 Update Pack Tool
2) Создайте новую папку. Например: Updates
3) Поместите в неё файл Update.exe
4) Поместите в неё все обновления с расширениями .msu и .cab, которые Вы желаете установить.
5) Создайте внутри Вашей папки Updates папку SpecialUpdates
6) Поместите в папку SpecialUpdates все обновления с расширениями .msi и .exe, которые Вы желаете установить.
7) Запустите файл Update.exe
8) Выберите пункт Install updates. Для этого нажмите на клавиатуре цифру 1 и затем Enter
9) Программа произведет поиск обновлений: .msu и .cab в главной папке, и .msi и .exe в папке SpecialUpdates
10) Нажмите любую клавишу(например: Enter) и программа установит обновления
11) По окончании установки программа напишет список устанавливаемых обновлений и попросит перезагрузки.
12) Перезагрузите компьютер и Вы получите систему с установленными обновлениями.

17. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузиться в специальный режим Windows.
1) Сразу после включения компьютера нажмите F8. Далее вы попадете либо в меню выбора режимов загрузки Windows, либо в меню выбора диска для загрузки.
2) Нам нужен меню выбора режимов загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter, а затем быстро нажмите F8 до начала запуска Windows и окажитесь там, где нам нужно.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов. Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобиться программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С оффициального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи используйте рекомендации из совета 6 в "Тонких настройках".
Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriverPlus она добавит небольшое изменение в загрузчик, которое автоматизмрует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriverPlus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriverPlus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник -> Компьютер -> Локальный диск (C:)
1.2) В Панели меню выберите Сервис -> Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом местенахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву(Например: Z) и нажите OK
2.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriverPlus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом местенахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriverPlus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriverPlus перезагрузитесь. В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

Настройки

1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Hужно установить пароль на учетную запись администратора и работать из под нее.

2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

3. Как изменить параметры загрузки, где в Windows 7 файл boot.ini?
Начиная с Windows Vista такого файла больше нет, но Вы можете изменить необходимые Вам для загрузки параметры используя инструмент Конфигурация системы. Окно Конфигурация системы запускается так: Панель управления -> Администрирование -> Конфигурация системы -> Загрузка (или нажав Win+R -> msconfig -> Ok)

Данный инструмент позволяет:
- получить информацию о текущей и загружаемой по умолчанию системах;
- выбрать систему, загружаемую по умолчанию;
- удалить ненужную запись из меню загрузки.
- отредактировать время в секундах (таймаут), по истечении которого будет загружена операционная система, выбранная по умолчанию.
- включить\выключить экран приветствия(Без GUI);
- включить\выключить загрузку стандартных драйверов VGA, вместо драйверов экрана, соответствующих видеооборудованию компьютера(Базовое видео).

А через Дополнительные параметры:

- Число процессоров, используемых при загрузке.
- Максимальный объем памяти в мегабайтах, используемый для моделирования конфигурации с малым объемом памяти.

При помощи окна Конфигурация системы нельзя изменить(но это возможно, при помощи программы Bcdedit):

- наимнование существующих записей;
- положение записи в меню загрузки.

Для выбора системы, загружаемой по умолчанию, выберите необходимую Вам операционную систему и нажмите кнопку «Использовать по умолчанию».
Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».
Для редактирование таймаута, в нужном поле установите желаемое количество секунд.

Для применения, сделанных Вами изменений - перезагрузите компьютер.

4. Увеличение скорости загрузки ОС для многоядерных процессоров.

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить(или Win+R)
2) Введите msconfig и нажмите OK
3) Перейдите на вкладку Загрузка
4) Нажмите Дополнительные параметры
5) Поставьте флажок напротив значения Число процессоров
6) Выберите в активировавшемся ниспадающем меню число ядер Вашего процессора (По умолчанию 1)
Установка меньшего значения, чем количество ядер Вашего процессора не рекомендуется, так как система может продолжить использование указанного Вами числа ядер и после завершения загрузки.
7) Нажмите OK и перезагрузите компьютер

Также рекомендую включить(установить в значение Enabled) в BIOS (Вызывается нажатием клавиши Delete, сразу после начала загрузки компьютера) функцию ACPI APIC Support. Данная функция находится во вкладке Power.

5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны. К примеру, чтобы изменить временную зону на время по Гринвичу, нужно использовать следующую команду:
tzutil /s “gmt standard time”
» “tzutil /g” покажет текущие установки временной зоны;
» “tzutil /l” выводит список всех возможных временных зон;
» “tzutil /?” выводит справку по работе утилиты.

6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавишы Ctrl+Alt+, выбор третьей клавишы за вами, как вам удобнее. Например, Ctrl+Alt+S.

7. Отключение (включение) неиспользуемых компонентов Windows.
В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

8. Как отменить (изменить) ассоциирование типов файлов с определенными программами?

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Искать в реестре в ветке [HKEY_CLASSES_ROOT]
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

9. Как отключить всплывающие подсказки?

Отключить всплывающие подсказки можно используя редактор групповой политики.
Нажмите Пуск, в поле Начать поиск напишите gpedit.msc и нажмите ОК.
Перейдите в раздел Конфигурация пользователя - Административные шаблоны - Меню Пуск и Панель задач.
Откройте параметр "Удалить всплывающие подсказки для элементов главного меню", выберите пункт Включен и нажмите ОК

10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии «Завершение работы». Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние «Перезагрузка». Для этого выполняем правый клик по кнопке Пуск, выбираем пункт меню Свойства и переключаем “Действие кнопки питания” в состояние “Перезагрузка”. Также вы можете выбрать функции “Блокировка”, “Смена пользователя” и “Завершение сеанса”.

11. Как быстро перейти к часто используемой папке?

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

bcdedit - инструмент, позволяющий изменить значения загрузчика Windows, а также произвести его(загрузчика) восстановление. Чтобы увидеть предлагаемые системой для изменения параметры: запустите командную строку от имени администратора (Win+R -> cmd -> Ok), наберите в ней bcdedit и нажмите Enter. Все команды, приведенные в данном варианте, необходимо будет запускать в командной строке, запущенной от имени администратора (Win+R -> cmd -> Ok) Также данные команды могут выполняются в командной строке среды восстановления или в командной строке ERD Commander.

Некоторые значения параметров BCD записаны в фигурных скобках – {}. Это идентификаторы – {CLSID}. Любой идентификатор имеет буквенно-цифровой код вида {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. Стандартные идентификаторы имеют названия, например: {default}, {bootmgr}, {ntldr} и так далее.

Наиболее интересующими нас компонентами являются:

идентификатор – CLSID той или иной записи;
device – показывает раздел, на котором расположены файлы загрузки (это может быть операционная система или папка BOOT);
osdevice – показывает раздел, на котором расположены системные файлы операционной системы. Обычно, значения параметров device и osdevice равны;
path – если device определял раздел диска, который содержит файлы операционной системы, то этот параметр определяет остальной путь к загрузчику операционной системы;
default – показывает ID операционной системы, загружаемой по умолчанию, если операционная система, в которой запустили командную строку, загружается по умолчанию, параметру default присваивается значение {current};
displayorder – показывает порядок, в котором расположены записи о загружаемых системах;
timeout – таймаут(время - по истечении которого будет загружена операционная система), значение показано и устанавливается в секундах;
locale – указывает язык загрузочного меню или меню дополнительных параметров загрузки;
description – показывает название операционной системы, отображающееся в меню загрузки.

Внимание: Если в выполняемой Вами команде, с использованием программы bcdedit.exe, отсутствует параметр /set с дальнейшим указанием идентификатора, то внесенные Вами изменения будут добавлены в Диспетчер загрузки Windows (Windows Boot Manager), а не в Загрузка Windows (Windows Boot Loader)

Перед тем, как начнете вносить необходимые Вам изменения, создайте резервную копию загрузчика. Для этого, создайте на любом диске папку с названием BCDREZ и выполните следующую команду:
bcdedit /export X:\BCDREZ\bcd
где X - буква диска, на котором находится папка BCDREZ.

Если Вы решите вернуть все сделанные Вами изменения к начальным настройкам, то выполните следующую команду:
bcdedit /import X:\BCDREZ\bcd
Для дальнейших примеров, предположим, что наше меню загрузки содержит три записи с идентификаторами {ID1}, {ID2}, {ID3}.

Изменение системы, загружаемой по умолчанию

Введите параметр /default и {ID} той системы, которую Вы хотите загружать по умолчанию. Например, для системы с {ID2} команда:
bcdedit /default {ID2}
Данная команда не перемещает запись о системе, загружаемой по умолчанию, на верхнюю строчку меню загрузки.

Изменение расположения записей в меню загрузки

1) Перемещение выбранной записи вверх списка:
bcdedit /displayorder {ID} /addfirst
2) Перемещение выбранной записи вниз списка:
bcdedit /displayorder {ID} /addlast
3) Формирование меню в выбранном порядке:
bcdedit /displayorder {ID3} {ID1} {ID2}
Изменение таймаута
bcdedit /timeout XX
где XX – время в секундах.

Изменение языка диспетчера загрузки
bcdedit /set {bootmgr} locale ln-LN
где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение языка меню дополнительных вариантов загрузки

В связи с тем, что программа восстановления запуска, выполняющаяся из среды восстановления, использует параметры "по-умолчанию", меню дополнительных вариантов загрузки, которое появляется при нажатии F8 после наведения на строку меню с нужной операционной системой, может стать англоязычным. Вернуть необходимый Вам язык, можно выполнив следующую команду:
bcdboot %Windir% /l ln-LN
где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение названия загружаемой системы

После использования среды восстановления, в названии операционной системы появляется надпись - (восстановлено). Вы также можете исправить значение "Предыдущая версия Windows" на более удобное Вам "Windows XP" или добавить версию и разрядность к текущей(используемой по умолчанию) версии Windows. Вы можете изменить это указанной ниже командой:
bcdedit /set {ID} description "Новое название"
Например:
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"
Изменение буквы раздела, на котором расположена папка операционной системы и ее загрузочные файлы
bcdedit /set {ID} device partition=X:
bcdedit /set {ID} osdevice partition=X:
где X – буква раздела жесткого диска. Обычно значения device и osdevice совпадают.

Добавление новой операционной системы (Windows Vista или Windows 7) в загрузчик.

1) Скопируйте существующую запись текущей системы с новым названием:
bcdedit /copy {current} /d "Microsoft Windows Vista"
2) Дождитесь сообщение «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
3) Измените значения параметров device и osdevice на соответствующие добавляемой операционной системе.
bcdedit /set {хххххххх-хххх-хххх-хххх-хххххххххххх} device partition=X:
bcdedit /set {хххххххх-хххх-хххх-хххх-хххххххххххх} osdevice partition=X:
где X – буква диска, на котором находится операционная система. Вместо крестиков, введите значение {ID}, полученное после успешного окончания копирования.
4) Выполните команду, добавляющую новую запись в диспетчер загрузки:
bcdedit /displayorder {хххххххх-хххх-хххх-хххх-хххххххххххх} /addlast
Запись будет добавлена внизу существующего списка.

Удаление записи загрузки системы из BCD и диспетчера загрузки.

Удаление записи об установленной операционной системе из BCD и диспетчера загрузки выполняется с помощью команды bcdedit /delete {ID}. Есть особенность выполнения команды: если в качестве ID указывается известная запись, например {ntldr}, то команда должна выполняться с ключом /f:
bcdedit /delete {ntldr} /f
Если же ID записывается в буквенно-цифровом коде, ключ /f не нужен.

В случае отсутствия одного из файлов, необходимых для работы с загрузчиком, Вы можете скачать архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe из Windows 7 Ultimate x86/x64)

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

13. Установка пользовательского разрешения экрана.

У некоторых мониторов разрешение экрана может не соответствовать ни одному из предлагаемых Windows.

Если у Вас установлена видеокарта Nvidia Вы можете добавить своё разрешение экрана одним из указанных способов:

Способ 1.

1) Запустить Панель управления Nvidia.
2) Открыть Дисплей -> Изменение разрешения -> Добавить разрешения... -> Создать пользовательское разрешение
3) Задать нужные Вам параметры, протестировать их и добавить его в список для выбора
4) Выбрать его и использовать.

Способ 2.

Используя реестр добавить нужное Вам разрешение в параметр NV_Modes

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{some number}\0000

Также можете найти другие ветки содержащие параметр NV_Modes и также добавить в них необходимое Вам разрешение экрана.

Способ 3. Перед установкой драйвера.

Откройте файл "nv_disp.inf" в папке C:\NVIDIA\Win7\xxx.xx и найдите значение [nv_commonDisplayModes_addreg]
Под ним в NV_Modes будут все доступные разрешения экрана, добавьте туда свое.

Но бывает что даже после указанных выше манипуляций, новое разрешение не хочет добавляться. В таком случае, для принудительного добавления пользовательского разрешения Вам придется использовать специальные программы. Рекомендую поискать в интернете следующие программы:

PowerStrip - Программа управления параметрами видеоподсистемы вашего компьютера, поддерживается огромное разнообразие видео карт. Это - фактически единственная программа своего рода, которая поддерживает видео карты из многочисленного набора чипсетов и поставщиков,одновременно, под любой операционной системой. Программа спокойно сидит в трее и оттуда обеспечивает доступ к более 500 элементов управления над вашими дисплейными аппаратными средствами, включая цветные инструментальные средства коррекции, установки уровня периода экранной геометрии, и драйверо-независимыми элементами управления часов.

Screen Resolution Manager - Программа, позволяющая каждому пользователю компьютера устанавливать свое разрешение экрана. Помимо разрешения можно настроить глубину цвета, частоту, яркость и контрастность, цветовую гамму и другие настройки, которые автоматически вступят в силу после загрузки профиля определенного пользователя.

14. Создание диска восстановления системы и загрузка с него.

Если у вас есть установочный диск Windows 7, создавать диск восстановления необязательно. Если же установочного диска у вас нет, создать диск восстановления нужно обязательно - он вам рано или поздно пригодится. С установочного диска можно загрузиться в среду восстановления Windows RE.

Создание диска восстановления системы

1) Вставьте чистый компакт-диск в привод.
2) Откройте Пуск -> Панель Управления -> Архивация и восстановление (Backup and Restore)
3) В левой панели щелкните ссылку Создать диск восстановления системы.

Загрузка с диска восстановления системы

1) Вставьте диск восстановления в привод и перезагрузитесь
2) В BIOS должен быть установлен приоритет загрузки с привода. Будет выполнена загрузка в Windows RE.
3) Выберите систему, которую вы хотите восстановить.
4) Установите переключатель Используйте средства восстановления... и нажмите кнопку Далее. Вы увидите окно с вариантами восстановления.

15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

1) Запустите cmd.exe от имени администратора(Win+R -> cmd -> Ok)
2) Выполните следующие команды, нажимая после введения каждой Enter
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"

16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

Вы решили заменить или продать один из ваших жестких дисков. Прежде чем это сделать, убедитесь что файлы загрузки Windows 7 не содержаться на удаляемом Вами из системы жестком диске.
Windows 7 хранит свои файлы для загрузки на активном диске, который может отличаться от того на котором установлена Windows 7. Файлами загрузки для Windows 7 являются файл bootmgr и хранилище данных конфигурации загрузки BCD (Boot Configuration Data), находящееся в скрытой и системной папке Boot.

При загрузке Windows 7 проверяет соблюдение 3 условий:

- Является ли диск, с которого выполняется загрузка активным;
- Совместима ли Главная Загрузочная Запись (Master Boot Record - MBR) с bootmgr (Диспетчером загрузки Windows);
- Находиться ли файлы загрузки операционной системы на активном диске должны.

В случае не соблюдения одного из условий, загрузка становится невозможной.

Предположим, что Ваша Windows 7 установлена на диск С:, который не активен. Активным является только диск D:, который Вы собираетесь удалить из системы и на котором находятся Файлы загрузки Windows 7, имеющие атрибуты Скрытый и Системный.

В качестве решения предлагаю Вам выполнить перенесение файлов загрузки Windows 7 с активного раздела (удаляемый жесткий диск) на неактивный раздел (остающийся в системе жесткий диск, с присвоением ему атрибута - Активный).

1) Выяснение атрибутов дисков и присвоение остающемуся в системе жесткому диску атрибута Активный.

Способ 1. Используя оснастку "Управление дисками".

1.1.1) Нажмите Win + R, в строке "Выполнить" наберите diskmgmt.msc и нажмите OK
1.1.2) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7 Буква тома здесь, идентична букве диска с Window 7 из Мой Компьютер.
1.1.3) Под буквой тома, размером диска и файловой системой будут указаны атрибуты диска. Посмотрите имеет ли наш том атрибут "Активный". Если да, то Вы сможете спокойно удалить Ваш диск из системы. Если же нет, то Вам необходимо будет присвоить данный атрибут, в соответствии с написанным ниже.
1.1.4) Если Ваша Windows 7 установлена на жесткий диск, разбитый на несколько разделов, то выберите первый слева раздел остающегося у Вас диска, его мы сделаем загрузочным и активным. Если же раздел всего один, то выберите его.
1.1.5) Щелкните правой кнопкой мыши по выбранному разделу и выберите в контекстном меню пункт "Сделать раздел активным". Учтите, что этот раздел должен иметь атрибут "Основной".

Способ 2. Используя командную строку.

1.2.1) Запустите командную строку с правами администратора. Нажмите Win + R, в строке "Выполнить" наберите cmd и нажмите OK.
1.2.2) Последовательно выполните все команды без выхода из командной строки:
DISKPART
list disk
sel disk X
list partition
sel part 1
active
exit
где X - номер диска, который предполагается оставить, в списке дисков (команда list disk).

2) Перезапись загрузочного сектора MBR и установка его совместимости с bootmgr:

2.1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2.2) Создайте папку Boot
2.3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
2.4) Запустите командную строку с правами администратора.
X:\boot\bootsect.exe /nt60 all /force
где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /force - принудительно отключает один или несколько томов во время обновления загрузочного кода. Необходим, при наличии в конфигурации 2-х и более жестких дисков.

3) Перенесение BCD (Boot Configuration Data) и файла bootmgr на новый активный раздел:
X:\boot\bcdboot.exe %Windir% /l ru-RU /s С:
где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /l - выбор языковых параметров менеджера загрузки. Если ваша система не русскоязычная, используйте другие значения этого ключа, например, для английского языка - en-US, для немецкого - de-DE, и т.д.
- ключ /s - определяет букву тома, назначенную целевому системному разделу, в который копируются файлы среды загрузки. Это раздел, который мы сделали активным. Windows 7 использует текущий загрузочный раздел (в нашем случае - раздел D:) до завершения своей работы. Поэтому применение этого ключа с указанием буквы нового загрузочного раздела (в нашем случае - раздел С:) - обязательно.

17. Способы доступа к элементам Панели управления.

В разных статьях Вы можете увидеть разное описание пути к одинаковым элементам Панели управления. Такое происходит потому что в Windows существует два вида отображения элементов: Категория(элементы сгруппированы по тематикам) и Крупные или Мелкие значки (элементы отображаются полным списком) Имхо, наиболее удобным является Крупные или Мелкие значки(их полный список).

Существует несколько способов доступа к элементам Панели управления:

1) Через меню Пуск.

Для быстрого доступа к элементам Панели управления, рекомендуется добавить в меню Пуск всплывающее меню содержащее все элементы Панели Управления.
1.1) Нажмите правой кнопкой мыши на кнопке Пуск и щелкните на пункте Свойства.
1.2) Нажмите Настроить...
1.3) Промотайте до записи Панель управления.
1.4) Установите значение переключателя под ней в положение Отображать как меню и нажмите OK
Всплывающее меню Панели управления будет отображаться полным списком, независимо от Вашего выбора вида отображения.

2) Через Проводник Windows.

2.1) Запустите Проводник
2.2) В панели меню выберите Сервис и нажмите Параметры папок
2.3) Под надписью Область переходов установите флажок напротив значения Показать все папки и нажмите OK
Теперь Панель управления будет доступна в Проводнике в Области переходов слева. Преимущество данного способа в том что Вы можете работать, как сразу с полным списком элементов: Проводник -> Панель управления -> Все элементы панели управления, так и с отдельными разделами: Проводник -> Панель управления -> Нужный Вам раздел.

3) На рабочем столе.

3.1) Щелкните правой кнопкой мыши на Рабочем столе и нажмите Персонализация
3.2) Щелкните Изменение значков рабочего стола
3.3) Установите флажок напротив Панель управления и нажмите ОК
На Рабочем столе появится ярлык запускающий папку Панель управления. Способ отображения зависит от выбранного Вами значения параметра Просмотр.

4) Добавление или запуск папки Панель управления используя {GUID}

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

Control Panel.{26EE0668-A00A-44D7-9371-BEB064C98683}

Для её запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}

5) Запуск элементов Панели управления, используя канонические имена.

Русское название элемента | Английское название элемента | Команда
Панель управления | Control Panel | control
Windows CardSpace | Windows CardSpace | control /name Microsoft.CardSpace
Windows SideShow | Windows SideShow | control /name Microsoft.WindowsSideShow
Автозапуск | AutoPlay | control /name Microsoft.AutoPlay
Автономные файлы | Offline Files | control /name Microsoft.OfflineFiles
Администрирование | Administrative Tools | control /name Microsoft.AdministrativeTools
Архивация и восстановление | Backup and Restore | control /name Microsoft.BackupAndRestore
Биометрические устройства | Biometric Devices | control /name Microsoft.BiometricDevices
Брандмауэр Windows | Windows Firewall | control /name Microsoft.WindowsFirewall
Восстановление | Recovery | control /name Microsoft.Recovery
Гаджеты рабочего стола | Desktop Gadgets | control /name Microsoft.DesktopGadgets
Дата и Время | Date and Time | control /name Microsoft.DateAndTime
Датчик расположения и другие датчики | Location and Other Sensors | control /name Microsoft.LocationAndOtherSensors
Диспетчер устройств | Device Manager | control /name Microsoft.DeviceManager
Диспетчер учетных данных | Credential Manager | control /name Microsoft.CredentialManager
Домашняя группа | HomeGroup | control /name Microsoft.HomeGroup
Защитник Windows | Windows Defender | control /name Microsoft.WindowsDefender
Звук | Sound | control /name Microsoft.Sound
Значки области уведомлений | Notification Area Icons | control /name Microsoft.NotificationAreaIcons
Игровые устройства | Game Controllers | control /name Microsoft.GameControllers
Инфракрасная связь | Infrared | control /name Microsoft.Infrared
Папка "Fonts" | Fonts Folder | control /name Microsoft.Fonts
Параметры индексирования | Indexing Options | control /name Microsoft.IndexingOptions
Параметры папок | Folder Options | control /name Microsoft.FolderOptions
Параметры планшетного компьютера | Tablet PC Settings | control /name Microsoft.TabletPCSettings
Перо и сенсорные устройства | Pen and Touch | control /name Microsoft.PenAndTouch
Персонализация | Personalization | control /name Microsoft.Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | control /name Microsoft.RemoteAppAndDesktopConnections
Получение программ | Get Programs | control /name Microsoft.GetPrograms
Приступая к работе | Getting Started | control /name Microsoft.GettingStarted
Программы и компоненты | Programms and Features | control /name Microsoft.ProgramsAndFeatures
Программы по умолчанию | Default Programs | control /name Microsoft.DefaultPrograms
Распознавание речи | Speech Recognition | control /name Microsoft.SpeechRecognition
Расположение по умолчанию | Default Location | control /name Microsoft.DefaultLocation
Родительский контроль | Parental Controls | control /name Microsoft.ParentalControls
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | control /name Microsoft.TaskbarAndStartMenu
Свойства речи | Text to Speech | control /name Microsoft.TextToSpeech
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | control /name Microsoft.iSCSIInitiator
Свойства: Интернет | Internet Properties | control /name Microsoft.InternetOptions
Свойства: Клавиатура | Keyboard Properties | control /name Microsoft.Keyboard
Свойства: Мышь | Mouse Properties | control /name Microsoft.Mouse
Система | System | control /name Microsoft.System
Сканеры и камеры | Scanners and Cameras | control /name Microsoft.ScannersAndCameras
Соседние пользователи | People Near Me | control /name Microsoft.PeopleNearMe
Счетчики и средства производительности | Performance Information and Tools | control /name Microsoft.PerformanceInformationAndTools
Телефон и модем | Phone and Modem | control /name Microsoft.PhoneAndModem
Управление цветом | Color Management | control /name Microsoft.ColorManagement
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control /name Microsoft.DevicesAndPrinters
Учетные записи пользователей | User Accounts | control /name Microsoft.UserAccounts
Центр мобильности Windows | Windows Mobility Center | control /name Microsoft.MobilityCenter
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | control /name Microsoft.ActionCenter
Центр синхронизации | Sync Center | control /name Microsoft.SyncCenter
Центр специальных возможностей | Ease of Access Center | control /name Microsoft.EaseOfAccessCenter
Центр управления сетями и общим доступом | Network and Sharing Center | control /name Microsoft.NetworkAndSharingCenter
Шифрование диска BitLocker | BitLocker Drive Encryption | control /name Microsoft.BitLockerDriveEncryption
Экран (размер текста) | Display (size of text) | control /name Microsoft.Display
Электропитание | Power Options | control /name Microsoft.PowerOptions
Язык и региональные стандарты | Region and Language | control /name Microsoft.RegionAndLanguage

При отсутствии в системе необходимого устройства, драйверов или определенных компонентов, соответствующий ему элемент Панели управления может не запуститься.

Администрирование

1. Активировал учетную запись администратора, но некоторые папки\файлы все равно не удаляются.

Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду
net user Администратор /active:yes
В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:
net user Administrator /active:yes
Команду необходимо выполнять в командной строке с повышенными правами пользователя. Для этого нажмите кнопку Пуск, выберите пункт Стандартные, щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора.

2. Как разрешить запуск "Диспетчера задач"?

Запустите редактор системных политик: Пуск > Выполнить > gpedit.msc.
Слева в дереве политик выберите Конфигурация пользователя > Административные шаблоны > Система > Возможности Ctrl+Alt+Del.
В правом окне двойным щелчком откройте свойства политики Удалить диспетчер задач, выберите Отключен и нажмите ОК.
Изменения вступят в действие после перезагрузки.

3. Как добавить свою иконку в список рисунков учетных записей?

По умолчанию рисунки учетных записей располагаются в следующей папке:
C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

4. Автоматический вход в систему и отключение экрана пользователей при запуске.

Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

1. Нажмите на клавиатуре Win+R (или пункт Выполнить в меню Пуск).
2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Enter.
3. В окне Учетные записи пользователей во вкладке Пользователи выделите свою учетную запись и уберите флажок с “Требовать ввод имени пользователя и пароля”.
4. Нажмите Принять.
5. В открывшемся окне Автоматический вход в систему будут три поля - Пользователь, Пароль и Подтверждение. Введите свой пароль в поле Пароль и еще раз - в поле Подтверждение и нажмите ОК.

Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
(Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

5. Как ограничить пользователей в наборе программ, которые они могут запускать?

Контроль за приложениями сводится к настройке правил. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные определенным издателем (например, Microsoft). Запустите GPEDIT.MSC и перейдите к функции AppLocker() через Computer Configuration > Windows Settings > Security Settings > Application Control Policies или Конфигурация компьютера > Конфигурация Windows > Параметры безопасности > Политики управления приложениями, чтобы посмотреть, как это работает.

6. Как быстро запустить программу с правами администратора?

Удерживайте Ctrl+Shift и нажмите на иконку приложения (у вашей учетной записи, конечно, должны быть соответствующие права).

7. Как убрать значки запрета доступа на папках?

Для этого надо в свойствах назначения прав папкам и файлам, добавить пользователя Администратор, и дать ему все разрешения, после чего значек с папки или файла будет убран.

8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
2) Нажимаете "Создать задачу"
3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
5) Указываете путь к нужному приложению и нажимаете "Открыть"
6) Нажимаете "ОК", затем снова "ОК"
7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
8) В поле Расположение объекта введите:
schtasks /run /tn mytask_admin
где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
9) Введите имя ярлыка и нажмите Готово

Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

Скачать можно здесь или здесь

9. Перемещение профилей пользователей и изменение путей к ним.

Указанные в с 1 по 4 вариантах действия, необходимо повторять для каждого профиля. Переместив таким образом все профили, и изменив их пути в реестре, исходные папки можно будет удалить.

Вариант 1. С помощью компонента Windows - "Профили пользователей".

Копируем профиль пользователя в конечное размещение:

1) Если папка для профиля существует, переходим к следующему шагу, при этом используя рекомендации; если папка, в которой будет храниться профиль, не существует, создаем ее, используя рекомендации.

Рекомендации:

  • Если на компьютере только одна учетная запись, можно присвоить папке профиля имя учетной записи; если учетных записей несколько, лучше всего создать папку верхнего уровня, например, с именем Пользователи, а в нее вложить папки с именами пользователей компьютера, в которых и будут храниться наши профили. Хотя использовать папку верхнего уровня лучше сразу, на случай добавления новых учетных записей;
  • Если конечная папка уже существует и она имеет содержимое, которое необходимо сохранить, ее необходимо скопировать в другое размещение, а затем, после завершения перемещения профилей, переместить это содержимое в папку с профилем пользователя

    • 2) Открываем Свойства системы: команда свойства контекстного меню Моего компьютера или сочетание Windows + Break.
    3) Щелкаем Дополнительные параметры системы. Щелкаем Продолжить, если появится соответствующий запрос системы контроля учетных записей.
    4) Открываем вкладку Дополнительно.
    5) Щелкаем кнопку Параметры в рамке Профили пользователей.
    6) Выбираем профиль, который необходимо переместить. Активный профиль не выбирается. Чтобы его можно было выбрать для осуществления необходимых действий, нужно войти под другой учетной записью и иметь права администратора.
    7) Нажимаем кнопку Копировать.
    8) Выбираем папку, в которой будет находиться профиль, созданную на шаге 1.
    9) Нажимаем OK; если выбранная папка не пустая, система выдаст запрос на копирование профиля в нее, так как при этом удаляется все ее содержимое! (не забудьте о рекомендациях!). Нажимаем Да.

    Вносим изменения в системный реестр.

    1) Открываем меню Выполнить: Пуск -> Выполнить (либо Win+R)
    2) Вводим regedit.exe, нажимаем Enter.
    3) Изменяем значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя.
    Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    4) Перезагружаем компьютер.

    Внесение изменений в системный реестр может привести к снижению стабильности и производительности системы или ее отказу, поэтому настоятельно рекомендуется создать резервную копию реестра перед выполнением данной операции. В данном случае удобно воспользоваться экспортом изменяемого ключа или Восстановлением системы.

    Вариант 2. На другой диск вручную.

    1) Запустите оснастку "Локальные пользователи и группы" (Win+R -> lusrmgr.msc -> Ok)
    2) Включите системную запись администратора. Выбираете "Пользователи". В свойствах пользователя "Администратор" снимаете галку "Отключить пользователя". Если же Вы уже работаете в учетной записи Администратор, то создайте новую учетную запись с правами администратора.
    3) Для полного доступа к файлам и папкам перезапустите компьютер, и зайдите под аккаунтом "Администратор" (или под созданным Вами с правами администратора).

    Указанные выше действия необходимы, потому что профиль под которым Вы зайдете, для осуществления необходимых действий не выбирается. Соответственно залогинившись под одним профилем, Вы можете работать только с другими.

    4) Запустите "Проводник" в режиме администратора:
    Щелкните правой кнопкой мыши на иконке Проводника
    Щелкните правой кнопкой мыши на слове Проводник
    Выберите пункт "Запуск от имени администратора"
    5) Создайте на диске D: папку Users.
    6) Поменяйте права на "D:\Users", исходя из прав на системный Users.
    Оставьте только "Чтение и выполнение" для группы "Everyone"(Все), и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно)
    Владелец папки, установите на "Administrators" (Администраторы).
    7) В Проводнике запущеном от имени Администратора скопируйте необходимую Вам папку пользователя в "D:\Users".

    Так как Проводник не умеет копировать "junction" (точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог), то их придется создавать самостоятельно. Например, "junction" являются папки "Application Data", "Local Settings", "SendTo" и другие.

    8) Запустите командную строку от имени администратора (Win+R -> CMD -> Ok)
    9) Для показа только скрытых файлов введите команду "dir /ah" (без кавычек) и нажмите Enter. Вы увидете примерно следующее:
    C:\Users\ВашПрофиль>dir /ah
Том в устройстве C не имеет метки.
Серийный номер тома: F018-696C

Содержимое папки C:\Users\ВашПрофиль

23.11.2009  20:05    <DIR>          AppData
23.11.2009  20:05    <JUNCTION>     Application Data [C:\Users\ВашПрофиль\AppData\Roaming]
23.11.2009  20:05    <JUNCTION>     Cookies [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Cookies]
23.11.2009  20:05    <JUNCTION>     Local Settings [C:\Users\ВашПрофиль\AppData\Local]
23.11.2009  20:05    <JUNCTION>     My Documents [C:\Users\ВашПрофиль\Documents]
23.11.2009  20:05    <JUNCTION>     NetHood [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Network Shortcuts]
21.01.2010  05:09         4 718 592 NTUSER.DAT
21.01.2010  05:09           262 144 ntuser.dat.LOG1
23.11.2009  20:05                 0 ntuser.dat.LOG2
23.11.2009  20:14            65 536 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TM.blf
23.11.2009  20:14           524 288 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TMContainer00000000000000000001.regtrans-ms
23.11.2009  20:14           524 288 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TMContainer00000000000000000002.regtrans-ms
24.11.2009  00:19            65 536 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TM.blf
24.11.2009  00:19           524 288 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TMContainer00000000000000000001.regtrans-ms
24.11.2009  00:19           524 288 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TMContainer00000000000000000002.regtrans-ms
23.11.2009  20:05                20 ntuser.ini
23.11.2009  20:05    <JUNCTION>     PrintHood [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Printer Shortcuts]
23.11.2009  20:05    <JUNCTION>     Recent [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Recent]
23.11.2009  20:05    <JUNCTION>     SendTo [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\SendTo]
23.11.2009  20:05    <JUNCTION>     Start Menu [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Start Menu]
23.11.2009  20:05    <JUNCTION>     Templates [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Templates]
              10 файлов      7 208 980 байт
              11 папок  22 173 192 192 байт свободно
    10) Создайте аналогичные "Junction" каталоги:

    Способ 1. Вручную для каждого "Junction" каталога.

    1) В командной строке переходите в созданную Вами папку:
    C:\Users\Administrator>d:
D:\>cd Users\ВашПрофиль
    2) И для каждой "Junction" выполняете команду:
    mklink /J <Link> <Target>
    Например: mklink /J "Application Data" "AppData\Roaming"

    Способ 2. Создание bat-файла.

    Если Вам предстоит перенести несколько профилей, то проще будет создать bat-файл, так как "Junction" у Вас скорее всего будут такие же.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "profiles.bat")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    В моем случае получился такой, Вы можете создать аналогичный для своих папок (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):
    mklink /J "Application Data" "AppData\Roaming"
mklink /J "Cookies" "AppData\Roaming\Microsoft\Windows\Cookies"
mklink /J "Local Settings" "AppData\Local"
mklink /J "My Documents" "Documents"
mklink /J "NetHood" "AppData\Roaming\Microsoft\Windows\Network Shortcuts"
mklink /J "PrintHood" "AppData\Roaming\Microsoft\Windows\Printer Shortcuts"
mklink /J "Recent" "AppData\Roaming\Microsoft\Windows\Recent"
mklink /J "SendTo" "AppData\Roaming\Microsoft\Windows\SendTo"
mklink /J "Start Menu" "AppData\Roaming\Microsoft\Windows\Start Menu"
mklink /J "Templates" "AppData\Roaming\Microsoft\Windows\Templates"
    Если у Вас папки имеют русские названия, то для правильной работы данного bat-файла, надо его сохранять в кодировке CP866 (Блокнот Windows, в ней не сохраняет, используйте для этого программы сторонних производителей например: Akelpad).
    11) Присвойте "Junction" каталогам скрытые и системные аттрибуты, как в оригинале.

    Либо, вручную для каждого в командной строке.
    attrib /S /D /L +H +S "имя папки"
    Например: attrib /S /D /L +H +S "Application Data"

    Либо, создав bat-файл (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):
    attrib /S /D /L +H +S "Application Data"
attrib /S /D /L +H +S "Cookies"
attrib /S /D /L +H +S "Local Settings"
attrib /S /D /L +H +S "My Documents"
attrib /S /D /L +H +S "NetHood"
attrib /S /D /L +H +S "PrintHood"
attrib /S /D /L +H +S "Recent"
attrib /S /D /L +H +S "SendTo"
attrib /S /D /L +H +S "Start Menu"
attrib /S /D /L +H +S "Templates"
    12) Запустите Реестр Windows(Win+R -> regedit -> Enter) и измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID c "C:\Users\ВашПрофиль" на "D:\Users\ВашПрофиль" , где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя. Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    13) Переименуйте или удалите каталог профиля в "C:\Users\", чтобы предотвратить к нему запросы.
    14) Перезагрузите компьютер, чтобы Windows подхватила внесенные нами настройки.
    15) Вновь зайдите под аккаунтом Администратор.
    16) Запустите Реестр Windows(Win+R -> regedit -> Enter)
    17) Используя Поиск найдите все строки с путем к папке "C:\Users\ВашПрофиль" и исправьте на "D:\Users\ВашПрофиль" (Чем ближе к чистой установке Вы это сделаете, тем меньше строк Вам придется исправлять).
    18) Поменяйте права на каталог профиля в "D:\Users".
    Установите "Полный доступ" пользователелю - владельцу профиля, и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно).
    Владелец папки, установите на "System".
    19) Перезагрузите компьютер, теперь вы можете войти в перемещенный аккаунт и проделать всё указанное выше для другого профиля.

    Вариант 3. При помощи ERD Commander.

    1) Скачиваете утилиту Junction от SysInternals. Она позволяет создавать точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог.
    2) Копируете junction.exe в C:\Windows\System32
    3) Загружаетесь в Erd Commander.
    4) Выбираете опцию, чтобы реестр не импортировася
    5) Копируете например: "C:\Documents and Settings\ВашПрофиль" в "D:\Users\ВашПрофиль"
    6) После копирования, удаляете "C:\Documents and Settings\ВашПрофиль"
    7) Запускаете командную строку и переходите в папку C:\Windows\System32
    c:\
cd\windows
cd system32
junction.exe "C:\Documents and Settings\ВашПрофиль" "D:\Users\ВашПрофиль"
    8) После сообщения Sucsess, можете зайти в папку проверяем C:\Documents and Settings\ и увидите там папку ВашПрофиль, только это уже ссылка...

    Вариант 4. При помощи Far Manager.

    1) Скачиваете Far Manager и устанавливаете его.
    2) Входите в систему под другим пользователем с правами администратора
    3) Запускаете Far Manager
    4) Находите нужный профиль пользователя.
    5) Перемещаете папку с ним на другой диск (например, C:\Documents and Settings\ВашПрофиль -> D:\Users\ВашПрофиль).
    6) Устанавливаете на перемещённую папку нужные права и нужного владельца.
    7) Создаёте на исходном разделе символическую связь с новой папкой (Alt+F6).
    8) На новую папку ставите атрибут "Скрытый".

    Вариант 5. Изменение пути к каталогам пользователей при установке Windows.

    Вы можете изменить расположение папки Пользователи (Users), в которой будут храниться профили пользователей, ещё при установке Windows.

    1) Создайте файл Autounattend.xml следующего содержания:
    2) Скопируйте его в папку \Sources установочного диска.
    3) Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="oobeSystem">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <FolderLocations>
    <ProfilesDirectory>D:\Users</ProfilesDirectory>
    </FolderLocations>
    </component>
    </settings>
    <settings pass="specialize">
    <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <EnableLUA>false</EnableLUA>
    </component>
    </settings>
    </unattend>

    10. Отключение отображения имени последнего пользователя.
    Для отключения запоминания имени последнего пользователя отображаемого на эране переключения пользователей.

    1) Нажмите Пуск, в строке поиска введите secpol.msc и нажмите Enter
    2) Раскройте группу Локальные политики и перейдите к разделу Параметры безопасности
    3) Используя двойной щелчок мыши откройте параметр Интерактивный вход в систему: не отображать последнее имя пользователя и выберите состояние Включен
    Этот параметр безопасности определяет, будет ли в экране входа в Windows отображено имя последнего пользователя, выполнившего вход.
    Если эта политика включена, в диалоговом окне входа не будет отображаться имя последнего пользователя, выполнившего вход.
    Если эта политика отключена, отображается имя последнего пользователя, выполнившего вход.

    Интерфейс

    1. Как открыть диспетчер задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту?

    Вариант 1

    Используйте ctrl+shift+esc.

    Вариант 2

    Правой кнопкой на панели задач --> Start Task Manager

    2. Использование средней кнопкой мыши при работе с панелью задач.

    Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

    3. Как уменьшить размер иконки на рабочем столе ?

    1) Правый клик на рабочем столе - Вид - Мелкие значки;
    2) Нажимаем Сtrl и крутим колесико.

    4. Управление заготовками положений размеров окон.

    Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

    5. Где скачать и как установить дополнительные темы для Windows 7?

    Скачать дополнительные темы для Вашей Windows 7 Вы можете на оффициальной странице тем от Microsoft: Персонализация компьютера
    После скачивания понравившейся Вам темы, нажмите на скачавшийся themepack-файл и Windows автоматически его установит.
    Также дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT.

    Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
    Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
    C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
    C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
    C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
    C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
    C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

    6. Как перезапустить рабочий стол?

    Откройте Task Manager - вкладка Applications - нажимаете кнопку New task - далее кнопку Browse - переходите в папку Windows и выбираете explorer.exe, затем нажимаете ОК (это же действие можно выполнить через ярлык).

    7. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

    1) Щелкаем правой кнопкой на Компьютер (например в Пуске) и выбираем Управление
    2) В левом окне выбираем Управление дисками
    3) Посередине вверху смотрим, какие из томов не имеют букву. Среди них должен быть раздел размером 200 МБ. Его НЕ трогать!!!
    4) Присваиваем букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкаем на нем правой кнопкой и в контекстном меню выбираем Изменить букву диска или путь к диску. Жмем Добавить. Выбираем букву. Жмем OK.
    5) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
    Также должна стоять галочка в Панель управления-Параметры папок-Вид "Отображать буквы дисков"

    8. Включение и отключение Области переходов.

    Область переходов – это специальная панель (дерево папок), которая находится слева в каждой папке.
    Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
    При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

    Включить или отключить Область переходов можно так:

    1) Нажмите вверху слева Упорядочить->Представление
    2) Поставьте или уберите галочку в пункте Область переходов

    9. Изменение ширины меню Пуск.

    Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui
    113, "0, 0, 406, 440"
    114, "0, 0, 145, 75"
    115, "0, 0, 64, 64"
    116, "0, 0, 145, 44"
    117, "0, 0, 261, 30"
    118, "0, 0, 145, 332"
    119, "0, 0, 261, 383"
    120, "0, 0, 261, 37"
    121, "0, 0, 400, 50"

    10. Изменение прозрачности окон в Windows 7.

    До | После
Рисунок 1 из 2 | Рисунок 2 из 2

    Выключить матовый-стеклянный (Blur эффект) и включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

    Инструкция:

    1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
    2. Это займет немного времени и вы увидите окно без эффекта матовости.
    3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
    4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
    Изменения становятся видимыми после перезагрузки.

    Сайт автора скрипта

    11. Открытие командной строки из конкретной папки.

    Одной из самых популярных утилит в наборе Windows XP Power Toys был пункт контекстного меню проводника «Открыть командную строку отсюда» (“Open Command Prompt Here”).
    В Windows 7 этот пункт есть в контекстном меню, для его использования при вызове меню нужно удерживать клавишу Shift, вследствие чего в меню появляется пункт "Открыть окно команд".

    12. Как улучшить качество передачи цветов монитором?

    Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова мастера кликните Start, введите DCCW и нажмите <Enter>.

    13. Включение Flip3D — отображение окон под углом.

    1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
    2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
    3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

    14. Как расширить функциональность часов в трее или изменить их вид?

    Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

    15. Использование переменных окружения для быстрого перехода к системным папкам.

    Чтобы узнать какие из них присутствуют в вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения вашей Windows.

    %AllUsersProfile% - C:\ProgramData
    %AppData% - C:\Users\%UserName%\AppData\Roaming
    %CommonFavorites% - C:\Documents and Settings\All Users\Избранное
    %CommonFiles% - C:\Program Files\Common Files
    %CommonProgramFiles% - C:\Program Files\Common Files
    %CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
    %ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
    %HomePath% - C:\Users\Administrator
    %LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
    %ProgramData% - C:\ProgramData
    %ProgramFiles% - C:\Program Files
    %ProgramFiles(x86)% - C:\Program Files (x86)
    %PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
    %SystemDir% - C:\Windows\System32
    %SystemDrive% - C:\
    %SystemRoot% - C:\Windows
    %Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
    %Tmp% - C:\Users\%UserName%\AppData\Local\Temp
    %UserProfile% - C:\Users\%UserName%
    %windir% - C:\Windows

    Если вы решите создать собственную переменную типа:
    %MyFolder%=C:\MyFolder

    1) Пройдите:
    Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
    2) Нажмите Создать...
    3) Укажите Имя перменной и Значение переменной
    4) Нажмите на каждое Ок
    5) Перезагрузите компьютер (иначе она не будет работать)

    16. Использование флажков для выделения (выбора) файлов и папок.

    В Windows есть удобная возможность помечать для выделения фалы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
    Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое срыто по умолчанию.
    Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
    Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
    Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

    17. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

    Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это пожно с помощью бесплатной программы 7Stacks.

    Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д. Для работы с программой надо создать папку и сложить туда ярлыки приложений, нужных нам в создаваемом меню. Потом запускаем 7Stacks, выбираем эту папку, настраиваем оформление и создаем ярлык на рабочем столе. Перетаскиваем его в панель задач. Вот и все.

    18. Добавление дополнительных операций к окнам.

    К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

    Добавляет дополнительные функции для окон:
    • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
    • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
    • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
    • и многие другие.
    Скачать программу

    19. Добавление командной строке эффекта прозрачности - Aero Glass.

    Для добавления командной строке эффекта прозрачности (Aero Glass) сделайте следующее:

    1) Скачайте архив: Glass_CMD.zip
    2) Распакуйте его и запустите исполняемый файл минискрипта Glass CMD.exe.
    3) Запустите командную строку(Win+R -> CMD ->Ok) и увидите эффект прозрачности (Aero Glass).
    Для использования данного эффекта скрипт Glass CMD.exe должен быть запущен. При закрытии Glass CMD.exe эффект прозрачности пропадет.
    При желании Вы можете добавить данный скрипт-программу в папку Автозагрузка в меню Пуск.
    Если Вы не хотите, чтобы в области уведомлений (трее) отображался значок скрипта, то в файле Settings.ini, который идет в архиве в комплекте с исполняемым файлом скрипта, установите значение параметра HideTrayIcon равным 1.

    20. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

    В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

    21. Как узнать цветовой код любой точки экрана на мониторе?

    Для того чтобы узнать цветовой код любой точки экрана на Вашем мониторе скачайте и установите небольшую, но функциональную программу ColorPic.

    Данная программа абсолютно бесплатна и Вы можете скачать её с официального сайта: http://www.iconico.com/colorpic/index.aspx

    Мощные средства для регулировки цвета позволяют Вам с легкостью менять индивидуальные цвета. С помощью четырех графических миксеров Вы сможете регулировать RGB, оттенки, насыщенность и код цвета. У Вас будет возможность просматривать CMYK печатные коды цвета, а для идеальной точности использовать увеличитель экрана. Вы сможете сохранять множество цветовых палитр для их использования в любом приложении.

    Содержащийся в программе раздел "Mixer" предоставляет Вам четыре мощных графических способа для анализа и изменения выбранного цвета. Цвета могут быть выбраны из любых шестиугольных форм, измененных миксером или настроенных шестью индивидуальными слайдерами для оттенков, насыщенности, кода и красных, зеленых и голубых цветовых компонентов. ColorPic также делает отчеты для регулировки голубого, пурпурного, желтого и черного цветовых кодов.

    Кроме того, ColorPic также предлагает возможность увеличения, предоставляя Вам супер детальную картинку при выборе цвета. Программа имеет простой в использовании слайдер для увеличения, который позволяет Вам выбирать или разовую пробу или 3x3 или 5x5 средний цвет из любого места на Вашем экране.

    Будучи неоценимым средством для любого графического дизайнера или веб-разработчика и будучи постоянно самым популярным бесплатным цветоподборщиком в сети, самая последняя версия ColorPic предлагает мощные средства для выбора цвета, которые до сих пор доступны только в дорогих приложениях.

    Использовать программу очень просто:

    1) Запускаете программу
    2) Наводите курсор в то место, цвет которого желаете узнать.
    3) Нажимаете Ctrl+G и в первой ячейке сохраняется информация о цвете.
    4) Затем выделяете следующую ячейку и проделываете указанное выше для определения другого цвета.

    Сети (Интернет и Локальная)

    1. Как сменить поиск по умолчанию в Firefox?

    Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

    1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
    2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
    3) Меняете его значение (без кавычек) на:

    "http://www.google.com/search?&q=" - Google.Com
    "http://yandex.ru/yandsearch?text=" - Yandex.Ru
    "http://www.bing.com/search?q=" - Bing.Com

    2. У сетевого адаптера Marvell Yukon сеть отключается через каждые 5 минут.

    Отменить в настройках Marvell Yukon "Разрешить этому устройству откл. для экономии энергии".

    3. Где можно объединить и удалить сети?

    Нажмите на скамейку.

    4. Как сделать так, чтобы интернет включался при запуске Windows в "невидимом режиме"?

    Control Panel\Network and Internet\Сетевые подключения\свойства ADSL. Во вкладке параметры сними галочки: отображать ход подключения, запрашивать имя и пароль. Ярлык ADSL поместите в папку автозагрузки.

    5. Как сделать, чтобы VPN подключение интернет происходило автоматически при запуске Windows?

    Вариант 1

    Вы можете добавить задачу в Планировщик заданий.
    1) Откройте планировщик задний из меню Пуск - Администрирование - Планировщик заданий или выполнив команду taskschd.msc из меню Пуск - Поиск.
    2) Нажмите создать задачу

    Вкладка Имя - Имя подключения
    Размещение оставляем как есть.

    Вкладка Триггеры-Создать-Начать задачу: При входе в систему

    Вкладка Действия-Создать
    Действие:Запуск программы
    Программа или сценарий: rasdial "имя подключения" пользователь пароль

    Вкладка Параметры-Создать
    Поставить галочки:
    Немедленно запускать задачу, если пропущен плановый запуск
    При сбое выполнения перезапускать через 1 мин.
    Количество попыток перезапуска 99.
    Убрать галочку:
    Останавливать задачу выполняемую дольше

    Вариант 2

    Наличие скриптов в одной папке connect.bat обязательно.
    1) По ссылке ниже берете скрипт (bat-файл)
    2) Настраиваете его под себя (имя соединения, логин,пароль)
    3) Сохраняете(выкладываете) исправленный файл на рабочий стол, называете его "connect.bat"
    connect1.zip
    4) Затем берете архив со скриптом скрытого запуска отсюда
    hs_exec.zip
    hide_programm.zip
    5) Извлекаем файлы из архива и кладем в ту же самую папку где лежит файл "connect.bat" запускаем либо "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd.
    6) Для автоматической загрузки добавляем в Автозагрузка ярлык (не сам файл скрипта) для "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd

    Вариант 3

    Создайте маленький bat-файл(типа Connect.bat) следующего содержания, положите его на рабочий стол и запускайте через него при случайном разрыве (имя подключения должно быть на английском иначе может быть ошибка 623):
    @echo off

    set conn="Golden Telecom"
    :: название вашего подключения к интернету

    set login="loginname@golden.ru"
    :: ваш логин подключения к интернету

    set pass="12345678"
    :: ваш пароль подключения к интернету

    set pause=10
    :: пауза в секундах между проверкой соединения, если соединение разорвалось произойдет подключение

    rasdial %conn% %login% %pass%

    exit

    6. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

    Переименуйте имя соединения на английский язык и всё должно заработать.

    7. Как просмотреть исходный код любой страницы в интернете.

    Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

    В Firefox

    Установите расширение Web Developer.
    Затем в меню Web Developer -> Код -> Сгенерированный код.
    Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
    Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

    В Internet Explorer

    Меню Сервис -> Средства разработчика
    Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.

    Тонкие настройки

    1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

    Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново.
    Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

    Отключаем ее:
    1. Создайте пустой текстовый файл,
    2. Скопируйте в него powercfg -h off,
    3. При сохранении изменить расширение "TXT" на "CMD",
    4. Запустите его как обычную программу,
    5. Перезагрузка.

    Также Вы можете запустить командную строку с правами администратора (Нажать Win+R, ввести Cmd и нажать Ok) и выполнить в ней данную команду:
    powercfg /h off

    2. Как скрыть значок "Центр действий" в трее возле часов?

    1) Пройдите Пуск\Панель управления\Значки области уведомлений
    2) Выберите значки которые хотите скрыть и нажмите Ok

    3. Как убрать текст под значком ярлыка или файла?

    1) Щелкните правой кнопкой мыши на иконке.
    2) Кликните Переименовать.
    3) Удерживая клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
    Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
    Если вы захотите переименовать несколько ярлыков, то, когда вы будете переименовывать следующий, вам потребуется нажать Alt и ввести 255 дважды. Так для третьего значка вам потребуется ввести ALT+255, ALT+255, ALT+255.

    4. Создаем (восстанавливаем) панель быстрого запуска (Quick Launch).

    1) Правой кнопкой по панели задач ->Панели(Toolbars )-->Создать панель инструментов(New Toolbar)-->
    2) Выберите папку: %appdata%\Microsoft\Internet Explorer\Quick Launch
    3) Нажмите кнопку выбора папки “Select Folder”.
    4) Правой кнопкой на панели задач -> снять галку "Закрепить панель задач";
    5) Правой кнопкой мыши на появившемся "quick launch"--->убираем галки с "Показывать подписи" и "Показывать заголовок"
    6) Перетаскиваем в левую сторону и закрепляем обратно панель --->Все!

    5. Удаление или разблокирование для замены любого файла защищённого Windows.

    1. Качаем и устанавливаем программу Unlocker
    2. Копируем файл(ы) в буфер обмена, для дальнейшей замены.
    3. С помощью программы Unlocker, удаляем заменяемый(е) файл(ы).
    4. После удаления файла(ов), вставляем заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления) и перезагружаем компьютер.
    P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, переходим к папке C:\Windows\rescache и с помощью этой же программы Unlocker удаляем её содержимое. Перезагружаемся.

    Для 64-битных систем аналогом является программа LockHunter 64-bit.

    6. Убираем лишние надписи на рабочем столе.

    Открываете с помощью Restorator или PE Explorer файлы C:\Windows\System32\ru-RU\user32.dll.mui и C:\Windows\System32\en-US\user32.dll.mui и в строковой таблице удаляем строчки с 715 по 718 включительно и строки 737 и 738 , для того чтобы лишних надписей на рабочем столе не было.

    715 %wsWindows %ws
    716 %ws Сборка %ws
    717 Пробная копия.
    718 Только для тестов.

    737 Ваша копия Windows не является подлинной
    738 Тестовый режим

    7. Смена названия операционной системы из Максимальная на Ultimate.

    Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

    8. Использование всей оперативной памяти в 32-битных Windows.

    Данная программа добавляет второе ядро для загрузки операционной системы: ntkr128g.exe

    1) Скачать здесь автоскрипт от deepxw.
    2) 3апустить ReadyFor4GB.exe
    3) Нажать на кнопку Check, затем на кнопку Apply.
    4) Перезагрузить компьютер и вам станут доступны все 4 ГБ оперативки на вашей установленной ОС Windows 7 (x86), или если у вас установлено более >4ГБ, то ваш объем Оперативной памяти также станет доступен в полном объеме без ограничений...

    Примечание: Файлы обязательно запускать как администратор, запускайте этот скрипт строго в операционной системе Windows 7 x86 (32-Bit) для которой вам нужно снять ограничение.

    Статья (на английском), объясняющая принцип работы данной программы: http://www.geoffchappell.com/viewer.htm?doc=notes/windows/license/memory.htm

    9. Изменение папки открываемой по умолчанию в Проводнике.

    Настраиваем нажатие на кнопку Проводник (Windows Explorer), чтобы оно приводило в указанную Вами папку, вместо Libraries.

    1) Нажмите правой кнопкой мыши на значок Проводника в Панели задач.
    2) Нажмите правой кнопкой мыши на Проводник
    3) Нажмите левой кнопкой мыши на Свойства
    4) Измените поле Объект (Target) на %SystemRoot%\explorer.exe /n, /e, С:\My Folder
    где C:\My Folder - путь к Вашей папке.
    Для запуска папки Компьютер измените на значение: %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
    Чтобы это изменение затронуло и ссылку в меню Пуск, то вам потребуется изменить поле Объект в свойствах ярлыка Проводник в папке Стандартные (Accessories) из меню Пуск.
    Комбинация клавиш Win+E откроет Проводник в «Компьютере»

    10. Добавление или прямой запуск папки Все задачи (Расширенная Панель Управления).

    Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

    Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

    All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

    Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

    shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

    11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.
    Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
    Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

    1) Нажмите кнопку "Пуск",
    2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
    3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
    4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

    В выпадающем списке выберите подходящее для Вас значение.

    12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

    У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

    Если в настройках фонового рисунка рабочего стола, вызываемых:
    1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
    2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
    Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

    Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
    cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

    Вы можете создать новую библиотеку и добавить в неё Ваши папками.

    1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:
    shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
    2) Нажимаете ПКМ -> Создать -> Библиотека
    3) Переименовываете её. Например: Обои для рабочего стола
    4) Щелкаете ПКМ и выбираете Свойства
    5) Добавляете отдельно каждую папку
    6) В графе Оптимизировать эту библиотеку: выбираете Изображения
    7) Нажимаете применить, затем Ок.
    8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

    Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки,в которой он находится).

    Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

    Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

    Её ключевые возможности:
    - Создание библиотеки из произвольного набора папок.
    - Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
    - Переименование библиотеки.
    - Указание типа содержимого новой или редактируемой библиотеки.
    - Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
    - Управление отображением библиотеки в панели навигации проводника.
    - Отображение библиотеки в виде XML-файла.
    - Отображение системного диалога папок, включенных в библиотеку.

    Скачать данную программу можно здесь или здесь

    13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.
    Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

    Для установки необходимы права локального администратора.

    1) Скачайте архив MouseRate.zip и распакуйте его в папку.
    2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
    3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
    4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
    5) Откройте папку HIDUSBF
    6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
    7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
    8) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

    Если у Вас появится сообщение о неподписанных драйверах - не волнуйтесь, все нормально. Подпишем его программой Driver Signature Enforcement Overrider, о которой упоминалось в совете Как добавить подпись к драйверам? из раздела Установка. На время её работы UAC(Контроль учетных записей пользователей) в Windows должен быть отключен.

    1) Запустите файл dseo13b.exe из папки Driver Signature Enforcement Overrider и выберите там "Enable Test Mode".
    2) Перезапустите компьютер.
    3) После перезапуска снова откройте файл dseo13b.exe и выберите "Sign a system file".
    4) В окне пропишите: "C:\Windows\System32\Drivers\HIDUSBF.sys". Если вы сделали это правильно, то вы увидите сообщение: "Система была подписана успешно" ("The system file has been signed succesfully")
    5) Снова перезапустите компьютер.
    6) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
    7) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

    14. Перемещение системных папок и изменение их путей.

    Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящимися в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

    Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей продеайте следующее:

    1) Создайте новую папку, желательно с аналогичным перемещаемой папке наименованием.
    2) Откройте в Windows Explorer: Рабочий стол\Ваш Профиль (Например: Рабочий стол\Администратор)
    3) Щелкните правой кнопкой мыши на название папки, которую Вы собираетесь переместить (Например: Мои Документы) и выберите Свойства.
    4) Откройте вкладку Расположение
    5) Нажмите кнопку Переместить и укажите путь к созданной Вами новой папке
    6) Далее система спросит Вас: Переместить все файлы из старого расположения в новое? (Рекомендуемый ответ - Да)
    7) Соглашаетесь с новыми параметрами применяя их и выходите.
    8) Перезагружаете Компьютер.

    15. Запуск команд Windows Shell, используя названия и {GUID} объектов.

    Microsoft Windows Shell - интерпретатор команд операционной системы (ОС), обеспечивающий интерфейс для взаимодействия пользователя с функциями системы. Позволяет получить доступ к диалоговым окнам, к файловой системе, запускать программы и изменять системные настройки.
    Для быстрого перехода к компонентам Windows используется команда shell.
    GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Использование GUID гарантирует, что две версии одного компонента могут иметь одно и то же имя, но быть отличимыми по GUID. Microsoft применяет GUID в качестве идентификаторов для большого количества своих объектов. Зная GUID Вы сможете открыть многие компоненты Windows: элементы Панели управления, системные папки, различные программы и настройки.

    Для запуска любого из объектов Windows, используя {GUID}, применяется команда:
    Shell:::{GUID}
    где {GUID} - идентификатор {GUID} нужного Вам объекта. Например, для запуска Панели управления наберите команду:
    Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
    Вы можете поискать нужные Вам {GUID} в разделе реестра HKEY_CLASSES_ROOT\CLSID или воспользоваться таблицей №1.

    Таблица №1.

    Русское название элемента | Английское название элемента | Команда
Flip 3D (Win+Tab) | Flip 3D (Win+Tab) | Shell:::{3080F90E-D7AD-11D9-BD98-0000947B0257}
Fusion Cache | Fusion Cache | Shell:::{1D2680C9-0E2A-469d-B787-065558BC7D43}
Internet Explorer | Internet Explorer | Shell:::{871C5380-42A0-1069-A2EA-08002B30309D}
Microsoft Outlook | Microsoft Outlook | Shell:::{2559a1f5-21d7-11d4-bdaf-00c04f60b9f0}
Windows CardSpace | Windows CardSpace | Shell:::{78CB147A-98EA-4AA6-B0DF-C8681F69341C}
Windows SideShow | Windows SideShow | Shell:::{E95A4861-D57A-4be1-AD0F-35267E261739}
Автозапуск | AutoPlay | Shell:::{9C60DE1E-E5FC-40f4-A487-460851A8D915}
Автономные файлы | Offline Files | Shell:::{D24F75AA-4F2B-4D07-A3C4-469B3D9030C4}
Администрирование | Administrative Tools | Shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Архивация и восстановление | Backup and Restore | Shell:::{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}
Библиотеки | Libraries | Shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Биометрические устройства | Biometric Devices | Shell:::{0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}
Брандмауэр Windows | Windows Firewall | Shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423}
Восстановление | Recovery | Shell:::{9FE63AFD-59CF-4419-9775-ABCC3849F861}
Восстановление системы | System Restore | Shell:::{3f6bc534-dfa1-4ab4-ae54-ef25a74e0107}
Все задачи | All Tasks | Shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Все элементы панели управления | All Control Panel Items | Shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Выполнить | Run | Shell:::{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}
Гаджеты рабочего стола | Desktop Gadgets | Shell:::{37efd44d-ef8d-41b1-940d-96973a50e9e0}
Дата и Время | Date and Time | Shell:::{E2E7934B-DCE5-43C4-9576-7FE4F75E7480}
Датчик расположения и другие датчики | Location and Other Sensors | Shell:::{E9950154-C418-419e-A90A-20C5287AE24B}
Диспетчер устройств | Device Manager | Shell:::{74246bfc-4c96-11d0-abef-0020af6b0b7a}
Диспетчер учетных данных | Credential Manager | Shell:::{1206F5F1-0569-412C-8FEC-3204630DFB70}
Домашняя группа | HomeGroup | Shell:::{67CA7650-96E6-4FDD-BB43-A8E774F73A57}
Домашняя группа - папка | HomeGroup folder | Shell:::{6785BFAC-9D2D-4be5-B7E2-59937E8FB80A}
Защитник Windows | Windows Defender | Shell:::{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}
Звук | Sound | Shell:::{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}
Значки области уведомлений | Notification Area Icons | Shell:::{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}
Игровые устройства | Game Controllers | Shell:::{259EF4B1-E6C9-4176-B574-481532C9BCE8}
Игры | Games | Shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
Избранное | Favorites | Shell:::{323CA680-C24D-4099-B94D-446DD2D7249E}
Инфракрасная связь | Infrared | Shell:::{A0275511-0E86-4ECA-97C2-ECD8F1221D08}
Карта сети | Network Map | Shell:::{E7DE9B1A-7533-4556-9484-B26FB486475E}
Компоненты Windows | Windows Features | Shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Компьютер | Computer | Shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина | Recycle Bin | Shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Мои Документы | My Documents | Shell:::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Настройка доступа программ и умолчаний | Set Program access and Windows defaults | Shell:::{2559a1f7-21d7-11d4-bdaf-00c04f60b9f0}
Недавние места | Recent Places | Shell:::{22877a6d-37a1-461a-91b0-dbda5aaebc99}
Общие | Public | Shell:::{4336a54d-038b-4685-ab02-99bb52d3fb8b}
Панель управления (заданного Вами вида) | Control Panel | Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Панель управления (Категория) | Control Panel (Category) | Shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Параметры индексирования | Indexing Options | Shell:::{87D66A43-7B11-4A28-9811-C86EE395ACF7}
Параметры папок | Folder Options | Shell:::{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}
Параметры планшетного компьютера | Tablet PC Settings | Shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}
Параметры шрифта | Font settings | Shell:::{93412589-74D4-4E4E-AD0E-E0CB621440FD}
Переносные устройства | Portable Devices | Shell:::{35786D3C-B075-49b9-88DD-029876E11C01}
Перо и сенсорные устройства | Pen and Touch | Shell:::{F82DF8F7-8B9F-442E-A48C-818EA735FF9B}
Персонализация | Personalization | Shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | Shell:::{241D7C96-F8BF-4F85-B01F-E2B043341A4B}
Поиск Windows | Search | Shell:::{2559a1f0-21d7-11d4-bdaf-00c04f60b9f0}
Получение программ | Get Programs | Shell:::{15eae92e-f17a-4431-9f28-805e482dafd4}
Принтеры | Printers | Shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Приступая к работе | Getting Started | Shell:::{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}
Программы и компоненты | Programms and Features | Shell:::{7b81be6a-ce2b-4676-a29e-eb907a5126c5}
Программы по умолчанию | Default Programs | Shell:::{17cd9488-1228-4b2f-88ce-4298e93e0966}
Рабочий стол | Desktop | Shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}
Распознавание речи | Speech Recognition | Shell:::{58E3C745-D971-4081-9034-86E34B30836A}
Расположение по умолчанию | Default Location | Shell:::{00C6D95F-329C-409a-81D7-C46C66EA7F33}
Родительский контроль | Parental Controls | Shell:::{96AE8D84-A250-4520-95A5-A47A7E3C548B}
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | Shell:::{0DF44EAA-FF21-4412-828E-260A8728E7F1}
Свойства речи | Text to Speech | Shell:::{D17D1D6D-CC3F-4815-8FE3-607E7D5D10B3}
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | Shell:::{A304259D-52B8-4526-8B1A-A1D6CECC8243}
Свойства: Интернет | Internet Properties | Shell:::{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}
Свойства: Клавиатура | Keyboard Properties | Shell:::{725BE8F7-668E-4C7B-8F90-46BDB0936430}
Свойства: Мышь | Mouse Properties | Shell:::{6C8EEC18-8D75-41B2-A177-8831D59D2D50}
Сетевые подключения | Network Connections | Shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сетевые подключения в Области уведомления | Network Connections in Notification area | Shell:::{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}
Сеть | Network | Shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Система | System | Shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE}
Сканеры и камеры | Scanners and Cameras | Shell:::{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}
Соседние пользователи | People Near Me | Shell:::{5224F545-A443-4859-BA23-7B5A95BDC8EF}
Справка и Поддержка | Windows Help and Support | Shell:::{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}
Счетчики и средства производительности | Performance Information and Tools | Shell:::{78F3955E-3B90-4184-BD14-5397C15F1EFC}
Телефон и модем | Phone and Modem | Shell:::{40419485-C444-4567-851A-2DD7BFA1684D}
Управление беспроводными сетями | Manage Wireless networks | Shell:::{1FA9085F-25A2-489B-85D4-86326EEDCD87}
Управление цветом | Color Management | Shell:::{B2C761C6-29BC-4f19-9251-E6195265BAF1}
Установленные обновления | Installed Updates | Shell:::{d450a8a1-9568-45c7-9c0e-b4f9fb4537bd}
Устранение неполадок | Troubleshooting | Shell:::{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}
Устройства Bluetooth | Bluetooth Devices | Shell:::{28803F59-3A75-4058-995F-4EE5503B023C}
Устройства и принтеры | Devices and Printers | Shell:::{A8A91A66-3A7D-4424-8D24-04E180695C7A}
Учетные записи пользователей | User Accounts | Shell:::{60632754-c523-4b62-b45c-4172da012619}
Центр мобильности Windows | Windows Mobility Center | Shell:::{5ea4f148-308c-46d7-98a9-49041b1dd468}
Центр обновления Windows | Windows Update | Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
Центр поддержки | Action Center | Shell:::{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}
Центр синхронизации | Sync Center | Shell:::{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}
Центр специальных возможностей | Ease of Access Center | Shell:::{D555645E-D4F8-4c29-A827-D93C859C4F2A}
Центр управления сетями и общим доступом | Network and Sharing Center | Shell:::{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}
Шифрование диска BitLocker | BitLocker Drive Encryption | Shell:::{D9EF8727-CAC2-4e60-809E-86F80A666C91}
Экран (размер текста) | Display (size of text) | Shell:::{C555438B-3C23-4769-A71F-B6D3D9B6053A}
Электропитание | Power Options | Shell:::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Язык и региональные стандарты | Region and Language | Shell:::{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

    Для некоторых системных папок, Вы можете создать их копии, в любом, необходимом для Вас месте. Такие папки не будут занимать место на диске, а будут служить символическими ссылками на оригинальные. Для создания такой папки-ссылки:

    1) Создайте в любом нужном Вам месте новую папку (Щелчок ПКМ -> Создать -> Папку)
    2) Переименуйте её следующим образом:

    Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
    Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
    Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
    Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
    Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
    Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
    Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
    Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
    Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
    Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
    Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

    Принцип запуска команд Shell, используя имя объектов, намного легче. Данный способ не требует от Вас знания большого количества цифр и букв, и позволяет снизить величину ошибок при наборе команды. Его основное применение - открытие системных папок.

    Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет в проводнике будет открыта папка: C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

    Для запуска любого из объектов Windows, используя его имя, применяется команда:
    Shell:Имя объекта
    Вы можете найти нужные Вам имена объектов в разделах ветки реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FolderDescriptions или воспользоваться таблицей №2.

    Таблица №2.

    Имя программы или папки | Адрес папки | Команда
32-разрядный Internet Explorer | C:\Program Files\Internet Explorer или C:\Program Files (x86)\Internet Explorer | shell:InternetFolder
Common Files (в 32-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommon
Common Files (в 64-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommonX64
Common Files (в 64-битной Windows 7) | C:\Program Files (x86)\Common Files | shell:ProgramFilesCommonX86
Cookies | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies | shell:Cookies
Credentials | C:\Users\User-Name\AppData\Roaming\Microsoft\Credentials | shell:CredentialManager
Crypto | C:\Users\User-Name\AppData\Roaming\Microsoft\Crypto | shell:CryptoKeys
DeviceMetadataStore | C:\ProgramData\Microsoft\Windows\DeviceMetadataStore | shell:Device Metadata Store
Documents | C:\Users\Public\Documents | shell:Common Documents
Fonts (шрифты) | C:\Windows\Fonts | shell:Fonts
Gadgets | C:\Program Files\Windows Sidebar\Gadgets | shell:default Gadgets
Gadgets | C:\Users\User-Name\AppData\Local\Microsoft\WindowsSidebar\Gadgets | shell:Gadgets
GameExplorer | C:\ProgramData\Microsoft\Windows\GameExplorer | shell:PublicGameTasks
GameExplorer (Обозреватель игр) | C:\Users\User-Name\AppData\Local\Microsoft\Windows\GameExplorer | shell:GameTasks
History | C:\Users\User-Name\AppData\Local\Microsoft\Windows\History | shell:History
ImplicitAppShortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts | shell:ImplicitAppShortcuts
Local | C:\Users\User-Name\AppData\Local | shell:Local AppData
LocalLow | C:\Users\User-Name\AppData\LocalLow | shell:LocalAppDataLow
Low | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies\Low | shell:Cookies\Low
Network Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\NetworkShortcuts | shell:NetHood
Printer Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\PrinterShortcuts | shell:PrintHood
Program Files | C:\Program Files | shell:ProgramFiles
Program Files (x86) (в 64-битной Windows 7) | C:\Program Files (x86) | shell:ProgramFilesX86
Program Files (в 64-битной Windows 7) | C:\Program Files | shell:ProgramFilesX64
ProgramData | C:\ProgramData | shell:Common AppData
Protect | C:\Users\User-Name\AppData\Roaming\Microsoft\Protect | shell:dpapiKeys
Quick Launch (Быстрый запуск) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch | shell:Quick Launch
Resources (содержит темы Windows) | C:\Windows\Resources | shell:ResourceDir
Ringtones | C:\ProgramData\Microsoft\Windows\Ringtones | shell:CommonRingtones
Roaming | C:\Users\User-Name\AppData\Roaming | shell:AppData
SendTo (элементы контекстного меню Отправить) | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\SendTo | shell:SendTo
System32 | C:\Windows\System32 | shell:System
SystemCertificates | C:\Users\User-Name\AppData\Roaming\Microsoft\SystemCertificates | shell:SystemCertificates
SysWOW64 | C:\Windows\SysWOW64 | shell:SystemX86
Templates | C:\ProgramData\Microsoft\Windows\Templates | shell:Common Templates
Templates | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Templates | shell:Templates
Temporary Internet Files | C:\Users\User-Name\AppData\Local\Microsoft\Windows\TemporaryInternet Files | shell:Cache
User Pinned (Закрепленные элементы) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned | shell:User Pinned
User-Name (файлы Вашей учетной записи) | C:\Users\User-Name | shell:UsersFilesFolder
User-Name (Ваш учетный профиль) | C:\Users\User-Name | shell:Profile
Windows (главная папка системы) | C:\Windows | shell:Windows
Автозагрузка | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup | shell:Common Startup
Автозагрузка | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup | shell:Startup
Администрирование | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Administrative Tools
Администрирование | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Common Administrative Tools
Библиотеки | Библиотеки | shell:Libraries
Библиотеки | Библиотеки | shell:UsersLibrariesFolder
Видео | Библиотеки\Видео | shell:VideosLibrary
Временная папка для записи | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Burn\Burn | shell:CD Burning
Все элементы панели управления | Панель управления\Все элементы панели управления | shell:ControlPanelFolder
Главное меню | C:\ProgramData\Microsoft\Windows\Start Menu | shell:Common Start Menu
Главное меню | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu | shell:Start Menu
Документы | Библиотеки\Документы | shell:DocumentsLibrary
Домашняя группа | Домашняя группа | shell:HomeGroupFolder
Загрузки | C:\Users\User-Name\Downloads | shell:downloads
Згрузки | C:\Users\Public\Downloads | shell:CommonDownloads
Игры | Игры | shell:Games
Избранное | C:\Users\User-Name\Favorites | shell:Favorites
Изображения | C:\Users\Public\Pictures | shell:CommonPictures
Изображения | C:\Users\User-Name\Pictures | shell:My Pictures
Изображения | Библиотеки\Изображения | shell:PicturesLibrary
Компьютер | Компьютер | shell:MyComputerFolder
Контакты | C:\Users\User-Name\Contacts | shell:Contacts
Конфликты | Панель управления\Все элементы панели управления\Центрсинхронизации\Конфликты | shell:ConflictFolder
Корзина | Корзина | shell:RecycleBinFolder
Мои видеозаписи | C:\Users\User-Name\Videos | shell:CommonVideo
Мои видеозаписи | C:\Users\User-Name\Videos | shell:My Video
Мои документы | C:\Users\User-Name\Documents | shell:Personal
Моя Музыка | C:\Users\Public\Music | shell:CommonMusic
Моя музыка | C:\Users\User-Name\Music | shell:My Music
Музыка | Библиотеки\Музыка | shell:MusicLibrary
Настройка синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Настройка синхронизации | shell:SyncSetupFolder
Недавние документы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Recent | shell:Recent
Образцы видео | C:\Users\Public\Videos\Sample Videos | shell:SampleVideos
Образцы изображений | C:\Users\Public\Pictures\Sample Pictures | shell:SamplePictures
Образцы музыки | C:\Users\Public\Music\Sample Music | shell:SampleMusic
Общие | C:\Users\Public | shell:Public
Папка с рингтонами Windows 7 | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Ringtones | shell:Ringtones
Поиск Windows | search-ms: | shell:SearchHomeFolder
Поиски (информация о поисках) | C:\Users\User-Name\Searches | shell:Searches
Получение программ | Панель управления\Все элементы панели управления\Получение программ | shell:AddNewProgramsFolder
Пользователи | C:\Users | shell:UserProfiles
Принтеры | Все элементы панели управления\Принтеры | shell:PrintersFolder
Программы | C:\ProgramData\Microsoft\Windows\Start Menu\Programs | shell:Common Programs
Программы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu\Programs | shell:Programs
Программы и компоненты | Панель управления\Все элементы панели управления\Программы и компоненты | shell:ChangeRemoveProgramsFolder
Рабочий стол | C:\Users\Public\Desktop | shell:Common Desktop
Рабочий стол | C:\Users\User-Name\Desktop | shell:desktop
Результаты синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Результаты синхронизации | shell:SyncResultsFolder
Сетевые подключения | Панель управления\Все элементы панели управления\Сетевые подключения | shell:ConnectionsFolder
Сеть | Сеть | shell:NetworkPlacesFolder
Сохраненные игры | C:\Users\User-Name\Saved Games | shell:SavedGames
Ссылки | C:\Users\User-Name\Links | shell:Links
Установленные обновления | Программы и компоненты\Установленные обновления | shell:AppUpdatesFolder
Центр синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации | shell:SyncCenterFolder

    16. Добавление элементов в контекстное меню "Отправить".

    При попытке открыть более 15 элементов сразу используя меню, вызываемое правой кнопкой мыши в Проводнике, пункт меню Открыть пропадет. Если Вам необходимо открыть большее количество элементов одновременно, то Вы можете сделать это добавив нужную Вам программу в контекстное меню "Отправить".
    Чтобы добавить свою программу в контекстное меню "Отправить". Сделайте следующее:

    1) Откройте папку C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo , где UserName - Ваше имя пользователя.
    Также Вы можете открыть данную папку так:
    1.1) В адресной строке Проводника введите команду shell:SendTo и нажмите Enter.
    1.2) Нажмите Win+R, введите команду shell:SendTo и нажмите Enter.
    2) Создайте в открывшейся папке ярлык для необходимой Вам программы:
    2.1) Используйте меню, вызываемое правой кнопкой мыши. Создать -> Ярлык -> Укажите расположение программы -> Введите имя ярлыка
    2.2) Удерживая нажатой клавишу Alt скопируйте Вашу программу в вышеуказанную папку и переименуйте ярлык.

    17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

    Скопируйте необходимый Вам ярлык в папку C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Windows\Network Shortcuts
    где Имя пользователя - это имя Вашей учетной записи (Например: Администратор).

    18. Замена элементов в диалоговом окне открытия/сохранения файлов.

    Вы можете заменить стандартные папки из диалогового окна открытия/сохранения файлов на указанные Вами.

    1) Откройте меню Пуск
    2) В строке поиска введите gpedit.msc
    3) Откройте папку Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Проводник Windows.\Общее диалоговое окно открытия файлов
    4) Сделайте двойной щелчок мышью на Элементы, отображаемые в панели мест
    5) Установите переключатель на значение Включить
    6) Введите в текстовых полях напротив Элементов, пути к папкам и нажмите ОК.
    Для добавления папки Рабочий стол необходимо ввести: shell:desktop

    Виртуализация

    1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

    VHD (Virtual Hard Disk) - это формат файлов, используемых виртуальными машинами для эмуляции жесткого диска. Вы сможете создать себе виртуальный диск и использовать его для хранения виртуальных операционных систем, программ и других файлов в одном файле-образе, который можно открыть различными программами виртуализации или виртуальными машинами. Виртуальные жесткие диски позволяют нескольким операционным системам одновременно находиться на одном компьютере.

    Вариант 1. Работа с виртуальными дисками используя графический интерфейс.

    Создание виртуального жесткого диска.

    1) Откройте меню Пуск.
    2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
    3) Откроется оснастка "Управление дисками". В панели меню выберите пункт Действие и нажмите на Создать виртуальный жесткий диск

    Рисунок 1 из 13

    4) В открывшемся окне укажите:

    Рисунок 2 из 13

    4.1) Имя файла и его расположение. Вы можете как написать это вручную, так и нажав на кнопку Обзор и воспользовавшись диалоговым окном Просмотр файлов виртуального диска
    4.2) Размер виртуального диска. Возле текстового поля, в которое нужно ввести размер диска, присутствует раскрывающийся список, где можно выбрать размер жесткого диска. Доступные значения – мегабайты, гигабайты и терабайты. Создайте размер не меньше 20 ГБ.
    4.3) Тип виртуального диска. Динамически расширяемый дисковый образ обеспечивает объем пространства, необходимый для хранения данных.
    Размер VHD-файла в момент создания диска небольшой, но увеличивается по мере добавления данных на диск. Распределение данных осуществляется в блоках. При удалении данных с виртуального жесткого диска размер VHD-файла автоматически не уменьшается. Фиксированный размер создает VHD-файл, размер которого задается при создании виртуального жесткого диска. Размер VHD-файла остается постоянным независимо от объема хранимых данных.
    5) Нажмите на кнопку «ОК».

    Чтобы диспетчер локальных дисков смог получить доступ к созданному Вами виртуальному диску его необходимо инициализировать и создать на нем простой том. Для этого также используется оснастка "Управление дисками".

    Инициализация виртуального жесткого диска.

    1) Найдите Ваш виртуальный диск и щелкните на нем правой кнопкой мыши
    2) Нажмите на пункт Инициализировать диск

    Рисунок 3 из 13

    3) Выберите стиль разделов - MBR и нажмите OK

    Рисунок 4 из 13

    Создание простого тома на виртуальном жестком диске.

    После того как Вы проинициализировали Ваш виртуальный диск, на нем необходимо создать простой том.

    1) Найдите Ваш виртуальный диск и щелкните на нераспределенной области справа от него
    2) Нажмите на пункт Создать простой том

    Рисунок 5 из 13

    3) В первом диалоге Мастера создания простого тома нажмите на кнопку Далее
    4) В диалоге указания размера тома, укажите размер будущего тома в мегабайтах и нажмите на кнопку Далее

    Рисунок 6 из 13

    5) В диалоге Назначение буквы диска или пути укажите букву для будущего диска и нажмите на кнопку Далее

    Рисунок 7 из 13

    6) В диалоге Форматирование раздела укажите нужную файловую систему, размер кластера, название диска и установите флажок возле опции Быстрое форматирование - для того, чтобы диск был сразу отформатирован. После чего нажмите на кнопку Далее

    Рисунок 8 из 13

    7) Для принятия всех настроенных параметров в диалоге Завершение мастера создания простого тома нажмите на кнопку Готово.
    8) Виртуальный диск появится в таблице дисков. В оснастке управления дисками, значок виртуального диска визуально отличается от значков физических дисков. В проводнике Windows виртуальные диски выглядят так же, как и физические.

    Рисунок 9 из 13

    Присоединение виртуального жесткого диска.

    Если у Вас уже имеется созданный виртуальный жесткий диск, то Вы также можете присоединить его в оснастке "Управление дисками".

    1) Откройте меню Пуск.
    2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
    3) В панели меню выберите пункт Действие и нажмите на Присоединить виртуальный жесткий диск.

    Рисунок 10 из 13

    4) Укажите расположение для виртуального жесткого диска на компьютере и нажмите OK Указать расположение Вы можете либо введя значение вручную, либо нажав на кнопку Обзор, и используя диалоговое окно Просмотр файлов виртуального диска. Если Вам не нужно записывать данные на диск, то в этом диалоге можно установить флажок Только для чтения.

    Рисунок 11 из 13

    Отсоединение (удаление) виртуального жесткого диска.

    1) Найдите виртуальный диск, который хотите отсоединить, нажмите на нем правой кнопкой мыши
    2) Нажмите на пункт Отсоединить виртуальный жесткий диск

    Рисунок 12 из 13

    3) Если Вы желаете отсоединить виртуальный диск без удаления его из системы, то нажмите OK. Для полного удаления диска из системы, отметьте Удалить виртуальный диск после удаления диска и после этого нажмите OK.

    Рисунок 13 из 13

    Вариант 2. Работа с виртуальными дисками используя программу Diskpart в командной строке.

    Создание виртуального жесткого диска.

    1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
    2) В командной строке наберите Diskpart и нажмите Enter
    Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
    3) Для создания виртуального диска воспользуйтесь командой Create Vdisk. Синтаксис команды следующий:
    Create Vdisk File=<"имя_файла"> Maximum= [Type={Fixed|Expandable}] [Source=<"имя_файла">]
    Где:

    File=<"имя_файла"> - Указание полного пути и имени файла виртуального диска.
    Maximum=<n> - Максимальное дисковое пространство, предоставляемое виртуальным диском, заданное в мегабайтах (МБ).
    [Type={Fixed|Expandable}] - Используется для указания формата виртуального диска. Существует два значения для данного параметра:
    Fixed создает файл виртуального диска фиксированного размера;
    Expandable создает динамически расширяемый образ виртуального диска.
    [Source=<"имя_файла">] - Путь к существующему файлу виртуального диска для предварительного заполнения нового файла виртуального диска. При использовании параметра Source данные из исходного файла виртуального диска копируются блок за блоком в создаваемый файл виртуального диска. Если Вы при копировании динамического диска не укажете параметр Type=Expandable, то копия будет создана максимального размера выделенного для исходного диска, независимо от его текущего размера.

    Примеры использования команды:

    Create Vdisk File="E:\VHD\Virtual_disk_1.vhd" Maximum=512 Type=Expandable
    Create Vdisk File="E:\VHD\Virtual_disk_2.vhd" Source="E:\VHD\Virtual_disk_1.vhd"

    Рисунок 1 из 3

    Присоединение виртуального жесткого диска.

    1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
    2) В командной строке наберите Diskpart и нажмите Enter Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
    3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk. Синтаксис команды следующий:
    Select Vdisk File=<"имя_файла">
    Пример использования команды:
    Select Vdisk File="E:\VHD\Virtual_disk_1.vhd"
    4) Для присоединения выбранного виртуального диска воспользуйтесь командой Attach Vdisk. Синтаксис команды следующий:
    Attach Vdisk [Readonly] { [SD=<строка sddl>] | [Usefilesd] }
    [Readonly] - Присоединяет виртуальный диск в режиме только для чтения. Любая операция записи приведет к возникновению ошибки ввода-вывода устройства.
    [Usefilesd] - Указывает, что для виртуального диска следует использовать дескриптор безопасности самого виртуального файла. Если параметр не указан, то у диска не будет явно заданного дескриптора безопасности, если не был также задан параметр SD=(строка SDDL).
    [SD=<строка sddl>] - Задает дескриптор безопасности в формате SDDL. По умолчанию дескриптор безопасности обеспечивает доступ, аналогичный любому физическому диску. Дополнительные сведения о формате строки SDDL см. в справке по команде Create Vdisk.

    Примеры использования команды:

    Attach Vdisk
    Attach Vdisk Readonly
    Attach Vdisk Usefilesd

    Рисунок 2 из 3

    Отсоединение виртуального жесткого диска.

    1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
    2) В командной строке наберите Diskpart и нажмите Enter
    Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
    3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk.
    4) Для отсоединения выбранного виртуального диска воспользуйтесь командой Detach Vdisk.

    Рисунок 3 из 3

    2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

    Для работы нам потребуются программа DISM, входящая в состав Windows 7, либо включенная в WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

    Вариант 1

    1) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
    2) Запускаете утилиту WinImage, открываете в ней VHD-образ. В открывшемся диалоге щелкаете ОК. Выделяете справа все файлы и щелкаете на выделенном правой кнопкой. Выбираете Extract, затем щелкаете Browse и выбираете папку VHD. Чуть ниже выбираете Extract with pathname. Ждете завершения процесса распаковки. Если появится ошибка, просто нажимаете продолжить.

    Рисунок 1 из 5

    3) Распакуйте образ дистрибутива(ваш ISO), с помощью программы архиватора 7zip в папку C:\DVD
    4) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
    5) Запустите коммандную строку от имени администратора (Win+R -> cmd -> Ok)
    6) Распакуйте lp.cab в папку C:\Lip\uLip выполнив в консоли команду:
    expand C:\Lip\lp.cab -f:* C:\Lip\uLip
    7) При помощи GimageX узнаете индекс Ultimate

    Рисунок 2 из 5

    8) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

    Рисунок 3 из 5

    9) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

    Рисунок 4 из 5

    10) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

    Рисунок 5 из 5

    11) Перезагрузите компьютер.
    Примечание: Комманды DISM Вы можете также выполнять в командной строке ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
    12) Запустите коммандную строку от имени администратора (Win+R -> cmd -> Ok)
    13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:
    dism /Mount-Wim /WimFile:C:\mWim\install.wim /index:1 /MountDir:C:\Mount
    14) Интегрируете LIP в install.wim
    dism /image:C:\Mount\ /Add-Package /PackagePath:C:\Lip\lp.cab /ScratchDir:C:\Temp
    15) Применяете все настройки для русского языка командой:
    dism /image:C:\Mount /Set-AllIntl:ru-RU
    16) Копируете все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer)
    17) Демонтируете install.wim с сохранением изменений из C:\Mount:
    dism /Unmount-Wim /MountDir:C:\Mount /commit
    18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount
    dism /Mount-Wim /WimFile:C:\mWim\boot.wim /index:1 /MountDir:C:\Mount
    19) Добавляете в boot.wim русский язык:
    xcopy C:\Lip\uLip\setup\* C:\Mount\ /cheryki
    20) Добавляете в boot.wim файлы лицензий:
    xcopy C:\Lip\uLip\sources\license\* C:\Mount\sources\license\ /cheryki
    21) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini
    [Available UI Languages]
    ru-RU = 2
    en-US = 3

    [Fallback Languages]
    ru-RU = ru-ru
    en-US = en-us
    22) Демонтируете boot.wim с сохранением изменений из C:\Mount:
    dism /Unmount-Wim /MountDir:C:\Mount /commit
    23) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:
    [Available UI Languages]
    ru-RU = 2
    en-US = 3

    [Fallback Languages]
    ru-RU = ru-ru
    en-US = en-us
    24) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
    25) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
    26) Перезагружаетесь в Windows
    27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
    28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
    29) Сохраняете в другое место или под другим именем.

    Вариант 2

    1) Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
    2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
    3) Указываете местонахождение VHD-образа, жмете ОК

    Рисунок 1 из 2

    4) Выбираете нужную вам букву для данного диска
    5) Установите Windows AIK
    6) Запустите программу GImageX и укажите в параметрах как на рисунке:

    Source: - путь к виртуальному диску
    Destination - путь куда будет сохранен готовый install.wim файл
    Name - Имя образа (Windows 7 Ultimate)
    Description - Описание образа (Windows 7 Ultimate)
    Compression - Сжатие полученного install.wim файла (Maximum)

    Рисунок 2 из 2

    7) Открываете с помощью UltraISO образ дистрибутива Windows 7
    8) Удаляете в папке \Sources файл install.wim
    9) Добавляете созданный вами новый install.wim вместо старого.
    10) Сохраняете образ под новым именем.
    11) Записываете образ на USB флеш-накопитель (флешку) или DVD.

    Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

    3. Установка и загрузка Windows 7 из VHD-файла.

    Вариант 1

    Первое, что потребуется - это сам VHD-образ. Второе - необходимо подготовить логический диск. Желательно выделить для установки чистый диск с размером 15-25Гб. Третье, это утилита WinImage.

    1) Запускаете утилиту WinImage.
    2) Открываете в Winimage Ваш VHD-образ.
    3) В открывшемся диалоге нажимаете ОК.
    4) Выделяете справа все файлы
    5) Нажимаете на выделенном правой кнопкой мыши и выбираете Extract
    6) Нажимаете Browse и выбираете предварительно подготовленный диск.
    7) Ниже выбираете Extract with pathname. Ждете завершения процесса распаковки.
    8) После завершения распаковки скачиваете утилиту EasyBCD.
    9) В окне приложения нажимаете Add/Remove Entries
    10) В поле Add entries выбираете имя для Вашей новой ОС (к примеру, Windows 7 - VHD)
    11) Указываете тип (Windows Vista/7)
    12) Выбираете диск, на который Вы извлекли содержимое образа.
    13) Нажимаете Add entry, а затем вверху нажимаете Save. В списке ОС теперь должно быть два пункта.
    14) Заходите в раздел Change Settings
    15) Выбираете в качестве ОС, загружаемой по умолчанию, Windows 7 - VHD.
    16) Нажимаете Save settings и перезагружаете компьютер.

    Вариант 2 как основная система.

    1) Создаем папку VHD на любом разделе диска. Открываем VHD-образ утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
    2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
    3) Выбираем Micosoft Diagnostics and Recovery Toolset -> Explorer и удаляем все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
    4) Переносим все файлы из папки VHD на диск C:/. Папка VHD-> выделяем все файлы-> щелкаем правой кнопкой-> параметр move to-> выбираем диск С:\
    5) Удаляем папку VHD.
    6) Перезагружаемся снова в ERD. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
    7) Радуемся установленной Windows 7.

    Вариант 3 как вторая система.

    Способ 1. Автоматически.

    1) Открываем VHD-образ утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем любой логический диск (необязательно форматированный, у меня например там фильмы лежат). Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
    2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
    3) После выбора языка раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
    4) После перезагрузки нам становиться доступен выбор из двух ОС. Нас интересует вторая Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Выбираем её и ждем пока закончится настройка системы. В процессе, компьютер будет два раза перезагружен, незабываем после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Всё, VHD-образ установлен.
    5) Если загружаетесь через Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено) , то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все).Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc).Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкаем правой кнопкой на диске, выбираем Change Drive Letter and Paths, нажимаем Add, выбираем любую букву для диска, ОК, диск доступен.

    Способ 2. В ручную без Winimage, при помощи программы Bcedit.

    Для данного способа используйте программу bcedit, входящую в состав средств Windows или средств Восстановления.

    1) Запустите командную строку от имени администратора в Windows или в командной строке средств Восстановления, или в Erd Commander (при запуске необходимо выбрать текущую систему). Все дальнейшие команды вводите в командной строке.
    2) При помощи указанной команды, скопируйте существующую запись текущей системы с новым названием:
    bcdedit /copy {current} /d "Windows 7 Virtual"
    3) Дожидаетесь сообщения «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
    Указанный в данном сообщении буквенно-цифровой код, подставляйте в команды, указанные ниже вместо {ID}:
    4) Укажите раздел, на котором расположены файлы загрузки (device) и раздел, на котором расположены системные файлы операционной системы (osdevice). Так как у нас виртуальный диск, то значения параметров device и osdevice будут равны.
    bcdedit /set {ID} device vhd=X:\DIR\filename.vhd
    bcdedit /set {ID} osdevice vhd= X:\DIR\filename.vhd
    где X:\DIR\filename.vhd – полный путь к файлу VHD и указание имени файла.
    5) Для форсирования автоматического определения в Windows диска через соответствующий уровень абстракции — Hardware Abstraction Layer (разрешать ли операционной системе ускоренное автоматическое определение версии HAL и файла ядра при загрузке), выполните следующую команду:
    bcdedit /set {ID} detecthal on
    6)Установите добавленную систему на последнее место в списке загрузок
    bcdedit /displayorder {ID} /addlast
    7) Перезагрузите компьютер

    Если посмотреть на диски, присутствующие в системе, будет видно, что помимо виртуального диска на 16 Гб (обведен оранжевым), с которого, собственно, загружена Windows 7, также присутствуют второй раздел виртуального диска на 200 Мб под системные файлы и реальный(!) жесткий диск, установленный на компьютере. Если открыть диск, где ранее располагался vhd-файл, то можно обнаружить, что его размер увеличился до тех самых 16Гб, причем размер этот теперь строго ограничен.

    Некоторые сайты также советуют внести в листинг menu.lst(должен появится при загрузке компьютера) следующие изменения:
    title Windows 7 Virtual
    root (hd0,0)
    chainloader /bootmgr

    4. Установка Windows 7 на виртуальный диск в VHD-файл.

    Установив систему на виртуальный диск, в один VHD-файл, Вы получаете такие преимущества по сравнению с обычной системой:
    - сможете сделать копию операционной системы просто скопировав VHD-файл
    - сможете тестироть бета версии программ, не беспокоясь за систему
    - сможете изучать систему, экспериментировать с реестром, не боясь её испортить.

    1) Вставьте установочный диск Windows 7 в привод, загрузитесь с него
    2) Доходите до шага мастера установки, где Вас просят выбрать или создать тот раздел диска, на который будет установлена Windows 7.
    3) Нажмите комбинацию клавиш "Shift+F10".
    Это сочетание клавиш предоставит доступ к командной строке. Напечатайте в ней Diskpart и нажмите Enter.
    Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
    3) Введите в DISKPART следующую команду:
    create vdisk file="E:\VHD\win7.vhd" type=expandable maximum=30000
    Она означает - создать файл win7.vhd расширяемого типа, максимальный размер ограничить 30 Гигабайтами. Замените E: на имя диска, на котором вы хотите хранить создаваемый файл.

    4) Смонтируйте VHD-файл, чтобы он был доступен программе установки:
    select vdisk file="E:\win7.vhd" attach vdisk
    5) После успешного выполнения всех операций, набираете команду exit для выхода из утилиты diskpart, и еще раз команду exit – уже в приглашении CMD.EXE для закрытия командной строки.

    Рисунок 1 из 2

    6) Вы снова окажетесь в окне Выберите раздел для установки.
    7) Нажмите кнопку Обновить, расположенную под списком дисков и Вы увидите Ваш новый диск
    8) Так как на нем ещё нет разделов, то будет написано Незанятое место на диске...
    9) Выберите его и нажмите Настройка диска
    10) Щелкните на кнопке "Создать", укажите объем создаваемого радела и щелкните на кнопке "Применить".
    11) Ещё раз убедитесь, что Вы выбрали созданный Вами виртуальный диск и нажмите Далее, игнорируя предупреждение: Невозможно установить Windows на диск...

    Рисунок 2 из 2

    Процесс установки Windows 7 на раздел VHD-диска продолжится так, как будто это обычный логический раздел жесткого диска. При этом будет не только установлена новая ОС, но и подменен загрузчик на "физическом" системном разделе для успешного старта с VHD. При установке Windows 7 на "чистую" систему, мастер установки автоматически создаст на диске системный раздел в 100МБ, на котором помещается загрузчик, а уже для самой системы создаст отдельный раздел.

    5. Конвертирование тома жесткого диска в VHD-файл.

    Для создания VHD-файлов из томов жесткого диска, Вам необходимо воспользоваться утилитой Disk2vhd. Она позволяет создать VHD-образ прямо с запущенной операционной системы. Для своей работы, программа использует Модуль теневого копирования тома (Volume Snapshot), являющийся функцией используемой операционной системой для создания последовательных снимков томов на определенный момент времени. Таким образом, Вы сможете создать VHD-файл прямо на том же разделе, который в него упаковываете. При создании VHD-файла, программа включает в него только системный том и исключает разделы с данными.

    Созданный утилитой виртуальный диск может быть подключен к виртуальной машине как IDE-диск. Не используйтейте VHD-файл, для загрузки через менеджер загрузки Windows 7 на реальной машине. Windows специальным образом подписывает жесткие диски, и присваивает VHD-диску новый уникальный идентификатор. При попытке загрузки с VHD система выдаст ошибку об отсутствии загрузочного диска или просто перезагрузится без уведомления пользователя. Но при использовании данного VHD-образа в Virtual PC, система отлично стартует и работает.

    Для работы с Вашим VHD-файлом Вы также можете использовать оснастку Управление дисками (diskmgmt.msc).
    Eсли снимаете образ системного диска, и у вас есть раздел восстановления (System Reserved), не забудьте включить его в VHD-образ, так как без него система не загрузится. Для создания VHD-файла сделайте следующее:

    1) Скачайте программу Disk2vhd
    2) Разархивируйте скачанный архив и запустите Disk2vhd
    3) В поле под VHD File name укажите путь и имя создаваемого Вами VHD-файла.
    4) Установите флажки напротив томов жесткого диска, которые необходимо включить в создаваемый Вами VHD-файл.
    5) Нажмите Create

    Для создания скриптов утилита поддерживает командную строку:
    disk2vhd <[drive: [drive:]...]|[*]> <vhdfile>
    Укажите какие тома необходиво включить в VHD-файл или используйте * для конвертирования всех томов.
    disk2vhd c: e:\Your-PC.vhd
    disk2vhd * e:\Your-PC.vhd

    6. Конвертирование DVD-образа Windows 7 в VHD-файл.

    Для конвертирования DVD-образа Windows 7 в VHD-файл, Вам потребуются Набор автоматической установки Windows (AIK) для Windows 7 (Размер скачиваемого файла 1,25 ГБ и инструмент командной строки WIM2VHD

    WIM2VHD - это сценарий Windows Scripting Host, предназначенный для использования в командной строке и позволяющий создать аппаратно-независимый VHD-файл из инсталляционного диска Windows 7, при инициализации которого система минует стадию начальной загрузки и распаковки файлов и будет готова к определению оборудования компьютера, на котором она запущена.

    Суть метода заключается в преобразовании файла install.wim в VHD-файл.

    1) Установите Набор автоматической установки Windows (AIK) для Windows 7
    2) Поместите скаченный файл WIM2VHD.WSF в папку C:\Program Files\Windows AIK\Tools\x86\, если используете 32-разрядную систему, или в C:\Program Files\Windows AIK\Tools\amd64\, если 64-разрядную.
    3) Запустите командную строку с правами администратора, для чего нажмите "Пуск", в поле поиска введите cmd.exe и нажмите CTRL+ENTER.
    4) Перейдите в папку со скриптом используя команду CD . Например:

    Для 32-битной Windows:
    С:\>cd /d "C:\Program Files\Windows AIK\Tools\x86\"
    Для 64-битной Windows:
    С:\>cd /d "C:\Program Files\Windows AIK\Tools\amd64\"
    Измените пути на соответствующие Вашей системе.

    5) Запустите скрипт wim2vhd. Для этого, введите в командной строке следующее:
    cscript wim2vhd.wsf /wim:h:\sources\install.wim /sku:ultimate /vhd:e:\vhd\win7.vhd
    Командная строка расшифровывается так:
    Взять файл h:\sources\install.wim, и редакцию ultimate преобразовать в e:\vhd\win7.vhd

    6) Дождитесь окончания операции.

    Рисунок 1 из 1

    7) Для подключения полученного VHD-файла к имеющемуся загрузчику Windows 7, используйте команду:
    bcdedit /copy {current} /d "Windows 7 Virtual"
    Команда дублирует загрузочную запись текущей запущенной Windows 7. Вместо "Windows 7 Virtual" Вы можете написать любое значение.

    8) Bcdedit выведет на экран {GUID} только что созданной записи-дубликата - скопируйте его в буфер обмена и используйте для внесения VHD-файла в опции загрузки:
    bcdedit /set {ваш GUID} device vhd=[c:]\win7.vhd
    bcdedit /set {ваш GUID} osdevice vhd=[c:]\win7.vhd
    bcdedit /set {ваш GUID} detecthal on

    Для информации: Работа скрипта WIM2VHD базируется на использовании утилиты imagex.exe из WAIK. Другие примеры использования скрипта WIM2VHD описаны здесь.

    7. Включение Aero Glass в Windows на Virtual PC.

    1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
    2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
    3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
    4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
    5. Установить Сетевое соединение между двумя компьютерами.

    На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
    С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
    Нажмите Connect и вводите логин.

    Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

    В итоге, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

    8. Установка Windows 7 в виртуальную машину VirtualBox.
    VirtualBox - специальная программа для создания в памяти ПК виртуальных компьютеров. Каждый виртуальный компьютер может содержать произвольный набор виртуальных устройств и отдельную операционную систему. Область применения виртуальных компьютеров очень широка - от выполнения функций по тестированию ПО до создания целых сетей, которые легко масштабировать, распределять нагрузку и защищать. VirtualBox распространяется бесплатно, с открытым исходным кодом.

    1) Скачайте последнюю версию программы VirtualBox с оффициального сайта: http://www.virtualbox.org/wiki/Downloads
    2) Установите ее на свой компьютер.

    2.1) Запустите установщик; В первом окне нажмите Next
    2.2) Выберите пункт I accept the terms in the License Agreement и нажмите Next.
    2.3) Нажмите Next, затем снова Next
    2.4) Нажмите на кнопку Yes. Внимание: На следующем шаге после нажатия кнопки Install произойдет разрыв связи с сетью (как локальной, так и Интернет)
    2.5) Нажмите Install для продолжения установки
    2.6) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
    2.7) В последнем окне оставьте флажок, чтобы приступить к созданию виртуальной машины сразу или уберите флажок для создания виртуальной машины позднее. Нажмите кнопку Finish. Если Вы убрали флажок, то для запуска программы воспользуйтесь значком на рабочем столе.

    3) В главном окне программы нажмите на кнопке Создать. Откроется Мастер создания новой виртуальной машины. Нажмите кнопку Далее.
    4) Введите имя виртуальной машины, в разделе Тип ОС установите значения:
    Операционная система: Microsoft Windows
    Версия: Windows 7.
    Нажмите кнопку Далее.

    Рисунок 1 из 9

    5) Введите размер оперативной памяти, выделяемый для виртуальной машины.
    Внимание: Память будет выделяться из физической памяти установленной в Вашем компьютере. Не устанавливайте память ниже 512 Мегабайт и выше 50% от размера установленной физической памяти. Нажмите кнопку Далее.
    6) Выберите загрузочный виртуальный жесткий диск. Установите переключатель в значение: Создать новый жесткий диск. Нажмите кнопку Далее.

    Рисунок 2 из 9

    7) Откроется Мастер создания нового виртуального диска. Нажмите кнопку Далее.
    8) Выберите тип виртуального жесткого диска. Динамический образ изначально займет немного места, и будет расширяться постепенно. Фиксированный образ сразу создаст диск указанного размера - это может занять продолжительное время. Нажмите кнопку Далее.

    Рисунок 3 из 9

    9) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\.VirtualBox.
    Выберите размер виртуального жесткого диска. (По умолчанию 20 Гигабайт). Нажмите кнопку Далее.

    Рисунок 4 из 9

    10) Нажмите на кнопку Готово и Вы вернетесь в предыдущее окно, где будут указаны параметры создаваемой Вами виртуальной машины. Нажмите на кнопку Готово в окне Итог, и Вы создадите новую виртуальную машину.

    Виртуальная машина для установки на нее Windows 7 создана.

    Рисунок 5 из 9

    11) Перед началом установки Windows 7 на Вашу виртуальную машину ее необходимо настроить. Для настройки Вашей виртуальной машины нажмите на кнопку Свойства.
    12) В разделе настроек из списка слева выберите Дисплей. Установите размер видеопамяти, доступной для виртуальной машины не менее 26 Мегабайт. Поставьте флажки для элементов настроек Включить 3D-ускорение и Включить 2D-ускорение видео.

    Рисунок 6 из 9

    13) В разделе настроек из списка слева выберите Носители.
    14) В дереве настроек Носители информации выберите значок DVD диска.
    Если у Вас установочный диск Windows 7 записан на DVD-диск, то вставьте его в DVD-привод и в графе Атрибуты напротив элемента Привод выберите его из ниспадаюшего списка. Также установите флажок для Разрешить прямой доступ.
    Если у Вас установочный диск Windows 7 имеется в виде ISO-образа, то в графе Атрибуты нажмите на значок папки, чтобы открыть Менеджер виртуальных носителей
    15) В окне Менеджер виртуальных носителей нажмите кнопку Добавить. Выберите файл образа и нажмите Открыть. Нажмите на кнопку Выбрать

    Рисунок 7 из 9

    16) Ваш образ добавится дереве настроек Носители информации, следующим за файлом виртуального жесткого диска. Нажмите кнопку OK.

    Рисунок 8 из 9

    17) Вы окажетесь в основном окне программы. Нажмите на кнопку Старт
    18) Если появятся информационные окна, то нажмите в них на кнопку OK
    19) Щелкните кнопкой мыши внутри экрана виртуальной машины, и в информационном окне нажмите на кнопку Захватить
    20) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
    21) После завершения установки Windows 7 на виртуальную машину, VirtualBox сразу запустит Вам Windows 7 внутри виртуальной машины.

    22) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Control.
    Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Дополнения гостевой ОС. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Устройства -> Установить Дополнения гостевой ОС

    Рисунок 9 из 9

    23) Во всплывшем окне Автозапуск нажмите VBoxWindowsAdditions.exe и установите программу.
    24) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Машина -> Закрыть -> Выключить машину.
    25) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Старт.

    9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.
    Microsoft Virtual PC - это мощная программа, которая позволяет эмулировать на одном компьютере работу сразу нескольких виртуальных машин. Каждая из таких машин может находиться под управлением своей собственной операционной системы (Windows любой версии, Netware, Linux, Solaris и т.д.), выполнять уникальную задачу, иметь собственную конфигурацию и т.д.

    1) Скачайте последнюю версию программы Virtual PC с оффициального сайта:
    http://www.microsoft.com/downloads/details.aspx?familyid=28c97d22-6eb8-4a09-a7f7-f6c7a1f000b5&displaylang=en
    2) Установите программу. Внимание программа установки без предупреждения выключит соединение с сетью (как локальной, так и Интернет).
    3) Скачайте и установите обновление KB958162.msp для Virtual PC
    4) Запустите программу. Нажмите кнопку Пуск -> Все программы -> Microsoft Virtual PC
    5) В окне с надписью: "You are not running on a supported operating system" нажмите ОК.
    6) В окне New Virtual Machine Wizard нажмите кнопку Next. Данное окно Вы также можете запустить нажав кнопку New в Virtual PC Console или в меню File выбрать New Virtual Machine Wizard.

    Рисунок 1 из 7

    7) Установите переключатель на Create a Virtual Machine. Нажмите кнопку Next.

    Рисунок 2 из 7

    8) Выберите имя и расположение для файла Вашей виртуальной машины. По умолчанию имя файла New Virtual Machine, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\Documents\My Virtual Machines. Нажмите кнопку Next.
    9) Выберите тип операционной системы. В связи с отсутствием пункта Windows 7 в Virtual PC, выберите Windows Vista или Other. Нажмите кнопку Next.

    Рисунок 3 из 7

    10) Установите переключатель на Adjusting the RAM. Выберите необходимое Вам количество оперативной памяти выделяемое виртуальной машине, не менее 512 Мегабайт. Нажмите кнопку Next.

    Рисунок 4 из 7

    11) Установите переключатель на A new virtual hard disk, чтобы создать новый виртуальный образ. Нажмите кнопку Next.
    12) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, к котрой добавлено Hard Disk, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке:
    C:\Users\UserName\Documents\My Virtual Machines\ИмяВиртуальнойМашины\
    Укажите величину создаваемого вами виртуального жесткого диска в мегабайтах. Рекомендую указать 20480 Мб (20 Гб). Для информации: 1 Гб = 1024 Мб. Нажмите кнопку Next.

    Рисунок 5 из 7

    13) Нажмите кнопку Finish, для создания виртуальной машины. Вы снова окажетесь в окне Virtual PC Console.
    14) Выберите созданную Вами виртуальную машину и нажмите кнопку Start
    15) Виртуальная машина начнет свою работу и остановится с сообщением: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device, поскольку отсутствует инсталляционный диск с Windows 7. Выберите команду CD>Capture CD Image и укажите образ ISO с Windows 7.

    Рисунок 6 из 7

    16) Перезагрузите виртуальную машину, выбрав команду Action -> Ctrl+Alt+Del или нажав Правый Alt+DEL в окне виртуальной машины.
    17) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
    18) После завершения установки Windows 7 на виртуальную машину, Microsoft Virtual PC сразу запустит Вам Windows 7 внутри виртуальной машины.
    19) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Alt.
    Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Virtual Machine Additions. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Action –> Install or Update Virtual Machine Additions и нажмите Continue.

    Рисунок 7 из 7

    20) Во всплывшем окне Автозапуск нажмите Setup.exe и установите программу.
    21) Нажмите Yes по окончанию установки Virtual Machine Additions и виртуальная машина перезагрузится.
    22) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Action -> Close -> Turn Off и нажмите OK.
    23) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Start.

    10. Установка Windows 7 в виртуальную машину VMware Workstation.
    VMware Workstation — популярная программа для виртуализации систем. VMware Workstation является массивным решением для разработчиков программного обеспечения и системных админов, создающих и тестирующих полно-комплексные сетевые приложения класса серверов, работающие в разнообразных средах.

    1) Заходите на страницу оффициального сайта для скачивания программы: http://downloads.vmware.com/d/
    2) Нажимаете на ссылку VMware Workstation
    3) На открывшейся странице выбираете для скачивания VMware Workstation X.X.X for Windows (где X.X.X - номер версии)
    4) Щелкаете на кнопке Download рядом с Workstation for Windows 32-bit and 64-bit with VMware Tools.
    5) Нажимаете на кнопку Register и заполняете регистрационную форму и нажимаете Continue
    6) Внизу EULA соглашения нажимаете Yes и оказываетесь на странице загрузки. Программа бесплатна для полнофункционального использования 30 дней. По истечении данного срока Вам необходимо её зарегистрировать.
    7) Скачиваете Workstation for Windows 32-bit and 64-bit Main installation file with Tools. В отличие от других виртуальных машин, программа установки VMware Workstation имеет размер более 500 Мегабайт.
    8) Установите программу. Перезапустите компьютер, для этого в последнем окне программы нажмите Restart Now или нажмите Restart Later и перезапустите вручную позже.
    9) Запустите программу. Установите переключатель на Yes, I accept the terms in the license agreement и нажмите OK
    10) В главном окне программы нажмите на значок New Vitual Machine.

    Рисунок 1 из 6

    11) Установите переключатель на Typical (recommended). Нажмите кнопку Next.

    Рисунок 2 из 6

    12) Установите переключатель на Installer disk image file (iso). Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Next.

    Рисунок 3 из 6

    13) Укажите свой инсталяционный код Windows 7, имя пользователя и пароль и нажмите кнопку Next. Если Вы решили ввести эти данные позже, то после нажатия кнопки Next, нажмите на кнопку Yes.
    14) Выберите имя и расположение для файла Вашей виртуальной машины. Нажмите кнопку Next.

    Рисунок 4 из 6

    15) Задайте размер Вашего виртуального жесткого диска в гигабайтах.

    Рисунок 5 из 6

    16) Нажмите кнопку Finish, для создания виртуальной машины.
    17) В окне VMware Workstation Activation нажмите Enter Serial Number, чтобы ввести имеющийся у Вас серийный номер. Если у Вас нет серийного номера, то Вы можете получить серийный номер на 30 дней для полнофункционального тестирования программы: https://www.vmware.com/tryvmware/?p=workstation&lp=default
    18) После введения пробного номера во всплывшем окне Register your version of VMware Workstation now! нажмите кнопку Register
    19) В главном окне программы перейдите на вкладку с названием Вашей виртуальной машины (по умолчанию Windows 7) и нажмите ссылку Power on this virtual machine.

    Рисунок 6 из 6

    20) В отличие от других виртуальных машин установка Windows 7 начнется сама и большую часть установки VMware Workstation выполнит автоматически, Ваше участие в процессе установки Windows 7 почти не потребуется.
    21) После завершения установки Windows 7 на виртуальную машину, VMware Workstation сразу запустит Вам Windows 7 внутри виртуальной машины.
    22) Сразу после запуска VMware Workstation самостоятельно установит Вам дополнительные инструменты VMware Tools, а также в случае наличия у Вас подключения к Интернет самостоятельно установит все необходимые драйвера.
    23) Используйте комбинацию клавиш Ctrl+G для разблокировки одновременного использования мыши как в виртуальной системе, так и в основной.
    24) Чтобы выключить виртуальную машину, завершите работу в виртуальной Windows 7 как в обычной Windows. Пуск -> Завершение работы.
    25) Чтобы запустить установленную Windows 7 в основном окне программы в колонке слева выберите наименование Вашей операционной системы. В открывшейся вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) нажмите ссылку Power on this virtual machine.

    11. Создание общей папки для виртуальной и основной Windows в VirtualBox.
    Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VirtualBox и хостовой (реальной) Windows 7, сделайте следующее:

    1) В меню запущенной виртуальной машины откройте Устройства -> Общие папки

    Рисунок 1 из 4

    2) Нажмите на клавиатуре кнопку Insert, либо нажмите на значок папки с плюсом.

    Рисунок 2 из 4

    3) Установите флажок для параметра Создать постоянную папку.
    4) В ниспадающем меню рядом с текстом Путь к папке выберите пункт Другой....
    5) Укажите путь к Вашей папке и нажмите на каждую кнопку ОК.

    Рисунок 3 из 4

    6) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> VBOXSVR -> Ваша папка

    Рисунок 4 из 4

    12. Создание общей папки для виртуальной и основной Windows в Microsoft Virtual PC.
    Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину Microsoft Virtual PC и хостовой (реальной) Windows 7, сделайте следующее:

    1) В меню запущенной виртуальной машины откройте Edit -> Settings или нажмите сочетание клавиш: правый Alt+E

    Рисунок 1 из 4

    2) Выберите в списке Shared Folders и нажмите кнопку Share Folder...

    Рисунок 2 из 4

    3) Установите флажок на Share Every Time, укажите Вашу общую папку и установите букву диска в виде которго будет отображаться папка в виртуальной Windows, затем нажмите OK.

    Рисунок 3 из 4

    4) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Компьютер -> Отключенное сетевое устройство (назначенная вами буква диска)

    Рисунок 4 из 4

    13. Создание общей папки для виртуальной и основной Windows в VMware Workstation.
    Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VMware Workstation и хостовой (реальной) Windows 7, сделайте следующее:

    1) В вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) перейдите на вкладку Options.
    2) Сделайте двойной щелчок на папке Shared Folders

    Рисунок 1 из 4

    3) Установите переключатель на Always enabled.

    Рисунок 2 из 4

    4) Нажмите кнопку Add..., а затем кнопку Next.
    5) Нажмите кнопку Browse. Укажите путь к Вашей общей папке в хостовой (реальной) Windows 7 и ее имя в виртуальной Windows, затем нажмите OK.

    Рисунок 3 из 4

    6) Нажмите кнопку Next, а затем кнопку Finish. Выйдите из опций нажав на OK.
    7) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> vmware-host -> Shared Folders -> Ваша папка

    Рисунок 4 из 4

    Твики Реестра

    Твики Реестра - Добавление

    1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

    Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
    @="\"%1\" /X:\"%1_unpacked\""
    В итоге, при распаковке WindowsXP-KB922582-x86-RUS.exe, на выходе получаем папку WindowsXP-KB922582-x86-RUS.exe_unpacked с извлечёнными файлами. Минус один - команда Unpack HotFix встраивается в контекстное меню всех екзешников, а не только файлов от MS.

    Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:
    Windows Registry Editor Version 5.00

    [-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix]
    [-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
    @=-

    Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

    2. Как задать полный доступ к файлу или папке?

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\*\shell\runas]
    @="Стать владельцем и задать полный доступ к объекту"
    "NoWorkingDirectory"=""

    [HKEY_CLASSES_ROOT\*\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"

    [HKEY_CLASSES_ROOT\Directory\shell\runas]
    @="Стать владельцем и задать полный доступ к объекту"
    "NoWorkingDirectory"=""

    [HKEY_CLASSES_ROOT\Directory\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"

    3. Автоматическое VPN подключение к интернет при запуске Windows (реестр).

    1. Создайте ваше VPN подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
    2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:
    "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run"

    (если хотите сделать автозапуск только для текущего пользователя) или
    "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run"

    (если хотите сделать автозапуск для всех пользователей)
    В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
    2. В качестве значения созданного параметра внесите строку вида:
    rasdial "имя_вашего соединения" <логин> <пароль> (Например: rasdial "VPN connection" nz15vl 1234)
    3. Закройте реестр и перезагрузите компьютер.

    4. Добавляем пункт "Открыть в блокноте" в контекстное меню файлов.

    Для того, чтобы добавить в контекстное меню файлов пункт "Открыть в Блокноте" текст кода сохраните в текстовый файл, присвойте ему расширение *.reg, запустите и согласитесь с добавлением данных в реестр.
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте]
    @=""

    [HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте\command]
    @="notepad.exe %1"

    5. Как добавить дополнительные функции в папку Компьютер?

    Администрирование

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]

    Корзина

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{645FF040-5081-101B-9F08-00AA002F954E}]

    Панель управления

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\Controls]
    @="{21EC2020-3AEA-1069-A2DD-08002B30309D}"

    Принтеры и факсы

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}]

    Учетные записи пользователей

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{7A9D77BD-5403-11d2-8785-2E0420524153}]
    В итоге получаем:

    6. Добавляем произвольную команду в контекстное меню рабочего стола.

    Для этого создаем файл fix.txt
    Открываем блокнот и копируем туда это содержимое, сохраняем и меняем разширение на .reg
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\DesktopBackground\Shell\name]
    @="Свойства папки"
    "Icon"="imageres.dll,200"
    "Position"="Top"

    [HKEY_CLASSES_ROOT\DesktopBackground\Shell\name\command]
    @="control folders"
    Сохраняем файл и выполняем его.
    В параметре "Icon"="imageres.dll,200" цифра 200 отвечает за номер иконки. Вы можете указать свою.
    Таким образом можно добавить практически любую команду (управление учетными записями Control userpasswords).

    7. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.
    1) Скачиваете утилиту Reg2inf (необходим Framework 2 или 3)
    2) Помешаете её в System32
    3) Добавление в реестр добавляется следующее:
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\regfile\shell\reg2inf\command]
    @="Reg2Inf.exe \"%1\" \"%1.inf\" /RepVars"

    [HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Application]
    @="Reg2Inf"

    [HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Topic]
    @="System"
    В итоге, в контекстное меню reg файлов добавляется команда reg2inf и, к примеру, файл test.reg конвертируется в test.reg.inf

    8. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".
    Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\*\Shell]

    [HKEY_CLASSES_ROOT\*\Shell\astext]
    @="Как текст..."

    [HKEY_CLASSES_ROOT\*\Shell\astext\command]
    @="notepad.exe \"%1\""

    [HKEY_CLASSES_ROOT\*\Shell\Expand]
    @="Распаковать .cab"

    [HKEY_CLASSES_ROOT\*\Shell\Expand\command]
    @="expand -r \"%1\""

    [HKEY_CLASSES_ROOT\*\Shell\MakeCab]
    @="Запаковать в .cab"

    [HKEY_CLASSES_ROOT\*\Shell\MakeCab\command]
    @="makecab /D CompressionType=LZX /D CompressionMemory=21 \"%1\""

    [HKEY_CLASSES_ROOT\*\Shell\UpperCase]
    @="Имя в ВЕРХНИЙ РЕГИСТР"

    [HKEY_CLASSES_ROOT\*\Shell\UpperCase\command]
    @="FILECASE /U \"%1\""

    [HKEY_CLASSES_ROOT\Directory\shell\CabPack]
    @="Запаковать папку в .cab"

    [HKEY_CLASSES_ROOT\Directory\shell\CabPack\command]
    @="cabs.cmd %L"

    [HKEY_CLASSES_ROOT\Directory\shell\Dirs]
    @="Создать список файлов папки"

    [HKEY_CLASSES_ROOT\Directory\shell\Dirs\command]
    @="dirs.cmd %L"

    9. Добавление пункта "Удалить содержимое папки" в контекстное меню.

    Как добавить в контекстное меню папки команду для удаления содержимого папки без удаления самой папки? Вы можете создать себе пункт Удалить содержимое папки в контекстном меню и Вам достаточно будет его только выбрать. Вам не придется открывать папку, выделять все файлы и нажимать на клавишу Delete.

    Вариант 1.

    1) Запустите редактор реестра: Win+R -> regedit -> Ok
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
    3) Создайте в ней раздел DeleteFolderContent
    4) Создайте в нем строковый(String) параметр MUIVerb со строкой Удалить содержимое папки.
    5) В разделе DeleteFolderContent создайте подраздел command
    6) Измените значение параметра (По умолчанию) раздела command на следующее:
    cmd /c "cd /d %1 && del /s /f /q *.*"

    Вариант 2.

    1) Запустите редактор реестра: Win+R -> regedit -> Ok
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
    3) Создайте в ней раздел Удалить содержимое папки
    4) В разделе Удалить содержимое папки создайте подраздел command
    6) Измените значение параметра (По умолчанию) раздела command на следующее:
    cmd /c "cd /d %1 && del /s /f /q *.*"

    Вариант 3.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Directory\shell\DeleteFolderContent]
    @="Удалить содержимое папки"

    [HKEY_CLASSES_ROOT\Directory\shell\DeleteFolderContent\command]
    @="cmd /c \"cd /d %1 && del /s /f /q *.*\" "
    Вы можете скачать готовые reg-файлы: DeleteFolderContent.zip

    10. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

    По какой-то неизвестной причине, разработчики Microsoft решили не включать в контекстное меню Проводника пункты Копировать в папку (Copy To) и Переместить в папку (Move To). Используя их, можно легко и быстро скопировать или переместить файл или папку. Для этого, достаточно выбрать желаемое место их размещения в соответствующем диалоговом окне. Для того, чтобы добавить эти команды в контекстное меню, достаточно создать, соответствующие им параметры в реестре.

    Вариант 1

    1) Запустите Редактор Реестра (нажмите копку «Пуск» (Start), введите regedit в строке «Найти программы и файлы» и нажмите Enter).
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers
    3) Создайте в ней раздел со следующим именем (включая фигурные скобки):
    Для добавления в контекстное меню пункта Копировать в папку
    {C2FBB630-2971-11D1-A18C-00C04FD75D13}
    Для добавления в контекстное меню пункта Переместить в папку
    {C2FBB631-2971-11D1-A18C-00C04FD75D13}
    4) Нажмите Enter
    5) Перезагрузите Проводник Windows (Windows Explorer) или перезайдите в систему, и данные пункты появятся в контекстном меню.

    Вариант 2

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\{C2FBB630-2971-11D1-A18C-00C04FD75D13}]
    @=""

    [HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\{C2FBB631-2971-11D1-A18C-00C04FD75D13}]
    @=""

    11. Включение скрытых настроек электропитания.

    Чтобы настроить в Windows 7 параметры электропитания, необходимо открыть Панель управления\Система и безопасность\Электропитание. Там можно выбрать нужный план электропитания и при необходимости более детально настроить параметры, перейдя в Настройка плана электропитания -> Изменить дополнительные параметры питания.
    Однако более детально настроить параметры электропитания помогает консольная утилита Powercfg. Но работать в командной строке, разбираясь с каждым параметром может занять продолжительное время. Для того чтобы функции предоставляемые powercfg стали доступны Вам в графической оболочке, необходимо внести некоторые изменения в ветке реестра:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings
    В данной ветке содержатся разделы, отвечающие за определенную группу настроек.
    Например, раздел 0012ee47-9041-4b5d-9b77-535fba8b1442 относится к настройкам управления питанием жесткого диска, а 54533251-82be-4824-96c1-47b60b740d00 к настройкам управления питанием процессора.
    В свою очередь, в каждом из данных разделов есть подразделы, отвечаяющие за какую-либо настройку электропитания. Описание каждой из настроек указано в значении параметра Description, а её отображение в графической оболочке в значении параметра Attributes. По умолчанию, многие настройки имеют значение параметра Attributes равное «1», для того, чтобы необходимая Вам настройка был виден в графической оболочке, необходимо заменить его на «0». Доступные для отображения настройки, на ноутбуке и стационарном компьютере могут отличаться, в связи с особенностью их систем электропитания.

    Для отображения политики простоя устройств, необходимо импортировать в реестр:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\4faab71a-92e5-4726-b531-224559672d19]
    "Attributes"=dword:00000000
    Для отображения скрытых параметров по настройке работы жесткого диска, необходимо импортировать в реестр:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\dab60367-53fe-4fbc-825e-521d069d2456]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\0b2d69d7-a2a1-449c-9680-f91c70521c60]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\80e3c60e-bb94-4ad8-bbe0-0d3195efc663]
    "Attributes"=dword:00000000
    Для отображения скрытых параметров по настройке кнопок питания, необходимо импортировать в реестр:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\4f971e89-eebd-4455-a8de-9e59040e7347\833a6b62-dfa4-46d1-82f8-e09e34d029d6]
    "Attributes"=dword:00000000
    Для отображения скрытых параметров по настройке управления питания процессора, необходимо импортировать в реестр:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\3b04d4fd-1cc7-4f23-ab1c-d1337819c4bb]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\5d76a2ca-e8c0-402f-a133-2158492d58ad]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\a55612aa-f624-42c6-a443-7397d064c04f]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\ea062031-0e34-4ff1-9b6d-eb1059334028]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\0cc5b647-c1df-4637-891a-dec35c318583]
    "Attributes"=dword:00000000
    Импортированное значение реестра позволяет увидеть только малую часть параметров, доступных для настройки управлением процессора. Всего их более 30.

    Для отображения скрытых параметров по настройке спящего режима, необходимо импортировать в реестр:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\25DFA149-5DD1-4736-B5AB-E8A37B5B8187]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\d4c1d4c8-d5cc-43d3-b83e-fc51215cb04d]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\abfc2519-3608-4c2a-94ea-171b0ed546ab]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\A4B195F5-8225-47D8-8012-9D41369786E2]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0]
    "Attributes"=dword:00000000
    Для отображения скрытых параметров по настройке экрана, необходимо импортировать в реестр:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\A9CEB8DA-CD46-44FB-A98B-02AF69DE4623]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\FBD9AA66-9553-4097-BA44-ED6E9D65EAB8]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\90959d22-d6a1-49b9-af93-bce885ad335b]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\EED904DF-B142-4183-B10B-5A1197A37864]
    "Attributes"=dword:00000000

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\82DBCF2D-CD67-40C5-BFDC-9F1A5CCD4663]
    "Attributes"=dword:00000000
    Также к этому разделу относится настройка параметров графического адаптера, но доступность конкретных настроек будет определяется драйвером.

    У себя в системе я обнаружил 54 скрытых настройки электропитания. Для включения сразу всех скрытых настроек электропитания: экспортируйте всю ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings в reg-файл. Отредактируйте полученный reg-файл: оставьте в нем только наименование веток реестра и их параметры Attributes и присвойте им значения «0». Также Вы можете скачать и применить, готовый reg-файл PowerSettings.reg

    12. Добавление своего ярлыка папки или программы в папку Компьютер.

    Если Вы часто пользуйтесь какой-либо программой, то помимо добавления её значка на Рабочий стол, Вы также можете добавить его в папку Компьютер. Поскольку скопировать напрямую или создать ярлык в данной папке нельзя, то предлагаю Вам решение, как это возможно осуществить.

    1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}]
    @="Имя программы"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\DefaultIcon]
    @="Путь к иконке программы"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell\Open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell\Open\Command]
    @="Путь к файлу программы"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{GUID}]
    2) Скачайте программу Microsoft Exchange Server GUID Generator
    3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
    4) Установите переключатель на значение Registry Format
    5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
    6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
    7) Вставьте вместо {GUID}, сгенерированный программой GUID.
    Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {FF4A6226-C00B-409e-88A6-6C401C52BD98}
    Внимание! Для добавления при указывании пути к иконе и файлу объекта слэш должен быть двойным.
    8) Например, если путь к программе: C:\MyProgram\MyProgram.exe, то необходимо указать его как: C:\\MyProgram\\MyProgram.exe
    Так как, чаще всего икона программы встроена в саму программу, то значения "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" могут совпадать.
    9) При добавлении ярлыка папки измените "Путь к иконке для ярлыка" на %SystemRoot%\\system32\\SHELL32.dll,4
    А значение "Путь к папке или файлу программы" на explorer /n, /e, C:\\ВашаПапка
    10) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    11) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
    12) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Пример reg-файла для добавления программы WinDjView в папку Компьютер:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
    @="WinDjView"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\DefaultIcon]
    @="C:\\Program Files\\WinDjView\\WinDjView.exe"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open\Command]
    @="C:\\Program Files\\WinDjView\\WinDjView.exe"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
    Пример reg-файла для добавления папки Downloads в папку Компьютер:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
    @="Downloads"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\DefaultIcon]
    @="%SystemRoot%\\system32\\SHELL32.dll,4"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open\Command]
    @="explorer /n, /e, C:\\My Folder\\Downloads"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
    В итоге Вы получите тот же самый эффект, что был упомянут в совете 5 раздела "Твики Реестра - Добавление".

    Твики Реестра - Изменение

    1. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

    Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
    Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

    1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
    2) Введите команду
    unregmp2.exe /SwapTo:64
    (команда чувствительна к регистру)
    3) Откройте редактор реестра: Win+R --> regedit
    4) Перейдите к ветке
    HKLM\Software\Microsoft\Windows\CurrentVersion\App Paths\wmplayer.exe\
    и кликните два раза по значению Path
    5) Измените
    "%ProgramFiles(x86)%\Windows Media Player"
    на
    "%ProgramFiles%\Windows Media Player"
    6) Закройте реестр и наслаждайтесь Windows Media Player х64

    Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

    2. Ускорение выключения компьютера.

    Измените задержку перед выключением компьютера в реестре в разделе:
    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WaitToKillServiceTimeout" - отвечает за задержку перед выключением.
    По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
    Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки)

    3. Отмена автозапуска для носителей и устройств.

    1) Пуск -> выполнить -> regedit
    2) открыть ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) В этом разделе создать ключ(Параметр DWORD) NoDriveTypeAutoRun

    Допустимые значения ключа:

    0x1 - отключить автозапуск на приводах неизвестных типов
    0x4 - отключить автозапуск сьемных устройств
    0x8 - отключить автозапуск НЕсьемных устройств
    0x10 - отключить автозапуск сетевых дисков
    0x20 - отключить автозапуск CD-приводов
    0x40 - отключить автозапуск RAM-дисков
    0x80 - отключить автозапуск на приводах неизвестных типов
    0xFF - отключить автозапуск вообще всех дисков.

    4. Смена фона в экране авторизации.

    1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background

    2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
    3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
    4) Поместите сюда свой файл
    5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

    background768x1280.jpg
    background900x1440.jpg
    background960x1280.jpg
    background1024x1280.jpg
    background1280x1024.jpg
    background1024x768.jpg
    background1280x960.jpg
    background1600x1200.jpg
    background1440x900.jpg
    background1920x1200.jpg
    background1280x768.jpg
    background1360x768.jpg
    backgroundDefault.jpg - в случае нестандартного расширения монитора

    Размер изображений не должен превышать 256Кб.
    Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

    5. Ускорение анимации всплывающего меню в меню Пуск и появления окна предварительного просмотра в панели задач.

    Если Вы желаете изменить время задержки до показа всплывающего меню в меню Пуск, проделайте следующее:

    1)Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
    3) Создайте в нем(или измените) параметр MenuShowDelay
    4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
    5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    6) Выберите желательное значение от 1 до 4000, означающее задержку в милисекундах, до показа всплывающего меню в меню Пуск.
    7) Закройте regedit и перезагрузите систему.

    6. Изменение состояния встроенного динамика персонального компьютера.

    1) Запустите редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Sound
    3) Измените значение параметра Beep на "No" чтобы отключить и на "Yes" чтобы включить.

    7. Переназначение гнезд звуковой карты Realtek используя реестр.
    На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
    Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
    Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

    1) Установите драйвера звуковой карты
    2) Запустите редактор реестра (Win+К -> regedit -> Ok)
    3) Пройдите к папке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\
    4) Откройте папку Drv6013_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
    5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

    Рисунок 1 из 2

    Имя(вставлять без кавычек):

    "Pin01" = Заднее зеленое гнездо
    "Pin02" = Заднее черное гнездо
    "Pin03" = Заднее коричневое гнездо
    "Pin04" = Заднее серое гнездо
    "Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
    "Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

    "Pin06" = Переднее розовое гнездо
    "Pin08" = Переднее зеленое гнездо

    Значение(вставлять без кавычек):

    "00 00 00 00" = Линейный вход
    "01 00 00 00" = Микрофон
    "02 00 00 00" = Наушники
    "04 00 00 00" = Передние динамики
    "05 00 00 00" = Тыловые динамики
    "06 00 00 00" = Центральный канал/Сабвуфер
    "07 00 00 00" = Боковые динамики

    Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

    Drv6013_DevType_0888_SS10438357 - на версию вашего драйвера
    (имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
    Pin04 - на любое значение из списка Имя
    hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\Drv6013_DevType_0888_SS10438357]
    "Pin04"=hex:02,00,00,00

    Рисунок 2 из 2

    8. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

    Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
    Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

    1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
    2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
    3) Измените значение параметра MessageDuration.

    9. Настройка диалога переключения между окнами ("Alt"+"Tab").

    1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
    2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
    В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

    Для создания твика, воспользуйтесь инструкцией:

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Параметры, отвечающие за количество отображаемых столбцов и строк

    Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
    Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

    Пример твика реестра с использованием этих параметров:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
    "Columns"=dword:00000005
    "Rows"=dword:00000003
    Параметры, отвечающие за отступы в диалоге переключения между окнами

    Упомянутые ниже параметры указываются в пикселях.

    TopMarginPx - величина верхнего поля, добавляемого в диалог
    SideMarginPx - величина бокового поля, добавляемого в диалог
    BottomMarginPx - величина нижнего поля, добавляемого в диалог
    MinWidthPx - минимальная возможная ширина диалога AltTab
    ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
    ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

    Пример твика реестра с использованием этих параметров:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
    "TopMarginPx"=dword:00000027
    "SideMarginPx"=dword:00000005
    "BottomMarginPx"=dword:00000003
    "MinWidthPx"=dword:00000050
    "ThumbSpacingXPx"=dword:00000006
    "ThumbSpacingYPx"=dword:00000015
    Параметры, отвечающие за значки эскизов окон

    Упомянутые ниже параметры указываются в пикселях.

    OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
    OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
    OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

    Пример твика реестра с использованием этих параметров:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
    "OverlayIconDYPx"=dword:00000008
    "OverlayIconDXPx"=dword:00000008
    "OverlayIconPx"=dword:00000030
    Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

    Упомянутые ниже параметры указываются в пикселях.
    MaxThumbSizePx - максимальный размер эскизов окон
    MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
    TextButtomPx - высота заголовка диалога переключения между окнами

    Пример твика реестра с использованием этих параметров:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
    "MinThumbSizePcent"=dword:00000010
    "MaxThumbSizePx"=dword:00000085
    "TextButtomPx"=dword:00000010
    Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

    FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
    FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
    FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

    StartAlpha - начальная прозрачность диалога переключения между окнами
    FinalAlpha - конечная прозрачность диалога переключения между окнами

    Пример твика реестра с использованием этих параметров:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
    "FadeOut_ms"=dword:00000100
    "FadeIn_ms"=dword:00000100
    "StartAlpha"=dword:00000002
    "FinalAlpha"=dword:00000004
    Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

    10. Настройка параметров всплывающих эскизов окон в панели задач.

    Изменив несколько настроек в реестре Вы сможете придать своим всплывающим эскизам окон больше эффективности в работе.

    1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) Создайте в нем(или измените) параметры:

    ExtendedUIHoverTime - Задержка до появления всплывающего эскиза окна на экране, после наведения курсора мыши на иконку в панели задач.
    ThumbnailLivePreviewHoverTime - Задержка до появления окна программы, после наведения курсора мыши на всплывший эскиз окна.

    4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
    5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    6) В графе Система исчисления установите значение параметра на Десятичная.
    7) Введите необходимое Вам значение. Значение 1000 = 1 секунде.

    8) Откройте в реестре раздел: HKEY_CLASSES_ROOT\SystemFileAssociations\image
    9) Сделайте двойной щелчок на параметре Treatment - Данный параметр изменяет вид бордюра всплывающего эскиза окна.
    10) Выберите необходимое Вам значение:

    0 - Без бордюра
    1 - Бордюр с тенью
    2 - Фоторамка (по умолчанию)
    3 - Видеорамка

    11) Закройте regedit и перезагрузите систему.

    11. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

    Когда Вы наводите курсор на крайнюю кнопку, находящуюся за часами на панели задач (обычно правый нижний угол экрана), система показывает Вам рабочий стол. При желании Вы можете ускорить или замедлить данный процесс.

    1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) Измените значение параметра DesktopLivePreviewHoverTime. Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    4) В графе Система исчисления установите значение параметра на Десятичная.
    5) Введите необходимое Вам значение. Значение 1000 = 1 секунде.
    6) Закройте regedit, перезайдите в систему или перезагрузите систему.

    12. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

    Как известно, при выделении более 15 файлов команды контекстного меню, такие как "Открыть/Печать/Редактировать" становятся недоступны.
    Для отмены данного ограничения проделайте следующее:

    1)Запустите редактор реестра ( Win+R -> regedit -> OK)
    2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
    3) Создайте в ней параметр MultipleInvokePromptMinimum типа DWORD.
    4) Установите значение данного параметра равным 16.

    Для уменьшения количества файлов на которых действует ограничение применения команд, введите значение от 1 до 15.
    При выделении файлов выше выбранного Вами значения команды в контекстном меню применяться не будут. При указании значения 0 произойдет полное отключение команд, включая команду "Открыть".

    13. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

    1) Откройте Редактор групповой локальной политики (Win+R -> gpedit.msc - Ok)
    2) Перейдите в раздел Конфигурация пользователя\Административные шаблоны\Панель управления.
    3) Выберите команду Скрыть указанные элементы панели управления
    4) Установите переключатель в значение Включить.
    5) Нажмите на кнопку Показать.
    6) Добавьте новую запись: Microsoft.DevicesAndPrinters и нажмите Ok.
    7) Запустите редактор реестра (Win+R -> regedit.exe -> Ok).
    8) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
    9) Создайте в ней новый раздел {2227a280-3aea-1069-a2de-08002b30309d}.
    10) Присвойте параметру По умолчанию значение - Принтеры (Printers).

    Данную папку Вы сможете увидеть в Панели управления в контекстном меню Пуск, если у Вас установлено значение "Отображать как меню" или при просмотре полного списка всех элементов при её открытии.

    Твики Реестра - Удаление

    1. Как убрать цифру при пересоздании адаптера сети в Диспетчере устройств?

    Вариант 1

    1) Удалите драйвер сетевого адаптера
    2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" установите значение адаптера сети на 0.
    3) Создайте драйвер сетевого адаптера

    Вариант 2

    1) Удалите драйвер сетевого адаптера
    2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" удалите ваш сетевой адаптер.
    3) Создайте драйвер сетевого адаптера.

    2. Как отключить проверку подписи для загруженных программ?

    Избавляет от этого:

    1) В Панель управления -> Свойства браузера-> вкладка Дополнительно -> снять галочку "Проверка подписи для загруженных программ" и поставить галочку "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
    2) Создайте и примените reg-файл следующего содержания.
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
    "DefaultFileTypeRisk"=dword:00006152

    ;Отключить предупреждение при открытии файлов, загруженных из Интернета
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
    "HideZoneInfoOnProperties"=dword:00000001
    "SaveZoneInformation"=dword:00000002

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDriveTypeAutoRun"=dword:00000095

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
    "LowRiskFileTypes"=".zip;.rar;.nfo;.txt;.exe;.bat;.com;.cmd;.reg;.msi;.htm;.html;.gif;.bmp;.jpg;.avi;.mpg;.mpeg;.mov;.mp3;.m3u;.wav;"

    3. Как удалить (вернуть) стрелки с ярлыков Windows?

    Готовые файлы для убирания стрелок вы можете скачать по ссылке:
    Shortcut_Arrows.zip
    1) Распакуйте и откройте папку нужного вам варианта
    2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat или Remove_Shortcut_Arrow.reg
    3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat или Restore_Shortcut_Arrow.reg

    Вариант 1

    Для удаления стрелок с ярлыков:

    1) Запустите диалоговое окно "Выполнить" (Win + R)
    2) Скопируйте код указанный ниже и нажмите OK
    REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %WINDIR%\system32\shell32.dll,50 /f
    Для восстановления стрелок на ярлыках:
    REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f
    Или в ручную удалите данную ветку.

    Вариант 2

    Для удаления стрелок с ярлыков:

    1) Создайте пустой файл иконки назовите его Blank.ico
    2) Скопируйте его в папку C:\Windows
    3) Запустите диалоговое окно "Выполнить" (Win + R)
    4) Скопируйте код указанный ниже и нажмите OK
    REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %SystemRoot%\Blank.ico,0 /f
    Для восстановления стрелок на ярлыках:

    1) Удалите файл Blank.ico из папки C:\Windows
    2) Запустите диалоговое окно "Выполнить" (Win + R)
    3) Скопируйте код указанный ниже и нажмите OK
    REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f
    Или в ручную удалите данную ветку.

    Побочным эффектом при использовании данного варианта является, появление черных квадратиков вместо стрелочек, если в папке Windows у Вас будет отсутствовать файл Blank.ico.

    Вариант 3

    1) Скопируйте текст в блокнот.
    2) Сохраните как Remove_Shortcut_Arrow.reg (для удаления) или Restore_Shortcut_Arrow.reg (для восстановления).
    3) Выполните файл, чтобы его содержание было внесено в реестр.
    4) Обратите внимание на знак минуса в команде "IsShortCut"=-. Вокруг него нет кавычек. Эта команда удаляет значение IsShortCut и сам ключ IsShortCut. Если вы введёте команду "IsShortCut"="-", то тогда ключ удалён не будет, а его значение поменяется на минус. "IsNotShortCut"="" создаёт ключ и присваивает ему нулевое значение.

    Файл .reg для удаления стрелок с ярлыков
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\lnkfile]
    "IsShortCut"=-
    "IsNotShortCut"=""
    Файл .reg для восстановления стрелок на ярлыках
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\lnkfile]
    "IsShortCut"=""
    "IsNotShortCut"=-
    Побочным эффектом при использовании данного варианта является, исчезновение пункта "Закрепить программу в панели задач". Если Вам необходимо будет закрепить какую-либо программу в Панели задач, то воспользуйтесь reg-файлом для восстановления стрелок на ярлыках, закрепите программу, а затем снова воспользуйтесь reg-файлом для удаления стрелок с ярлыков.

    4. Как отключить или переназначить клавишу Caps Lock?

    Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
    Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

    Клавиша Caps Lock будет выполнять действие клавиши Ctrl
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
    "Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,1d,00,3a,00,00,00,00,00
    Клавиша Caps Lock будет выполнять действие клавиши Shift

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
    "Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,2a,00,3a,00,00,00,00,00
    Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
    "Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,3A,00,46,00,00,00,00,00
    Отключает клавишу Caps Lock
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
    "Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,00,00,00,00
    Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
    "Scancode Map"=-

    5. Удаление просроченных элементов в области уведомления панели задач.

    1. Запустите редактор реестра: Win+R --> regedit
    2. Перейдите в следующий раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
    3. Удалите параметры "IconStreams" и "PastIconsStream"
    4. Запустите диспетчер задач Ctrl+Shift+Esc
    5. Остановите процесс explorer.exe
    6. File --> New Task (Run...) --> explorer --> ОК.
    7. Установите необходимые параметры отображения области уведомления панели задач.

    6. Удаление папок из Рабочего стола в Проводнике.

    Если вы хотите, удалить папки из Рабочего стола в Проводнике.

    Вариант 1

    1) Нажмите Win+R
    2) Введите regedit и нажмите Ок
    3) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
    4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
    5) Удалите следующие ветки:
    Favorites(Избранное)             = {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки)            = {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа)       = {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Документы)    = {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер)              = {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть)                    = {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) = {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина)             = {645FF040-5081-101B-9F08-00AA002F954E}

    Вариант 2

    1) Нажмите Win+R
    2) Введите regedit и нажмите Ок
    Для удаления Favorites(Избранное), измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
    "Attributes"=dword:a9400100
    Для восстановления Favorites(Избранное) по умолчанию, измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
    "Attributes"=dword:a0900100
    Для удаления Libraries(Библиотеки), измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
    "Attributes"=dword:b090010d
    Для восстановления Libraries(Библиотеки) по умолчанию, измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
    "Attributes"=dword:b080010d
    Для удаления Homegroup(Домашняя группа), измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
    "Attributes"=dword:b094010c
    Для восстановления Homegroup(Домашняя группа) по умолчанию, измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
    "Attributes"=dword:b084010c
    Для удаления Computer(Компьютер), измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
    "Attributes"=dword:b094010c
    Для восстановления Computer(Компьютер) по умолчанию, измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
    "Attributes"=dword:b084010c
    Для удаления Network(Сеть), измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
    "Attributes"=dword:b0940064
    Для восстановления Network(Сеть) по умолчанию, измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
    "Attributes"=dword:b0040064
    Для удаления Recycle Bin(Корзина), измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
    "Attributes"=hex:70,01,00,20
    Для восстановления Recycle Bin(Корзина) по умолчанию, измените значение реестра на:
    [HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
    "Attributes"=hex:40,01,00,20

    7. Очистка устаревших значков из диалога выбора значков и уведомлений.

    После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
    С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
    "PastIconsStream"=-
    "IconStreams"=-
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

    Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

    8. Очистка истории расположений фонов рабочего стола в Windows 7.

    В окне настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев Рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

    1. Фоны рабочего стола Windows;
    2. Библиотека изображений;
    3. Самые популярные фотографии;
    4. Сплошные цвета.

    Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

    Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

    Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

    9. Удаление папки Общие Документы и пользовательского профиля Общие.

    Для спокойного удаления папки Общие Документы и пользовательского профиля Общие указанные ниже действия рекомендуется выполнять на чистой установленной системе. Если же у Вас система уже установлена, и на ней уже установлены программы, то прежде чем выполнять инструкции ниже скопируйте все папки из C:\Users\Public\* в C:\Users\ВашПрофиль\*

    Вариант 1.

    1) В командной строке(Пуск->Выполнить) наберите REGEDIT
    2) Найдите ветку HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\
    3) Затем нажмите правой кнопкой мыши на правой панели и выберите Создать -> Параметр "DWORD".
    4) Дайте этому параметру имя NoSharedDocuments и присвойте ему значение 1
    5) Перезагрузите компьютер

    Вариант 2.

    1) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
    2) Удалите следующую ветку: {59031a47-3f72-44a7-89c5-5595fe6b30ee}
    3) Пройдите к ветке реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\DelegateFolders\
    4) Удалите следующую ветку(если есть): {59031a47-3f72-44a7-89c5-5595fe6b30ee}

    Вариант 3.

    1) Откройте Панель управления\Все элементы панели управления\Система(или Пуск -> Компьютер -> Свойства)
    2) Откройте Дополнительные параметры системы
    3) Пройдите на вкладку Имя Компьютера и нажмите Идентификация...
    4) Выберите пункт Компьютер предназначен для домашнего использования.
    5) Нажмите Далее, затем Готово, затем Ок
    6) Перезагрузите компьютер

    После того, как воспользуйтесь решением одного из вариантов проделайте следующие действия:

    1) В ветке реестра: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders замените значения с C:\Users\Public\ на C:\Users\ВашПрофиль\

    2) В ветке реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders замените значения с %PUBLIC%\ на %USERPROFILE%\

    3) Удалите папки (если они остались):

    Диск С: -> Пользователи -> Общие (C:\Users\Public\)
    Библиотеки -> Документы -> Общие Документы

    Внимание: Если не хотите,чтобы у Вас на рабочем столе появились дублирующиеся иконки файлов, не устанавливайте значение параметра Common Desktop, идентичное рабочему столу Вашего профиля. Например, вместо C:\Users\ВашПрофиль\Desktop укажите C:\Users\ВашПрофиль\Public\Desktop, а вместо %USERPROFILE%\Desktop укажите %USERPROFILE%\Public\Desktop.

    10. Отключение суффикса "-Ярлык" при создании новых ярлыков.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
    3) В правой части окна, дважды щелкните на параметр реестра "link".
    4) Измените значение на 00 00 00 00.
    5) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
    "link"=hex:00,00,00,00

    11. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) В правой части окна, дважды щелкните на параметр реестра "ShowInfoTip".
    4) Измените значение на 0.
    5) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
    "ShowInfoTip"=dword:00000000

    12. Запрет запуска контекстного меню Проводника при нажатии правой кнопкой мыши.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в NoViewContextMenu
    5) Измените значение на 1.
    6) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:
    Windows Registry Editor Version 5.00

    [HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoViewContextMenu"=dword:00000001

    13. Удаление пункта меню Файл из Проводника.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в NoFileMenu
    5) Измените значение на 1.
    6) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:
    Windows Registry Editor Version 5.00

    [HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoFileMenu"=dword:00000001
    Данный пункт будет также удален из всех мест, использующих оболочку Windows

    14. Запрещение запуска программ.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в RestrictRun
    5) Измените значение на 1.
    6) Перезагрузите компьютер.
    7) Создайте подраздел с аналогичным именем RestrictRun
    8) Создайте в разделе (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun) список разрешенных к запуску программ для текущего пользователя.
    8.1) Создайте строковые(String) параметры
    8.2) Укажите названия для создаваемый строковых параметров, начиная с 1 и далее
    8.3) Установите в значениях параметров пути к Вашим приложениям и их имена. Файлы должны указываться с расширением. Например:

    1 REG_SZ regedit.exe
    2 REG_SZ calc.exe
    3 REG_SZ Iexplore.exe

    Не забудьте указать файл regedit.exe, чтобы Вы могли зайти в него и отменить установленные Вами ограничения!
    Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0 или удалить его.

    Если Вы забыли указать regedit.exe в списке или не создали подраздел RestrictRun, чтобы запретить запуск всех программ. Для отмены запрета проделайте следующее:

    1) Перезапустите компьютер.
    2) До начала запуска Windows нажмите на клавишу F8 и выберите пункт Безопасный режим с поддержкой командной строки
    3) В командной строке введите regedit и нажмите Enter.
    4) Пройдите в ветку HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    5) Удалите ключ RestrictRun или установите его значение на 0.

    Устранение неполадок

    Устранение неполадок - Интерфейс и загрузка.

    1. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

    Вероятно, аэро - отключено.
    Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху).
    Или C:\Windows\Resources\Themes выбрать aero.

    2. Решение проблемы с анимацией DWM (Desktop Window Manager).

    1) Нажимаете "Пуск" на панели задач
    2) Нажимаете правой кнопкой на Компьютер
    3) Выбираете Свойства -> Дополнительные параметры системы
    4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
    5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

    3. Принудительное включение Windows Aero (только для Standard Administrator).

    1) Нажмите Win+R и введите regedit
    2) Установите следующие значения в регистре:
    HKCU\Software\Microsoft\Windows\DWM\Composition равный 1 (32-bit DWORD)
    HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy равынй 2 (32-bit DWORD)
    HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend равный 1 (32-bit DWORD)
    Готовый reg-файл enableaero.reg
    3) Перезапустите DWM из command prompt, запущенного с правами администратора:
    net stop UxSms
    net start UxSms

    4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

    Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
    Для очистки кэша эскизов сделайте следующее.

    1) Нажмите комбинацию клавишь WinKey+R, в поле Открыть напишите cleanmgr и нажмите OK
    2) Выберите диск C: и после оценки объема отметьте "Эскизы" и нажмите OK
    3) В папке %USERPROFILE%\AppData\Local\ стереть файл IconCache.db

    Еще можно попробовать увеличить размер этого кеша, создав в реестре в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] новый параметр Max Cached Icons типа строки (REG_SZ) и занеся в него 4096 (а если такой параметр уже был, увеличить его вдвое).

    5. Причины перехода цветовой схемы на упрощенный стиль.

    Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

    1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
    2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
    3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
    4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

    Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

    1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
    1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter
    или
    1.2) Нажмите Win+R и введите команду в диалоговом окне Выполнить
    msdt.exe -ep WindowsHelp -id AeroDiagnostic
    2) Нажмите Далее

    6. Выбор настроек во время установки для предотвращения замены русских букв знаками вопросов.

    На начальном этапе установки выводится окно, содержащее три строчки.
    Первая строчка - язык, на котором работает система (английский US или русский RU). При возможности выберите русский.
    Вторая строчка - месторасположение компьютера, для выбора страны (от Афганистана и до Ямайки). Выберите страну - Russian Federation.
    Третья строчка - язык раскладки клавиатуры по умолчанию. При выборе во второй строчке страны (РФ), здесь автоматически устанавливается русский. Вы можете выбрать здесь любой используемый Вами язык раскладки клавиатуры.

    7. Замена кодовой страницы для решения проблемы с отображением русских букв.
    1) Замените в реестре в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage С "1252"="c_1252.nls" на "1252"="c_1251.nls"
    2) В папке \WINDOWS\system32\ найдите файлы С_1251 и С_1252. С_1251 куда-нибудь копируем и переименовываем в С_1252.
    3) Оригинальный С_1252 переименовываем или удаляем (потребуется изменить права доступа). Возвращаем новую версию 1252 на место. В итоге файл С_1252, должен быть переименованной копией С_1251
    4) Пуск-Панель управления-Язык и региональные установки-Дополнительно. Выбрать в пункте Текущий язык программ не поддерживающий Юникод: Русский (Россия)
    5) Перезагружаемся.

    8. Запись последовательности действий пользователя для анализа их разработчиком.

    Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
    Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
    Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
    Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
    Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
    Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
    Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

    9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

    Если при попытке выходе из спящего/ждущего режима Вы попадаете в черный экран или в BSOD (синий экран смерти) Вы можете попробовать несколько способов. Первым делом, скачайте и установите более новые версии драйверов для Вашей видеокарты, чем те что у Вас есть.

    Вариант 1. Изменение настроек BIOS:

    1) Во времени загрузки зайдите в BIOS (для этого нажмите клавишу Delete после начала загрузки компьютера)
    2) В BIOS пройдите на вкладку Power
    3) Попробуйте изменить значение параметра Suspend Mode (Auto, S1 (POS) Only, S3 Only) названия может отличаться, ищите похожие со значениями S1, S3.
    4) Также попробуйте включить\отключить ACPI 2.0 Support -> Enabled\Disabled

    Вариант 2. Запрет вывода из спящего режима используя USB мышь или USB клавиатуру.

    Некоторые USB-устройства неправильно поддерживают спящий режим Windows. Два основных устройства с помощью которых Вы можете выйти из спящего режима - это клавиатура и мышь. Одно из них может блокировать Вам выход, в таком случае ему надо просто запретить это делать. Внимание: Не запрещайте одновременно клавиатуре и мыши, иначе Вы не сможете выйти из него.

    1) Запустите Диспетчер устройств. Для этого пройдите в Пуск -> Выполнить (или Win+R) -> devmgmt.msc -> OK
    2) В Диспетчере устройств разверните узел Мыши и иные указывающие устройства или Клавиатуры
    3) Щелкните правой кнопкой на USB-мышь или USB-клавиатуру и выберите пункт Свойства.
    4) Откройте вкладку Управление электропитанием.
    5) Снимите флажок Разрешить устройству вывод компьютера из спящего режима и нажмите кнопку ОК.

    Вариант 3. Отключение спящего/ждущего режима.

    1) Пройдите в Пуск -> Выполнить (Win+R) -> powercfg.cpl -> OK
    2) Выберите слева пункт Настройка перехода в спящий режим
    3) Присвойте обоим параметрам: Отключать дисплей и Переводить компьютер в спящий режим, значение - Никогда.
    Также можно отключить и функцию сна. Выберите пункт "Изменить дополнительные параметры питания". Найдите в окне режим Сон, разверните Сон после и установите значение находящихся там параметров на Никогда
    Если несмотря на проделанное выше, компьютер по прежнему продолжает отлючаться, то Вам необходимо выполнить ещё некоторые действия:
    4) Скачайте reg-файл PowerSettings.reg и примените его.
    5) Откройте вкладку Сон
    6) Установите следующие значения параметрам, открыв их вкладки:
    6.1) Сон после - значение равным 0, оно идентично значению Никогда
    6.2) Разрешить политику требуемую системой - значение Да (это предотвратит автоматический переход в ждущий режим)
    6.3) Разрешить таймеры пробуждения - Включить (позволит автоматически выводить компьютер из спящего режима при помощи заданных событий)
    7) Если у Вас одно из устройств USB например мышь, а второе клавиатура PS/2, то Вы можете отключать USB порт на время работы спящего режима.
    Откройте вкладку Параметры USB в ней вкладку Параметр временного отключения USB- порта и установите значение в Разрешено.
    8) Нажмите OK

    10. Восстановление загрузки Windows 7 без установочного диска.

    Вариант 1. Автоматически - при помощи среды восстановления Windows RE в Windows 7.

    Во время установки Windows 7 на жестком диске автоматически создается служебный раздел, обеспечивающий доступ в среду восстановления Windows RE (Recovery Environment). Используя данный служебный раздел, Вы можете:

    - загрузиться в среду восстановления с жесткого диска
    - создать компакт-диск, содержащий среду восстановления

    1) Выполните загрузку в среду восстановления с жесткого диска или диска восстановления системы.
    Для того чтобы войти в меню Дополнительные варианты загрузки, нажмите F8 после включения компьютера (но до загрузки операционной системы).
    2) Выберите первый пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter.
    3) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи.
    4) Введите пароль администратора. После ввода пароля вы увидите окно с вариантами восстановления.
    5) Выберите пункт Восстановление запуска(Startup repair), также иногда может помочь пункт Восстановление системы (System Restore), позволяющий вернуться к точке, созданной до возникновения проблемы.

    Вариант 2. Восстановление вручную, с созданием мультизагрузочного меню.

    Здесь главное - это добраться до командной строки для введения дальнейших команд.

    1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
    2) Создайте папку Boot
    3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
    4) Запустите среду необходимую для работы:
    5) Загрузитесь в Windows, установленную на другой диск или в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
    6) Запустите командную строку.
    В Windows: Win+R -> cmd -> Ok.
    В среде восстановления: Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt)

    Далее все команды вводимые в командную строку будут одинаковы как в Windows, так и в среде восстановления.

    1) Windows 7 использует усовершенствованный метод загрузки - хранилище данных конфигурации загрузки. Это хранилище содержит все сведения обо всех операционных системах, установленных на компьютере. Следовательно,загрузчики более ранних операционных систем Windows, не могут быть использованы для ее запуска. Итак, для восстановления, загрузочного сектор Windows 7, перезаписываем загрузочный сектор на всех разделах:
    X:\boot\bootsect.exe /nt60 all
    где Х - буква диска, на котором содержится программа Bootsect.exe
    2) Если у Вас вторая система Windows XP, то Вам необходимо выполнить ещё ряд действий:

    Создайте в хранилище загрузки Windows 7 - хранилище для загрузки Windows XP.
    Bcdedit /create {ntldr} /d "Microsoft Windows XP"
    Если же система откажется это делать, значит данное хранилище уже создано, поэтому необходимо его только переименовать:
    Bcdedit /set {ntldr} description "Microsoft Windows XP"
    Далее укажите загрузчику Windows 7 устройство расположения файлов загрузки Windows XP:
    Bcdedit /set {ntldr} device partition=C:
    Затем укажите загрузчику Windows 7 путь к загрузчику Windows XP:
    Bcdedit /set {ntldr} path \ntldr
    После добавьте строчку о выборе Windows XP в меню загрузки и расположив ее под остальными:
    Bcdedit /displayorder {ntldr} /addlast
    Также для работы с загрузчиками, Вы можете воспользоваться программой EasyBCD, позволяющей выполнять указанные выше действия, используя графический интерфейс.

    Для информации:

    Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
    Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

    Вариант 3. Восстановление вручную, при помощи bootrec.exe.

    1) Загрузитесь в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
    2) Выберите операционную систему, которую необходимо восстановить, и нажмите "Next"("Далее").
    3) В окне Опции системы восстановления (System Recovery Options) выберите пункт Командная строка (Command Prompt).
    4) Откроется окно интерпретатора командной строки cmd.exe, где следует ввести:
    Bootrec.exe /FixMbr
    Параметр /FixMbr записывает в системный раздел основную загрузочную запись, совместимую с Windows 7. Этот параметр не перезаписывает существующую таблицу разделов. Данный параметр следует использовать для устранения проблем, связанных с повреждением основной загрузочной записи, или если необходимо удалить из основной загрузочной записи нестандартный код.
    Bootrec.exe /FixBoot
    Параметр /FixBoot записывает в системный раздел новый загрузочный сектор с использованием загрузочного сектора, совместимого с Windows 7. Этот параметр следует использовать, если выполняется хотя бы одно из перечисленных ниже условий.

    - Загрузочный сектор Windows 7 был заменен нестандартным загрузочным сектором
    - Загрузочный сектор поврежден
    - После установки Windows 7 на компьютер была установлена более ранняя версия операционной системы Windows. В данном случае для запуска компьютера вместо диспетчера загрузки Windows (Bootmgr.exe) используется загрузчик Windows NT (NTLDR).
    Bootrec.exe /RebuildBcd
    Параметр /RebuildBcd выполняет поиск установленных операционных систем, совместимых с Windows 7, на всех дисках. Кроме того, этот параметр позволяет выбрать установленные системы, которые необходимо добавить в хранилище данных конфигурации загрузки. Этот параметр следует использовать в том случае, если необходимо выполнить полную перестройку данных конфигурации загрузки.

    Если Вы не запомнили необходимого Вам значения Вы можете просто ввести:
    Bootrec.exe
    и утилита выведет справку по доступным ключам командной строки.

    11. Восстановление стандартного анимированного экрана загрузки Windows 7.

    В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, после неудачно внесенных различного рода изменений в загрузчик ОС. Предлагаю Вам простые и действенные решения:

    Вариант 1

    Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК. Не забываем о разрешении экрана (17" -1280*1024)

    Вариант 2

    1. Откройте командную строку от имени администратора: Пуск -> Выполнить (или Win+R) -> cmd -> Ok
    2. В открытом окне консоли введите команду:
    bcdedit /set {current} locale en-US
    Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
    3. Закройте окно командной строки.
    4. Перезагрузите Ваш компьютер.

    Вариант 3

    1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить (или Win+R)
    2) В открытом окне консоли введите команду: msconfig и нажмите OK
    3) Перейдите на вкладку "Загрузка" и проверьте не установлен ли флажок напротив значения "Без GUI". Если флажок установлен - снимите его.
    4) Закройте окно Конфигурации системы.
    5) Перезагрузите компьютер

    12. Как получить полный доступ к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

    Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
    Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
    Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

    ERD Commander для x86 или x64

    13. Моргание игр в режиме OpenGL.

    Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

    14. Исправление невозможности запуска службы Центра обеспечения безопасности.

    1) Отключены компоненты от которых зависит данная служба.

    1.1) Откройте: Администрирование -> Службы
    1.2) Проверьте включены ли следующие службы:

    - Инструментарий управления Windows
    - Удаленный вызов процедур (RPC)
    - Модуль запуска процессов DCOM-сервера
    - Сопоставитель конечных точек RPC

    2) Востановите начальные параметры в реестре, используя значения с компьютера, на котором данная служба работает.

    2.1) Загрузите и примените готовый reg-файл. wscsvc.zip

    Устранение неполадок - Рабочий стол, Проводник, Панель задач.

    1. Исправление исчезновения панели быстрого запуска после перезагрузки.

    Если Вы создаете панель быстрого запуска, но после перезагрузки она исчезает, то попробуйте любое из предложенных ниже решений.

    1) Попробуйте создать панель быстрого запуска со значением отличающимся от Вашего:

    %userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
    %appdata%\Microsoft\Internet Explorer\Quick Launch
    C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

    2) Установите ползунок контроля учетных записей (UAC) в предпоследнее значение.

    3) Создайте и добавьте в реестр следующий reg-файл:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoSaveSettings"=dword:00000000
    "QuickLaunch"=dword:00000001
    4) Откройте C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer
    Добавьте на вкладке Свойства -> Безопасность пользователя Все и задайте ему полный доступ.

    5) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду control userpasswords2 и нажмите Enter. Поставьте флажок на "Требовать ввод имени пользователя и пароля"

    6) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
    Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
    Измените параметр политики Отображение панели быстрый запуск на панели задач на значение Включить.

    7) Закройте Языковую панель и установите вместо неё Punto Switcher.

    2. Исправление сбоев в Проводнике и Windows Installer (msiexec.exe).

    Вариант 1

    Запустите командную строку от имени Администратора (Пуск->Все программы->Стандартные->Командная строка) и скопируйте следущую строчку:
    reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\Disabled Sessions /va /f

    Вариант 2

    1) В меню Выполнить введите "gpedit.msc" перейдите по адресу:
    Конфигурация компьютера->Административные шаблоны->Система->Управление связью через Интернет->Параметры связи через Интернет.
    2) Щелкните на строчку "Отключить программу по улучшению качества программного обеспечения Windows"
    3) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

    3. Восстановление пункта "Выполнить" в меню "Пуск".

    Если у Вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает Вы можете восстановить его так:
    1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
    2) В левой части открывшегося окна пройти к вкладке:
    Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
    3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
    4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

    4. Как убрать появляющуюся в меню "Пуск" полоску справа, которая пропадает при следующем открытии.

    1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
    2) Перелогиниваетесь или перезапускаете компьютер
    3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
    4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
    5) Возвращаете язык интерфейса на русский
    6) Радуетесь!
    Для тех у кого изначально русская, выкладываю данный файл отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

    Также Вы можете скачать и запустить от имени Администратора готовый патч: MenuFix_Rus_x86_x64_Final.rar
    После его применения понадобиться перезагрузить компьютер.

    5. Как восстановить ассоциацию с файлами *.cpl?

    Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

    1) Щелкаете ПКМ на любом файле *.cpl
    2) Выбираете Свойства -> Приложение -> Изменить
    3) Заходим в папку C:\Windows\System32 и выбираем там control.exe
    4) Жмем Ок

    6. Исправление вылета проводника при нажатии правой клавиши на файле.

    Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
    1) Скачайте небольшую утилиту ShellExView: с оффициального сайта или с зеркала.
    2) После установки и запуска программы, найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
    3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
    4) Перезагрузите компьютер.

    7. Восстановление исчезнувшей языковой панели.

    Исчезновение языковой панели, чаще всего происходит после использования чистильщика или оптимизатора системы.
    Перед использованием одного из предложенных вариантов, сделайте следующее:

    1) Откройте редактор реестра (Win+R -> regedit -> OK )
    2) Проверьте, не добавлен ли запрет на запуск языковой панели в следующую папку реестра:
    HKEY_CURRENT_USER\Control Panel\don't load
    3) Проверьте, присутствует ли в реестре ветки:

    Region and Language

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

    Keyboard

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{725BE8F7-668E-4C7B-8F90-46BDB0936430}

    4) Проверьте значение параметров, в ветке реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Low Rights\ElevationPolicy\{85fc331e-bb64-4c53-ba25-3d8a956c02fd}

    – значение REG_SZ-параметра AppName должно быть ctfmon.exe
    – значение REG_SZ-параметра AppPath должно быть С:\Windows\system32.

    где C: - буква диска на который у Вас установлена Windows

    Вариант 1

    1) Идете в Панель управления - Язык и региональные стандарты
    2) Делаете все по пунктам на скриншотах.

    Рисунок 1 из 2

    Установите переключатель на значение Закреплена в панели задач и отметьте флажок Отображать текстовые метки на языковой панели и нажмите OK
    3) Щелкаете правой кнопкой на панели задач, выбираете Свойства.
    4) В пункте Область уведомлений щелкаем кнопку Настроить

    Рисунок 2 из 2

    5) В открывшемся окне поставьте флажок напротив "Всегда показывать все значки и уведомления на панели задач" и нажмите OK

    Вариант 2

    В контекстном меню панели задач уберите флажок со значения Закрепить панель задач, расширьте границы для всех панелей, а затем снова поставьте флажок напротив Закрепить панель задач.

    Вариант 3

    Найдите файл ctfmon.exe и добавьте его в Атозагрузку или создайте reg-файл со следующим содержанием:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
    "CTFMon"="C:\Windows\system32\ctfmon.exe"

    Вариант 4

    1) Откройте Языки и службы текстового ввода
    Так:

    1.1.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
    1.1.2) Ввести: RunDll32.exe shell32.dll,Control_RunDLL C:\Windows\system32\input.dll
    1.1.3) Нажать OK

    Или так:

    1.2.1) Открыть Панель управления\Часы, язык и регион
    1.2.2) Нажать на ссылку Смена раскладки клавиатуры или других способов ввода
    1.2.3) Нажать на кнопку Изменить клавиатуру
    2) На вкладке Общие удалите все раскладки клавиатуры кроме Английский
    3) На вкладке Языковая панель снимите все флажки и установите переключатель в значение Скрыта
    4) Выгрузите вручную библиотеки.
    4.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
    4.2) Выполните поочередно комманды:
    Regsvr32.exe /u Msctf.dll
    Regsvr32.exe /u Msctf.dll.mui

    5) Перезагрузите компьютер.
    6) Откройте Языки и службы текстового ввода
    7) На вкладке Общие добавьте нужные Вам раскладки клавиатуры
    8) На вкладке Языковая панель установите переключатель в значение Закреплена в панели задач и установите флажок напротив пункта Отображать текстовые метки на языковой панели.
    9) Нажмите OK.

    Как альтернативный вариант можете установить программу Punto Switcher, она добавляет собственную языковую панель и функцию автоматического переключения раскладки при неправильном её выборе.

    8. Как исправить, если папки "Недавние места" и "Недавние документы" пустые?

    1) Щелкните правой кнопкой мыши на кнопке Пуск и нажмите на Свойства
    2) Установите флажки напротив пунктов:
    "Хранить и отображать список недавно открывшихся программ в меню "Пуск"
    "Хранить и отображать список недавно открывшихся элементов в меню "Пуск" и на панели задач"
    3) Нажмите OK.

    9. Удаление появившейся на Рабочем столе папки "Недавние места".

    1) Удалите папку C:\Users\Default\AppData\Roaming\Microsoft\Windows\Recent
    2) Перезагрузите компьютер или перезапустите систему
    3) Зайдите в C:\Users\Default\AppData\Roaming\Microsoft\Windows\
    4) Если Windows 7 не восстановил папку Recent заново, создайте её самостоятельно.

    10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"
    Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
    Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
    Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

    Необходимо восстановить через реестр значение по умолчанию "JSFile" .

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Запустите reg-файл.
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.JS]
    @="JSFile"

    11. Гаджеты или их настройки отказываются запускаться.

    Для нормального функционирования гаджетов не отключайте UAC системы полностью. Выставьте минимальный уровень.
    В случае если вы хотите восстановить работоспособность гаджетов при отключенном UAC, понимая уязвимость такого решения, вы можете применить твик реестра, указанный ниже. После перезагрузки гаджеты будут работать.
    "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings"
    "AllowElevatedProcess"=dword:00000001

    12. Восстановление пункта "Закрепить программу в панели задач".

    Если у вас пропал пункт "Закрепить программу в панели задач":
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\lnkfile]
    "IsShortCut"=""
    "IsNotShortCut"=-

    13. Пользовательские папки отображаются обычными иконками.

    Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
    Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
    В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
    Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

    Содержимое файлов desktop.ini для стандартных пользовательских папок

    Документы
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235
    Изображения
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236
[LocalizedFileNames]
Sample Pictures.lnk=@%SystemRoot%\system32\shell32.dll,-21805
    Музыка
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21790
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\imageres.dll,-108
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-237
[LocalizedFileNames]
Sample Music.lnk=@%SystemRoot%\system32\shell32.dll,-21806
    Видео
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21791
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\imageres.dll,-189
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-238
[LocalizedFileNames]
Sample Videos.lnk=@%SystemRoot%\system32\shell32.dll,-21807
    Поиски
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-9031
IconResource=%SystemRoot%\system32\imageres.dll,-18
[LocalizedFileNames]
Indexed Locations.search-ms=@shell32.dll,-32811
Everywhere.search-ms=@shell32.dll,-32814
Shared By Me.search-ms=@shell32.dll,-32802
Recent Music.search-ms=@shell32.dll,-32803
Recent Documents.search-ms=@shell32.dll,-32804
Recent Pictures and Videos.search-ms=@shell32.dll,-32806
Recent E-mail.search-ms=@shell32.dll,-32807
Recently Changed.search-ms=@shell32.dll,-3281
    Загрузка
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21798
IconResource=%SystemRoot%\system32\imageres.dll,-184
    Избранное
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21796
IconResource=%SystemRoot%\system32\imageres.dll,-115
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-173
    Контакты
    [.ShellClassInfo]
LocalizedResourceName=@%CommonProgramFiles%\system\wab32res.dll,-10100
InfoTip=@%CommonProgramFiles%\system\wab32res.dll,-10200
IconResource=%SystemRoot%\system32\imageres.dll,-181
    Рабочий стол
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
    Ссылки
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21810
IconResource=%SystemRoot%\system32\imageres.dll,-185
DefaultDropEffect=4
[LocalizedFileNames]
Public.lnk=@shell32.dll,-21816
Searches.lnk=@shell32.dll,-9031
Recently Changed.lnk=@shell32.dll,-32813
Music.lnk=@shell32.dll,-21790
Pictures.lnk=@shell32.dll,-21779
Documents.lnk=@shell32.dll,-21770
    Сохраненные игры
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21814
IconResource=%SystemRoot%\system32\imageres.dll,-186
    Общий рабочий стол
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799
    Общие документы
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21801
IconResource=%SystemRoot%\system32\shell32.dll,-235
    Общая музыка
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21803
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\shell32.dll,-237
    Общие изображения
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21802
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\shell32.dll,-236
    Общее видео
    [.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21804
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\shell32.dll,-238

    14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

    Если при создании, копировании или перемещении на рабочий стол любого документа/ярлыка/папки, после обновления экрана или перезагрузки компьютера, у Вас появляются их дубликаты (точная копия, без (2) в названии), то это означает, что Ваш собственный рабочий стол и общий рабочий стол прописаны в реестре в одной папке. Данная проблема решается указанием для них отдельных отличающихся между собою папок.

    1) Запустите Редактор реестра. Для этого в строке поиска в меню Пуск введите regedit и нажмите Enter
    2) Откройте раздел: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    3) Измените значение параметра Common Desktop на одно из предложенных ниже:

    C:\Users\Public\Desktop - значение Windows по умолчанию
    C:\Users\ВашПрофиль\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

    4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
    5) Измените значение параметра Common Desktop на одно из предложенных ниже:

    %Public%\Desktop - значение Windows по умолчанию
    %USERPROFILE%\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

    15. Восстановление поиска в Проводнике и в меню Пуск.

    1) Используя Реестр (Win+R -> regedit)
    1.1) Откройте ветку реестра:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    1.2) В случае обнаружения параметра NoFind, удалите его.

    2) Используя Панель управления
    2.1) Откройте Панель управления\Программы\Программы и компоненты
    2.2) Запустите "Включение и отключение компонентов Windows" (или Win+R -> OptionalFeatures.exe)
    2.3) Проверьте, включен ли у Вас компонент Windows Search (Поиск Windows).

    Устранение неполадок - Устройства и BSOD.

    1. При использовании сторонних плееров для видео, выкидывает в BSOD.

    Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

    В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
    В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

    2. В папке "Компьютер" не отображаются DVD-дисководы.

    Уберите флажок в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

    3. В Windows и Nero не стираются диски DVD RW и CD RW.

    Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
    Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
    После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

    4. Определение драйвера, вызвавшего BSOD.

    Включение записи дампов памяти

    1) Нажимаете комбинацию клавиш Win+Pause
    2) Щелкаете ссылку Дополнительные параметры системы
    3) Переходите на вкладку Дополнительно
    4) Нажимаете кнопку Параметры в Загрузка и восстановление

    Рисунок 1 из 2

    5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

    Рисунок 2 из 2

    Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

    Вариант 1

    1) Загрузите и установите Debugging Tools for Windows.
    2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
    3) Распакуйте архив в любую папку.
    Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
    Путь к папке указан после параметра set dbgpath=
    4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
    5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)
    kdfe.cmd "%systemroot%\Minidump\Mini1110307-01.dmp"
    6) Дождитесь завершениия анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

    Вариант 2

    1) Скачиваете утилиту BlueScreenView.
    2) Устанавливаете BlueScreenView.
    3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
    4) Запускаете BlueScreenView.

    Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
    Для найденных дампов памяти утилита отображает:
    • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
    • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
    Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

    5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

    Порой, получив какую-либо ошибку синего экрана смерти, вы задумываетесь из-за чего же она произошла. Для этого случая, скачайте подборку с разъяснениями значений часто встречающихся ошибок и способами устранения многих из них.
    Скачать: BSOD.rar

    6. В Windows x64 стало показывать меньше памяти, чем есть.

    Зайдите:
    Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
    Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

    Также посмотрите значение функций в биосе:

    1. HPET Mode должно быть 64-bit (если есть такая функция)
    или
    2. Memory Remap Feature должно быть Enabled
    3. Memory Hole должно быть Disabled

    7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

    Попробуйте следующие варианты решений:

    1) Попробуйте установить другую сборку или версию Windows 7.
    2) Сбросьте настройки BIOS в стандартные и установите Windows заново.
    3) Обнулите на материнской плате CMOS: либо переустановив и вернув перемычку, либо нажав на кнопку сброса на материнской плате.
    4) Установите в списке загрузок с жестких дисков в BIOS, приоритет загрузки Вашего диска с Windows 7 на первое место.
    5) Подключите диск выделенный для Windows 7, как Primary Master.

    8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.
    Если на Вашей мультимедиа или офисной клавиатуре перестали работать дополнительные клавиши расширяющие её функциональность, то сделайте следующее.
    Во-первых, проверьте установлено ли у Вас программное обеспечение с диска идущего в комплекте к клавиатуре или с оффициального сайта.
    Если же оно установлено, то одной из наиболее часто встречающихся причин может быть остановка службы Доступ к HID-устройствам.

    1) Зайдите в Панель управления\Система и безопасность\Администрирование и запустите Службы или
    Нажмите кнопку Пуск, щелкните в поле Начать поиск, введите services.msc и нажмите клавишу Enter.
    2) Проверьте указано ли в колонке Состояние, напротив службы Доступ к HID-устройствам значение: Работает
    Если данная служба отключена и не работает, сделайте следующее:
    3) Нажмите на ней правой кнопкой мыши и в появившемся меню выберите Свойства
    4) Для запуска службы нажмите на кнопку Запустить
    5) Также Вы можете установить Тип запуска: Автоматически, и система будет автоматически запускать данную службу при старте Windows.
    6) Перейдите на вкладку Восстановление и установите действия выполняющиеся при первом или втором сбое, а также при последующих сбоях на значение Перезапуск службы и нажмите OK.

    9. Исправление появившихся красных крестиков на значках локальных дисков.

    1) Откройте Панель Управления -> Диспетчер Устройств
    1.1) Проверьте включены ли все IDE ATA/ATAPI контроллеры
    1.2) Проверьте включены ли все Дисковые устройства
    2) Если есть общий доступ, попробуйте его отключить
    Щелкните ПКМ на диске -> Общий доступ -> Расширенная настройка общего доступа... -> Расширенная настройка...
    3) Почистите кэш иконок: для этого в папке %USERPROFILE%\AppData\Local\ удалите файл IconCache.db
    4) Воспользуйтесь специальными утилитами для оптимизации работы компьютера. Например:
    4.1.) TuneUp Utilities

    4.1.1) В колонке Customize Windows нажимаете All functions и выбираете Change Windows appearance
    4.1.2) В меню слева в списке группы Icons выбираете Repair
    4.1.3) Нажмите на кнопку Reload Icons, а после на кнопку Repair Icon Cache

    4.2) Windows 7 Manager

    4.2.1) В меню слева во вкладке Information выберите Repair Center
    4.2.2) В меню слева в Repair Center нажмите Icon Repair
    4.2.3) В разделе Rebuild Icon Cache нажмите Rebuild

    10. Восстановление автозапуска для всех типов приводов и устройств.
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Запустите reg-файл.
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
    "NoDriveTypeAutoRun"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
    "AutoRun"=dword:00000001

    11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.
    На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
    Скачать исправление KB977178 : для x86 или для x64

    Устранение неполадок - Локальная сеть и Интернет

    1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

    Установите, как минимум, пониженый уровень UAC.

    2. Если гаджет погоды пишет service unavailable for your region.

    Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
    Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
    А панель настройки гаджетов может стать недоступной.

    Вариант 1

    Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

    Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:
    207.68.172.246 www.msnweather.com
    198.78.215.126 blst.msn.com
    65.55.228.63 weather.msn.com
    65.55.17.39 weather.service.msn.com

    Вариант 2

    Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget

    3. В Windows Update при попытке обновления появляется error 80072ee7.

    Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

    IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

    Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

    1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
    2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
    3. Дважды щелкните папку Windows, а затем - папку System32.
    4. Дважды щелкните папку драйверы, а затем - папку и т. д..
    5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
    6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
    7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

    4. Решение проблемы с punkbuster на Windows 7.

    Вариант 1

    Решение проблемы вылетов игр (COD 5 и battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136). Лечится так:
    1. обновляем punkbuster - качаем это запускаем и добавляем туда игру, pb которой нужно обновить и жмем check for updates. в конце появится сообщение об окончании.
    2. находим на диске с windows два файла: PnkBstrA.exe и PnkBstrB.exe оба лежат в C:\Windows\SysWOW64 (для х64) и C:\Windows\System32 (для х86) (PnkBstrB.exe еще есть в папке с игрой C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb (думаю аналогично и в cod5). У этих файлов в свойствах выставить совместимость с XP и Vista.

    Вариант 2

    1. в %WINDIR%\system32\ файлам PnkBstrA.exe, PnkBstrB.exe поставить совместимость с Вистой и Права администратора.
    2.На рабочем столе создать батник с следующим содержанием :
    :start

    sc config PnkBstrA type= own type= interact

    sc config PnkBstrB type= own type= interact

    timeout 60

    goto start
    3. Запускать батник перед запуском игр.
    4. Играть

    5. Как исправить высокий пинг в Windows 7?

    1. Пуск - Выполнить - regedit
    2. Ищем там HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
    3. Ищем там интерфейс по которому у вас работает интернет, если не в курсе то делаем следующий шаг во всех
    4. Создаем DWORD-параметр, называем его TcpAckFrequency, открываем Изменить, ставим значение переключателя на шестнадцатиричное, и пишем значение 1
    5. Идем в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
    Если такого пункта в реестре нет, а его скорее всего нет, то делаем следующие шаги:
    Открываем - Пуск - Панель управления - Программы и Компоненты-(слева)Включение и отключение компонентов Windows.
    Там находим пункт - Сервер очереди сообщений Майкрософт (MSMQ), и ставим галочку напротив него и все галочки внутри в выпадающем списке компонентов. Перегружаемся, идем в реестр и видим там нужную нам запись.

    6. В месте указанном в пункте 5 ищем TCPNoDelay, если нету создаем DWORD параметр с таким названием. значение 1.

    6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

    При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

    Internet Explorer не удается загрузить / из help
    Не удается открыть этот узел Интернета. Узел не доступен или не найден. Повторите попытку позднее.

    Это может происходить по причине неправильного сопоставления программам типа файлов .xml
    Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.xml]
    @="xmlfile"
    "Content Type"="text/xml"
    "PerceivedType"="text"

    [HKEY_CLASSES_ROOT\.xml\OpenWithList]

    [HKEY_CLASSES_ROOT\.xml\OpenWithList\winword.exe]
    @=""

    [HKEY_CLASSES_ROOT\.xml\PersistentHandler]
    @="{7E9D8D44-6926-426F-AA2B-217A819A5CCE}"

    7. Причины перехода цветовой схемы на упрощенный стиль.

    Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

    1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
    2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
    3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
    4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

    Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

    1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
    1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter
    или
    1.2) Нажмите Win+R и введите команду в диалоговом окне Выполнить
    msdt.exe -ep WindowsHelp -id AeroDiagnostic
    2) Нажмите Далее

    Разное

    1. Где можно скачать последнюю версию DirectX?
    Оффициальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

    Оффициальный сайт DirectX
    Полная версия: directx_feb2010_redist.exe
    Web версия: dxwebsetup.exe

    2. Как открыть файлы с расширением .hlp?

    Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
    Оффициальная ссылка: здесь

    3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

    Диалоговое окно Выполнить используется в Windows для открытия программы, папки или документа. Оно позволяет создать задание для запуска с правами администратора. Самые известные команды выполняемые в окне Выполнить это cmd (Командная строка) и regedit (Редактор реестра). Зная точное названия команды Вы можете запустить любое системное приложения или оснастку Windows.
    Диалоговое меню Выполнить запускается либо Пуск -> Выполнить, либо нажатием клавиатуре Win+R.
    Для выполнения команды введите её название и нажмите Enter.

    Русское название элемента | Английское название элемента | Команда
Ftp-протокол (командная строка) | Ftp-protocol (command prompt) | ftp
Iexpress Wizard (не переведена) | Iexpress Wizard | iexpress
Internet Explorer | Internet Explorer | iexplore
Paint | Paint | mspaint
Windows Firewall | Брандмауэр Windows | firewall.cpl
Wordpad | Wordpad | write
Администратор источников данных ODBC | ODBC Data Source Administrator | odbcad32
Администрирование | Administrative Tools | control admintools
Архивация и восстановление | Backup and Restore | sdclt
Блокнот | Notepad | notepad
Включение и отключение компонентов Windows | Turn Windows features on or off | OptionalFeatures.exe
Восстановление системы | System Restore | rstrui
Выйти из системы | Log Out Of Windows | logoff
Дата и Время | Date and Time | timedate.cpl
Дефрагментация диска | Disk Defragmenter | dfrgui
Диспетчер авторизации | Authorization Manager | azman.msc
Диспетчер задач Windows | Windows Task Manager | taskmgr
Диспетчер проверки драйверов | Driver Verifier Manager | verifier
Диспетчер устройств | Device Manager | devmgmt.msc
Диспетчер устройств | Device Manager | hdwwiz.cpl
Дополнительные часы | Additional Clocks | control timedate.cpl,,1
Завершение работы Windows | Shuts Down Windows | shutdown /s
Записки | Sticky Note | StikyNot
Защита БД учетных записей Windows | Securing the Windows Account Database | syskey
Звук | Sound | mmsys.cpl
Звуки (звуковая схема) | Sounds (sound theme) | control mmsys.cpl,,2
Звукозапись | Sound Recorder | soundrecorder
Игровые устройства | Game Controllers | joy.cpl
Инициализация оборудования безопасности для TPM | Initialize the TMP security hardware | TpmInit
Калибровка цветов экрана | Display Color Calibration | dccw
Калькулятор | Calculator | calc
Командная строка | Command Prompt | cmd
Компоненты Windows | Windows Features | OptionalFeatures
Консоль управления(MMC) | Microsoft Management Console | mmc
Конфигурация системы | System Configuration | msconfig
Локальная политика безопастности | Local Security Policy | secpol.msc
Локальные пользователи и группы | Local Users and Groups | lusrmgr.msc
Мастер загрузки изображений Windows | Windows Picture Acquisition Wizard | wiaacmgr
Мастер создания общих ресурсов | Create A Shared Folder Wizard | shrpubw
Мастер установки драйверов устройств | Driver Package Installer | dpinst
Мастер установки оборудования | Add Hardware Wizard | hdwwiz
Микшер громкости | Sound Volume | sndvol
Монитор ресурсов | Resource Monitor | resmon
Настройка доступа программ и умолчаний | Set Program Access and Computer Defaults | control appwiz.cpl,,3
Настройка Контроля Учетных Записей | User Account Control Settings | UserAccountControlSettings
Ножницы | Snipping Tool | snippingtool
Общие папки | Shared Folders | fsmgmt.msc
Очистка диска | Disk Cleanup Utility | cleanmgr
Панель управления | Control Panel | control
Папка "Fonts" | Fonts Folder | fonts
Папка "Загрузки" | "Downloads" Folder | Downloads
Параметры папок | Folder Options | control folders
Перезагрузка | Restart Windows | shutdown /r
Перенос принтеров | Printer Migration | PrintBrmUi
Перо и сенсорные устройства | Pen and Touch | TabletPC.cpl
Персонализация | Personalization | control desktop
Планировщик заданий | Task Sheduler | control schedtasks
Подключение к удаленному рабочему столу | Remote Desktop Connection | mstsc
Получение программ | Get Programs | control appwiz.cpl,,1
Проверка диска | Check Disk Utility | chkdsk
Проверка и восстановление системных файлов | System File Checker (Scan and Repair) | sfc /scannow
Проверка подписи файла | File Signature Verification | sigverif
Проводник | Windows Explorer | explorer
Программа DiskPart | Disk Partition Manager | diskpart
Программы и компоненты | Programms and Features | appwiz.cpl
Просмотр событий | Event Viewer | eventvwr.msc
Разрешение экрана | Screen Resolution | desk.cpl
Редактор личных знаков | Private Character Editor | eudcedit
Редактор локальной групповой политики | Local Group Policy Editor | gpedit.msc
Редактор реестра | Registry Editor | regedit
Редактор реестра | Registry Editor | regedt32
Редактор титульных страниц факсов | Fax Cover Sheet Editor | fxscover
Результирующая политика | Resultant Set of Policy | rsop.msc
Сведения о системе | System Information | msinfo32
Свойства системы | System Properties | sysdm.cpl
Свойства системы: Дополнительно | System Properties: Advanced | SystemPropertiesAdvanced
Свойства системы: Защита системы | System Properties: System Protection | SystemPropertiesProtection
Свойства системы: Оборудование | System Properties: Hardware | SystemPropertiesHardware
Свойства системы: Удаленный доступ | System Properties: Remote | SystemPropertiesRemote
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | iscsicpl
Свойства: Интернет | Internet Properties | inetcpl.cpl
Свойства: Клавиатура | Keyboard Properties | control keyboard
Свойства: Мышь | Mouse Properties | control mouse
Свойства: Мышь | Mouse Properties | main.cpl
Свойства: Мышь: Параметры указателя | Mouse Properties: Pointer Options | control main.cpl,,2
Свойства: Мышь: Указатели (схема) | Mouse Properties: Pointers | control main.cpl,,1
Сертификаты | Sertificates | certmgr.msc
Сетевые подключения | Network Connections | control netconnections
Сетевые подключения | Network Connections | ncpa.cpl
Системный монитор | Performance Monitor | perfmon
Служба индексирования | Indexing Service | ciadv.msc
Службы компонентов | Component Services | dcomcnfg
Службы компонентов | Component Services | comexp.msc
Совместимость программы | Program Compatibility | msdt.exe -id PCWDiagnostic
Создать диск восстановления системы | Create a system repair disk | recdisc
Соседние пользователи | People Near Me | collab.cpl
Сохранение имен пользователей и паролей | Stored User Names and Passwords | credwiz
Средство диагностики DirectX | Direct X Troubleshooter | dxdiag
Средство диагностики службы технической поддержки | Microsoft Support Diagnostic Tool | msdt
Средство калибровки дигитайзера | Ditilizer Calibration Tool | tabcal
Средство настройки текста ClearType | ClearType Text Tuner | cttune
Средство просмотра XPS | XPS Viewer | xpsrchvw
Стредство записи действий по воспроизведению неполадок | Problem Steps Recorder | psr
Таблица символов | Character Map | charmap
Телефон и модем | Phone and Modem | telephon.cpl
Удаленный помощник Windows | Windows Remote Assistance | msra
Управление дисками | Disk Management | diskmgmt.msc
Управление компьютером | Computer Management | compmgmt.msc
Управление печатью | Print Management | printmanagement.msc
Управление цветом | Color Management | colorcpl
Установка или удаление языков интерфейса | Install or uninstall display languages | lpksetup
Устройства и принтеры | Devices and Printers | control printers
Учетные записи пользователей | User Accounts | Netplwiz
Цвет и внешний вид окна | Window Color and Appearance | control color
Центр мобильности Windows | Windows Mobility Center | mblctr
Центр поддержки | Action Center | wscui.cpl
Центр синхронизации | Sync Center | mobsync
Центр специальных возможностей | Ease of Access Center | utilman
Шифрующая файловая система (EFS) | Encryption File System | rekeywiz
Шрифты (добавление или удаление) | Fonts | control fonts
Экран (размер текста) | Display (size of text) | dpiscaling
Экранная клавиатура | On-Screen Keyboard | osk
Экранная лупа | Magnifier | magnify
Экранный диктор | Microsoft Narrator | narrator
Электропитание | Power Options | powercfg.cpl
Электропитание: Дополнительные параметры | Power Options: Advanced Settings | control powercfg.cpl,,1
Элемент управления WMI | Windows Management Infrastructure | wmimgmt.msc
Язык и региональные стандарты | Region and Language | intl.cpl
Язык и региональные стандарты: Дополнительно | Region and Language: Administrative | control intl.cpl,,3
Язык и региональные стандарты: Языки и клавиатуры | Region and Language: Keyboards and Languages | control intl.cpl,,2

    Если какой-либо из элементов списка не запускается, то скорее всего это означает что он неустановлен. Многие из компонентов Windows можно установить в Пуск -> Панель Управления -> Програмы и Компоненты -> Включение и отключение компонентов Windows

    4. Список клавиатурных сокращений.

    Основные:

    Win+Up - Развернуть окно
    Win+Down - Восстановить / Минимизировать окно
    Win+Left - Прикрепить окно к левому краю экрана
    Win+Right - Прикрепить окно к правому краю экрана
    Win+Shift+Left - Переключиться на левый монитор
    Win+Shift+Right - Переключиться на правый монитор
    Win+Break(или Pause) - Запустить элемент Система из Панели Управления (пункт Свойства при нажатии правой кнопкой мыши на Компьютер в меню Пуск)
    Win+Home - Минимизировать / Восстановить все неактивные окна
    Win+Space - Показать рабочий стол
    Win+B - Переход в область уведомлений(трей)
    Win+D - Свернуть окна или восстановить все окна
    Win+E - Запустить Проводник(Explorer)
    Win+F - Запустить встроенный диалог поиска Windows
    Win+Ctrl+F - Запустить Поиск по компьютеру из домена
    Win+F1 - Запустить встроенный диалог Windows: Справка и Поддержка
    Win+G - Отобразить гаджеты поверх всех окон
    Win+L - Блокировка рабочей станции(текущего сеанса пользователя)
    Win+M - Минимизировать все окна
    Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
    Win+R - Запустить диалоговое окно Выполнить
    Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
    Win+U - Запустить Центр специальных возможностей (Ease of Access Center)
    Win+X - Запустить Mobility Center
    Win+цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
    Win + "+" - Увеличить масштаб
    Win + "-" - Уменьшить масштаб
    Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

    В Проводнике (Explorer):
    Alt+P - Показать / Скрыть Область предпросмотра

    Панель задач:
    Shift + щелчок на иконке - Открыть новое окно приложения
    Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
    Shift + щелчок правой кнопкой на иконке - Показать меню приложения
    Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / cвернуть все / Закрыть все
    Ctrl + щелчок по группе икнонок - Развернуть все окна группы

    5. Перезагрузка компьютера в безопасный режим без использования клавиатуры.

    Для того, чтобы перезагрузиться в Безопасный режим достаточно во время загрузки нажать клавишу F8 и выбрать пункт Safe Mode. А чтобы вернуться обратно в Нормальный режим достаточно всего лишь перезагрузить компьютер (не нажимая F8) и система вернется в своё стандартное состояние.
    Но на некоторых материнских платах клавиша F8 используется для выбора физического устройства, с которого должен начать загрузку компьютер.
    В этом случае необходимо выбрать жесткий диск, на котором установлена операционная система. После нажатия клавиши Enter необходимо сразу же снова нажимать клавишу F8 до тех пор, пока на экране не появится меню выбора вариантов загрузки ОС Windows. Вы должны успеть сделать это довольно быстро, а иначе начнется обычная загрузка Windows.
    Если же нет желания играть на скорость, есть более легкий вариант решения:

    1) Откройте Конфигурация системы (Пуск -> Выполнить -> msconfig -> Ok или Win+R -> msconfig -> Ok)
    2) Перейдите на вкладку Загрузка
    3) Поставьте галочку напротив значения Безопасный режим в разделе Параметры загрузки
    4) Нажмите Ok и перезагрузите компьютер.
    5) Чтобы вернуться обратно в Нормальный режим: находясь в Безопасном режиме уберите данную галочку и перезагрузите компьютер.

    6. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

    Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

    1) Закройте *.chm файл
    2) Зайдите в Internet Explorer
    3) Нажмите правую кнопку мыши
    4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
    5) Запустите ваш *.chm и система сама определит кодировку.

    7. Автоматическое переключение русской и английской раскладок клавиатуры.
    Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
    Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

    Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
    Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
    Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

    8. Удаление Windows 7 без форматирования раздела и без потери данных.
    Для удаления Windows 7 описанным здесь способом вам потребуются:

    а) ERD Commander;
    б) Установочный диск Windows 7;

    Шаг I. Удаление загрузочной информации Windows 7.

    1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
    2) Запустите Command Prompt
    3) В открывшемся окне введите команду
    E:\boot\bootsect.exe /nt60 ALL C: /force
    Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

    Шаг II. Удаление файлов и папок Windows 7.

    1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
    2) Как в обычном Explorer, тем же способом удалите следующие папки:
    • PerfLogs
    • Users
    • Windows
    • Recycle.Bin
    • Documents and Settings
    • ProgramData
    • Recovery

    9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

    Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
    Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

    По инструкции ниже создаете свой образ ERD Commander:

    1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
    2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

    Рисунок 1 из 3

    3) Щелкаете Ок, затем несколько раз кнопку Далее
    4) На вкладке Выбор программных средств снова нажимаете Далее
    5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

    Рисунок 2 из 3

    6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
    7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
    8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
    9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
    10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на USB флеш-накопитель (флешку) и нажимаете Далее.

    Рисунок 3 из 3

    На USB флеш-накопитель (флешку) образ записывается через программу UltraISO так:
    1) Открывате образ в UltraISO.
    2) Выбираете Самозагрузка -> Записать образ жесткого диска...
    3) Нажимаете Записать

    11) Перезагружаемся в ERD Commander.
    12) Would you like to initialize network connectivity in the background?
    Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
    13) Would you like to remap the drive letters to match the mappings from the target operating system?
    Для сопоставления букв дисков целевой операционной системе выбираете выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
    14) Select a keyboard input method
    Выбираете нужную раскладку, нажимаете Next
    15) В окне для выбора операционной системы:

    Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

    Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
    16) Нажимаете Next.

    10. Активация Windows 7 по телефону.

    1) Пуск - правой кнопкой мыши по Компьютер - Свойства.
    2) Изменить ключ продукта
    3) Вводим ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
    4) Жмем Активировать.
    5) Ждем. Затем выбираем Другие способы активации - Активация по телефону. Выбираете свой регион.
    6) Звоним по бесплатному номеру (можно через Скайп) .
    7) Девушка робот начнет перечислять варианты активации.
    8) Жмем 1(активировать продукт майкрософт).
    9) На вопрос на скольких компьютерах установлен продукт, нажимаем 1.
    10) Затем вас попросят ввести код. Вводите, в ответ другая девушка-робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
    11) Вносим цифры в окно активации.
    12) Жмем Далее. Интернет, может быть отключен (без разницы). Windows 7 активирована.

    11. Как быстро переключиться с одного монитора на другой или с монитора на проектор?
    Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

    12. Как быстро открыть ещё одну копию приложения?

    Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

    13. Как разместить любое окно Windows поверх других?

    При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

    Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

    14. Автоматическая очистка временных папок при выходе из Windows.

    Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

    1) Создайте командный файл сценария:

    Инструкция:

    1. Скопируйте код в любой текстовый редактор (например, Блокнот).
    2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
    3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
    4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    PUSHD %TEMP% 2>Nul RD /S/Q "%TEMP%" POPD PUSHD %WinDir%\TEMP 2>Nul RD /S/Q "%WinDir%\TEMP" POPD
    2) Скопируйте его для удобства в корневую папку диска С:
    3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
    4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
    5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
    6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами командного файла c:\tempdirclean.cmd
    7) Нажмите Ок, затем снова Ок
    Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

    Внимание: Если по указанной выше схеме Вы добавите командный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

    Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

    15. Где в Windows 7 храняться значки (иконки)?

    Если Вы хотите использовать одну из иконок (значков) Windows 7, то большую их часть Вы можете найти в следующих файлах:

    C:\Windows\System32\shell32.dll
    C:\Windows\System32\imageres.dll

    Для извлечения необходимой Вам иконки:

    1) Откройте один из предложенных файлов, с помощью программы Restorator.
    2) В панели Дерево ресурсов откройте папку Иконка
    3) Выберите любую из понравившихся Вам иконок.
    4) В панели Дерево ресурсов щелкните правой кнопкой мыши на данном ресурсе и выберите Извлечь... > Извлечь как "имя_ресурса.ico"
    5) Выберите папку для извлечения и нажмите Сохранить

    Вы также можете извлечь все иконки сразу, для этого:
    6) В панели Дерево ресурсов щелкните правой кнопкой мыши на папке Иконка и выберите Извлечь... > Извлечь все как тип "Иконка"
    7) Выберите папку для извлечения и нажмите OK

    16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

    Многие используя в Windows функцию Форматировать, замечали пункт Создание загрузочного диска MS-DOS. Он используется для создания загрузочного диска MS-DOS на определенных типах устройств, для других же типов устройств он заблокирован.
    Выясняя откуда Windows берет образ MS-DOS для записи, я узнал что он содержится в файле diskcopy.dll. Но тут появился другой вопрос, а как его оттуда извлечь? Предлагаю Вам несколько способов его извлечения.

    Способ 1 Использование редакторов ресурсов.

    Открываете файл diskcopy.dll любым редактором ресурсов и извлекаете(сохраняете) ресурс 1 из папки BINFILE как diskcopy.img

    Способ 2 Программа Disk Extract

    1) Указываете в поле File(s) to search and extract byte sequence (wildcards *.* accepted) - файл для поиска и извлечения необходимого количества байтов: C:\Windows\System32\diskcopy.dll
    2) Указываете в поле Byte sequence to find - с какого байта искать: EB3C90
    3) Указываете в поле Bytes to copy - сколько байт скопировать: 1474560
    4) Указываете в поле Save as - куда и под каким именем сохранить (например так): D:\Temp\diskcopy\diskcopy.img
    5) Нажимаете на кнопку Play
    6) В появившемся окне Confirm нажимаете Yes

    Способ 3 Программа GETBTDSK со скриптом

    Запускаете файл GETBTDSK.bat и получаете в итоге готовый файл diskcopy.img
    Некоторые антивирусные программы могут воспринять попытку её обращения к системному файлу как разновидность вируса, поэтому для работы скрипта либо изолируйте файл GETBTDSK.EXE, или папку где он находится из поиска антивирусной программой, либо воспользуйтесь первым способом.

    Хорошо, образ мы извлекли и у нас есть готовый файл diskcopy.img. Что же дальше, спросите Вы. А дальше, Вы можете:

    1) Распаковать полученный файл с помощью программы архиватора 7zip и дальше работать с файлами по-своему усмотрению.

    2) Записать загрузочный MS-DOS образ diskcopy.img на USB флеш-накопитель (флешку).

    1. Открываете файл diskcopy.img в программе UltraISO
    2. Выбираете Самозагрузка -> Записать образ жесткого диска...
    3. Метод записи оставляете USB-HDD+
    4. Нажимаете Записать

    Чтобы не искать в интернете эти программы, Вы можете скачать архив с ними: msdosboot.zip

    17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

    Скачивая какой-либо продукт Microsoft в интернете, помимо его названия Вы можете увидеть дополнительные обозначения в наименовании. Если Вам интересно, что означает "CTP", "Escrow", "LDR", "RC", "RTM" и тому подобное - предлагаю Вам, расшифровку особо часто встречающихся из них.

    BBT - Basic Block Tools или Binary Profile Feedback Optimization framework
    BBT - пакет инструментов оптимизации, помогающий уменьшить требования к рабочему набору Win32 приложения. Для этого применяется дополнительный статический анализ и эвристика кода. Также в результате мониторинга потока выполнения программы происходит интеграция профиля данных. Для дополнительной компрессии страниц памяти, BBT реорганизовывает статистические данные и секции ресурсов.
    BBT - cпециальный анализатор, оптимизирующий величину кода, путем игнорирования не используемой части, и архивации оставшейся.
    Другое значение BBT - это “Black Box Testing”, тестирование "чёрного ящика" или что-то в этом духе.

    BVT - Build Verification Test
    Небольшой набор тестов, проверяющих уровень качества сборки, на этапе её создания. Например, BVT для Блокнота может выглядеть как: "Запустить, напечатать текст, сохранить, выйти". Если сборка не проходит данный тест, то воизбежание дальнейших ошибок при тестировании, она отправляется на доработку. Порядок действий BVT редко меняется, а результаты - тщательно контролируются.

    CPP - Customer Preview Program
    Программа предварительного ознакомления.

    CTP - Community Technology Preview
    Предварительный технологический релиз для сообщества, впервые использован для сборки Vista build 5219, так называемый январьский CTP.

    DNSRV - .NET (DotNet) Server
    Раннее кодовое имя Windows Server 2003.

    EBS - Essential Business Server
    Серверное решение от Microsoft, имеет в своей основе ядро Windows Small Business Server 2008, ориентировано на рынок среднего бизнеса.

    EDW - External Developer Workstation
    Этот термин, использовался во времена разработки Windows Vista, для обозначения сборок выпущенных между RC и RTM сборками.

    Escrow
    Сборки, не имеющие серьёзных ошибок. Они, как правило, становятся в итоге Релиз-кандидатами или RTM (после того, как сборка подписана к выпуску).

    Exit Criteria
    Набор тестов, проверяющих наиболее важные аспекты корректной работы основных функций приложения. Как выглядит тот или иной тест, определяется командой-разработчиком функции, результаты прохождения теста долдны точно совпадать с ожидаемыми. Полное прохождение таких тестов ознаменует переход к следующему этапу разработки.

    FBL - Feature build lab
    Группа разработки какого-либо функционала.

    FVT - Feature Verification Tests
    Тоже самое, что и BVT, только для конкретной функции.

    GA - General Availability
    Означает, что програмное обеспечение доступно на основном рынке через Интернет или на каком-либо физическом носителе.

    GDR - General Distribution Release
    Используется для обновлений и хотфиксов, содержащих только заплатки критических ошибок и исправления, влияющие на стабильность.

    HSBS - Home and Small Business Server

    IDS - Internal Developer Server

    IDW - Internal Developer Workstation

    IDX - Internal Developer Client/Server

    LCTP - Limited Community Technology Preview
    Ограниченный предварительный технологический релиз.

    LDR - Limited Distribution Release
    Используется для обновлений и хотфиксов, содержащих “прочие” исправления, как правило, для ошибок, возникающих у весьма специфической группы пользователей.

    MMS - Mid-Market Server
    Раннее название Essential Business Server.

    QFE - Quick Fix Engineering
    Аналогично LDR.

    QHSV - Q Home Server
    Раннее название Windows Home Server.

    RC - Release Candidate
    Качество сборки на данной стадии разработки наиболее близко к стабильному, критические ошибки уже исправлены, однако, в ходе текущего тестирования могут быть найдены новые ошибки.

    RDP - Rapid Deployment Program

    RTM - Release To Manufacturing
    Стабильная сборка, прошедшая все стадии тестирования, в которой исправлены все найденные ошибки, и готовая к применению.

    RTW - Release To Web
    Это RTM, предназначенный для распространения через Интернет.

    SBS - Small Business Server

    Self host
    Сброки, прошедшие тесты Exit Criteria tests, готовые к более глубокому тестированию.

    Self test
    Сборки, прошедшие BVT и FVT тесты.

    Self toast
    Сборки, не прошедшие BVT.
    Sign-off
    Подписание, означает, что функция/продукт готова к продаже.

    TAP - Technology Adoption Program
    Программа технологического утверждения, в ходе которого собираются отзывы тестеров, в качестве которых могут выступать и заказчики компании.

    TP - Technical Preview

    VBL - Virtual Build Lab
    Термин обозначает группу разработчиков объединенных в виртуальную лабораторию.

    WHS - Windows Home Server

    WSSG - Windows Server Solutions Group

    WSUS - Windows Server Update Services

    18. Как удалить установленное обновление?
    Если Вы установили обновление в Windows, для добавления дополнительной функции, а оно Вам не понравилось, то Вы можете спокойно его удалить.
    Для удаления любого обновления сделайте следующее:

    1) Откройте Панель управления\Программы
    2) Нажмите на ссылку Просмотр установленных обновлений
    3) Нажмите правой кнопкой на любом обновлении, которое желаете удалить и щелкните на появившемся слове Удалить.
    4) В случае необходимости, перезагрузите компьютер.

    19. Создание значков управления состоянием компьютера.

    Для быстрого изменения состояния системы Вы можете создать на рабочем столе ярлыки позволяющие изменить его одним мажатием мыши.

    Для создания ярлыков выполните следующие действия:
    1) Нажмите правую клавишу мыши на рабочем столе, выберите пункт меню Создать -> Ярлык
    2) В поле Укажите расположение объекта введите необходимую команду для создания ярлыка и нажмите OK.

    Блокировка компьютера
    rundll32.exe User32.dll,LockWorkStation
    Выход из системы
    Shutdown.exe /l
    Завершение работы
    Shutdown.exe -s -t 00
    Перезагрузка
    Shutdown.exe -r -t 00
    Сон
    rundll32.exe powrprof.dll,SetSuspendState Sleep

    20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

    Текст из окна сообщения Windows выделить для копирования невозможно, так как он заблокирован. Но Вы можете скопировать данный текст в буфер обмена.
    Для того чтобы это нажмите комбинацию клавиш Ctrl+C, а затем вставьте текст из буфера в любой текстовый редактор используя комбинацию клавиш Ctrl+V. Окно, текст которого нужно скопировать, должно быть активным.
    Например, попробуйте закрыть окно оснастки Службы при открытом окне свойств отдельной службы, и Вы увидите одно из таких сообщений Windows.


Установка

1. Как добавить новое устройство(драйвер) вручную?

1) Нажимаем Windows + R
2) В открывшемся окне набираем hdwwiz, жмём OK
3) В открывшемся окне, жмем Далее(Next)
4) В следующем окне выбираем Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list), жмём Далее(Next)
5) Выбираем в списке самую верхнюю строчку Показать все устройства(Show all devices), жмём Далее(Next)
6) В следующем окне нажимаем на кнопку Установить с диска(Install From Disk), в нижнем правом углу
7) В открывшемся окне нажимаем кнопку Обзор(Browse) и указываем путь к файлу драйвера (inf-файл), нажимаем Ok, а затем Далее(Next)
8) Подтверждаем желание установить нажатием Далее(Next)

2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

Все обновления, которые Вы скачиваете или устанавливаете через внутреннюю службу Windows Центр обновления Windows (Windows Update) хранятся в папке: C:\Windows\SoftwareDistribution\Download, а также в подпапках внутри неё. После установки обновлений, Вы можете сохранить их себе на компьютер просто скопировав из папки нужный Вам файл. Файлы содержащие в своем названии -express, могут повторно не установиться. Следовательно Вы можете их и не копировать.

3. Как определить неизвестное устройство?

Узнаем VendorID(VEN) или HardwareID(DEV) устройства. В диспетчере устройств нажимаем у неизвестного устройства Свойства. Далее Сведения-Проматываем до ID оборудования.
Теперь идем на http://www.pcidatabase.com/. И вводим одно из найденных значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:
Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные
там тоже это указывается.

4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

6. Установка Windows 7 с USB флеш-накопителя (флешки).

Вариант 1

1) Вставьте Ваш флеш-диск в USB-порт.
2) Откройте ISO-образ Windows программой UltraISO

Так:

Щелкните на ISO-файле правой кнопкой мыши и выберите пункт Открыть, используя UltraISO

Или так:

В программе UltraISO в меню Файл нажмите на пункт Открыть, выберите нужный Вам образ Windows 7 и нажмите Открыть.

3) Убедившись, что образ открыт - выберите в меню Самозагрузка пункт Записать образ Жесткого диска
4) В списке Disk Drive:, выберите Ваш флеш-накопитель, в пункте Метод записи: USB-HDD+ и нажмите Записать.
5) В появившемся окне об уничтожении информации Подсказка, нажмите кнопку Да. Дождитесь, когда завершится запись (от 5 до 20 минут).
6) Не вынимая флеш-диска из USB-порта перезагрузите компьтер.
7) Сразу после начала перезапуска нажмите на клавиатуре Delete (Del), чтобы попасть в BIOS.
8) В BIOS установите загрузку в первую очередь с USB-HDD.
9) Сохраните настройки и выйдите из BIOS. Компьютер перезапуститься и начнет загрузку с флеш-накопителя.
10) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флеш-диска.

Вариант 2

Подготовка USB флеш-накопителя (флешки) для будущей загрузки и установки Windows 7:

1) Подключаете USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
2) В строке поиска меню Пуск вводите cmd.exe, щелкаете на найденном правой кнопкой мыши и нажимаете Запуск от имени администратора
3) Запускате утилиту управления дисками diskpart, дожидаетесь приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них Ваш диск USB, в моём примере это Disk 2
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 2. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаете выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируете раздел в файловую систему NTFS
12) Выполняете команду assign – активируете процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходите из diskpart в командную строку.

Рисунок 1 из 2

14) Вставляете имеющийся у Вас дистрибутив Windows 7 в дисковод, или монтируете образ в виртуальный диск.
15) Допустим, что он у Вас установлен в дисковод H:, тогда в командной строке (не в diskpart !!!) выполняете команду:
H:\Boot\bootsect.exe /nt60 I:
где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
16) Копируете все файлы с Вашего дистрибутива на Ваш USB флеш-накопитель (флешку). Используйте для этого либо Windows Explorer, либо команду:
xcopy H: I: /s /e /h /k

Рисунок 2 из 2

Всё, USB-драйв готов. Загружаете ПК с полученного USB флеш-накопителя.

Для ускорения процесса копирования опытные пользователи могут воспользоваться программой RichCopy, она является графической оболочкой команды robocopy, и включает всебя большое количество настроек. В число многочисленных параметров входят сортировка файлов по атрибутам и папкам, предотвращение ошибок, смена атрибутов, тайминг копирования, редактирование отметки о времени, установка количества потоков и размера используемого кэша.

7. Интеграция языковых пакетов и обновлений в дистрибутив Windows 7.

Вариант 1 вручную с помощью DISM.

Для работы нам потребуются WAIK, GimageX

1) Скачайте и установите Windows® Automated Installation Kit (AIK) for Windows® 7
2) Перезагрузите компьютер.

Русификация установщика install.Wim
1) Создаёте на диске D: папки Lip, Mount и mWim
2) Копируете lp.cab и все обновления (MSU и CAB) в папку Lip и создаёте в ней подпапку uLip
3) При помощи GimageX экспортируете из папки \Sources\install.wim в папку D:\mWim образ Ultimate (индекс 5 для 32-битных версий или Индекс 4 для 64-битных версий) как install.wim
4) Выполняете перезагрузку вашего ПК.
5) Запускаете командную строку от имени администратора (Win+R -> cmd -> Ok) и монтируете файл D:\mWim\install.wim в папку D:\Mount выполнив в консоли команду:
(команды копируете, и вставляете в консоль по правому клику)
dism /Mount-Wim /WimFile:D:\mWim\install.wim /index:1 /MountDir:D:\Mount
6) Интегрируете языковой пакет и обновления:
Для интеграции языкового пакета введите команду:
dism /image:D:\Mount /Add-Package /PackagePath:D:\Lip\lp.cab
Для интеграции обновления, используйте команду аналогичную предыдущей, подставляя вместо lp.cab, наименование интегрируемого обновления. Вот пример интеграции произвольного обновления:
dism /image:D:\Mount /Add-Package /PackagePath:D:\Lip\Windows6.1-KB123456-x64.msu
7) Применяем все настройки для русского языка командой:
dism /image:D:\Mount /Set-AllIntl:ru-RU
Примеры запуска команд DISM:
dism /image:D:\Mount /Set-UILang:ru-RU (язык интерфейса системы)
dism /image:D:\Mount /Set-SysLocale:ru-RU (язык системной локали для не Unicode)
dism /image:D:\Mount /Set-UserLocale:ru-RU (денежный формат, формат времени)
dism /image:D:\Mount /Set-InputLocale:0419:00000419 (настройки ввода с клавиатуры)
dism /image:D:\Mount /Set-TimeZone:"Russian Standard Time" (временная зона)
8) Демонтируете образ с сохранением изменений:
dism /Unmount-Wim /MountDir:D:\Mount /commit
Демонтаж без сохранения:
dism /Unmount-Wim /MountDir:D:\Mount /discard
9) Заменяете файл sources\install.wim в дистрибутиве, файлом D:\mWim\install.wim 10) Там же правите текст файла sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
Русификация установщика Boot.Wim
1) Распаковываете lp.cab в папку D:\Lip\uLip
expand D:\Lip\lp.cab -f:* D:\Lip\uLip
2) Очищаете папку D:\Mount
3) При помощи GimageX экспортируем из файла \Sources\boot.wim (индекс 2 !!!) в папку D:\mWim\ как boot.wim.
4) Монтируете файл boot.wim в папку D:\Mount
dism /Mount-Wim /WimFile:D:\mWim\boot.wim /index:1 /MountDir:D:\Mount
5) Добавляете в boot.wim русский язык:
xcopy D:\Lip\uLip\setup\* D:\Mount\ /cheryki
6) Добавляете в boot.wim файлы лицензий:
xcopy D:\Lip\uLip\sources\license\* D:\Mount\sources\license\ /cheryki
7) Правите текст файла D:\Mount\sources\lang.ini так же, как описано выше. 8) Демонтируете с сохранением файл boot.wim, папку uLip можно удалить.
dism /Unmount-Wim /MountDir:D:\Mount /commit
9) Заменяете файл sources\boot.wim в дистрибутиве, файлом D:\mWim\boot.wim

Вариант 2 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дождитесь успешного выполнения и увидите результат.

Вариант 3 с помощью командного файла скрипта.

1) Скачайте LPIntegrator.zip
2) Распакуйте скачанный архив в папку
3) Нажмите правой кнопкой мыши на файле LPIntegrator.bat и щелкните на пункте меню Изменить
4) Измените значение параметра set LANG=ru-RU, на язык интегрируемого языкового пакета, где en-US - для английского языка, de-DE - для немецкого языка и т.д.
5) Сохраните изменения и закройте редактирование.
6) Запустите LPIntegrator.bat
7) Выберите версию Вашего образа Windows 7
8) Распакуйте ISO-образ в папку C:\7Work\DVD или скопируйте туда все файлы Вашего инсталяционного диска.
9) Скопируйте языковой пакет, который Вы хотите интегрировать в папку C:\7Work\LP
10) Скопируйте обновления, которые Вы хотите интегрировать в папку C:\7Work\CABS
11) Нажмите любую клавишу(например, Enter) для продолжения.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

8. Добавление новых языков интерфейса в Windows.

Для добавления языков интерфейса необходимо установить дополнительные языковые файлы. После установки языковых файлов можно просматривать текст мастеров, диалоговых окон, меню, разделов справки и прочих элементов Windows на другом языке. Существуют 2 варианта добавления новых языков интерфейса: первый - через Центр обновления Windows(Windows Update), а второй - скачав и установив файл языкового пакета вручную. Перед началом работы измените в Панели Управления (Control Panel) способ просмотра(View by), вместо Категория(Category) на Крупные (Large icons) или Мелкие значки(Small icons).

Вариант1. Через Центр обновления Windows(Windows Update)

1) Откройте Центр обновления Windows

Пуск -> Все программы -> Центр обновления Windows (Start -> All Programs -> Windows Update)
или
Панель управления\Все элементы панели управления\Центр обновления Windows (Control Panel\All Control Panel Items\Windows Update)

1a) Также вы можете нажать Win+R, в поле Выполнить ввести указанную ниже команду и нажать Ok
Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
2) Выберите пункт Необязательных обновлений XX шт. доступны (XX options updates are available)
3) Поставьте флажок напротив нужного Вам языкового пакета (Language Pack) и нажмите Ok

Вариант 2. При наличии файла языка интерфейса lp.cab

1) Заходите в Панель Управления(Control Panel)
2) Открываете Язык и региональные стандарты (Regional and Language)
3) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
4) Нажимаете Установить или удалить язык (Install/uninstall languages...)
4a) Также вы можете нажать Win+R, в поле Выполнить ввести lpksetup и нажать Ok
5) Нажимаете Установить языки интерфейса (Install display languages)
6) Нажимаете кнопку Обзор...(Browse...)
7) Указываете путь к папке с lp.cab и нажимаете Ok
8) Выбираете необходимый Вам язык и нажимаете Далее(Next)

Вариант 3. Установка файла скачанного с сервера Windows Update

Вы можете установить необходимый Вам язык интерфейса, скачав exe-файл по прямой ссылке с сервера Windows Update и просто запустив его.

Оффициальные языковые пакеты для 32-bit (x86) Windows 7 RTM:

Арабский (Arabic):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ar-sa_210ccc96338a1ff683803eb4034e5f53d6d54c97.exe

Болгарский (Bulgarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-bg-bg_2e5d91b00775e0f974d4ec213fc20d470ff6850e.exe

Китайский (упрощенное письмо) (Chinese (Simplified)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-zh-cn_ab024143b556395e6638e26712b1e0f3bc031fcf.exe

Китайский (традиционное письмо) (Chinese (Traditional)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-zh-hk_90617b75cfaab716a43e7c082b00490a6d475376.exe

Хорватский (Croatian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-hr-hr_d8a4131aee5d5de039a3a0dc517ca0c07ebc3472.exe

Чешский (Czech):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-cs-cz_2759680ec6e2f4a7629c7d02b1fbce0a0d410a4e.exe

Датский (Danish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-da-dk_e1c57a4dcbd336ac73e349a9bb9d30de17ac093f.exe

Нидерландский (Dutch):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-nl-nl_194a2ca7b589e77b0be73b822f77760823183c51.exe

Английский (English):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe

Эстонский (Estonia):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-et-ee_3a99769fac5d6a11e6616297f842a9074c045699.exe

Финский (Finnish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-fi-fi_dd1973cc63ab7dea0e5d660af06869a8beefe36a.exe

Французский (French):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-fr-fr_1878fd391b990054787a14b0db4a5db00b793bf1.exe

Немецкий (German):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-de-de_1b86ff9b8f4c517dd341d76f24c74399278b05fc.exe

Греческий (Greek):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-el-gr_1f366d5e4fbde7df89b106821236fc1d3b3c9230.exe

Иврит (Hebrew):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-he-il_a3d6a6ae858f33ffa11a14c2a966e6603c134ef9.exe

Венгерский (Hungarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-hu-hu_12feb47da4bb28f60b6a30d379044356581c20f8.exe

Итальянский (Italian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-it-it_079a3afeb88f14d24a3b4204812225e78c2e0bb8.exe

Японский (Japanese):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ja-jp_08758c23cc64a53949072d53dd7bf6bbc8b45420.exe

Корейский (Korean):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ko-kr_bb2de1652c37394be4de87438661b129f8b56908.exe

Латышский (Latvian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-lv-lv_8b7a0b361dd37f7cd3926f798a79a90d378b18b2.exe

Литовский (Lithuanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-lt-lt_7aee9ce232cb46701f479fafdb0aea369ce1ad6a.exe

Норвежский (Norwegian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-nb-no_d65ea89195cf5f7d3170ccb1db7bae3c157f5b24.exe

Польский (Polish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe

Португальский (Бразилия) (Portuguese (Brazil)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pt-br_0a3fe79820d6d199dd43495d4efa5c40f270e45a.exe

Португальский (Португалия) (Portuguese (Portugal)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pt-pt_4165bd9cd083abd8ddd81986e18b1fd86aab5ce9.exe

Румынский (Romanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ro-ro_e1c324236046eb608e478570cf4396776ff02a72.exe

Русский (Russian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ru-ru_f4df4bcb8d3194323f17a086a17f46dd0c9c492a.exe

Сербский ()латиница (Serbian (Latin)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sr-latn-cs_6e049bae4d75b82405b28455e2def0a0d0055a9c.exe

Словацкий (Slovak):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sk-sk_dd2ce36a7e94fceff650cb892b8c954b8af6025a.exe

Словенский (Slovenian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sl-si_17786270766d556ba9bf3693762cb98805df9f50.exe

Испанский (Spanish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-es-es_1943a073d8f00e387301deb22cd177bf77319ee8.exe

Шведский (Swedish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sv-se_687085e8bbdf9c17a668b801f28f7f9c74e7a86a.exe

Тайский (Thai):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-th-th_780885dd42c039d9926ac004c76ba3ba9c30c6d0.exe

Турецкий (Turkish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-tr-tr_13015cb75811f874c83fdd679beb4c22c930a57c.exe

Украинский (Ukrainian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-uk-ua_0a467bf14bc4f524c18877f570a20c58e91ceba9.exe

Оффициальные языковые пакеты для 64-bit (x64) Windows 7 RTM:

Арабский (Arabic):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ar-sa_aaac936bd625c12b607dffea19fab8be9cfa28f6.exe

Болгарский (Bulgarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-bg-bg_155634f17868659db4b65cfeff57059b2436515f.exe

Китайский (упрощенное письмо) (Chinese (Simplified)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-zh-cn_a649e9af1e28514d48bdc51f7956be08060e54bc.exe

Китайский (традиционное письмо) (Chinese (Traditional)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-zh-hk_d428bc1cca4aea20163936e6687221c0e6b99ec4.exe

Хорватский (Croatian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-hr-hr_06468f799a1c1f295bc3abbc85c14116e2645122.exe

Чешский (Czech):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-cs-cz_f136df3188c54ff234ca77253fee2cf3e91966b7.exe

Датский (Danish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-da-dk_2b7590d389ca96af6f367408150cb6bc9aa8f4b4.exe

Нидерландский (Dutch):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-nl-nl_2ac14543f6e46c61ae226d7f0f5aee7f4d500e9f.exe

Английский (English):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe

Эстонский (Estonian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-et-ee_3c0479d7049109bcb42fd9ec59d1c65449704687.exe

Финский (Finnish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-fi-fi_4378f72d1233b00e2bdfc680a13f62ae11ab0fcb.exe

Французский (French):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-fr-fr_0e50cd2ea794e4cdfac861b194d2e996b7bbc8d8.exe

Немецкий (German):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-de-de_399ac15b2d55fd5dea0770d98825d7e75f4ad533.exe

Греческий (Greek):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-el-gr_9ae588ba70896f9100a10cb8ed68a79678d6fc32.exe

Иврит (Hebrew):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-he-il_86c22105bb32269c9c0deaf2710fcb1531a29817.exe

Венгерский (Hungarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-hu-hu_e5c47bffe398b9ace42d4326de2646a6172d39b5.exe

Итальянский (Italian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-it-it_3f0f5d78202e074e17a495beec821e1d326a8e2a.exe

Японский (Japanese):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ja-jp_9d73b1c1270deacbe7a2329559476a94daddb848.exe

Корейский (Korean):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ko-kr_e6b3322c3865cfd328d84376e192c4f9d41aa0e6.exe

Латышский (Latvian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe

Литовский(Lithuanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lt-lt_ede5a878aae2b0d64e81ff739e950b6f105df580.exe

Норвежский (Norwegian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-nb-no_1b7f93a0906a62eecd6b200979f8df986a7556f1.exe

Польский (Polish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe

Португальский (Бразилия) (Portuguese (Brazil)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pt-br_276b65f3b6b2657c8fe936f9841dc1243e02dc7b.exe

Португальский (Португалия) (Portuguese (Portugal)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pt-pt_f8310aa4a73841aec29b3f4e74ecaece56b695e9.exe

Румынский (Romanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ro-ro_810f2d590dd5aac92561eea5884ed1c70f34dbd9.exe

Русский (Russian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ru-ru_f0acfc688d609ee45d43cc60c6412a3071a665bd.exe

Сербский ()латиница (Serbian (Latin)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sr-latn-cs_275e0a17cbec543aa1bd7eebc883a1d21c11b514.exe

Словацкий (Slovak):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sk-sk_15f397de2ceaaff8dbfe670bcc6c013791a297c3.exe

Словенский (Slovenian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sl-si_8cfc82e0d15ed94634d3da69674008dc56755b93.exe

Испанский (Spanish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-es-es_2e593c26d9e23ad8176224a53c68a04f996ee014.exe

Шведский (Swedish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sv-se_1f4c415e0f4ca77064d597975f6ac7a9e0b8af63.exe

Тайский (Thai):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-th-th_080c8631d44a53c34ffdab8fd73820572dd87be4.exe

Турецкий (Turkish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-tr-tr_6bd6660158289e0b5d4b5a7f7fded6e3528a9a04.exe

Украинский (Ukrainian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-uk-ua_c6c4e44c9d903049a4c60fed9d42effa18f345bd.exe

Смена Вашего языка интерфейса на новый:

1) Заходите в Панель Управления(Control Panel)
1.1) Открываете Язык и региональные стандарты (Regional and Language)
1.1a) Также вы можете нажать Win+R, в поле Выполнить ввести intl.cpl и нажать Ok
1.2) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
2) Выбираете в пункте Выберите язык интерфейса (Choose a display language:) нужный Вам язык и нажимаете Ok
3) Нажимаете кнопку Выйти из системы сейчас (Log off now)
4) В появившемся экране выбираете своего пользователя.
5) В случае необходимости вводите свой пароль и попадаете в Windows на выбранном Вами языке

9. Как не вводить ключ при инсталляции Windows?

Вариант 1

по материалам technet.microsoft.com:
EI.cfg is a Windows Setup-specific configuration file used to determine what edition and license will be used during installation. This file replaces PID.txt and is located on the product media under the \sources folder.
Добавьте в файл EI.cfg находящийся в папке \sources строку:
[PID]
Value="xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

Вариант 2

Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>MyName</FullName>
<Organization>Microsoft</Organization>
<ProductKey>
<Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
</component>
</settings>
</unattend>

10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузиться в специальный режим Windows.
1) Сразу после включения компьютера нажмите F8. Далее вы попадете либо в меню выбора режимов загрузки Windows, либо в меню выбора диска для загрузки.
2) Нам нужен меню выбора режимов загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter, а затем быстро нажмите F8 до начала запуска Windows и окажитесь там, где нам нужно.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов. Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобиться программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С оффициального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи используйте рекомендации из совета 6 в "Тонких настройках".
Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriverPlus она добавит небольшое изменение в загрузчик, которое автоматизмрует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriverPlus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriverPlus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник -> Компьютер -> Локальный диск (C:)
1.2) В Панели меню выберите Сервис -> Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом местенахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву(Например: Z) и нажите OK
2.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriverPlus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом местенахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriverPlus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriverPlus перезагрузитесь. В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

11. Где можно скачать последние обновления для Windows 7?

Компания Microsoft периодически выпускает обновления для Windows 7. Но не все из них включены в Центр обновления Windows (Windows Update). Все последние версии обновлений, Вы можете скачать без регистрации на форуме My Digital Life:

http://forums.mydigitallife.info/threads/10571-Windows-7-RTM-Updates-Packs-x86-x64

Для того, чтобы не устанавливать каждое обновление по-отдельности, Вы можете воспользоваться предложенной там программой Windows 7 Update Pack Tool, для установки всех обновлений сразу.

12. Повышение оценки производительности жесткого диска.

Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

13. Автоматическая установка OEM-информации.

Представляем вашему вниманию небольшой скрипт, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
Не забудьте заменить серийный ключ (product key) на ваш и назовите файл autounattend.xml.
<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0409:00000409</InputLocale>
<SystemLocale>en-US</SystemLocale>
<UILanguage>en-US</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>en-US</UserLocale>
</component>
<component name=”Microsoft-Windows-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<DiskConfiguration>
<Disk wcm:action=”add”>
<CreatePartitions>
<CreatePartition wcm:action=”add”>
<Extend>false</Extend>
<Type>Primary</Type>
<Order>1</Order>
<Size>40000</Size>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action=”add”>
<Order>1</Order>
<PartitionID>1</PartitionID>
<Format>NTFS</Format>
<Letter>C</Letter>
<Extend>true</Extend>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass=”oobeSystem”>
<component name=”Microsoft-Windows-Shell-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<OEMInformation>
<Logo>E:\oemlogo.bmp</Logo>
<Manufacturer>Fabrikam</Manufacturer>
<Model>Superfast1000</Model>
<SupportHours>Anytime, day or night</SupportHours>
<SupportPhone>1-800-SUPPORT</SupportPhone>
<SupportURL>www.fabrikam.com</SupportURL>
</OEMInformation>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
<AutoLogon>
<Password>
<Value>Password</Value>
<PlainText>true</PlainText>
</Password>
<Username>Administrator</Username>
<Enabled>true</Enabled>
<LogonCount>5</LogonCount>
</AutoLogon>
<UserAccounts>
<AdministratorPassword>
<Value>Password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
<cpi:offlineImage cpi:source=”wim:c:/documents%20and%20settings/vmux/desktop/sourceos/install.wim#Windows 7 ULTIMATE” xmlns:cpi=”urn:schemas-microsoft-com:cpi” />
</unattend>

Внимание!!!
Не используйте данный метод, если имеете важную информацию на жестком диске или же сделайте резервную копию системы. Дело в том, что файл ответов в данном совете стирает все разделы и логические диски при установке.
Если же вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

14. Автоматическая установка OEM-Logo.

Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass=”windowsPE”>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OEMInformation>
<HelpCustomized>false</HelpCustomized>
<Manufacturer>Hewlett-Packard</Manufacturer>
<Model>Compaq Presario SR1610IL</Model>
<Logo>C:\Windows\Sytem32\oemlogo.bmp</Logo>
<SupportHours>9 AM to 9 PM (Mon-Sat)</SupportHours>
<SupportPhone>1-600-114772 (Toll free), 0124-2346992 (Toll Number)</SupportPhone>
<SupportURL>http://www.hp.com/in/support</SupportURL>
</OEMInformation>
</component>
</settings>
</unattend>
oemlogo.bmp
положите ваше лого в папку " \Sources\$OEM$\$$\System32\oemlogo.bmp"

15. Как установить LocalPack-RU?

Нужно в командной строке от имени Администратора выполнить команду: DISM /Online /Add-Package /PackagePath:<полный_путь_к_локал-паку>.CAB
Если не сработает - значит, нужно проделать почти то же самое, но загрузившись с установочного носителя.
Тогда /Online нужно будет заменить на /image:<буква_диска_с_установленной_системой>:.
Этим способом, кстати, MVE, можно установить лангпак на любую редакцию Windows 7
После установки нужно зайти в C:\Windows\Globalization\MCT\MCT-...\Theme

16. Автоматическая установка обновлений Windows.

Вариант 1. Использование Bat-файла (для MSU и CAB обновлений).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Update.bat")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
@Echo Off
Title Installing Windows7 Updates
For %%F In (MSU\*.msu) Do Call :msin %%F
For %%A In (CAB\*.cab) Do Call :kbin %%A
Exit
:msin
Start /Wait %1 /quiet /norestart
:kbin
Start /Wait pkgmgr /ip /m:%1 /quiet /norestart
GoTo :EOF
Exit
5) Рядом с bat-файлом cоздайте папки CAB и MSU.
6) Поместите обновления .msu в папку MSU и .cab в папку CAB.
7) Запустите Update.bat и дождитесь закрытия окна командной строки.

Для правильности работы скрипта проверьте у себя соблюдение следующих пунктов:

1) Проверьте разрядность обновлений (х86\х64)
2) В имени файла не должно быть слова EXPRESS, такое обновление копировать бесполезно, оно не установится.
3) Файл Update.bat должен находиться в папке на один уровень выше папок CAB и MSU.

Скачать готовый Update.bat

Вариант 2. Использование программы Windows 7 Update Pack Tool.

Наиболее простым решением для автоматической установки обновлений является программа Windows 7 Update Pack Tool.

Инструкция:

1) Скачайте Windows 7 Update Pack Tool
2) Создайте новую папку. Например: Updates
3) Поместите в неё файл Update.exe
4) Поместите в неё все обновления с расширениями .msu и .cab, которые Вы желаете установить.
5) Создайте внутри Вашей папки Updates папку SpecialUpdates
6) Поместите в папку SpecialUpdates все обновления с расширениями .msi и .exe, которые Вы желаете установить.
7) Запустите файл Update.exe
8) Выберите пункт Install updates. Для этого нажмите на клавиатуре цифру 1 и затем Enter
9) Программа произведет поиск обновлений: .msu и .cab в главной папке, и .msi и .exe в папке SpecialUpdates
10) Нажмите любую клавишу(например: Enter) и программа установит обновления
11) По окончании установки программа напишет список устанавливаемых обновлений и попросит перезагрузки.
12) Перезагрузите компьютер и Вы получите систему с установленными обновлениями.


1. Как добавить новое устройство(драйвер) вручную?

1) Нажимаем Windows + R
2) В открывшемся окне набираем hdwwiz, жмём OK
3) В открывшемся окне, жмем Далее(Next)
4) В следующем окне выбираем Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list), жмём Далее(Next)
5) Выбираем в списке самую верхнюю строчку Показать все устройства(Show all devices), жмём Далее(Next)
6) В следующем окне нажимаем на кнопку Установить с диска(Install From Disk), в нижнем правом углу
7) В открывшемся окне нажимаем кнопку Обзор(Browse) и указываем путь к файлу драйвера (inf-файл), нажимаем Ok, а затем Далее(Next)
8) Подтверждаем желание установить нажатием Далее(Next)

Назад на страницу раздела Установка.


2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

Все обновления, которые Вы скачиваете или устанавливаете через внутреннюю службу Windows Центр обновления Windows (Windows Update) хранятся в папке: C:\Windows\SoftwareDistribution\Download, а также в подпапках внутри неё. После установки обновлений, Вы можете сохранить их себе на компьютер просто скопировав из папки нужный Вам файл. Файлы содержащие в своем названии -express, могут повторно не установиться. Следовательно Вы можете их и не копировать.

Назад на страницу раздела Установка.


3. Как определить неизвестное устройство?

Узнаем VendorID(VEN) или HardwareID(DEV) устройства. В диспетчере устройств нажимаем у неизвестного устройства Свойства. Далее Сведения-Проматываем до ID оборудования.
Теперь идем на http://www.pcidatabase.com/. И вводим одно из найденных значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:
Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные
там тоже это указывается.

Назад на страницу раздела Установка.


4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

Назад на страницу раздела Установка.


5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

Назад на страницу раздела Установка.


6. Установка Windows 7 с USB флеш-накопителя (флешки).

Вариант 1

1) Вставьте Ваш флеш-диск в USB-порт.
2) Откройте ISO-образ Windows программой UltraISO

Так:

Щелкните на ISO-файле правой кнопкой мыши и выберите пункт Открыть, используя UltraISO

Или так:

В программе UltraISO в меню Файл нажмите на пункт Открыть, выберите нужный Вам образ Windows 7 и нажмите Открыть.

3) Убедившись, что образ открыт - выберите в меню Самозагрузка пункт Записать образ Жесткого диска
4) В списке Disk Drive:, выберите Ваш флеш-накопитель, в пункте Метод записи: USB-HDD+ и нажмите Записать.
5) В появившемся окне об уничтожении информации Подсказка, нажмите кнопку Да. Дождитесь, когда завершится запись (от 5 до 20 минут).
6) Не вынимая флеш-диска из USB-порта перезагрузите компьтер.
7) Сразу после начала перезапуска нажмите на клавиатуре Delete (Del), чтобы попасть в BIOS.
8) В BIOS установите загрузку в первую очередь с USB-HDD.
9) Сохраните настройки и выйдите из BIOS. Компьютер перезапуститься и начнет загрузку с флеш-накопителя.
10) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флеш-диска.

Вариант 2

Подготовка USB флеш-накопителя (флешки) для будущей загрузки и установки Windows 7:

1) Подключаете USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
2) В строке поиска меню Пуск вводите cmd.exe, щелкаете на найденном правой кнопкой мыши и нажимаете Запуск от имени администратора
3) Запускате утилиту управления дисками diskpart, дожидаетесь приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них Ваш диск USB, в моём примере это Disk 2
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 2. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаете выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируете раздел в файловую систему NTFS
12) Выполняете команду assign – активируете процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходите из diskpart в командную строку.

14) Вставляете имеющийся у Вас дистрибутив Windows 7 в дисковод, или монтируете образ в виртуальный диск.
15) Допустим, что он у Вас установлен в дисковод H:, тогда в командной строке (не в diskpart !!!) выполняете команду:
H:\Boot\bootsect.exe /nt60 I:
где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
16) Копируете все файлы с Вашего дистрибутива на Ваш USB флеш-накопитель (флешку). Используйте для этого либо Windows Explorer, либо команду:
xcopy H: I: /s /e /h /k
Всё, USB-драйв готов. Загружаете ПК с полученного USB флеш-накопителя.

Для ускорения процесса копирования опытные пользователи могут воспользоваться программой RichCopy, она является графической оболочкой команды robocopy, и включает всебя большое количество настроек. В число многочисленных параметров входят сортировка файлов по атрибутам и папкам, предотвращение ошибок, смена атрибутов, тайминг копирования, редактирование отметки о времени, установка количества потоков и размера используемого кэша.

Назад на страницу раздела Установка.


7. Интеграция языковых пакетов и обновлений в дистрибутив Windows 7.

Вариант 1 вручную с помощью DISM.

Для работы нам потребуются программа DISM, входящая в состав Windows 7, либо включенная в WAIK, а также программа GimageX.

Русификация установщика install.Wim
1) Создаёте на диске D: папки Lip, Mount и mWim
2) Копируете lp.cab и все обновления (MSU и CAB) в папку Lip и создаёте в ней подпапку uLip
3) При помощи GimageX экспортируете из папки \Sources\install.wim в папку D:\mWim образ Ultimate (индекс 5 для 32-битных версий или Индекс 4 для 64-битных версий) как install.wim
4) Выполняете перезагрузку вашего ПК.
5) Запускаете командную строку от имени администратора (Win+R -> cmd -> Ok) и монтируете файл D:\mWim\install.wim в папку D:\Mount выполнив в консоли команду:
(команды копируете, и вставляете в консоль по правому клику)
dism /Mount-Wim /WimFile:D:\mWim\install.wim /index:1 /MountDir:D:\Mount
6) Интегрируете языковой пакет и обновления:
Для интеграции языкового пакета введите команду:
dism /image:D:\Mount /Add-Package /PackagePath:D:\Lip\lp.cab
Для интеграции обновления, используйте команду аналогичную предыдущей, подставляя вместо lp.cab, наименование интегрируемого обновления. Вот пример интеграции произвольного обновления:
dism /image:D:\Mount /Add-Package /PackagePath:D:\Lip\Windows6.1-KB123456-x64.msu
7) Применяем все настройки для русского языка командой:
dism /image:D:\Mount /Set-AllIntl:ru-RU
Примеры запуска команд DISM:
dism /image:D:\Mount /Set-UILang:ru-RU (язык интерфейса системы)
dism /image:D:\Mount /Set-SysLocale:ru-RU (язык системной локали для не Unicode)
dism /image:D:\Mount /Set-UserLocale:ru-RU (денежный формат, формат времени)
dism /image:D:\Mount /Set-InputLocale:0419:00000419 (настройки ввода с клавиатуры)
dism /image:D:\Mount /Set-TimeZone:"Russian Standard Time" (временная зона)
8) Демонтируете образ с сохранением изменений:
dism /Unmount-Wim /MountDir:D:\Mount /commit
Демонтаж без сохранения:
dism /Unmount-Wim /MountDir:D:\Mount /discard
9) Заменяете файл sources\install.wim в дистрибутиве, файлом D:\mWim\install.wim 10) Там же правите текст файла sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
Русификация установщика Boot.Wim
1) Распаковываете lp.cab в папку D:\Lip\uLip
expand D:\Lip\lp.cab -f:* D:\Lip\uLip
2) Очищаете папку D:\Mount
3) При помощи GimageX экспортируем из файла \Sources\boot.wim (индекс 2 !!!) в папку D:\mWim\ как boot.wim.
4) Монтируете файл boot.wim в папку D:\Mount
dism /Mount-Wim /WimFile:D:\mWim\boot.wim /index:1 /MountDir:D:\Mount
5) Добавляете в boot.wim русский язык:
xcopy D:\Lip\uLip\setup\* D:\Mount\ /cheryki
6) Добавляете в boot.wim файлы лицензий:
xcopy D:\Lip\uLip\sources\license\* D:\Mount\sources\license\ /cheryki
7) Правите текст файла D:\Mount\sources\lang.ini так же, как описано выше. 8) Демонтируете с сохранением файл boot.wim, папку uLip можно удалить.
dism /Unmount-Wim /MountDir:D:\Mount /commit
9) Заменяете файл sources\boot.wim в дистрибутиве, файлом D:\mWim\boot.wim

Вариант 2 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дождитесь успешного выполнения и увидите результат.

Вариант 3 с помощью командного файла скрипта.

1) Скачайте LPIntegrator.zip
2) Распакуйте скачанный архив в папку
3) Нажмите правой кнопкой мыши на файле LPIntegrator.bat и щелкните на пункте меню Изменить
4) Измените значение параметра set LANG=ru-RU, на язык интегрируемого языкового пакета, где en-US - для английского языка, de-DE - для немецкого языка и т.д.
5) Сохраните изменения и закройте редактирование.
6) Запустите LPIntegrator.bat
7) Выберите версию Вашего образа Windows 7
8) Распакуйте ISO-образ в папку C:\7Work\DVD или скопируйте туда все файлы Вашего инсталяционного диска.
9) Скопируйте языковой пакет, который Вы хотите интегрировать в папку C:\7Work\LP
10) Скопируйте обновления, которые Вы хотите интегрировать в папку C:\7Work\CABS
11) Нажмите любую клавишу(например, Enter) для продолжения.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Назад на страницу раздела Установка.


8. Добавление и использование новых языков интерфейса в Windows.

Для добавления языков интерфейса необходимо установить дополнительные языковые файлы. После установки языковых файлов можно просматривать текст мастеров, диалоговых окон, меню, разделов справки и прочих элементов Windows на другом языке. Существуют 2 варианта добавления новых языков интерфейса: первый - через Центр обновления Windows(Windows Update), а второй - скачав и установив файл языкового пакета вручную. Перед началом работы измените в Панели Управления (Control Panel) способ просмотра(View by), вместо Категория(Category) на Крупные (Large icons) или Мелкие значки(Small icons).

Вариант1. Через Центр обновления Windows(Windows Update)

1) Откройте Центр обновления Windows

Пуск -> Все программы -> Центр обновления Windows (Start -> All Programs -> Windows Update)
или
Панель управления\Все элементы панели управления\Центр обновления Windows (Control Panel\All Control Panel Items\Windows Update)

1a) Также вы можете нажать Win+R, в поле Выполнить ввести указанную ниже комманду и нажать Ok
Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
2) Выберите пункт Необязательных обновлений XX шт. доступны (XX options updates are available)
3) Поставьте флажок напротив нужного Вам языкового пакета (Language Pack) и нажмите Ok

Вариант 2. При наличии файла языка интерфейса lp.cab

1) Заходите в Панель Управления(Control Panel)
2) Открываете Язык и региональные стандарты (Regional and Language)
3) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
4) Нажимаете Установить или удалить язык (Install/uninstall languages...)
4a) Также вы можете нажать Win+R, в поле Выполнить ввести lpksetup и нажать Ok
5) Нажимаете Установить языки интерфейса (Install display languages)
6) Нажимаете кнопку Обзор...(Browse...)
7) Указываете путь к папке с lp.cab и нажимаете Ok
8) Выбираете необходимый Вам язык и нажимаете Далее(Next)

Вариант 3. Установка файла скачанного с сервера Windows Update

Вы можете установить необходимый Вам язык интерфейса, скачав exe-файл по прямой ссылке с сервера Windows Update и просто запустив его.

Оффициальные языковые пакеты для 32-bit (x86) Windows 7 RTM:

Арабский (Arabic):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ar-sa_210ccc96338a1ff683803eb4034e5f53d6d54c97.exe

Болгарский (Bulgarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-bg-bg_2e5d91b00775e0f974d4ec213fc20d470ff6850e.exe

Китайский (упрощенное письмо) (Chinese (Simplified)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-zh-cn_ab024143b556395e6638e26712b1e0f3bc031fcf.exe

Китайский (традиционное письмо) (Chinese (Traditional)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-zh-hk_90617b75cfaab716a43e7c082b00490a6d475376.exe

Хорватский (Croatian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-hr-hr_d8a4131aee5d5de039a3a0dc517ca0c07ebc3472.exe

Чешский (Czech):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-cs-cz_2759680ec6e2f4a7629c7d02b1fbce0a0d410a4e.exe

Датский (Danish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-da-dk_e1c57a4dcbd336ac73e349a9bb9d30de17ac093f.exe

Нидерландский (Dutch):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-nl-nl_194a2ca7b589e77b0be73b822f77760823183c51.exe

Английский (English):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe

Эстонский (Estonia):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-et-ee_3a99769fac5d6a11e6616297f842a9074c045699.exe

Финский (Finnish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-fi-fi_dd1973cc63ab7dea0e5d660af06869a8beefe36a.exe

Французский (French):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-fr-fr_1878fd391b990054787a14b0db4a5db00b793bf1.exe

Немецкий (German):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-de-de_1b86ff9b8f4c517dd341d76f24c74399278b05fc.exe

Греческий (Greek):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-el-gr_1f366d5e4fbde7df89b106821236fc1d3b3c9230.exe

Иврит (Hebrew):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-he-il_a3d6a6ae858f33ffa11a14c2a966e6603c134ef9.exe

Венгерский (Hungarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-hu-hu_12feb47da4bb28f60b6a30d379044356581c20f8.exe

Итальянский (Italian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-it-it_079a3afeb88f14d24a3b4204812225e78c2e0bb8.exe

Японский (Japanese):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ja-jp_08758c23cc64a53949072d53dd7bf6bbc8b45420.exe

Корейский (Korean):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ko-kr_bb2de1652c37394be4de87438661b129f8b56908.exe

Латышский (Latvian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-lv-lv_8b7a0b361dd37f7cd3926f798a79a90d378b18b2.exe

Литовский (Lithuanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-lt-lt_7aee9ce232cb46701f479fafdb0aea369ce1ad6a.exe

Норвежский (Norwegian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-nb-no_d65ea89195cf5f7d3170ccb1db7bae3c157f5b24.exe

Польский (Polish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe

Португальский (Бразилия) (Portuguese (Brazil)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pt-br_0a3fe79820d6d199dd43495d4efa5c40f270e45a.exe

Португальский (Португалия) (Portuguese (Portugal)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-pt-pt_4165bd9cd083abd8ddd81986e18b1fd86aab5ce9.exe

Румынский (Romanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ro-ro_e1c324236046eb608e478570cf4396776ff02a72.exe

Русский (Russian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-ru-ru_f4df4bcb8d3194323f17a086a17f46dd0c9c492a.exe

Сербский ()латиница (Serbian (Latin)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sr-latn-cs_6e049bae4d75b82405b28455e2def0a0d0055a9c.exe

Словацкий (Slovak):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sk-sk_dd2ce36a7e94fceff650cb892b8c954b8af6025a.exe

Словенский (Slovenian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sl-si_17786270766d556ba9bf3693762cb98805df9f50.exe

Испанский (Spanish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-es-es_1943a073d8f00e387301deb22cd177bf77319ee8.exe

Шведский (Swedish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-sv-se_687085e8bbdf9c17a668b801f28f7f9c74e7a86a.exe

Тайский (Thai):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-th-th_780885dd42c039d9926ac004c76ba3ba9c30c6d0.exe

Турецкий (Turkish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-tr-tr_13015cb75811f874c83fdd679beb4c22c930a57c.exe

Украинский (Ukrainian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-uk-ua_0a467bf14bc4f524c18877f570a20c58e91ceba9.exe

Оффициальные языковые пакеты для 64-bit (x64) Windows 7 RTM:

Арабский (Arabic):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ar-sa_aaac936bd625c12b607dffea19fab8be9cfa28f6.exe

Болгарский (Bulgarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-bg-bg_155634f17868659db4b65cfeff57059b2436515f.exe

Китайский (упрощенное письмо) (Chinese (Simplified)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-zh-cn_a649e9af1e28514d48bdc51f7956be08060e54bc.exe

Китайский (традиционное письмо) (Chinese (Traditional)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-zh-hk_d428bc1cca4aea20163936e6687221c0e6b99ec4.exe

Хорватский (Croatian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-hr-hr_06468f799a1c1f295bc3abbc85c14116e2645122.exe

Чешский (Czech):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-cs-cz_f136df3188c54ff234ca77253fee2cf3e91966b7.exe

Датский (Danish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-da-dk_2b7590d389ca96af6f367408150cb6bc9aa8f4b4.exe

Нидерландский (Dutch):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-nl-nl_2ac14543f6e46c61ae226d7f0f5aee7f4d500e9f.exe

Английский (English):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe

Эстонский (Estonian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-et-ee_3c0479d7049109bcb42fd9ec59d1c65449704687.exe

Финский (Finnish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-fi-fi_4378f72d1233b00e2bdfc680a13f62ae11ab0fcb.exe

Французский (French):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-fr-fr_0e50cd2ea794e4cdfac861b194d2e996b7bbc8d8.exe

Немецкий (German):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-de-de_399ac15b2d55fd5dea0770d98825d7e75f4ad533.exe

Греческий (Greek):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-el-gr_9ae588ba70896f9100a10cb8ed68a79678d6fc32.exe

Иврит (Hebrew):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-he-il_86c22105bb32269c9c0deaf2710fcb1531a29817.exe

Венгерский (Hungarian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-hu-hu_e5c47bffe398b9ace42d4326de2646a6172d39b5.exe

Итальянский (Italian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-it-it_3f0f5d78202e074e17a495beec821e1d326a8e2a.exe

Японский (Japanese):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ja-jp_9d73b1c1270deacbe7a2329559476a94daddb848.exe

Корейский (Korean):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ko-kr_e6b3322c3865cfd328d84376e192c4f9d41aa0e6.exe

Латышский (Latvian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe

Литовский(Lithuanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lt-lt_ede5a878aae2b0d64e81ff739e950b6f105df580.exe

Норвежский (Norwegian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-nb-no_1b7f93a0906a62eecd6b200979f8df986a7556f1.exe

Польский (Polish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe

Португальский (Бразилия) (Portuguese (Brazil)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pt-br_276b65f3b6b2657c8fe936f9841dc1243e02dc7b.exe

Португальский (Португалия) (Portuguese (Portugal)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-pt-pt_f8310aa4a73841aec29b3f4e74ecaece56b695e9.exe

Румынский (Romanian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ro-ro_810f2d590dd5aac92561eea5884ed1c70f34dbd9.exe

Русский (Russian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-ru-ru_f0acfc688d609ee45d43cc60c6412a3071a665bd.exe

Сербский ()латиница (Serbian (Latin)):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sr-latn-cs_275e0a17cbec543aa1bd7eebc883a1d21c11b514.exe

Словацкий (Slovak):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sk-sk_15f397de2ceaaff8dbfe670bcc6c013791a297c3.exe

Словенский (Slovenian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sl-si_8cfc82e0d15ed94634d3da69674008dc56755b93.exe

Испанский (Spanish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-es-es_2e593c26d9e23ad8176224a53c68a04f996ee014.exe

Шведский (Swedish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-sv-se_1f4c415e0f4ca77064d597975f6ac7a9e0b8af63.exe

Тайский (Thai):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-th-th_080c8631d44a53c34ffdab8fd73820572dd87be4.exe

Турецкий (Turkish):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-tr-tr_6bd6660158289e0b5d4b5a7f7fded6e3528a9a04.exe

Украинский (Ukrainian):
http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-uk-ua_c6c4e44c9d903049a4c60fed9d42effa18f345bd.exe

Смена Вашего языка интерфейса на новый:

1) Заходите в Панель Управления(Control Panel)
1.1) Открываете Язык и региональные стандарты (Regional and Language)
1.1a) Также вы можете нажать Win+R, в поле Выполнить ввести intl.cpl и нажать Ok
1.2) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
2) Выбираете в пункте Выберите язык интерфейса (Choose a display language:) нужный Вам язык и нажимаете Ok
3) Нажимаете кнопку Выйти из системы сейчас (Log off now)
4) В появившемся экране выбираете своего пользователя.
5) В случае необходимости вводите свой пароль и попадаете в Windows на выбранном Вами языке

Назад на страницу раздела Установка.


9. Как не вводить ключ при инсталляции Windows?

Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>MyName</FullName>
<Organization>Microsoft</Organization>
<ProductKey>
<Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
</component>
</settings>
</unattend>

Назад на страницу раздела Установка.


10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузиться в специальный режим Windows.
1) Сразу после включения компьютера нажмите F8. Далее вы попадете либо в меню выбора режимов загрузки Windows, либо в меню выбора диска для загрузки.
2) Нам нужен меню выбора режимов загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter, а затем быстро нажмите F8 до начала запуска Windows и окажитесь там, где нам нужно.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов. Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобиться программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С оффициального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи используйте рекомендации из совета 6 в "Тонких настройках".
Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriverPlus она добавит небольшое изменение в загрузчик, которое автоматизмрует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriverPlus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriverPlus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник -> Компьютер -> Локальный диск (C:)
1.2) В Панели меню выберите Сервис -> Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом местенахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву(Например: Z) и нажите OK
2.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriverPlus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом местенахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriverPlus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriverPlus перезагрузитесь.

В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

Назад на страницу раздела Установка.


11. Где можно скачать последние обновления для Windows 7?

Компания Microsoft периодически выпускает обновления для Windows 7. Но не все из них включены в Центр обновления Windows (Windows Update). Все последние версии обновлений, Вы можете скачать без регистрации на форуме My Digital Life:

http://forums.mydigitallife.info/threads/10571-Windows-7-RTM-Updates-Packs-x86-x64

Для того, чтобы не устанавливать каждое обновление по-отдельности, Вы можете воспользоваться предложенной там программой Windows 7 Update Pack Tool, для установки всех обновлений сразу.

Назад на страницу раздела Установка.


12. Повышение оценки производительности жесткого диска.

Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

Назад на страницу раздела Установка.


13. Автоматическая установка OEM-информации.

Представляем вашему вниманию небольшой скрипт, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
Не забудьте заменить серийный ключ (product key) на ваш и назовите файл autounattend.xml.
<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0409:00000409</InputLocale>
<SystemLocale>en-US</SystemLocale>
<UILanguage>en-US</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>en-US</UserLocale>
</component>
<component name=”Microsoft-Windows-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<DiskConfiguration>
<Disk wcm:action=”add”>
<CreatePartitions>
<CreatePartition wcm:action=”add”>
<Extend>false</Extend>
<Type>Primary</Type>
<Order>1</Order>
<Size>40000</Size>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action=”add”>
<Order>1</Order>
<PartitionID>1</PartitionID>
<Format>NTFS</Format>
<Letter>C</Letter>
<Extend>true</Extend>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass=”oobeSystem”>
<component name=”Microsoft-Windows-Shell-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<OEMInformation>
<Logo>E:\oemlogo.bmp</Logo>
<Manufacturer>Fabrikam</Manufacturer>
<Model>Superfast1000</Model>
<SupportHours>Anytime, day or night</SupportHours>
<SupportPhone>1-800-SUPPORT</SupportPhone>
<SupportURL>www.fabrikam.com</SupportURL>
</OEMInformation>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
<AutoLogon>
<Password>
<Value>Password</Value>
<PlainText>true</PlainText>
</Password>
<Username>Administrator</Username>
<Enabled>true</Enabled>
<LogonCount>5</LogonCount>
</AutoLogon>
<UserAccounts>
<AdministratorPassword>
<Value>Password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
<cpi:offlineImage cpi:source=”wim:c:/documents%20and%20settings/vmux/desktop/sourceos/install.wim#Windows 7 ULTIMATE” xmlns:cpi=”urn:schemas-microsoft-com:cpi” />
</unattend>

Внимание!!!
Не используйте данный метод, если имеете важную информацию на жестком диске или же сделайте резервную копию системы. Дело в том, что файл ответов в данном совете стирает все разделы и логические диски при установке.
Если же вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

Назад на страницу раздела Установка.


14. Автоматическая установка OEM-Logo.

Создаете файл Autounattend.xml со следующим текстом и кладете в \Sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass=”windowsPE”>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OEMInformation>
<HelpCustomized>false</HelpCustomized>
<Manufacturer>Hewlett-Packard</Manufacturer>
<Model>Compaq Presario SR1610IL</Model>
<Logo>C:\Windows\Sytem32\oemlogo.bmp</Logo>
<SupportHours>9 AM to 9 PM (Mon-Sat)</SupportHours>
<SupportPhone>1-600-114772 (Toll free), 0124-2346992 (Toll Number)</SupportPhone>
<SupportURL>http://www.hp.com/in/support</SupportURL>
</OEMInformation>
</component>
</settings>
</unattend>
oemlogo.bmp
положите ваше лого в папку " \Sources\$OEM$\$$\System32\oemlogo.bmp"

Назад на страницу раздела Установка.


15. Как установить LocalPack-RU?

Нужно в командной строке от имени Администратора выполнить команду: DISM /Online /Add-Package /PackagePath:<полный_путь_к_локал-паку>.CAB
Если не сработает - значит, нужно проделать почти то же самое, но загрузившись с установочного носителя.
Тогда /Online нужно будет заменить на /image:<буква_диска_с_установленной_системой>:.
Этим способом, кстати, MVE, можно установить лангпак на любую редакцию Windows 7
После установки нужно зайти в C:\Windows\Globalization\MCT\MCT-...\Theme

Назад на страницу раздела Установка.


16. Автономная установка обновлений Windows.

16. Автоматическая установка обновлений Windows.

Вариант 1. Использование Bat-файла (для MSU и CAB обновлений).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Update.bat")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
@Echo Off
Title Installing Windows7 Updates
For %%F In (MSU\*.msu) Do Call :msin %%F
For %%A In (CAB\*.cab) Do Call :kbin %%A
Exit
:msin
Start /Wait %1 /quiet /norestart
:kbin
Start /Wait pkgmgr /ip /m:%1 /quiet /norestart
GoTo :EOF
Exit
5) Рядом с bat-файлом cоздайте папки CAB и MSU.
6) Поместите обновления .msu в папку MSU и .cab в папку CAB.
7) Запустите Update.bat и дождитесь закрытия окна командной строки.

Для правильности работы скрипта проверьте у себя соблюдение следующих пунктов:

1) Проверьте разрядность обновлений (х86\х64)
2) В имени файла не должно быть слова EXPRESS, такое обновление копировать бесполезно, оно не установится.
3) Файл Update.bat должен находиться в папке на один уровень выше папок CAB и MSU.

Скачать готовый Update.bat

Вариант 2. Использование программы Windows 7 Update Pack Tool.

Наиболее простым решением для автоматической установки обновлений является программа Windows 7 Update Pack Tool.

Инструкция:

1) Скачайте Windows 7 Update Pack Tool
2) Создайте новую папку. Например: Updates
3) Поместите в неё файл Update.exe
4) Поместите в неё все обновления с расширениями .msu и .cab, которые Вы желаете установить.
5) Создайте внутри Вашей папки Updates папку SpecialUpdates
6) Поместите в папку SpecialUpdates все обновления с расширениями .msi и .exe, которые Вы желаете установить.
7) Запустите файл Update.exe
8) Выберите пункт Install updates. Для этого нажмите на клавиатуре цифру 1 и затем Enter
9) Программа произведет поиск обновлений: .msu и .cab в главной папке, и .msi и .exe в папке SpecialUpdates
10) Нажмите любую клавишу(например: Enter) и программа установит обновления
11) По окончании установки программа напишет список устанавливаемых обновлений и попросит перезагрузки.
12) Перезагрузите компьютер и Вы получите систему с установленными обновлениями.

Назад на страницу раздела Установка.


Настройки

1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Hужно установить пароль на учетную запись администратора и работать из под нее.

2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

3. Как изменить параметры загрузки, где в Windows 7 файл boot.ini?
Начиная с Windows Vista такого файла больше нет, но Вы можете изменить необходимые Вам для загрузки параметры используя инструмент Конфигурация системы. Окно Конфигурация системы запускается так: Панель управления -> Администрирование -> Конфигурация системы -> Загрузка (или нажав Win+R -> msconfig -> Ok)

Данный инструмент позволяет:
- получить информацию о текущей и загружаемой по умолчанию системах;
- выбрать систему, загружаемую по умолчанию;
- удалить ненужную запись из меню загрузки.
- отредактировать время в секундах (таймаут), по истечении которого будет загружена операционная система, выбранная по умолчанию.
- включить\выключить экран приветствия(Без GUI);
- включить\выключить загрузку стандартных драйверов VGA, вместо драйверов экрана, соответствующих видеооборудованию компьютера(Базовое видео).

А через Дополнительные параметры:

- Число процессоров, используемых при загрузке.
- Максимальный объем памяти в мегабайтах, используемый для моделирования конфигурации с малым объемом памяти.

При помощи окна Конфигурация системы нельзя изменить(но это возможно, при помощи программы Bcdedit):

- наимнование существующих записей;
- положение записи в меню загрузки.

Для выбора системы, загружаемой по умолчанию, выберите необходимую Вам операционную систему и нажмите кнопку «Использовать по умолчанию».
Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».
Для редактирование таймаута, в нужном поле установите желаемое количество секунд.

Для применения, сделанных Вами изменений - перезагрузите компьютер.

4. Увеличение скорости загрузки ОС для многоядерных процессоров.

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить(или Win+R)
2) Введите msconfig и нажмите OK
3) Перейдите на вкладку Загрузка
4) Нажмите Дополнительные параметры
5) Поставьте флажок напротив значения Число процессоров
6) Выберите в активировавшемся ниспадающем меню число ядер Вашего процессора (По умолчанию 1)
Установка меньшего значения, чем количество ядер Вашего процессора не рекомендуется, так как система может продолжить использование указанного Вами числа ядер и после завершения загрузки.
7) Нажмите OK и перезагрузите компьютер

Также рекомендую включить(установить в значение Enabled) в BIOS (Вызывается нажатием клавиши Delete, сразу после начала загрузки компьютера) функцию ACPI APIC Support. Данная функция находится во вкладке Power.

5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны. К примеру, чтобы изменить временную зону на время по Гринвичу, нужно использовать следующую команду:
tzutil /s “gmt standard time”
» “tzutil /g” покажет текущие установки временной зоны;
» “tzutil /l” выводит список всех возможных временных зон;
» “tzutil /?” выводит справку по работе утилиты.

6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавишы Ctrl+Alt+, выбор третьей клавишы за вами, как вам удобнее. Например, Ctrl+Alt+S.

7. Отключение (включение) неиспользуемых компонентов Windows.
В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

8. Как отменить (изменить) ассоциирование типов файлов с определенными программами?

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Искать в реестре в ветке [HKEY_CLASSES_ROOT]
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

9. Как отключить всплывающие подсказки?

Отключить всплывающие подсказки можно используя редактор групповой политики.
Нажмите Пуск, в поле Начать поиск напишите gpedit.msc и нажмите ОК.
Перейдите в раздел Конфигурация пользователя - Административные шаблоны - Меню Пуск и Панель задач.
Откройте параметр "Удалить всплывающие подсказки для элементов главного меню", выберите пункт Включен и нажмите ОК

10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии «Завершение работы». Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние «Перезагрузка». Для этого выполняем правый клик по кнопке Пуск, выбираем пункт меню Свойства и переключаем “Действие кнопки питания” в состояние “Перезагрузка”. Также вы можете выбрать функции “Блокировка”, “Смена пользователя” и “Завершение сеанса”.

11. Как быстро перейти к часто используемой папке?

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

bcdedit - инструмент, позволяющий изменить значения загрузчика Windows, а также произвести его(загрузчика) восстановление. Чтобы увидеть предлагаемые системой для изменения параметры: запустите командную строку от имени администратора (Win+R -> cmd -> Ok), наберите в ней bcdedit и нажмите Enter. Все команды, приведенные в данном варианте, необходимо будет запускать в командной строке, запущенной от имени администратора (Win+R -> cmd -> Ok) Также данные команды могут выполняются в командной строке среды восстановления или в командной строке ERD Commander.

Некоторые значения параметров BCD записаны в фигурных скобках – {}. Это идентификаторы – {CLSID}. Любой идентификатор имеет буквенно-цифровой код вида {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. Стандартные идентификаторы имеют названия, например: {default}, {bootmgr}, {ntldr} и так далее.

Наиболее интересующими нас компонентами являются:

идентификатор – CLSID той или иной записи;
device – показывает раздел, на котором расположены файлы загрузки (это может быть операционная система или папка BOOT);
osdevice – показывает раздел, на котором расположены системные файлы операционной системы. Обычно, значения параметров device и osdevice равны;
path – если device определял раздел диска, который содержит файлы операционной системы, то этот параметр определяет остальной путь к загрузчику операционной системы;
default – показывает ID операционной системы, загружаемой по умолчанию, если операционная система, в которой запустили командную строку, загружается по умолчанию, параметру default присваивается значение {current};
displayorder – показывает порядок, в котором расположены записи о загружаемых системах;
timeout – таймаут(время - по истечении которого будет загружена операционная система), значение показано и устанавливается в секундах;
locale – указывает язык загрузочного меню или меню дополнительных параметров загрузки;
description – показывает название операционной системы, отображающееся в меню загрузки.

Внимание: Если в выполняемой Вами команде, с использованием программы bcdedit.exe, отсутствует параметр /set с дальнейшим указанием идентификатора, то внесенные Вами изменения будут добавлены в Диспетчер загрузки Windows (Windows Boot Manager), а не в Загрузка Windows (Windows Boot Loader)

Перед тем, как начнете вносить необходимые Вам изменения, создайте резервную копию загрузчика. Для этого, создайте на любом диске папку с названием BCDREZ и выполните следующую команду:
bcdedit /export X:\BCDREZ\bcd
где X - буква диска, на котором находится папка BCDREZ.

Если Вы решите вернуть все сделанные Вами изменения к начальным настройкам, то выполните следующую команду:
bcdedit /import X:\BCDREZ\bcd
Для дальнейших примеров, предположим, что наше меню загрузки содержит три записи с идентификаторами {ID1}, {ID2}, {ID3}.

Изменение системы, загружаемой по умолчанию

Введите параметр /default и {ID} той системы, которую Вы хотите загружать по умолчанию. Например, для системы с {ID2} команда:
bcdedit /default {ID2}
Данная команда не перемещает запись о системе, загружаемой по умолчанию, на верхнюю строчку меню загрузки.

Изменение расположения записей в меню загрузки

1) Перемещение выбранной записи вверх списка:
bcdedit /displayorder {ID} /addfirst
2) Перемещение выбранной записи вниз списка:
bcdedit /displayorder {ID} /addlast
3) Формирование меню в выбранном порядке:
bcdedit /displayorder {ID3} {ID1} {ID2}
Изменение таймаута
bcdedit /timeout XX
где XX – время в секундах.

Изменение языка диспетчера загрузки
bcdedit /set {bootmgr} locale ln-LN
где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение языка меню дополнительных вариантов загрузки

В связи с тем, что программа восстановления запуска, выполняющаяся из среды восстановления, использует параметры "по-умолчанию", меню дополнительных вариантов загрузки, которое появляется при нажатии F8 после наведения на строку меню с нужной операционной системой, может стать англоязычным. Вернуть необходимый Вам язык, можно выполнив следующую команду:
bcdboot %Windir% /l ln-LN
где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение названия загружаемой системы

После использования среды восстановления, в названии операционной системы появляется надпись - (восстановлено). Вы также можете исправить значение "Предыдущая версия Windows" на более удобное Вам "Windows XP" или добавить версию и разрядность к текущей(используемой по умолчанию) версии Windows. Вы можете изменить это указанной ниже командой:
bcdedit /set {ID} description "Новое название"
Например:
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"
Изменение буквы раздела, на котором расположена папка операционной системы и ее загрузочные файлы
bcdedit /set {ID} device partition=X:
bcdedit /set {ID} osdevice partition=X:
где X – буква раздела жесткого диска. Обычно значения device и osdevice совпадают.

Добавление новой операционной системы (Windows Vista или Windows 7) в загрузчик.

1) Скопируйте существующую запись текущей системы с новым названием:
bcdedit /copy {current} /d "Microsoft Windows Vista"
2) Дождитесь сообщение «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
3) Измените значения параметров device и osdevice на соответствующие добавляемой операционной системе.
bcdedit /set {хххххххх-хххх-хххх-хххх-хххххххххххх} device partition=X:
bcdedit /set {хххххххх-хххх-хххх-хххх-хххххххххххх} osdevice partition=X:
где X – буква диска, на котором находится операционная система. Вместо крестиков, введите значение {ID}, полученное после успешного окончания копирования.
4) Выполните команду, добавляющую новую запись в диспетчер загрузки:
bcdedit /displayorder {хххххххх-хххх-хххх-хххх-хххххххххххх} /addlast
Запись будет добавлена внизу существующего списка.

Удаление записи загрузки системы из BCD и диспетчера загрузки.

Удаление записи об установленной операционной системе из BCD и диспетчера загрузки выполняется с помощью команды bcdedit /delete {ID}. Есть особенность выполнения команды: если в качестве ID указывается известная запись, например {ntldr}, то команда должна выполняться с ключом /f:
bcdedit /delete {ntldr} /f
Если же ID записывается в буквенно-цифровом коде, ключ /f не нужен.

В случае отсутствия одного из файлов, необходимых для работы с загрузчиком, Вы можете скачать архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe из Windows 7 Ultimate x86/x64)

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

13. Установка пользовательского разрешения экрана.

У некоторых мониторов разрешение экрана может не соответствовать ни одному из предлагаемых Windows.

Если у Вас установлена видеокарта Nvidia Вы можете добавить своё разрешение экрана одним из указанных способов:

Способ 1.

1) Запустить Панель управления Nvidia.
2) Открыть Дисплей -> Изменение разрешения -> Добавить разрешения... -> Создать пользовательское разрешение
3) Задать нужные Вам параметры, протестировать их и добавить его в список для выбора
4) Выбрать его и использовать.

Способ 2.

Используя реестр добавить нужное Вам разрешение в параметр NV_Modes

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{some number}\0000

Также можете найти другие ветки содержащие параметр NV_Modes и также добавить в них необходимое Вам разрешение экрана.

Способ 3. Перед установкой драйвера.

Откройте файл "nv_disp.inf" в папке C:\NVIDIA\Win7\xxx.xx и найдите значение [nv_commonDisplayModes_addreg]
Под ним в NV_Modes будут все доступные разрешения экрана, добавьте туда свое.

Но бывает что даже после указанных выше манипуляций, новое разрешение не хочет добавляться. В таком случае, для принудительного добавления пользовательского разрешения Вам придется использовать специальные программы. Рекомендую поискать в интернете следующие программы:

PowerStrip - Программа управления параметрами видеоподсистемы вашего компьютера, поддерживается огромное разнообразие видео карт. Это - фактически единственная программа своего рода, которая поддерживает видео карты из многочисленного набора чипсетов и поставщиков,одновременно, под любой операционной системой. Программа спокойно сидит в трее и оттуда обеспечивает доступ к более 500 элементов управления над вашими дисплейными аппаратными средствами, включая цветные инструментальные средства коррекции, установки уровня периода экранной геометрии, и драйверо-независимыми элементами управления часов.

Screen Resolution Manager - Программа, позволяющая каждому пользователю компьютера устанавливать свое разрешение экрана. Помимо разрешения можно настроить глубину цвета, частоту, яркость и контрастность, цветовую гамму и другие настройки, которые автоматически вступят в силу после загрузки профиля определенного пользователя.

14. Создание диска восстановления системы и загрузка с него.

Если у вас есть установочный диск Windows 7, создавать диск восстановления необязательно. Если же установочного диска у вас нет, создать диск восстановления нужно обязательно - он вам рано или поздно пригодится. С установочного диска можно загрузиться в среду восстановления Windows RE.

Создание диска восстановления системы

1) Вставьте чистый компакт-диск в привод.
2) Откройте Пуск -> Панель Управления -> Архивация и восстановление (Backup and Restore)
3) В левой панели щелкните ссылку Создать диск восстановления системы.

Загрузка с диска восстановления системы

1) Вставьте диск восстановления в привод и перезагрузитесь
2) В BIOS должен быть установлен приоритет загрузки с привода. Будет выполнена загрузка в Windows RE.
3) Выберите систему, которую вы хотите восстановить.
4) Установите переключатель Используйте средства восстановления... и нажмите кнопку Далее. Вы увидите окно с вариантами восстановления.

15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

1) Запустите cmd.exe от имени администратора(Win+R -> cmd -> Ok)
2) Выполните следующие команды, нажимая после введения каждой Enter
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"

16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

Вы решили заменить или продать один из ваших жестких дисков. Прежде чем это сделать, убедитесь что файлы загрузки Windows 7 не содержаться на удаляемом Вами из системы жестком диске.
Windows 7 хранит свои файлы для загрузки на активном диске, который может отличаться от того на котором установлена Windows 7. Файлами загрузки для Windows 7 являются файл bootmgr и хранилище данных конфигурации загрузки BCD (Boot Configuration Data), находящееся в скрытой и системной папке Boot.

При загрузке Windows 7 проверяет соблюдение 3 условий:

- Является ли диск, с которого выполняется загрузка активным;
- Совместима ли Главная Загрузочная Запись (Master Boot Record - MBR) с bootmgr (Диспетчером загрузки Windows);
- Находиться ли файлы загрузки операционной системы на активном диске должны.

В случае не соблюдения одного из условий, загрузка становится невозможной.

Предположим, что Ваша Windows 7 установлена на диск С:, который не активен. Активным является только диск D:, который Вы собираетесь удалить из системы и на котором находятся Файлы загрузки Windows 7, имеющие атрибуты Скрытый и Системный.

В качестве решения предлагаю Вам выполнить перенесение файлов загрузки Windows 7 с активного раздела (удаляемый жесткий диск) на неактивный раздел (остающийся в системе жесткий диск, с присвоением ему атрибута - Активный).

1) Выяснение атрибутов дисков и присвоение остающемуся в системе жесткому диску атрибута Активный.

Способ 1. Используя оснастку "Управление дисками".

1.1.1) Нажмите Win + R, в строке "Выполнить" наберите diskmgmt.msc и нажмите OK
1.1.2) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7 Буква тома здесь, идентична букве диска с Window 7 из Мой Компьютер.
1.1.3) Под буквой тома, размером диска и файловой системой будут указаны атрибуты диска. Посмотрите имеет ли наш том атрибут "Активный". Если да, то Вы сможете спокойно удалить Ваш диск из системы. Если же нет, то Вам необходимо будет присвоить данный атрибут, в соответствии с написанным ниже.
1.1.4) Если Ваша Windows 7 установлена на жесткий диск, разбитый на несколько разделов, то выберите первый слева раздел остающегося у Вас диска, его мы сделаем загрузочным и активным. Если же раздел всего один, то выберите его.
1.1.5) Щелкните правой кнопкой мыши по выбранному разделу и выберите в контекстном меню пункт "Сделать раздел активным". Учтите, что этот раздел должен иметь атрибут "Основной".

Способ 2. Используя командную строку.

1.2.1) Запустите командную строку с правами администратора. Нажмите Win + R, в строке "Выполнить" наберите cmd и нажмите OK.
1.2.2) Последовательно выполните все команды без выхода из командной строки:
DISKPART
list disk
sel disk X
list partition
sel part 1
active
exit
где X - номер диска, который предполагается оставить, в списке дисков (команда list disk).

2) Перезапись загрузочного сектора MBR и установка его совместимости с bootmgr:

2.1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2.2) Создайте папку Boot
2.3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
2.4) Запустите командную строку с правами администратора.
X:\boot\bootsect.exe /nt60 all /force
где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /force - принудительно отключает один или несколько томов во время обновления загрузочного кода. Необходим, при наличии в конфигурации 2-х и более жестких дисков.

3) Перенесение BCD (Boot Configuration Data) и файла bootmgr на новый активный раздел:
X:\boot\bcdboot.exe %Windir% /l ru-RU /s С:
где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /l - выбор языковых параметров менеджера загрузки. Если ваша система не русскоязычная, используйте другие значения этого ключа, например, для английского языка - en-US, для немецкого - de-DE, и т.д.
- ключ /s - определяет букву тома, назначенную целевому системному разделу, в который копируются файлы среды загрузки. Это раздел, который мы сделали активным. Windows 7 использует текущий загрузочный раздел (в нашем случае - раздел D:) до завершения своей работы. Поэтому применение этого ключа с указанием буквы нового загрузочного раздела (в нашем случае - раздел С:) - обязательно.

17. Способы доступа к элементам Панели управления.

В разных статьях Вы можете увидеть разное описание пути к одинаковым элементам Панели управления. Такое происходит потому что в Windows существует два вида отображения элементов: Категория(элементы сгруппированы по тематикам) и Крупные или Мелкие значки (элементы отображаются полным списком) Имхо, наиболее удобным является Крупные или Мелкие значки(их полный список).

Существует несколько способов доступа к элементам Панели управления:

1) Через меню Пуск.

Для быстрого доступа к элементам Панели управления, рекомендуется добавить в меню Пуск всплывающее меню содержащее все элементы Панели Управления.
1.1) Нажмите правой кнопкой мыши на кнопке Пуск и щелкните на пункте Свойства.
1.2) Нажмите Настроить...
1.3) Промотайте до записи Панель управления.
1.4) Установите значение переключателя под ней в положение Отображать как меню и нажмите OK
Всплывающее меню Панели управления будет отображаться полным списком, независимо от Вашего выбора вида отображения.

2) Через Проводник Windows.

2.1) Запустите Проводник
2.2) В панели меню выберите Сервис и нажмите Параметры папок
2.3) Под надписью Область переходов установите флажок напротив значения Показать все папки и нажмите OK
Теперь Панель управления будет доступна в Проводнике в Области переходов слева. Преимущество данного способа в том что Вы можете работать, как сразу с полным списком элементов: Проводник -> Панель управления -> Все элементы панели управления, так и с отдельными разделами: Проводник -> Панель управления -> Нужный Вам раздел.

3) На рабочем столе.

3.1) Щелкните правой кнопкой мыши на Рабочем столе и нажмите Персонализация
3.2) Щелкните Изменение значков рабочего стола
3.3) Установите флажок напротив Панель управления и нажмите ОК
На Рабочем столе появится ярлык запускающий папку Панель управления. Способ отображения зависит от выбранного Вами значения параметра Просмотр.

4) Добавление или запуск папки Панель управления используя {GUID}

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

Control Panel.{26EE0668-A00A-44D7-9371-BEB064C98683}

Для её запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}

5) Запуск элементов Панели управления, используя канонические имена.

Русское название элемента | Английское название элемента | Команда
Панель управления | Control Panel | control
Windows CardSpace | Windows CardSpace | control /name Microsoft.CardSpace
Windows SideShow | Windows SideShow | control /name Microsoft.WindowsSideShow
Автозапуск | AutoPlay | control /name Microsoft.AutoPlay
Автономные файлы | Offline Files | control /name Microsoft.OfflineFiles
Администрирование | Administrative Tools | control /name Microsoft.AdministrativeTools
Архивация и восстановление | Backup and Restore | control /name Microsoft.BackupAndRestore
Биометрические устройства | Biometric Devices | control /name Microsoft.BiometricDevices
Брандмауэр Windows | Windows Firewall | control /name Microsoft.WindowsFirewall
Восстановление | Recovery | control /name Microsoft.Recovery
Гаджеты рабочего стола | Desktop Gadgets | control /name Microsoft.DesktopGadgets
Дата и Время | Date and Time | control /name Microsoft.DateAndTime
Датчик расположения и другие датчики | Location and Other Sensors | control /name Microsoft.LocationAndOtherSensors
Диспетчер устройств | Device Manager | control /name Microsoft.DeviceManager
Диспетчер учетных данных | Credential Manager | control /name Microsoft.CredentialManager
Домашняя группа | HomeGroup | control /name Microsoft.HomeGroup
Защитник Windows | Windows Defender | control /name Microsoft.WindowsDefender
Звук | Sound | control /name Microsoft.Sound
Значки области уведомлений | Notification Area Icons | control /name Microsoft.NotificationAreaIcons
Игровые устройства | Game Controllers | control /name Microsoft.GameControllers
Инфракрасная связь | Infrared | control /name Microsoft.Infrared
Папка "Fonts" | Fonts Folder | control /name Microsoft.Fonts
Параметры индексирования | Indexing Options | control /name Microsoft.IndexingOptions
Параметры папок | Folder Options | control /name Microsoft.FolderOptions
Параметры планшетного компьютера | Tablet PC Settings | control /name Microsoft.TabletPCSettings
Перо и сенсорные устройства | Pen and Touch | control /name Microsoft.PenAndTouch
Персонализация | Personalization | control /name Microsoft.Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | control /name Microsoft.RemoteAppAndDesktopConnections
Получение программ | Get Programs | control /name Microsoft.GetPrograms
Приступая к работе | Getting Started | control /name Microsoft.GettingStarted
Программы и компоненты | Programms and Features | control /name Microsoft.ProgramsAndFeatures
Программы по умолчанию | Default Programs | control /name Microsoft.DefaultPrograms
Распознавание речи | Speech Recognition | control /name Microsoft.SpeechRecognition
Расположение по умолчанию | Default Location | control /name Microsoft.DefaultLocation
Родительский контроль | Parental Controls | control /name Microsoft.ParentalControls
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | control /name Microsoft.TaskbarAndStartMenu
Свойства речи | Text to Speech | control /name Microsoft.TextToSpeech
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | control /name Microsoft.iSCSIInitiator
Свойства: Интернет | Internet Properties | control /name Microsoft.InternetOptions
Свойства: Клавиатура | Keyboard Properties | control /name Microsoft.Keyboard
Свойства: Мышь | Mouse Properties | control /name Microsoft.Mouse
Система | System | control /name Microsoft.System
Сканеры и камеры | Scanners and Cameras | control /name Microsoft.ScannersAndCameras
Соседние пользователи | People Near Me | control /name Microsoft.PeopleNearMe
Счетчики и средства производительности | Performance Information and Tools | control /name Microsoft.PerformanceInformationAndTools
Телефон и модем | Phone and Modem | control /name Microsoft.PhoneAndModem
Управление цветом | Color Management | control /name Microsoft.ColorManagement
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control /name Microsoft.DevicesAndPrinters
Учетные записи пользователей | User Accounts | control /name Microsoft.UserAccounts
Центр мобильности Windows | Windows Mobility Center | control /name Microsoft.MobilityCenter
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | control /name Microsoft.ActionCenter
Центр синхронизации | Sync Center | control /name Microsoft.SyncCenter
Центр специальных возможностей | Ease of Access Center | control /name Microsoft.EaseOfAccessCenter
Центр управления сетями и общим доступом | Network and Sharing Center | control /name Microsoft.NetworkAndSharingCenter
Шифрование диска BitLocker | BitLocker Drive Encryption | control /name Microsoft.BitLockerDriveEncryption
Экран (размер текста) | Display (size of text) | control /name Microsoft.Display
Электропитание | Power Options | control /name Microsoft.PowerOptions
Язык и региональные стандарты | Region and Language | control /name Microsoft.RegionAndLanguage

При отсутствии в системе необходимого устройства, драйверов или определенных компонентов, соответствующий ему элемент Панели управления может не запуститься.


1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Hужно установить пароль на учетную запись администратора и работать из под нее.

Назад на страницу раздела Настройки.


2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

Назад на страницу раздела Настройки.


3. Как изменить параметры загрузки, где в Windows 7 файл boot.ini?

Начиная с Windows Vista такого файла больше нет, но Вы можете изменить необходимые Вам для загрузки параметры используя инструмент Конфигурация системы. Окно Конфигурация системы запускается так: Панель управления -> Администрирование -> Конфигурация системы -> Загрузка (или нажав Win+R -> msconfig -> Ok)

Данный инструмент позволяет:
- получить информацию о текущей и загружаемой по умолчанию системах;
- выбрать систему, загружаемую по умолчанию;
- удалить ненужную запись из меню загрузки.
- отредактировать время в секундах (таймаут), по истечении которого будет загружена операционная система, выбранная по умолчанию.
- включить\выключить экран приветствия(Без GUI);
- включить\выключить загрузку стандартных драйверов VGA, вместо драйверов экрана, соответствующих видеооборудованию компьютера(Базовое видео).

А через Дополнительные параметры:

- Число процессоров, используемых при загрузке.
- Максимальный объем памяти в мегабайтах, используемый для моделирования конфигурации с малым объемом памяти.

При помощи окна Конфигурация системы нельзя изменить(но это возможно, при помощи программы Bcdedit):

- наимнование существующих записей;
- положение записи в меню загрузки.

Для выбора системы, загружаемой по умолчанию, выберите необходимую Вам операционную систему и нажмите кнопку «Использовать по умолчанию».
Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».
Для редактирование таймаута, в нужном поле установите желаемое количество секунд.

Для применения, сделанных Вами изменений - перезагрузите компьютер.

Назад на страницу раздела Настройки.


4. Увеличение скорости загрузки ОС для многоядерных процессоров.

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить(или Win+R)
2) Введите msconfig и нажмите OK
3) Перейдите на вкладку Загрузка
4) Нажмите Дополнительные параметры
5) Поставьте флажок напротив значения Число процессоров
6) Выберите в активировавшемся ниспадающем меню число ядер Вашего процессора (По умолчанию 1)
Установка меньшего значения, чем количество ядер Вашего процессора не рекомендуется, так как система может продолжить использование указанного Вами числа ядер и после завершения загрузки.
7) Нажмите OK и перезагрузите компьютер

Также рекомендую включить(установить в значение Enabled) в BIOS (Вызывается нажатием клавиши Delete, сразу после начала загрузки компьютера) функцию ACPI APIC Support. Данная функция находится во вкладке Power.

Назад на страницу раздела Настройки.


5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны. К примеру, чтобы изменить временную зону на время по Гринвичу, нужно использовать следующую команду:
tzutil /s “gmt standard time”
» “tzutil /g” покажет текущие установки временной зоны;
» “tzutil /l” выводит список всех возможных временных зон;
» “tzutil /?” выводит справку по работе утилиты.

Назад на страницу раздела Настройки.


6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавишы Ctrl+Alt+, выбор третьей клавишы за вами, как вам удобнее. Например, Ctrl+Alt+S.

Назад на страницу раздела Настройки.


7. Отключение(включение) неиспользуемых компонентов Windows.

В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

Назад на страницу раздела Настройки.


8. Как отменить (изменить) ассоциирование типов файлов с определенными программами?

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Искать в реестре в ветке [HKEY_CLASSES_ROOT]
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

Назад на страницу раздела Настройки.


9. Как отключить всплывающие подсказки?

Отключить всплывающие подсказки можно используя редактор групповой политики.
Нажмите Пуск, в поле Начать поиск напишите gpedit.msc и нажмите ОК.
Перейдите в раздел Конфигурация пользователя - Административные шаблоны - Меню Пуск и Панель задач.
Откройте параметр "Удалить всплывающие подсказки для элементов главного меню", выберите пункт Включен и нажмите ОК

Назад на страницу раздела Настройки.


10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии «Завершение работы». Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние «Перезагрузка». Для этого выполняем правый клик по кнопке Пуск, выбираем пункт меню Свойства и переключаем “Действие кнопки питания” в состояние “Перезагрузка”. Также вы можете выбрать функции “Блокировка”, “Смена пользователя” и “Завершение сеанса”.

Назад на страницу раздела Настройки.


11. Как быстро перейти к часто используемой папке?

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

Назад на страницу раздела Настройки.


12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

bcdedit - инструмент, позволяющий изменить значения загрузчика Windows, а также произвести его(загрузчика) восстановление. Чтобы увидеть предлагаемые системой для изменения параметры: запустите командную строку от имени администратора (Win+R -> cmd -> Ok), наберите в ней bcdedit и нажмите Enter. Все команды, приведенные в данном варианте, необходимо будет запускать в командной строке, запущенной от имени администратора (Win+R -> cmd -> Ok) Также данные команды могут выполняются в командной строке среды восстановления или в командной строке ERD Commander.

Некоторые значения параметров BCD записаны в фигурных скобках – {}. Это идентификаторы – {CLSID}. Любой идентификатор имеет буквенно-цифровой код вида {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. Стандартные идентификаторы имеют названия, например: {default}, {bootmgr}, {ntldr} и так далее.

Наиболее интересующими нас компонентами являются:

идентификатор – CLSID той или иной записи;
device – показывает раздел, на котором расположены файлы загрузки (это может быть операционная система или папка BOOT);
osdevice – показывает раздел, на котором расположены системные файлы операционной системы. Обычно, значения параметров device и osdevice равны;
path – если device определял раздел диска, который содержит файлы операционной системы, то этот параметр определяет остальной путь к загрузчику операционной системы;
default – показывает ID операционной системы, загружаемой по умолчанию, если операционная система, в которой запустили командную строку, загружается по умолчанию, параметру default присваивается значение {current};
displayorder – показывает порядок, в котором расположены записи о загружаемых системах;
timeout – таймаут(время - по истечении которого будет загружена операционная система), значение показано и устанавливается в секундах;
locale – указывает язык загрузочного меню или меню дополнительных параметров загрузки;
description – показывает название операционной системы, отображающееся в меню загрузки.

Внимание: Если в выполняемой Вами команде, с использованием программы bcdedit.exe, отсутствует параметр /set с дальнейшим указанием идентификатора, то внесенные Вами изменения будут добавлены в Диспетчер загрузки Windows (Windows Boot Manager), а не в Загрузка Windows (Windows Boot Loader)

Перед тем, как начнете вносить необходимые Вам изменения, создайте резервную копию загрузчика. Для этого, создайте на любом диске папку с названием BCDREZ и выполните следующую команду:
bcdedit /export X:\BCDREZ\bcd
где X - буква диска, на котором находится папка BCDREZ.

Если Вы решите вернуть все сделанные Вами изменения к начальным настройкам, то выполните следующую команду:
bcdedit /import X:\BCDREZ\bcd
Для дальнейших примеров, предположим, что наше меню загрузки содержит три записи с идентификаторами {ID1}, {ID2}, {ID3}.

Изменение системы, загружаемой по умолчанию

Введите параметр /default и {ID} той системы, которую Вы хотите загружать по умолчанию. Например, для системы с {ID2} команда:
bcdedit /default {ID2}
Данная команда не перемещает запись о системе, загружаемой по умолчанию, на верхнюю строчку меню загрузки.

Изменение расположения записей в меню загрузки

1) Перемещение выбранной записи вверх списка:
bcdedit /displayorder {ID} /addfirst
2) Перемещение выбранной записи вниз списка:
bcdedit /displayorder {ID} /addlast
3) Формирование меню в выбранном порядке:
bcdedit /displayorder {ID3} {ID1} {ID2}
Изменение таймаута
bcdedit /timeout XX
где XX – время в секундах.

Изменение языка диспетчера загрузки
bcdedit /set {bootmgr} locale ln-LN
где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение языка меню дополнительных вариантов загрузки

В связи с тем, что программа восстановления запуска, выполняющаяся из среды восстановления, использует параметры "по-умолчанию", меню дополнительных вариантов загрузки, которое появляется при нажатии F8 после наведения на строку меню с нужной операционной системой, может стать англоязычным. Вернуть необходимый Вам язык, можно выполнив следующую команду:
bcdboot %Windir% /l ln-LN
где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение названия загружаемой системы

После использования среды восстановления, в названии операционной системы появляется надпись - (восстановлено). Вы также можете исправить значение "Предыдущая версия Windows" на более удобное Вам "Windows XP" или добавить версию и разрядность к текущей(используемой по умолчанию) версии Windows. Вы можете изменить это указанной ниже командой:
bcdedit /set {ID} description "Новое название"
Например:
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"
Изменение буквы раздела, на котором расположена папка операционной системы и ее загрузочные файлы
bcdedit /set {ID} device partition=X:
bcdedit /set {ID} osdevice partition=X:
где X – буква раздела жесткого диска. Обычно значения device и osdevice совпадают.

Добавление новой операционной системы (Windows Vista или Windows 7) в загрузчик.

1) Скопируйте существующую запись текущей системы с новым названием:
bcdedit /copy {current} /d "Microsoft Windows Vista"
2) Дождитесь сообщение «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
3) Измените значения параметров device и osdevice на соответствующие добавляемой операционной системе.
bcdedit /set {хххххххх-хххх-хххх-хххх-хххххххххххх} device partition=X:
bcdedit /set {хххххххх-хххх-хххх-хххх-хххххххххххх} osdevice partition=X:
где X – буква диска, на котором находится операционная система. Вместо крестиков, введите значение {ID}, полученное после успешного окончания копирования.
4) Выполните команду, добавляющую новую запись в диспетчер загрузки:
bcdedit /displayorder {хххххххх-хххх-хххх-хххх-хххххххххххх} /addlast
Запись будет добавлена внизу существующего списка.

Удаление записи загрузки системы из BCD и диспетчера загрузки.

Удаление записи об установленной операционной системе из BCD и диспетчера загрузки выполняется с помощью команды bcdedit /delete {ID}. Есть особенность выполнения команды: если в качестве ID указывается известная запись, например {ntldr}, то команда должна выполняться с ключом /f:
bcdedit /delete {ntldr} /f
Если же ID записывается в буквенно-цифровом коде, ключ /f не нужен.

В случае отсутствия одного из файлов, необходимых для работы с загрузчиком, Вы можете скачать архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe из Windows 7 Ultimate x86/x64)

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Назад на страницу раздела Настройки.


13. Установка пользовательского разрешения экрана.

У некоторых мониторов разрешение экрана может не соответствовать ни одному из предлагаемых Windows.

Если у Вас установлена видеокарта Nvidia Вы можете добавить своё разрешение экрана одним из указанных способов:

Способ 1.

1) Запустить Панель управления Nvidia.
2) Открыть Дисплей -> Изменение разрешения -> Добавить разрешения... -> Создать пользовательское разрешение
3) Задать нужные Вам параметры, протестировать их и добавить его в список для выбора
4) Выбрать его и использовать.

Способ 2.

Используя реестр добавить нужное Вам разрешение в параметр NV_Modes

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{some number}\0000

Также можете найти другие ветки содержащие параметр NV_Modes и также добавить в них необходимое Вам разрешение экрана.

Способ 3. Перед установкой драйвера.

Откройте файл "nv_disp.inf" в папке C:\NVIDIA\Win7\xxx.xx и найдите значение [nv_commonDisplayModes_addreg]
Под ним в NV_Modes будут все доступные разрешения экрана, добавьте туда свое.

Но бывает что даже после указанных выше манипуляций, новое разрешение не хочет добавляться. В таком случае, для принудительного добавления пользовательского разрешения Вам придется использовать специальные программы. Рекомендую поискать в интернете следующие программы:

PowerStrip - Программа управления параметрами видеоподсистемы вашего компьютера, поддерживается огромное разнообразие видео карт. Это - фактически единственная программа своего рода, которая поддерживает видео карты из многочисленного набора чипсетов и поставщиков,одновременно, под любой операционной системой. Программа спокойно сидит в трее и оттуда обеспечивает доступ к более 500 элементов управления над вашими дисплейными аппаратными средствами, включая цветные инструментальные средства коррекции, установки уровня периода экранной геометрии, и драйверо-независимыми элементами управления часов.

Screen Resolution Manager - Программа, позволяющая каждому пользователю компьютера устанавливать свое разрешение экрана. Помимо разрешения можно настроить глубину цвета, частоту, яркость и контрастность, цветовую гамму и другие настройки, которые автоматически вступят в силу после загрузки профиля определенного пользователя.

Назад на страницу раздела Настройки.


14. Создание диска восстановления системы и загрузка с него.

Если у вас есть установочный диск Windows 7, создавать диск восстановления необязательно. Если же установочного диска у вас нет, создать диск восстановления нужно обязательно - он вам рано или поздно пригодится. С установочного диска можно загрузиться в среду восстановления Windows RE. Создание диска восстановления системы 1) Вставьте чистый компакт-диск в привод. 2) Откройте Пуск -> Панель Управления -> Архивация и восстановление (Backup and Restore) 3) В левой панели щелкните ссылку Создать диск восстановления системы. Загрузка с диска восстановления системы 1) Вставьте диск восстановления в привод и перезагрузитесь 2) В BIOS должен быть установлен приоритет загрузки с привода. Будет выполнена загрузка в Windows RE. 3) Выберите систему, которую вы хотите восстановить. 4) Установите переключатель Используйте средства восстановления... и нажмите кнопку Далее. Вы увидите окно с вариантами восстановления.

Назад на страницу раздела Настройки.


15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

1) Запустите cmd.exe от имени администратора(Win+R -> cmd -> Ok)
2) Выполните следующие команды, нажимая после введения каждой Enter
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"

Назад на страницу раздела Настройки.


16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

Вы решили заменить или продать один из ваших жестких дисков. Прежде чем это сделать, убедитесь что файлы загрузки Windows 7 не содержаться на удаляемом Вами из системы жестком диске.
Windows 7 хранит свои файлы для загрузки на активном диске, который может отличаться от того на котором установлена Windows 7. Файлами загрузки для Windows 7 являются файл bootmgr и хранилище данных конфигурации загрузки BCD (Boot Configuration Data), находящееся в скрытой и системной папке Boot.

При загрузке Windows 7 проверяет соблюдение 3 условий:

- Является ли диск, с которого выполняется загрузка активным;
- Совместима ли Главная Загрузочная Запись (Master Boot Record - MBR) с bootmgr (Диспетчером загрузки Windows);
- Находиться ли файлы загрузки операционной системы на активном диске должны.

В случае не соблюдения одного из условий, загрузка становится невозможной.

Предположим, что Ваша Windows 7 установлена на диск С:, который не активен. Активным является только диск D:, который Вы собираетесь удалить из системы и на котором находятся Файлы загрузки Windows 7, имеющие атрибуты Скрытый и Системный.

В качестве решения предлагаю Вам выполнить перенесение файлов загрузки Windows 7 с активного раздела (удаляемый жесткий диск) на неактивный раздел (остающийся в системе жесткий диск, с присвоением ему атрибута - Активный).

1) Выяснение атрибутов дисков и присвоение остающемуся в системе жесткому диску атрибута Активный.

Способ 1. Используя оснастку "Управление дисками".

1.1.1) Нажмите Win + R, в строке "Выполнить" наберите diskmgmt.msc и нажмите OK
1.1.2) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7 Буква тома здесь, идентична букве диска с Window 7 из Мой Компьютер.
1.1.3) Под буквой тома, размером диска и файловой системой будут указаны атрибуты диска. Посмотрите имеет ли наш том атрибут "Активный". Если да, то Вы сможете спокойно удалить Ваш диск из системы. Если же нет, то Вам необходимо будет присвоить данный атрибут, в соответствии с написанным ниже.
1.1.4) Если Ваша Windows 7 установлена на жесткий диск, разбитый на несколько разделов, то выберите первый слева раздел остающегося у Вас диска, его мы сделаем загрузочным и активным. Если же раздел всего один, то выберите его.
1.1.5) Щелкните правой кнопкой мыши по выбранному разделу и выберите в контекстном меню пункт "Сделать раздел активным". Учтите, что этот раздел должен иметь атрибут "Основной".

Способ 2. Используя командную строку.

1.2.1) Запустите командную строку с правами администратора. Нажмите Win + R, в строке "Выполнить" наберите cmd и нажмите OK.
1.2.2) Последовательно выполните все команды без выхода из командной строки:
DISKPART
list disk
sel disk X
list partition
sel part 1
active
exit
где X - номер диска, который предполагается оставить, в списке дисков (команда list disk).

2) Перезапись загрузочного сектора MBR и установка его совместимости с bootmgr:

2.1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2.2) Создайте папку Boot
2.3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
2.4) Запустите командную строку с правами администратора.
X:\boot\bootsect.exe /nt60 all /force
где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /force - принудительно отключает один или несколько томов во время обновления загрузочного кода. Необходим, при наличии в конфигурации 2-х и более жестких дисков.

3) Перенесение BCD (Boot Configuration Data) и файла bootmgr на новый активный раздел:
X:\boot\bcdboot.exe %Windir% /l ru-RU /s С:
где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /l - выбор языковых параметров менеджера загрузки. Если ваша система не русскоязычная, используйте другие значения этого ключа, например, для английского языка - en-US, для немецкого - de-DE, и т.д.
- ключ /s - определяет букву тома, назначенную целевому системному разделу, в который копируются файлы среды загрузки. Это раздел, который мы сделали активным. Windows 7 использует текущий загрузочный раздел (в нашем случае - раздел D:) до завершения своей работы. Поэтому применение этого ключа с указанием буквы нового загрузочного раздела (в нашем случае - раздел С:) - обязательно.

Назад на страницу раздела Настройки.


17. Способы доступа к элементам Панели управления.

В разных статьях Вы можете увидеть разное описание пути к одинаковым элементам Панели управления. Такое происходит потому что в Windows существует два вида отображения элементов: Категория(элементы сгруппированы по тематикам) и Крупные или Мелкие значки (элементы отображаются полным списком) Имхо, наиболее удобным является Крупные или Мелкие значки(их полный список).

Существует несколько способов доступа к элементам Панели управления:

1) Через меню Пуск.

Для быстрого доступа к элементам Панели управления, рекомендуется добавить в меню Пуск всплывающее меню содержащее все элементы Панели Управления.
1.1) Нажмите правой кнопкой мыши на кнопке Пуск и щелкните на пункте Свойства.
1.2) Нажмите Настроить...
1.3) Промотайте до записи Панель управления.
1.4) Установите значение переключателя под ней в положение Отображать как меню и нажмите OK
Всплывающее меню Панели управления будет отображаться полным списком, независимо от Вашего выбора вида отображения.

2) Через Проводник Windows.

2.1) Запустите Проводник
2.2) В панели меню выберите Сервис и нажмите Параметры папок
2.3) Под надписью Область переходов установите флажок напротив значения Показать все папки и нажмите OK
Теперь Панель управления будет доступна в Проводнике в Области переходов слева. Преимущество данного способа в том что Вы можете работать, как сразу с полным списком элементов: Проводник -> Панель управления -> Все элементы панели управления, так и с отдельными разделами: Проводник -> Панель управления -> Нужный Вам раздел.

3) На рабочем столе.

3.1) Щелкните правой кнопкой мыши на Рабочем столе и нажмите Персонализация
3.2) Щелкните Изменение значков рабочего стола
3.3) Установите флажок напротив Панель управления и нажмите ОК
На Рабочем столе появится ярлык запускающий папку Панель управления. Способ отображения зависит от выбранного Вами значения параметра Просмотр.

4) Добавление или запуск папки Панель управления используя {GUID}

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

Control Panel.{26EE0668-A00A-44D7-9371-BEB064C98683}

Для её запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}

5) Запуск элементов Панели управления, используя канонические имена.

Русское название элемента | Английское название элемента | Команда
Панель управления | Control Panel | control
Windows CardSpace | Windows CardSpace | control /name Microsoft.CardSpace
Windows SideShow | Windows SideShow | control /name Microsoft.WindowsSideShow
Автозапуск | AutoPlay | control /name Microsoft.AutoPlay
Автономные файлы | Offline Files | control /name Microsoft.OfflineFiles
Администрирование | Administrative Tools | control /name Microsoft.AdministrativeTools
Архивация и восстановление | Backup and Restore | control /name Microsoft.BackupAndRestore
Биометрические устройства | Biometric Devices | control /name Microsoft.BiometricDevices
Брандмауэр Windows | Windows Firewall | control /name Microsoft.WindowsFirewall
Восстановление | Recovery | control /name Microsoft.Recovery
Гаджеты рабочего стола | Desktop Gadgets | control /name Microsoft.DesktopGadgets
Дата и Время | Date and Time | control /name Microsoft.DateAndTime
Датчик расположения и другие датчики | Location and Other Sensors | control /name Microsoft.LocationAndOtherSensors
Диспетчер устройств | Device Manager | control /name Microsoft.DeviceManager
Диспетчер учетных данных | Credential Manager | control /name Microsoft.CredentialManager
Домашняя группа | HomeGroup | control /name Microsoft.HomeGroup
Защитник Windows | Windows Defender | control /name Microsoft.WindowsDefender
Звук | Sound | control /name Microsoft.Sound
Значки области уведомлений | Notification Area Icons | control /name Microsoft.NotificationAreaIcons
Игровые устройства | Game Controllers | control /name Microsoft.GameControllers
Инфракрасная связь | Infrared | control /name Microsoft.Infrared
Папка "Fonts" | Fonts Folder | control /name Microsoft.Fonts
Параметры индексирования | Indexing Options | control /name Microsoft.IndexingOptions
Параметры папок | Folder Options | control /name Microsoft.FolderOptions
Параметры планшетного компьютера | Tablet PC Settings | control /name Microsoft.TabletPCSettings
Перо и сенсорные устройства | Pen and Touch | control /name Microsoft.PenAndTouch
Персонализация | Personalization | control /name Microsoft.Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | control /name Microsoft.RemoteAppAndDesktopConnections
Получение программ | Get Programs | control /name Microsoft.GetPrograms
Приступая к работе | Getting Started | control /name Microsoft.GettingStarted
Программы и компоненты | Programms and Features | control /name Microsoft.ProgramsAndFeatures
Программы по умолчанию | Default Programs | control /name Microsoft.DefaultPrograms
Распознавание речи | Speech Recognition | control /name Microsoft.SpeechRecognition
Расположение по умолчанию | Default Location | control /name Microsoft.DefaultLocation
Родительский контроль | Parental Controls | control /name Microsoft.ParentalControls
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | control /name Microsoft.TaskbarAndStartMenu
Свойства речи | Text to Speech | control /name Microsoft.TextToSpeech
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | control /name Microsoft.iSCSIInitiator
Свойства: Интернет | Internet Properties | control /name Microsoft.InternetOptions
Свойства: Клавиатура | Keyboard Properties | control /name Microsoft.Keyboard
Свойства: Мышь | Mouse Properties | control /name Microsoft.Mouse
Система | System | control /name Microsoft.System
Сканеры и камеры | Scanners and Cameras | control /name Microsoft.ScannersAndCameras
Соседние пользователи | People Near Me | control /name Microsoft.PeopleNearMe
Счетчики и средства производительности | Performance Information and Tools | control /name Microsoft.PerformanceInformationAndTools
Телефон и модем | Phone and Modem | control /name Microsoft.PhoneAndModem
Управление цветом | Color Management | control /name Microsoft.ColorManagement
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control /name Microsoft.DevicesAndPrinters
Учетные записи пользователей | User Accounts | control /name Microsoft.UserAccounts
Центр мобильности Windows | Windows Mobility Center | control /name Microsoft.MobilityCenter
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | control /name Microsoft.ActionCenter
Центр синхронизации | Sync Center | control /name Microsoft.SyncCenter
Центр специальных возможностей | Ease of Access Center | control /name Microsoft.EaseOfAccessCenter
Центр управления сетями и общим доступом | Network and Sharing Center | control /name Microsoft.NetworkAndSharingCenter
Шифрование диска BitLocker | BitLocker Drive Encryption | control /name Microsoft.BitLockerDriveEncryption
Экран (размер текста) | Display (size of text) | control /name Microsoft.Display
Электропитание | Power Options | control /name Microsoft.PowerOptions
Язык и региональные стандарты | Region and Language | control /name Microsoft.RegionAndLanguage

При отсутствии в системе необходимого устройства, драйверов или определенных компонентов, соответствующий ему элемент Панели управления может не запуститься.

Назад на страницу раздела Настройки.


Администрирование

1. Активировал учетную запись администратора, но некоторые папки\файлы все равно не удаляются.

Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду
net user Администратор /active:yes
В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:
net user Administrator /active:yes
Команду необходимо выполнять в командной строке с повышенными правами пользователя. Для этого нажмите кнопку Пуск, выберите пункт Стандартные, щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора.

2. Как разрешить запуск "Диспетчера задач"?

Запустите редактор системных политик: Пуск > Выполнить > gpedit.msc.
Слева в дереве политик выберите Конфигурация пользователя > Административные шаблоны > Система > Возможности Ctrl+Alt+Del.
В правом окне двойным щелчком откройте свойства политики Удалить диспетчер задач, выберите Отключен и нажмите ОК.
Изменения вступят в действие после перезагрузки.

3. Как добавить свою иконку в список рисунков учетных записей?

По умолчанию рисунки учетных записей располагаются в следующей папке:
C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

4. Автоматический вход в систему и отключение экрана пользователей при запуске.

Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

1. Нажмите на клавиатуре Win+R (или пункт Выполнить в меню Пуск).
2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Enter.
3. В окне Учетные записи пользователей во вкладке Пользователи выделите свою учетную запись и уберите флажок с “Требовать ввод имени пользователя и пароля”.
4. Нажмите Принять.
5. В открывшемся окне Автоматический вход в систему будут три поля - Пользователь, Пароль и Подтверждение. Введите свой пароль в поле Пароль и еще раз - в поле Подтверждение и нажмите ОК.

Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
(Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

5. Как ограничить пользователей в наборе программ, которые они могут запускать?

Контроль за приложениями сводится к настройке правил. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные определенным издателем (например, Microsoft). Запустите GPEDIT.MSC и перейдите к функции AppLocker() через Computer Configuration > Windows Settings > Security Settings > Application Control Policies или Конфигурация компьютера > Конфигурация Windows > Параметры безопасности > Политики управления приложениями, чтобы посмотреть, как это работает.

6. Как быстро запустить программу с правами администратора?

Удерживайте Ctrl+Shift и нажмите на иконку приложения (у вашей учетной записи, конечно, должны быть соответствующие права).

7. Как убрать значки запрета доступа на папках?

Для этого надо в свойствах назначения прав папкам и файлам, добавить пользователя Администратор, и дать ему все разрешения, после чего значек с папки или файла будет убран.

8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
2) Нажимаете "Создать задачу"
3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
5) Указываете путь к нужному приложению и нажимаете "Открыть"
6) Нажимаете "ОК", затем снова "ОК"
7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
8) В поле Расположение объекта введите:
schtasks /run /tn mytask_admin
где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
9) Введите имя ярлыка и нажмите Готово

Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

Скачать можно здесь или здесь

9. Перемещение профилей пользователей и изменение путей к ним.

Указанные в с 1 по 4 вариантах действия, необходимо повторять для каждого профиля. Переместив таким образом все профили, и изменив их пути в реестре, исходные папки можно будет удалить.

Вариант 1. С помощью компонента Windows - "Профили пользователей".

Копируем профиль пользователя в конечное размещение:

1) Если папка для профиля существует, переходим к следующему шагу, при этом используя рекомендации; если папка, в которой будет храниться профиль, не существует, создаем ее, используя рекомендации.

Рекомендации:

  • Если на компьютере только одна учетная запись, можно присвоить папке профиля имя учетной записи; если учетных записей несколько, лучше всего создать папку верхнего уровня, например, с именем Пользователи, а в нее вложить папки с именами пользователей компьютера, в которых и будут храниться наши профили. Хотя использовать папку верхнего уровня лучше сразу, на случай добавления новых учетных записей;
  • Если конечная папка уже существует и она имеет содержимое, которое необходимо сохранить, ее необходимо скопировать в другое размещение, а затем, после завершения перемещения профилей, переместить это содержимое в папку с профилем пользователя

    • 2) Открываем Свойства системы: команда свойства контекстного меню Моего компьютера или сочетание Windows + Break.
    3) Щелкаем Дополнительные параметры системы. Щелкаем Продолжить, если появится соответствующий запрос системы контроля учетных записей.
    4) Открываем вкладку Дополнительно.
    5) Щелкаем кнопку Параметры в рамке Профили пользователей.
    6) Выбираем профиль, который необходимо переместить. Активный профиль не выбирается. Чтобы его можно было выбрать для осуществления необходимых действий, нужно войти под другой учетной записью и иметь права администратора.
    7) Нажимаем кнопку Копировать.
    8) Выбираем папку, в которой будет находиться профиль, созданную на шаге 1.
    9) Нажимаем OK; если выбранная папка не пустая, система выдаст запрос на копирование профиля в нее, так как при этом удаляется все ее содержимое! (не забудьте о рекомендациях!). Нажимаем Да.

    Вносим изменения в системный реестр.

    1) Открываем меню Выполнить: Пуск -> Выполнить (либо Win+R)
    2) Вводим regedit.exe, нажимаем Enter.
    3) Изменяем значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя.
    Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    4) Перезагружаем компьютер.

    Внесение изменений в системный реестр может привести к снижению стабильности и производительности системы или ее отказу, поэтому настоятельно рекомендуется создать резервную копию реестра перед выполнением данной операции. В данном случае удобно воспользоваться экспортом изменяемого ключа или Восстановлением системы.

    Вариант 2. На другой диск вручную.

    1) Запустите оснастку "Локальные пользователи и группы" (Win+R -> lusrmgr.msc -> Ok)
    2) Включите системную запись администратора. Выбираете "Пользователи". В свойствах пользователя "Администратор" снимаете галку "Отключить пользователя". Если же Вы уже работаете в учетной записи Администратор, то создайте новую учетную запись с правами администратора.
    3) Для полного доступа к файлам и папкам перезапустите компьютер, и зайдите под аккаунтом "Администратор" (или под созданным Вами с правами администратора).

    Указанные выше действия необходимы, потому что профиль под которым Вы зайдете, для осуществления необходимых действий не выбирается. Соответственно залогинившись под одним профилем, Вы можете работать только с другими.

    4) Запустите "Проводник" в режиме администратора:
    Щелкните правой кнопкой мыши на иконке Проводника
    Щелкните правой кнопкой мыши на слове Проводник
    Выберите пункт "Запуск от имени администратора"
    5) Создайте на диске D: папку Users.
    6) Поменяйте права на "D:\Users", исходя из прав на системный Users.
    Оставьте только "Чтение и выполнение" для группы "Everyone"(Все), и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно)
    Владелец папки, установите на "Administrators" (Администраторы).
    7) В Проводнике запущеном от имени Администратора скопируйте необходимую Вам папку пользователя в "D:\Users".

    Так как Проводник не умеет копировать "junction" (точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог), то их придется создавать самостоятельно. Например, "junction" являются папки "Application Data", "Local Settings", "SendTo" и другие.

    8) Запустите командную строку от имени администратора (Win+R -> CMD -> Ok)
    9) Для показа только скрытых файлов введите команду "dir /ah" (без кавычек) и нажмите Enter. Вы увидете примерно следующее:
    C:\Users\ВашПрофиль>dir /ah
Том в устройстве C не имеет метки.
Серийный номер тома: F018-696C

Содержимое папки C:\Users\ВашПрофиль

23.11.2009  20:05    <DIR>          AppData
23.11.2009  20:05    <JUNCTION>     Application Data [C:\Users\ВашПрофиль\AppData\Roaming]
23.11.2009  20:05    <JUNCTION>     Cookies [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Cookies]
23.11.2009  20:05    <JUNCTION>     Local Settings [C:\Users\ВашПрофиль\AppData\Local]
23.11.2009  20:05    <JUNCTION>     My Documents [C:\Users\ВашПрофиль\Documents]
23.11.2009  20:05    <JUNCTION>     NetHood [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Network Shortcuts]
21.01.2010  05:09         4 718 592 NTUSER.DAT
21.01.2010  05:09           262 144 ntuser.dat.LOG1
23.11.2009  20:05                 0 ntuser.dat.LOG2
23.11.2009  20:14            65 536 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TM.blf
23.11.2009  20:14           524 288 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TMContainer00000000000000000001.regtrans-ms
23.11.2009  20:14           524 288 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TMContainer00000000000000000002.regtrans-ms
24.11.2009  00:19            65 536 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TM.blf
24.11.2009  00:19           524 288 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TMContainer00000000000000000001.regtrans-ms
24.11.2009  00:19           524 288 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TMContainer00000000000000000002.regtrans-ms
23.11.2009  20:05                20 ntuser.ini
23.11.2009  20:05    <JUNCTION>     PrintHood [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Printer Shortcuts]
23.11.2009  20:05    <JUNCTION>     Recent [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Recent]
23.11.2009  20:05    <JUNCTION>     SendTo [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\SendTo]
23.11.2009  20:05    <JUNCTION>     Start Menu [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Start Menu]
23.11.2009  20:05    <JUNCTION>     Templates [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Templates]
              10 файлов      7 208 980 байт
              11 папок  22 173 192 192 байт свободно
    10) Создайте аналогичные "Junction" каталоги:

    Способ 1. Вручную для каждого "Junction" каталога.

    1) В командной строке переходите в созданную Вами папку:
    C:\Users\Administrator>d:
D:\>cd Users\ВашПрофиль
    2) И для каждой "Junction" выполняете команду:
    mklink /J <Link> <Target>
    Например: mklink /J "Application Data" "AppData\Roaming"

    Способ 2. Создание bat-файла.

    Если Вам предстоит перенести несколько профилей, то проще будет создать bat-файл, так как "Junction" у Вас скорее всего будут такие же.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "profiles.bat")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    В моем случае получился такой, Вы можете создать аналогичный для своих папок (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):
    mklink /J "Application Data" "AppData\Roaming"
mklink /J "Cookies" "AppData\Roaming\Microsoft\Windows\Cookies"
mklink /J "Local Settings" "AppData\Local"
mklink /J "My Documents" "Documents"
mklink /J "NetHood" "AppData\Roaming\Microsoft\Windows\Network Shortcuts"
mklink /J "PrintHood" "AppData\Roaming\Microsoft\Windows\Printer Shortcuts"
mklink /J "Recent" "AppData\Roaming\Microsoft\Windows\Recent"
mklink /J "SendTo" "AppData\Roaming\Microsoft\Windows\SendTo"
mklink /J "Start Menu" "AppData\Roaming\Microsoft\Windows\Start Menu"
mklink /J "Templates" "AppData\Roaming\Microsoft\Windows\Templates"
    Если у Вас папки имеют русские названия, то для правильной работы данного bat-файла, надо его сохранять в кодировке CP866 (Блокнот Windows, в ней не сохраняет, используйте для этого программы сторонних производителей например: Akelpad).
    11) Присвойте "Junction" каталогам скрытые и системные аттрибуты, как в оригинале.

    Либо, вручную для каждого в командной строке.
    attrib /S /D /L +H +S "имя папки"
    Например: attrib /S /D /L +H +S "Application Data"

    Либо, создав bat-файл (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):
    attrib /S /D /L +H +S "Application Data"
attrib /S /D /L +H +S "Cookies"
attrib /S /D /L +H +S "Local Settings"
attrib /S /D /L +H +S "My Documents"
attrib /S /D /L +H +S "NetHood"
attrib /S /D /L +H +S "PrintHood"
attrib /S /D /L +H +S "Recent"
attrib /S /D /L +H +S "SendTo"
attrib /S /D /L +H +S "Start Menu"
attrib /S /D /L +H +S "Templates"
    12) Запустите Реестр Windows(Win+R -> regedit -> Enter) и измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID c "C:\Users\ВашПрофиль" на "D:\Users\ВашПрофиль" , где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя. Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    13) Переименуйте или удалите каталог профиля в "C:\Users\", чтобы предотвратить к нему запросы.
    14) Перезагрузите компьютер, чтобы Windows подхватила внесенные нами настройки.
    15) Вновь зайдите под аккаунтом Администратор.
    16) Запустите Реестр Windows(Win+R -> regedit -> Enter)
    17) Используя Поиск найдите все строки с путем к папке "C:\Users\ВашПрофиль" и исправьте на "D:\Users\ВашПрофиль" (Чем ближе к чистой установке Вы это сделаете, тем меньше строк Вам придется исправлять).
    18) Поменяйте права на каталог профиля в "D:\Users".
    Установите "Полный доступ" пользователелю - владельцу профиля, и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно).
    Владелец папки, установите на "System".
    19) Перезагрузите компьютер, теперь вы можете войти в перемещенный аккаунт и проделать всё указанное выше для другого профиля.

    Вариант 3. При помощи ERD Commander.

    1) Скачиваете утилиту Junction от SysInternals. Она позволяет создавать точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог.
    2) Копируете junction.exe в C:\Windows\System32
    3) Загружаетесь в Erd Commander.
    4) Выбираете опцию, чтобы реестр не импортировася
    5) Копируете например: "C:\Documents and Settings\ВашПрофиль" в "D:\Users\ВашПрофиль"
    6) После копирования, удаляете "C:\Documents and Settings\ВашПрофиль"
    7) Запускаете командную строку и переходите в папку C:\Windows\System32
    c:\
cd\windows
cd system32
junction.exe "C:\Documents and Settings\ВашПрофиль" "D:\Users\ВашПрофиль"
    8) После сообщения Sucsess, можете зайти в папку проверяем C:\Documents and Settings\ и увидите там папку ВашПрофиль, только это уже ссылка...

    Вариант 4. При помощи Far Manager.

    1) Скачиваете Far Manager и устанавливаете его.
    2) Входите в систему под другим пользователем с правами администратора
    3) Запускаете Far Manager
    4) Находите нужный профиль пользователя.
    5) Перемещаете папку с ним на другой диск (например, C:\Documents and Settings\ВашПрофиль -> D:\Users\ВашПрофиль).
    6) Устанавливаете на перемещённую папку нужные права и нужного владельца.
    7) Создаёте на исходном разделе символическую связь с новой папкой (Alt+F6).
    8) На новую папку ставите атрибут "Скрытый".

    Вариант 5. Изменение пути к каталогам пользователей при установке Windows.

    Вы можете изменить расположение папки Пользователи (Users), в которой будут храниться профили пользователей, ещё при установке Windows.

    1) Создайте файл Autounattend.xml следующего содержания:
    2) Скопируйте его в папку \Sources установочного диска.
    3) Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="oobeSystem">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <FolderLocations>
    <ProfilesDirectory>D:\Users</ProfilesDirectory>
    </FolderLocations>
    </component>
    </settings>
    <settings pass="specialize">
    <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <EnableLUA>false</EnableLUA>
    </component>
    </settings>
    </unattend>

    10. Отключение отображения имени последнего пользователя.
    Для отключения запоминания имени последнего пользователя отображаемого на эране переключения пользователей.

    1) Нажмите Пуск, в строке поиска введите secpol.msc и нажмите Enter
    2) Раскройте группу Локальные политики и перейдите к разделу Параметры безопасности
    3) Используя двойной щелчок мыши откройте параметр Интерактивный вход в систему: не отображать последнее имя пользователя и выберите состояние Включен
    Этот параметр безопасности определяет, будет ли в экране входа в Windows отображено имя последнего пользователя, выполнившего вход.
    Если эта политика включена, в диалоговом окне входа не будет отображаться имя последнего пользователя, выполнившего вход.
    Если эта политика отключена, отображается имя последнего пользователя, выполнившего вход.


1. Активировал учетную запись администратора, но некоторые папки\файлы все равно не удаляются.

Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду

net user Администратор /active:yes
В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:
net user Administrator /active:yes
Команду необходимо выполнять в командной строке с повышенными правами пользователя. Для этого нажмите кнопку Пуск, выберите пункт Стандартные, щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора.

Назад на страницу раздела Администрирование.


2. Как разрешить запуск "Диспетчера задач"?

Запустите редактор системных политик: Пуск > Выполнить > gpedit.msc.
Слева в дереве политик выберите Конфигурация пользователя > Административные шаблоны > Система > Возможности Ctrl+Alt+Del.
В правом окне двойным щелчком откройте свойства политики Удалить диспетчер задач, выберите Отключен и нажмите ОК.
Изменения вступят в действие после перезагрузки.

Назад на страницу раздела Администрирование.


3. Как добавить свою иконку в список рисунков учетных записей?

По умолчанию рисунки учетных записей располагаются в следующей папке:
C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

Назад на страницу раздела Администрирование.


4. Автоматический вход в систему и отключение экрана пользователей при запуске.

Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

1. Нажмите на клавиатуре Win+R (или пункт Выполнить в меню Пуск).
2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Enter.
3. В окне Учетные записи пользователей во вкладке Пользователи выделите свою учетную запись и уберите флажок с “Требовать ввод имени пользователя и пароля”.
4. Нажмите Принять.
5. В открывшемся окне Автоматический вход в систему будут три поля - Пользователь, Пароль и Подтверждение. Введите свой пароль в поле Пароль и еще раз - в поле Подтверждение и нажмите ОК.

Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
(Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

Назад на страницу раздела Администрирование.


5. Как ограничить пользователей в наборе программ, которые они могут запускать?

Контроль за приложениями сводится к настройке правил. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные определенным издателем (например, Microsoft). Запустите GPEDIT.MSC и перейдите к функции AppLocker() через Computer Configuration > Windows Settings > Security Settings > Application Control Policies или Конфигурация компьютера > Конфигурация Windows > Параметры безопасности > Политики управления приложениями, чтобы посмотреть, как это работает.

Назад на страницу раздела Администрирование.


6. Как быстро запустить программу с правами администратора?

Удерживайте Ctrl+Shift и нажмите на иконку приложения (у вашей учетной записи, конечно, должны быть соответствующие права).

Назад на страницу раздела Администрирование.


7. Как убрать значки запрета доступа на папках?

Для этого надо в свойствах назначения прав папкам и файлам, добавить пользователя Администратор, и дать ему все разрешения, после чего значек с папки или файла будет убран.

Назад на страницу раздела Администрирование.


8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
2) Нажимаете "Создать задачу"
3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
5) Указываете путь к нужному приложению и нажимаете "Открыть"
6) Нажимаете "ОК", затем снова "ОК"
7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
8) В поле Расположение объекта введите:
schtasks /run /tn mytask_admin
где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
9) Введите имя ярлыка и нажмите Готово

Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

Скачать можно здесь или здесь

Назад на страницу раздела Администрирование.


9. Перемещение профилей пользователей и изменение путей к ним.

Указанные в с 1 по 4 вариантах действия, необходимо повторять для каждого профиля. Переместив таким образом все профили, и изменив их пути в реестре, исходные папки можно будет удалить.

Вариант 1. С помощью компонента Windows - "Профили пользователей".

Копируем профиль пользователя в конечное размещение:

1) Если папка для профиля существует, переходим к следующему шагу, при этом используя рекомендации; если папка, в которой будет храниться профиль, не существует, создаем ее, используя рекомендации.

Рекомендации:

  • Если на компьютере только одна учетная запись, можно присвоить папке профиля имя учетной записи; если учетных записей несколько, лучше всего создать папку верхнего уровня, например, с именем Пользователи, а в нее вложить папки с именами пользователей компьютера, в которых и будут храниться наши профили. Хотя использовать папку верхнего уровня лучше сразу, на случай добавления новых учетных записей;
  • Если конечная папка уже существует и она имеет содержимое, которое необходимо сохранить, ее необходимо скопировать в другое размещение, а затем, после завершения перемещения профилей, переместить это содержимое в папку с профилем пользователя

    • 2) Открываем Свойства системы: команда свойства контекстного меню Моего компьютера или сочетание Windows + Break.
    3) Щелкаем Дополнительные параметры системы. Щелкаем Продолжить, если появится соответствующий запрос системы контроля учетных записей.
    4) Открываем вкладку Дополнительно.
    5) Щелкаем кнопку Параметры в рамке Профили пользователей.
    6) Выбираем профиль, который необходимо переместить. Активный профиль не выбирается. Чтобы его можно было выбрать для осуществления необходимых действий, нужно войти под другой учетной записью и иметь права администратора.
    7) Нажимаем кнопку Копировать.
    8) Выбираем папку, в которой будет находиться профиль, созданную на шаге 1.
    9) Нажимаем OK; если выбранная папка не пустая, система выдаст запрос на копирование профиля в нее, так как при этом удаляется все ее содержимое! (не забудьте о рекомендациях!). Нажимаем Да.

    Вносим изменения в системный реестр.

    1) Открываем меню Выполнить: Пуск -> Выполнить (либо Win+R)
    2) Вводим regedit.exe, нажимаем Enter.
    3) Изменяем значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя.
    Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    4) Перезагружаем компьютер.

    Внесение изменений в системный реестр может привести к снижению стабильности и производительности системы или ее отказу, поэтому настоятельно рекомендуется создать резервную копию реестра перед выполнением данной операции. В данном случае удобно воспользоваться экспортом изменяемого ключа или Восстановлением системы.

    Вариант 2. На другой диск вручную.

    1) Запустите оснастку "Локальные пользователи и группы" (Win+R -> lusrmgr.msc -> Ok)
    2) Включите системную запись администратора. Выбираете "Пользователи". В свойствах пользователя "Администратор" снимаете галку "Отключить пользователя". Если же Вы уже работаете в учетной записи Администратор, то создайте новую учетную запись с правами администратора.
    3) Для полного доступа к файлам и папкам перезапустите компьютер, и зайдите под аккаунтом "Администратор" (или под созданным Вами с правами администратора).

    Указанные выше действия необходимы, потому что профиль под которым Вы зайдете, для осуществления необходимых действий не выбирается. Соответственно залогинившись под одним профилем, Вы можете работать только с другими.

    4) Запустите "Проводник" в режиме администратора:
    Щелкните правой кнопкой мыши на иконке Проводника
    Щелкните правой кнопкой мыши на слове Проводник
    Выберите пункт "Запуск от имени администратора"
    5) Создайте на диске D: папку Users.
    6) Поменяйте права на "D:\Users", исходя из прав на системный Users.
    Оставьте только "Чтение и выполнение" для группы "Everyone"(Все), и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно)
    Владелец папки, установите на "Administrators" (Администраторы).
    7) В Проводнике запущеном от имени Администратора скопируйте необходимую Вам папку пользователя в "D:\Users".

    Так как Проводник не умеет копировать "junction" (точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог), то их придется создавать самостоятельно. Например, "junction" являются папки "Application Data", "Local Settings", "SendTo" и другие.

    8) Запустите командную строку от имени администратора (Win+R -> CMD -> Ok)
    9) Для показа только скрытых файлов введите команду "dir /ah" (без кавычек) и нажмите Enter. Вы увидете примерно следующее:
    C:\Users\ВашПрофиль>dir /ah
Том в устройстве C не имеет метки.
Серийный номер тома: F018-696C

Содержимое папки C:\Users\ВашПрофиль

23.11.2009  20:05    <DIR>          AppData
23.11.2009  20:05    <JUNCTION>     Application Data [C:\Users\ВашПрофиль\AppData\Roaming]
23.11.2009  20:05    <JUNCTION>     Cookies [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Cookies]
23.11.2009  20:05    <JUNCTION>     Local Settings [C:\Users\ВашПрофиль\AppData\Local]
23.11.2009  20:05    <JUNCTION>     My Documents [C:\Users\ВашПрофиль\Documents]
23.11.2009  20:05    <JUNCTION>     NetHood [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Network Shortcuts]
21.01.2010  05:09         4 718 592 NTUSER.DAT
21.01.2010  05:09           262 144 ntuser.dat.LOG1
23.11.2009  20:05                 0 ntuser.dat.LOG2
23.11.2009  20:14            65 536 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TM.blf
23.11.2009  20:14           524 288 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TMContainer00000000000000000001.regtrans-ms
23.11.2009  20:14           524 288 NTUSER.DAT{016888bd-6c6f-11de-8d1d-001e0bcde3ec}.TMContainer00000000000000000002.regtrans-ms
24.11.2009  00:19            65 536 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TM.blf
24.11.2009  00:19           524 288 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TMContainer00000000000000000001.regtrans-ms
24.11.2009  00:19           524 288 NTUSER.DAT{cff5534c-d875-11de-96ed-00248c4bcc41}.TMContainer00000000000000000002.regtrans-ms
23.11.2009  20:05                20 ntuser.ini
23.11.2009  20:05    <JUNCTION>     PrintHood [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Printer Shortcuts]
23.11.2009  20:05    <JUNCTION>     Recent [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Recent]
23.11.2009  20:05    <JUNCTION>     SendTo [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\SendTo]
23.11.2009  20:05    <JUNCTION>     Start Menu [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Start Menu]
23.11.2009  20:05    <JUNCTION>     Templates [C:\Users\ВашПрофиль\AppData\Roaming\Microsoft\Windows\Templates]
              10 файлов      7 208 980 байт
              11 папок  22 173 192 192 байт свободно
    10) Создайте аналогичные "Junction" каталоги:

    Способ 1. Вручную для каждого "Junction" каталога.

    1) В командной строке переходите в созданную Вами папку:
    C:\Users\Administrator>d:
D:\>cd Users\ВашПрофиль
    2) И для каждой "Junction" выполняете команду:
    mklink /J <Link> <Target>
    Например: mklink /J "Application Data" "AppData\Roaming"

    Способ 2. Создание bat-файла.

    Если Вам предстоит перенести несколько профилей, то проще будет создать bat-файл, так как "Junction" у Вас скорее всего будут такие же.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "profiles.bat")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    В моем случае получился такой, Вы можете создать аналогичный для своих папок (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):
    mklink /J "Application Data" "AppData\Roaming"
mklink /J "Cookies" "AppData\Roaming\Microsoft\Windows\Cookies"
mklink /J "Local Settings" "AppData\Local"
mklink /J "My Documents" "Documents"
mklink /J "NetHood" "AppData\Roaming\Microsoft\Windows\Network Shortcuts"
mklink /J "PrintHood" "AppData\Roaming\Microsoft\Windows\Printer Shortcuts"
mklink /J "Recent" "AppData\Roaming\Microsoft\Windows\Recent"
mklink /J "SendTo" "AppData\Roaming\Microsoft\Windows\SendTo"
mklink /J "Start Menu" "AppData\Roaming\Microsoft\Windows\Start Menu"
mklink /J "Templates" "AppData\Roaming\Microsoft\Windows\Templates"
    Если у Вас папки имеют русские названия, то для правильной работы данного bat-файла, надо его сохранять в кодировке CP866 (Блокнот Windows, в ней не сохраняет, используйте для этого программы сторонних производителей например: Akelpad).
    11) Присвойте "Junction" каталогам скрытые и системные аттрибуты, как в оригинале.

    Либо, вручную для каждого в командной строке.
    attrib /S /D /L +H +S "имя папки"
    Например: attrib /S /D /L +H +S "Application Data"

    Либо, создав bat-файл (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):
    attrib /S /D /L +H +S "Application Data"
attrib /S /D /L +H +S "Cookies"
attrib /S /D /L +H +S "Local Settings"
attrib /S /D /L +H +S "My Documents"
attrib /S /D /L +H +S "NetHood"
attrib /S /D /L +H +S "PrintHood"
attrib /S /D /L +H +S "Recent"
attrib /S /D /L +H +S "SendTo"
attrib /S /D /L +H +S "Start Menu"
attrib /S /D /L +H +S "Templates"
    12) Запустите Реестр Windows(Win+R -> regedit -> Enter) и измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID c "C:\Users\ВашПрофиль" на "D:\Users\ВашПрофиль" , где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя. Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    13) Переименуйте или удалите каталог профиля в "C:\Users\", чтобы предотвратить к нему запросы.
    14) Перезагрузите компьютер, чтобы Windows подхватила внесенные нами настройки.
    15) Вновь зайдите под аккаунтом Администратор.
    16) Запустите Реестр Windows(Win+R -> regedit -> Enter)
    17) Используя Поиск найдите все строки с путем к папке "C:\Users\ВашПрофиль" и исправьте на "D:\Users\ВашПрофиль" (Чем ближе к чистой установке Вы это сделаете, тем меньше строк Вам придется исправлять).
    18) Поменяйте права на каталог профиля в "D:\Users".
    Установите "Полный доступ" пользователелю - владельцу профиля, и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно).
    Владелец папки, установите на "System".
    19) Перезагрузите компьютер, теперь вы можете войти в перемещенный аккаунт и проделать всё указанное выше для другого профиля.

    Вариант 3. При помощи ERD Commander.

    1) Скачиваете утилиту Junction от SysInternals. Она позволяет создавать точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог.
    2) Копируете junction.exe в C:\Windows\System32
    3) Загружаетесь в Erd Commander.
    4) Выбираете опцию, чтобы реестр не импортировася
    5) Копируете например: "C:\Documents and Settings\ВашПрофиль" в "D:\Users\ВашПрофиль"
    6) После копирования, удаляете "C:\Documents and Settings\ВашПрофиль"
    7) Запускаете командную строку и переходите в папку C:\Windows\System32
    c:\
cd\windows
cd system32
junction.exe "C:\Documents and Settings\ВашПрофиль" "D:\Users\ВашПрофиль"
    8) После сообщения Sucsess, можете зайти в папку проверяем C:\Documents and Settings\ и увидите там папку ВашПрофиль, только это уже ссылка...

    Вариант 4. При помощи Far Manager.

    1) Скачиваете Far Manager и устанавливаете его.
    2) Входите в систему под другим пользователем с правами администратора
    3) Запускаете Far Manager
    4) Находите нужный профиль пользователя.
    5) Перемещаете папку с ним на другой диск (например, C:\Documents and Settings\ВашПрофиль -> D:\Users\ВашПрофиль).
    6) Устанавливаете на перемещённую папку нужные права и нужного владельца.
    7) Создаёте на исходном разделе символическую связь с новой папкой (Alt+F6).
    8) На новую папку ставите атрибут "Скрытый".

    Вариант 5. Изменение пути к каталогам пользователей при установке Windows.

    Вы можете изменить расположение папки Пользователи (Users), в которой будут храниться профили пользователей, ещё при установке Windows.

    1) Создайте файл Autounattend.xml следующего содержания:
    2) Скопируйте его в папку \Sources установочного диска.
    3) Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="oobeSystem">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <FolderLocations>
    <ProfilesDirectory>D:\Users</ProfilesDirectory>
    </FolderLocations>
    </component>
    </settings>
    <settings pass="specialize">
    <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <EnableLUA>false</EnableLUA>
    </component>
    </settings>
    </unattend>

    Назад на страницу раздела Администрирование.


10. Отключение отображения имени последнего пользователя.

Для отключения запоминания имени последнего пользователя отображаемого на эране переключения пользователей.

1) Нажмите Пуск, в строке поиска введите secpol.msc и нажмите Enter
2) Раскройте группу Локальные политики и перейдите к разделу Параметры безопасности
3) Используя двойной щелчок мыши откройте параметр Интерактивный вход в систему: не отображать последнее имя пользователя и выберите состояние Включен
Этот параметр безопасности определяет, будет ли в экране входа в Windows отображено имя последнего пользователя, выполнившего вход.
Если эта политика включена, в диалоговом окне входа не будет отображаться имя последнего пользователя, выполнившего вход.
Если эта политика отключена, отображается имя последнего пользователя, выполнившего вход.

Назад на страницу раздела Администрирование.


Интерфейс

1. Как открыть диспетчер задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту?

Вариант 1

Используйте ctrl+shift+esc.

Вариант 2

Правой кнопкой на панели задач --> Start Task Manager

2. Использование средней кнопкой мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

3. Как уменьшить размер иконки на рабочем столе ?

1) Правый клик на рабочем столе - Вид - Мелкие значки;
2) Нажимаем Сtrl и крутим колесико.

4. Управление заготовками положений размеров окон.

Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

5. Где скачать и как установить дополнительные темы для Windows 7?

Скачать дополнительные темы для Вашей Windows 7 Вы можете на оффициальной странице тем от Microsoft: Персонализация компьютера
После скачивания понравившейся Вам темы, нажмите на скачавшийся themepack-файл и Windows автоматически его установит.
Также дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT.

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

6. Как перезапустить рабочий стол?

Откройте Task Manager - вкладка Applications - нажимаете кнопку New task - далее кнопку Browse - переходите в папку Windows и выбираете explorer.exe, затем нажимаете ОК (это же действие можно выполнить через ярлык).

7. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкаем правой кнопкой на Компьютер (например в Пуске) и выбираем Управление
2) В левом окне выбираем Управление дисками
3) Посередине вверху смотрим, какие из томов не имеют букву. Среди них должен быть раздел размером 200 МБ. Его НЕ трогать!!!
4) Присваиваем букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкаем на нем правой кнопкой и в контекстном меню выбираем Изменить букву диска или путь к диску. Жмем Добавить. Выбираем букву. Жмем OK.
5) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
Также должна стоять галочка в Панель управления-Параметры папок-Вид "Отображать буквы дисков"

8. Включение и отключение Области переходов.

Область переходов – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить Область переходов можно так:

1) Нажмите вверху слева Упорядочить->Представление
2) Поставьте или уберите галочку в пункте Область переходов

9. Изменение ширины меню Пуск.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui
113, "0, 0, 406, 440"
114, "0, 0, 145, 75"
115, "0, 0, 64, 64"
116, "0, 0, 145, 44"
117, "0, 0, 261, 30"
118, "0, 0, 145, 332"
119, "0, 0, 261, 383"
120, "0, 0, 261, 37"
121, "0, 0, 400, 50"

10. Изменение прозрачности окон в Windows 7.

До | После
Рисунок 1 из 2 | Рисунок 2 из 2

Выключить матовый-стеклянный (Blur эффект) и включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

Инструкция:

1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
2. Это займет немного времени и вы увидите окно без эффекта матовости.
3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
Изменения становятся видимыми после перезагрузки.

Сайт автора скрипта

11. Открытие командной строки из конкретной папки.

Одной из самых популярных утилит в наборе Windows XP Power Toys был пункт контекстного меню проводника «Открыть командную строку отсюда» (“Open Command Prompt Here”).
В Windows 7 этот пункт есть в контекстном меню, для его использования при вызове меню нужно удерживать клавишу Shift, вследствие чего в меню появляется пункт "Открыть окно команд".

12. Как улучшить качество передачи цветов монитором?

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова мастера кликните Start, введите DCCW и нажмите <Enter>.

13. Включение Flip3D — отображение окон под углом.

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

14. Как расширить функциональность часов в трее или изменить их вид?

Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

15. Использование переменных окружения для быстрого перехода к системным папкам.

Чтобы узнать какие из них присутствуют в вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения вашей Windows.

%AllUsersProfile% - C:\ProgramData
%AppData% - C:\Users\%UserName%\AppData\Roaming
%CommonFavorites% - C:\Documents and Settings\All Users\Избранное
%CommonFiles% - C:\Program Files\Common Files
%CommonProgramFiles% - C:\Program Files\Common Files
%CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
%ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
%HomePath% - C:\Users\Administrator
%LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
%ProgramData% - C:\ProgramData
%ProgramFiles% - C:\Program Files
%ProgramFiles(x86)% - C:\Program Files (x86)
%PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%SystemDir% - C:\Windows\System32
%SystemDrive% - C:\
%SystemRoot% - C:\Windows
%Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
%Tmp% - C:\Users\%UserName%\AppData\Local\Temp
%UserProfile% - C:\Users\%UserName%
%windir% - C:\Windows

Если вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
2) Нажмите Создать...
3) Укажите Имя перменной и Значение переменной
4) Нажмите на каждое Ок
5) Перезагрузите компьютер (иначе она не будет работать)

16. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения фалы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое срыто по умолчанию.
Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

17. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это пожно с помощью бесплатной программы 7Stacks.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д. Для работы с программой надо создать папку и сложить туда ярлыки приложений, нужных нам в создаваемом меню. Потом запускаем 7Stacks, выбираем эту папку, настраиваем оформление и создаем ярлык на рабочем столе. Перетаскиваем его в панель задач. Вот и все.

18. Добавление дополнительных операций к окнам.

К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу

19. Добавление командной строке эффекта прозрачности - Aero Glass.

Для добавления командной строке эффекта прозрачности (Aero Glass) сделайте следующее:

1) Скачайте архив: Glass_CMD.zip
2) Распакуйте его и запустите исполняемый файл минискрипта Glass CMD.exe.
3) Запустите командную строку(Win+R -> CMD ->Ok) и увидите эффект прозрачности (Aero Glass).
Для использования данного эффекта скрипт Glass CMD.exe должен быть запущен. При закрытии Glass CMD.exe эффект прозрачности пропадет.
При желании Вы можете добавить данный скрипт-программу в папку Автозагрузка в меню Пуск.
Если Вы не хотите, чтобы в области уведомлений (трее) отображался значок скрипта, то в файле Settings.ini, который идет в архиве в комплекте с исполняемым файлом скрипта, установите значение параметра HideTrayIcon равным 1.

20. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

21. Как узнать цветовой код любой точки экрана на мониторе?

Для того чтобы узнать цветовой код любой точки экрана на Вашем мониторе скачайте и установите небольшую, но функциональную программу ColorPic.

Данная программа абсолютно бесплатна и Вы можете скачать её с официального сайта: http://www.iconico.com/colorpic/index.aspx

Мощные средства для регулировки цвета позволяют Вам с легкостью менять индивидуальные цвета. С помощью четырех графических миксеров Вы сможете регулировать RGB, оттенки, насыщенность и код цвета. У Вас будет возможность просматривать CMYK печатные коды цвета, а для идеальной точности использовать увеличитель экрана. Вы сможете сохранять множество цветовых палитр для их использования в любом приложении.

Содержащийся в программе раздел "Mixer" предоставляет Вам четыре мощных графических способа для анализа и изменения выбранного цвета. Цвета могут быть выбраны из любых шестиугольных форм, измененных миксером или настроенных шестью индивидуальными слайдерами для оттенков, насыщенности, кода и красных, зеленых и голубых цветовых компонентов. ColorPic также делает отчеты для регулировки голубого, пурпурного, желтого и черного цветовых кодов.

Кроме того, ColorPic также предлагает возможность увеличения, предоставляя Вам супер детальную картинку при выборе цвета. Программа имеет простой в использовании слайдер для увеличения, который позволяет Вам выбирать или разовую пробу или 3x3 или 5x5 средний цвет из любого места на Вашем экране.

Будучи неоценимым средством для любого графического дизайнера или веб-разработчика и будучи постоянно самым популярным бесплатным цветоподборщиком в сети, самая последняя версия ColorPic предлагает мощные средства для выбора цвета, которые до сих пор доступны только в дорогих приложениях.

Использовать программу очень просто:

1) Запускаете программу
2) Наводите курсор в то место, цвет которого желаете узнать.
3) Нажимаете Ctrl+G и в первой ячейке сохраняется информация о цвете.
4) Затем выделяете следующую ячейку и проделываете указанное выше для определения другого цвета.

Назад на страницу раздела Разное.


1. Как открыть диспетчер задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту?

Вариант 1

Используйте ctrl+shift+esc.

Вариант 2

Правой кнопкой на панели задач --> Start Task Manager

Назад на страницу раздела Интерфейс.


2. Использование средней кнопкой мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

Назад на страницу раздела Интерфейс.


3. Как уменьшить размер иконки на рабочем столе ?

1) Правый клик на рабочем столе - Вид - Мелкие значки;
2) Нажимаем Сtrl и крутим колесико.

Назад на страницу раздела Интерфейс.


4. Управление заготовками положений размеров окон.

Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

Назад на страницу раздела Интерфейс.


5. Где скачать и как установить дополнительные темы для Windows 7?

Скачать дополнительные темы для Вашей Windows 7 Вы можете на оффициальной странице тем от Microsoft: Персонализация компьютера
После скачивания понравившейся Вам темы, нажмите на скачавшийся themepack-файл и Windows автоматически его установит.
Также дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT.

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

Назад на страницу раздела Интерфейс.


6. Как перезапустить рабочий стол?

Откройте Task Manager - вкладка Applications - нажимаете кнопку New task - далее кнопку Browse - переходите в папку Windows и выбираете explorer.exe, затем нажимаете ОК (это же действие можно выполнить через ярлык).

Назад на страницу раздела Интерфейс.


7. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкаем правой кнопкой на Компьютер (например в Пуске) и выбираем Управление
2) В левом окне выбираем Управление дисками
3) Посередине вверху смотрим, какие из томов не имеют букву. Среди них должен быть раздел размером 200 МБ. Его НЕ трогать!!!
4) Присваиваем букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкаем на нем правой кнопкой и в контекстном меню выбираем Изменить букву диска или путь к диску. Жмем Добавить. Выбираем букву. Жмем OK.
5) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
Также должна стоять галочка в Панель управления-Параметры папок-Вид "Отображать буквы дисков"

Назад на страницу раздела Интерфейс.


8. Включение и отключение Области переходов.

"Область переходов" – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить "Область переходов" можно так:

1) Нажмите вверху слева Упорядочить->Представление
2) Поставьте или уберите галочку в пункте "Область переходов"

Назад на страницу раздела Интерфейс.


9. Изменение ширины меню Пуск.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui
113, "0, 0, 406, 440"
114, "0, 0, 145, 75"
115, "0, 0, 64, 64"
116, "0, 0, 145, 44"
117, "0, 0, 261, 30"
118, "0, 0, 145, 332"
119, "0, 0, 261, 383"
120, "0, 0, 261, 37"
121, "0, 0, 400, 50"

Назад на страницу раздела Интерфейс.


10. Изменение прозрачности окон в Windows 7.

До | После
Выключить матовый-стеклянный (Blur эффект) и включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

Инструкция:

1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
2. Это займет немного времени и вы увидите окно без эффекта матовости.
3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
Изменения становятся видимыми после перезагрузки.

Сайт автора скрипта

Назад на страницу раздела Интерфейс.


11. Открытие командной строки из конкретной папки.

Одной из самых популярных утилит в наборе Windows XP Power Toys был пункт контекстного меню проводника «Открыть командную строку отсюда» (“Open Command Prompt Here”).
В Windows 7 этот пункт есть в контекстном меню, для его использования при вызове меню нужно удерживать клавишу Shift, вследствие чего в меню появляется пункт "Открыть окно команд".

Назад на страницу раздела Интерфейс.


12. Как улучшить качество передачи цветов монитором?

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова мастера кликните Start, введите DCCW и нажмите <Enter>.

Назад на страницу раздела Интерфейс.


13. Включение Flip3D — отображение окон под углом.

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

Назад на страницу раздела Интерфейс.


14. Как расширить функциональность часов в трее или изменить их вид?

Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

Назад на страницу раздела Интерфейс.


15. Использование переменных окружения для быстрого перехода к системным папкам.

Чтобы узнать какие из них присутствуют в вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения вашей Windows.

%AllUsersProfile% - C:\ProgramData
%AppData% - C:\Users\%UserName%\AppData\Roaming
%CommonFavorites% - C:\Documents and Settings\All Users\Избранное
%CommonFiles% - C:\Program Files\Common Files
%CommonProgramFiles% - C:\Program Files\Common Files
%CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
%ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
%HomePath% - C:\Users\Administrator
%LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
%ProgramData% - C:\ProgramData
%ProgramFiles% - C:\Program Files
%ProgramFiles(x86)% - C:\Program Files (x86)
%PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%SystemDir% - C:\Windows\System32
%SystemDrive% - C:\
%SystemRoot% - C:\Windows
%Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
%Tmp% - C:\Users\%UserName%\AppData\Local\Temp
%UserProfile% - C:\Users\%UserName%
%windir% - C:\Windows

Если вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
2) Нажмите Создать...
3) Укажите Имя перменной и Значение переменной
4) Нажмите на каждое Ок
5) Перезагрузите компьютер (иначе она не будет работать)

Назад на страницу раздела Интерфейс.


16. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения фалы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое срыто по умолчанию.
Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

Назад на страницу раздела Интерфейс.


17. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это пожно с помощью бесплатной программы 7Stacks.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д. Для работы с программой надо создать папку и сложить туда ярлыки приложений, нужных нам в создаваемом меню. Потом запускаем 7Stacks, выбираем эту папку, настраиваем оформление и создаем ярлык на рабочем столе. Перетаскиваем его в панель задач. Вот и все.

Назад на страницу раздела Интерфейс.


18. Добавление дополнительных операций к окнам.

К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу

Назад на страницу раздела Интерфейс.


19. Добавление командной строке эффекта прозрачности - Aero Glass.

Для добавления командной строке эффекта прозрачности (Aero Glass) сделайте следующее:

1) Скачайте архив: Glass_CMD.zip
2) Распакуйте его и запустите исполняемый файл минискрипта Glass CMD.exe.
3) Запустите командную строку(Win+R -> CMD ->Ok) и увидите эффект прозрачности (Aero Glass).
Для использования данного эффекта скрипт Glass CMD.exe должен быть запущен. При закрытии Glass CMD.exe эффект прозрачности пропадет.
При желании Вы можете добавить данный скрипт-программу в папку Автозагрузка в меню Пуск.
Если Вы не хотите, чтобы в области уведомлений (трее) отображался значок скрипта, то в файле Settings.ini, который идет в архиве в комплекте с исполняемым файлом скрипта, установите значение параметра HideTrayIcon равным 1.

Назад на страницу раздела Интерфейс.


20. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

Назад на страницу раздела Разное.


21. Как узнать цветовой код любой точки экрана на мониторе?

Для того чтобы узнать цветовой код любой точки экрана на Вашем мониторе скачайте и установите небольшую, но функциональную программу ColorPic.

Данная программа абсолютно бесплатна и Вы можете скачать её с официального сайта: http://www.iconico.com/colorpic/index.aspx

Мощные средства для регулировки цвета позволяют Вам с легкостью менять индивидуальные цвета. С помощью четырех графических миксеров Вы сможете регулировать RGB, оттенки, насыщенность и код цвета. У Вас будет возможность просматривать CMYK печатные коды цвета, а для идеальной точности использовать увеличитель экрана. Вы сможете сохранять множество цветовых палитр для их использования в любом приложении.

Содержащийся в программе раздел "Mixer" предоставляет Вам четыре мощных графических способа для анализа и изменения выбранного цвета. Цвета могут быть выбраны из любых шестиугольных форм, измененных миксером или настроенных шестью индивидуальными слайдерами для оттенков, насыщенности, кода и красных, зеленых и голубых цветовых компонентов. ColorPic также делает отчеты для регулировки голубого, пурпурного, желтого и черного цветовых кодов.

Кроме того, ColorPic также предлагает возможность увеличения, предоставляя Вам супер детальную картинку при выборе цвета. Программа имеет простой в использовании слайдер для увеличения, который позволяет Вам выбирать или разовую пробу или 3x3 или 5x5 средний цвет из любого места на Вашем экране.

Будучи неоценимым средством для любого графического дизайнера или веб-разработчика и будучи постоянно самым популярным бесплатным цветоподборщиком в сети, самая последняя версия ColorPic предлагает мощные средства для выбора цвета, которые до сих пор доступны только в дорогих приложениях.

Использовать программу очень просто:

1) Запускаете программу
2) Наводите курсор в то место, цвет которого желаете узнать.
3) Нажимаете Ctrl+G и в первой ячейке сохраняется информация о цвете.
4) Затем выделяете следующую ячейку и проделываете указанное выше для определения другого цвета.

Назад на страницу раздела Разное.


Сети (Интернет и Локальная)

1. Как сменить поиск по умолчанию в Firefox?

Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
3) Меняете его значение (без кавычек) на:

"http://www.google.com/search?&q=" - Google.Com
"http://yandex.ru/yandsearch?text=" - Yandex.Ru
"http://www.bing.com/search?q=" - Bing.Com

2. У сетевого адаптера Marvell Yukon сеть отключается через каждые 5 минут.

Отменить в настройках Marvell Yukon "Разрешить этому устройству откл. для экономии энергии".

3. Где можно объединить и удалить сети?

Нажмите на скамейку.

4. Как сделать так, чтобы интернет включался при запуске Windows в "невидимом режиме"?

Control Panel\Network and Internet\Сетевые подключения\свойства ADSL. Во вкладке параметры сними галочки: отображать ход подключения, запрашивать имя и пароль. Ярлык ADSL поместите в папку автозагрузки.

5. Автоматическое VPN подключение к интернет при запуске Windows.

Вариант 1

Вы можете добавить задачу в Планировщик заданий.
1) Откройте планировщик задний из меню Пуск - Администрирование - Планировщик заданий или выполнив команду taskschd.msc из меню Пуск - Поиск.
2) Нажмите создать задачу

Вкладка Имя - Имя подключения
Размещение оставляем как есть.

Вкладка Триггеры-Создать-Начать задачу: При входе в систему

Вкладка Действия-Создать
Действие:Запуск программы
Программа или сценарий: rasdial "имя подключения" пользователь пароль

Вкладка Параметры-Создать
Поставить галочки:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
Убрать галочку:
Останавливать задачу выполняемую дольше

Вариант 2

Наличие скриптов в одной папке connect.bat обязательно.
1) По ссылке ниже берете скрипт (bat-файл)
2) Настраиваете его под себя (имя соединения, логин,пароль)
3) Сохраняете(выкладываете) исправленный файл на рабочий стол, называете его "connect.bat"
connect1.zip
4) Затем берете архив со скриптом скрытого запуска отсюда
hs_exec.zip
hide_programm.zip
5) Извлекаем файлы из архива и кладем в ту же самую папку где лежит файл "connect.bat" запускаем либо "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd.
6) Для автоматической загрузки добавляем в Автозагрузка ярлык (не сам файл скрипта) для "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd

Вариант 3

Создайте маленький bat-файл(типа Connect.bat) следующего содержания, положите его на рабочий стол и запускайте через него при случайном разрыве (имя подключения должно быть на английском иначе может быть ошибка 623):
@echo off

set conn="Golden Telecom"
:: название вашего подключения к интернету

set login="loginname@golden.ru"
:: ваш логин подключения к интернету

set pass="12345678"
:: ваш пароль подключения к интернету

set pause=10
:: пауза в секундах между проверкой соединения, если соединение разорвалось произойдет подключение

rasdial %conn% %login% %pass%

exit

6. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

7. Как просмотреть исходный код любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

Установите расширение Web Developer.
Затем в меню Web Developer -> Код -> Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

В Internet Explorer

Меню Сервис -> Средства разработчика
Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.


1. Как сменить поиск по умолчанию в Firefox?

Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
3) Меняете его значение (без кавычек) на:

"http://www.google.com/search?&q=" - Google.Com
"http://yandex.ru/yandsearch?text=" - Yandex.Ru
"http://www.bing.com/search?q=" - Bing.Com

Назад на страницу раздела Сети (Интернет и Локальная).


2. У сетевого адаптера Marvell Yukon сеть отключается через каждые 5 минут.

Отменить в настройках Marvell Yukon "Разрешить этому устройству откл. для экономии энергии".

Назад на страницу раздела Сети (Интернет и Локальная).


3. Где можно объединить и удалить сети?

Нажмите на скамейку.

Назад на страницу раздела Сети (Интернет и Локальная).


4. Как сделать так, чтобы интернет включался при запуске Windows в "невидимом режиме"?

Control Panel\Network and Internet\Сетевые подключения\свойства ADSL. Во вкладке параметры сними галочки: отображать ход подключения, запрашивать имя и пароль. Ярлык ADSL поместите в папку автозагрузки.

Назад на страницу раздела Сети (Интернет и Локальная).


5. Автоматическое VPN подключение к интернет при запуске Windows.

Вариант 1

Вы можете добавить задачу в Планировщик заданий.
1) Откройте планировщик задний из меню Пуск - Администрирование - Планировщик заданий или выполнив команду taskschd.msc из меню Пуск - Поиск.
2) Нажмите создать задачу

Вкладка Имя - Имя подключения
Размещение оставляем как есть.

Вкладка Триггеры-Создать-Начать задачу: При входе в систему

Вкладка Действия-Создать
Действие:Запуск программы
Программа или сценарий: rasdial "имя подключения" пользователь пароль

Вкладка Параметры-Создать
Поставить галочки:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
Убрать галочку:
Останавливать задачу выполняемую дольше

Вариант 2

Наличие скриптов в одной папке connect.bat обязательно.
1) По ссылке ниже берете скрипт (bat-файл)
2) Настраиваете его под себя (имя соединения, логин,пароль)
3) Сохраняете(выкладываете) исправленный файл на рабочий стол, называете его "connect.bat"
connect1.zip
4) Затем берете архив со скриптом скрытого запуска отсюда
hs_exec.zip
hide_programm.zip
5) Извлекаем файлы из архива и кладем в ту же самую папку где лежит файл "connect.bat" запускаем либо "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd.
6) Для автоматической загрузки добавляем в Автозагрузка ярлык (не сам файл скрипта) для "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd

Вариант 3

Создайте маленький bat-файл(типа Connect.bat) следующего содержания, положите его на рабочий стол и запускайте через него при случайном разрыве (имя подключения должно быть на английском иначе может быть ошибка 623):
@echo off

set conn="Golden Telecom"
:: название вашего подключения к интернету

set login="loginname@golden.ru"
:: ваш логин подключения к интернету

set pass="12345678"
:: ваш пароль подключения к интернету

set pause=10
:: пауза в секундах между проверкой соединения, если соединение разорвалось произойдет подключение

rasdial %conn% %login% %pass%

exit

Назад на страницу раздела Сети (Интернет и Локальная).


6. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

Назад на страницу раздела Сети (Интернет и Локальная).


7. Как просмотреть исходный код любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

Установите расширение Web Developer.
Затем в меню Web Developer -> Код -> Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

В Internet Explorer

Меню Сервис -> Средства разработчика
Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.

Назад на страницу раздела Сети (Интернет и Локальная).


Тонкие настройки

1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново.
Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

Отключаем ее:
1. Создайте пустой текстовый файл,
2. Скопируйте в него powercfg -h off,
3. При сохранении изменить расширение "TXT" на "CMD",
4. Запустите его как обычную программу,
5. Перезагрузка.

Также Вы можете запустить командную строку с правами администратора (Нажать Win+R, ввести Cmd и нажать Ok) и выполнить в ней данную команду:
powercfg /h off

2. Как скрыть значок "Центр действий" в трее возле часов?

1) Пройдите Пуск\Панель управления\Значки области уведомлений
2) Выберите значки которые хотите скрыть и нажмите Ok

3. Как убрать текст под значком ярлыка или файла?

1) Щелкните правой кнопкой мыши на иконке.
2) Кликните Переименовать.
3) Удерживая клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
Если вы захотите переименовать несколько ярлыков, то, когда вы будете переименовывать следующий, вам потребуется нажать Alt и ввести 255 дважды. Так для третьего значка вам потребуется ввести ALT+255, ALT+255, ALT+255.

4. Создаем (восстанавливаем) панель быстрого запуска (Quick Launch).

1) Правой кнопкой по панели задач ->Панели(Toolbars )-->Создать панель инструментов(New Toolbar)-->
2) Выберите папку: %appdata%\Microsoft\Internet Explorer\Quick Launch
3) Нажмите кнопку выбора папки “Select Folder”.
4) Правой кнопкой на панели задач -> снять галку "Закрепить панель задач";
5) Правой кнопкой мыши на появившемся "quick launch"--->убираем галки с "Показывать подписи" и "Показывать заголовок"
6) Перетаскиваем в левую сторону и закрепляем обратно панель --->Все!

5. Удаление или разблокирование для замены любого файла защищённого Windows.

1. Качаем и устанавливаем программу Unlocker
2. Копируем файл(ы) в буфер обмена, для дальнейшей замены.
3. С помощью программы Unlocker, удаляем заменяемый(е) файл(ы).
4. После удаления файла(ов), вставляем заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления) и перезагружаем компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, переходим к папке C:\Windows\rescache и с помощью этой же программы Unlocker удаляем её содержимое. Перезагружаемся.

Для 64-битных систем аналогом является программа LockHunter 64-bit.

6. Убираем лишние надписи на рабочем столе.

Открываете с помощью Restorator или PE Explorer файлы C:\Windows\System32\ru-RU\user32.dll.mui и C:\Windows\System32\en-US\user32.dll.mui и в строковой таблице удаляем строчки с 715 по 718 включительно и строки 737 и 738 , для того чтобы лишних надписей на рабочем столе не было.

715 %wsWindows %ws
716 %ws Сборка %ws
717 Пробная копия.
718 Только для тестов.

737 Ваша копия Windows не является подлинной
738 Тестовый режим

7. Смена названия операционной системы из Максимальная на Ultimate.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

8. Использование всей оперативной памяти в 32-битных Windows.

Данная программа добавляет второе ядро для загрузки операционной системы: ntkr128g.exe

1) Скачать здесь автоскрипт от deepxw.
2) 3апустить ReadyFor4GB.exe
3) Нажать на кнопку Check, затем на кнопку Apply.
4) Перезагрузить компьютер и вам станут доступны все 4 ГБ оперативки на вашей установленной ОС Windows 7 (x86), или если у вас установлено более >4ГБ, то ваш объем Оперативной памяти также станет доступен в полном объеме без ограничений...

Примечание: Файлы обязательно запускать как администратор, запускайте этот скрипт строго в операционной системе Windows 7 x86 (32-Bit) для которой вам нужно снять ограничение.

Статья (на английском), объясняющая принцип работы данной программы: http://www.geoffchappell.com/viewer.htm?doc=notes/windows/license/memory.htm

9. Изменение папки открываемой по умолчанию в Проводнике.

Настраиваем нажатие на кнопку Проводник (Windows Explorer), чтобы оно приводило в указанную Вами папку, вместо Libraries.

1) Нажмите правой кнопкой мыши на значок Проводника в Панели задач.
2) Нажмите правой кнопкой мыши на Проводник
3) Нажмите левой кнопкой мыши на Свойства
4) Измените поле Объект (Target) на %SystemRoot%\explorer.exe /n, /e, С:\My Folder
где C:\My Folder - путь к Вашей папке.
Для запуска папки Компьютер измените на значение: %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Пуск, то вам потребуется изменить поле Объект в свойствах ярлыка Проводник в папке Стандартные (Accessories) из меню Пуск.
Комбинация клавиш Win+E откроет Проводник в «Компьютере»

10. Добавление или прямой запуск папки Все задачи (Расширенная Панель Управления).

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.
Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:
1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:
shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
2) Нажимаете ПКМ -> Создать -> Библиотека
3) Переименовываете её. Например: Обои для рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки,в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Скачать данную программу можно здесь или здесь

13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.

Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

Для установки необходимы права локального администратора.

1) Скачайте архив MouseRate.zip и распакуйте его в папку.
2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
5) Откройте папку HIDUSBF
6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
8) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Если у Вас появится сообщение о неподписанных драйверах - не волнуйтесь, все нормально. Подпишем его программой Driver Signature Enforcement Overrider, о которой упоминалось в совете Как добавить подпись к драйверам? из раздела Установка. На время её работы UAC(Контроль учетных записей пользователей) в Windows должен быть отключен.

1) Запустите файл dseo13b.exe из папки Driver Signature Enforcement Overrider и выберите там "Enable Test Mode".
2) Перезапустите компьютер.
3) После перезапуска снова откройте файл dseo13b.exe и выберите "Sign a system file".
4) В окне пропишите: "C:\Windows\System32\Drivers\HIDUSBF.sys". Если вы сделали это правильно, то вы увидите сообщение: "Система была подписана успешно" ("The system file has been signed succesfully")
5) Снова перезапустите компьютер.
6) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
7) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

14. Перемещение системных папок и изменение их путей.

Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящимися в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей продеайте следующее:

1) Создайте новую папку, желательно с аналогичным перемещаемой папке наименованием.
2) Откройте в Windows Explorer: Рабочий стол\Ваш Профиль (Например: Рабочий стол\Администратор)
3) Щелкните правой кнопкой мыши на название папки, которую Вы собираетесь переместить (Например: Мои Документы) и выберите Свойства.
4) Откройте вкладку Расположение
5) Нажмите кнопку Переместить и укажите путь к созданной Вами новой папке
6) Далее система спросит Вас: Переместить все файлы из старого расположения в новое? (Рекомендуемый ответ - Да)
7) Соглашаетесь с новыми параметрами применяя их и выходите.
8) Перезагружаете Компьютер.

15. Запуск команд Windows Shell, используя названия и {GUID} объектов.

Microsoft Windows Shell - интерпретатор команд операционной системы (ОС), обеспечивающий интерфейс для взаимодействия пользователя с функциями системы. Позволяет получить доступ к диалоговым окнам, к файловой системе, запускать программы и изменять системные настройки.
Для быстрого перехода к компонентам Windows используется команда shell.
GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Использование GUID гарантирует, что две версии одного компонента могут иметь одно и то же имя, но быть отличимыми по GUID. Microsoft применяет GUID в качестве идентификаторов для большого количества своих объектов. Зная GUID Вы сможете открыть многие компоненты Windows: элементы Панели управления, системные папки, различные программы и настройки.

Для запуска любого из объектов Windows, используя {GUID}, применяется команда:
Shell:::{GUID}
где {GUID} - идентификатор {GUID} нужного Вам объекта. Например, для запуска Панели управления наберите команду:
Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Вы можете поискать нужные Вам {GUID} в разделе реестра HKEY_CLASSES_ROOT\CLSID или воспользоваться таблицей №1.

Таблица №1.

Русское название элемента | Английское название элемента | Команда
Flip 3D (Win+Tab) | Flip 3D (Win+Tab) | Shell:::{3080F90E-D7AD-11D9-BD98-0000947B0257}
Fusion Cache | Fusion Cache | Shell:::{1D2680C9-0E2A-469d-B787-065558BC7D43}
Internet Explorer | Internet Explorer | Shell:::{871C5380-42A0-1069-A2EA-08002B30309D}
Microsoft Outlook | Microsoft Outlook | Shell:::{2559a1f5-21d7-11d4-bdaf-00c04f60b9f0}
Windows CardSpace | Windows CardSpace | Shell:::{78CB147A-98EA-4AA6-B0DF-C8681F69341C}
Windows SideShow | Windows SideShow | Shell:::{E95A4861-D57A-4be1-AD0F-35267E261739}
Автозапуск | AutoPlay | Shell:::{9C60DE1E-E5FC-40f4-A487-460851A8D915}
Автономные файлы | Offline Files | Shell:::{D24F75AA-4F2B-4D07-A3C4-469B3D9030C4}
Администрирование | Administrative Tools | Shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Архивация и восстановление | Backup and Restore | Shell:::{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}
Библиотеки | Libraries | Shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Биометрические устройства | Biometric Devices | Shell:::{0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}
Брандмауэр Windows | Windows Firewall | Shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423}
Восстановление | Recovery | Shell:::{9FE63AFD-59CF-4419-9775-ABCC3849F861}
Восстановление системы | System Restore | Shell:::{3f6bc534-dfa1-4ab4-ae54-ef25a74e0107}
Все задачи | All Tasks | Shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Все элементы панели управления | All Control Panel Items | Shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Выполнить | Run | Shell:::{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}
Гаджеты рабочего стола | Desktop Gadgets | Shell:::{37efd44d-ef8d-41b1-940d-96973a50e9e0}
Дата и Время | Date and Time | Shell:::{E2E7934B-DCE5-43C4-9576-7FE4F75E7480}
Датчик расположения и другие датчики | Location and Other Sensors | Shell:::{E9950154-C418-419e-A90A-20C5287AE24B}
Диспетчер устройств | Device Manager | Shell:::{74246bfc-4c96-11d0-abef-0020af6b0b7a}
Диспетчер учетных данных | Credential Manager | Shell:::{1206F5F1-0569-412C-8FEC-3204630DFB70}
Домашняя группа | HomeGroup | Shell:::{67CA7650-96E6-4FDD-BB43-A8E774F73A57}
Домашняя группа - папка | HomeGroup folder | Shell:::{6785BFAC-9D2D-4be5-B7E2-59937E8FB80A}
Защитник Windows | Windows Defender | Shell:::{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}
Звук | Sound | Shell:::{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}
Значки области уведомлений | Notification Area Icons | Shell:::{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}
Игровые устройства | Game Controllers | Shell:::{259EF4B1-E6C9-4176-B574-481532C9BCE8}
Игры | Games | Shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
Избранное | Favorites | Shell:::{323CA680-C24D-4099-B94D-446DD2D7249E}
Инфракрасная связь | Infrared | Shell:::{A0275511-0E86-4ECA-97C2-ECD8F1221D08}
Карта сети | Network Map | Shell:::{E7DE9B1A-7533-4556-9484-B26FB486475E}
Компоненты Windows | Windows Features | Shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Компьютер | Computer | Shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина | Recycle Bin | Shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Мои Документы | My Documents | Shell:::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Настройка доступа программ и умолчаний | Set Program access and Windows defaults | Shell:::{2559a1f7-21d7-11d4-bdaf-00c04f60b9f0}
Недавние места | Recent Places | Shell:::{22877a6d-37a1-461a-91b0-dbda5aaebc99}
Общие | Public | Shell:::{4336a54d-038b-4685-ab02-99bb52d3fb8b}
Панель управления (заданного Вами вида) | Control Panel | Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Панель управления (Категория) | Control Panel (Category) | Shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Параметры индексирования | Indexing Options | Shell:::{87D66A43-7B11-4A28-9811-C86EE395ACF7}
Параметры папок | Folder Options | Shell:::{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}
Параметры планшетного компьютера | Tablet PC Settings | Shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}
Параметры шрифта | Font settings | Shell:::{93412589-74D4-4E4E-AD0E-E0CB621440FD}
Переносные устройства | Portable Devices | Shell:::{35786D3C-B075-49b9-88DD-029876E11C01}
Перо и сенсорные устройства | Pen and Touch | Shell:::{F82DF8F7-8B9F-442E-A48C-818EA735FF9B}
Персонализация | Personalization | Shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | Shell:::{241D7C96-F8BF-4F85-B01F-E2B043341A4B}
Поиск Windows | Search | Shell:::{2559a1f0-21d7-11d4-bdaf-00c04f60b9f0}
Получение программ | Get Programs | Shell:::{15eae92e-f17a-4431-9f28-805e482dafd4}
Принтеры | Printers | Shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Приступая к работе | Getting Started | Shell:::{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}
Программы и компоненты | Programms and Features | Shell:::{7b81be6a-ce2b-4676-a29e-eb907a5126c5}
Программы по умолчанию | Default Programs | Shell:::{17cd9488-1228-4b2f-88ce-4298e93e0966}
Рабочий стол | Desktop | Shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}
Распознавание речи | Speech Recognition | Shell:::{58E3C745-D971-4081-9034-86E34B30836A}
Расположение по умолчанию | Default Location | Shell:::{00C6D95F-329C-409a-81D7-C46C66EA7F33}
Родительский контроль | Parental Controls | Shell:::{96AE8D84-A250-4520-95A5-A47A7E3C548B}
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | Shell:::{0DF44EAA-FF21-4412-828E-260A8728E7F1}
Свойства речи | Text to Speech | Shell:::{D17D1D6D-CC3F-4815-8FE3-607E7D5D10B3}
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | Shell:::{A304259D-52B8-4526-8B1A-A1D6CECC8243}
Свойства: Интернет | Internet Properties | Shell:::{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}
Свойства: Клавиатура | Keyboard Properties | Shell:::{725BE8F7-668E-4C7B-8F90-46BDB0936430}
Свойства: Мышь | Mouse Properties | Shell:::{6C8EEC18-8D75-41B2-A177-8831D59D2D50}
Сетевые подключения | Network Connections | Shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сетевые подключения в Области уведомления | Network Connections in Notification area | Shell:::{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}
Сеть | Network | Shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Система | System | Shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE}
Сканеры и камеры | Scanners and Cameras | Shell:::{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}
Соседние пользователи | People Near Me | Shell:::{5224F545-A443-4859-BA23-7B5A95BDC8EF}
Справка и Поддержка | Windows Help and Support | Shell:::{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}
Счетчики и средства производительности | Performance Information and Tools | Shell:::{78F3955E-3B90-4184-BD14-5397C15F1EFC}
Телефон и модем | Phone and Modem | Shell:::{40419485-C444-4567-851A-2DD7BFA1684D}
Управление беспроводными сетями | Manage Wireless networks | Shell:::{1FA9085F-25A2-489B-85D4-86326EEDCD87}
Управление цветом | Color Management | Shell:::{B2C761C6-29BC-4f19-9251-E6195265BAF1}
Установленные обновления | Installed Updates | Shell:::{d450a8a1-9568-45c7-9c0e-b4f9fb4537bd}
Устранение неполадок | Troubleshooting | Shell:::{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}
Устройства Bluetooth | Bluetooth Devices | Shell:::{28803F59-3A75-4058-995F-4EE5503B023C}
Устройства и принтеры | Devices and Printers | Shell:::{A8A91A66-3A7D-4424-8D24-04E180695C7A}
Учетные записи пользователей | User Accounts | Shell:::{60632754-c523-4b62-b45c-4172da012619}
Центр мобильности Windows | Windows Mobility Center | Shell:::{5ea4f148-308c-46d7-98a9-49041b1dd468}
Центр обновления Windows | Windows Update | Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
Центр поддержки | Action Center | Shell:::{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}
Центр синхронизации | Sync Center | Shell:::{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}
Центр специальных возможностей | Ease of Access Center | Shell:::{D555645E-D4F8-4c29-A827-D93C859C4F2A}
Центр управления сетями и общим доступом | Network and Sharing Center | Shell:::{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}
Шифрование диска BitLocker | BitLocker Drive Encryption | Shell:::{D9EF8727-CAC2-4e60-809E-86F80A666C91}
Экран (размер текста) | Display (size of text) | Shell:::{C555438B-3C23-4769-A71F-B6D3D9B6053A}
Электропитание | Power Options | Shell:::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Язык и региональные стандарты | Region and Language | Shell:::{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

Для некоторых системных папок, Вы можете создать их копии, в любом, необходимом для Вас месте. Такие папки не будут занимать место на диске, а будут служить символическими ссылками на оригинальные. Для создания такой папки-ссылки:

1) Создайте в любом нужном Вам месте новую папку (Щелчок ПКМ -> Создать -> Папку)
2) Переименуйте её следующим образом:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Принцип запуска команд Shell, используя имя объектов, намного легче. Данный способ не требует от Вас знания большого количества цифр и букв, и позволяет снизить величину ошибок при наборе команды. Его основное применение - открытие системных папок.

Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет в проводнике будет открыта папка: C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Для запуска любого из объектов Windows, используя его имя, применяется команда:
Shell:Имя объекта
Вы можете найти нужные Вам имена объектов в разделах ветки реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FolderDescriptions или воспользоваться таблицей №2.

Таблица №2.

Имя программы или папки | Адрес папки | Команда
32-разрядный Internet Explorer | C:\Program Files\Internet Explorer или C:\Program Files (x86)\Internet Explorer | shell:InternetFolder
Common Files (в 32-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommon
Common Files (в 64-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommonX64
Common Files (в 64-битной Windows 7) | C:\Program Files (x86)\Common Files | shell:ProgramFilesCommonX86
Cookies | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies | shell:Cookies
Credentials | C:\Users\User-Name\AppData\Roaming\Microsoft\Credentials | shell:CredentialManager
Crypto | C:\Users\User-Name\AppData\Roaming\Microsoft\Crypto | shell:CryptoKeys
DeviceMetadataStore | C:\ProgramData\Microsoft\Windows\DeviceMetadataStore | shell:Device Metadata Store
Documents | C:\Users\Public\Documents | shell:Common Documents
Fonts (шрифты) | C:\Windows\Fonts | shell:Fonts
Gadgets | C:\Program Files\Windows Sidebar\Gadgets | shell:default Gadgets
Gadgets | C:\Users\User-Name\AppData\Local\Microsoft\WindowsSidebar\Gadgets | shell:Gadgets
GameExplorer | C:\ProgramData\Microsoft\Windows\GameExplorer | shell:PublicGameTasks
GameExplorer (Обозреватель игр) | C:\Users\User-Name\AppData\Local\Microsoft\Windows\GameExplorer | shell:GameTasks
History | C:\Users\User-Name\AppData\Local\Microsoft\Windows\History | shell:History
ImplicitAppShortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts | shell:ImplicitAppShortcuts
Local | C:\Users\User-Name\AppData\Local | shell:Local AppData
LocalLow | C:\Users\User-Name\AppData\LocalLow | shell:LocalAppDataLow
Low | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies\Low | shell:Cookies\Low
Network Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\NetworkShortcuts | shell:NetHood
Printer Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\PrinterShortcuts | shell:PrintHood
Program Files | C:\Program Files | shell:ProgramFiles
Program Files (x86) (в 64-битной Windows 7) | C:\Program Files (x86) | shell:ProgramFilesX86
Program Files (в 64-битной Windows 7) | C:\Program Files | shell:ProgramFilesX64
ProgramData | C:\ProgramData | shell:Common AppData
Protect | C:\Users\User-Name\AppData\Roaming\Microsoft\Protect | shell:dpapiKeys
Quick Launch (Быстрый запуск) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch | shell:Quick Launch
Resources (содержит темы Windows) | C:\Windows\Resources | shell:ResourceDir
Ringtones | C:\ProgramData\Microsoft\Windows\Ringtones | shell:CommonRingtones
Roaming | C:\Users\User-Name\AppData\Roaming | shell:AppData
SendTo (элементы контекстного меню Отправить) | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\SendTo | shell:SendTo
System32 | C:\Windows\System32 | shell:System
SystemCertificates | C:\Users\User-Name\AppData\Roaming\Microsoft\SystemCertificates | shell:SystemCertificates
SysWOW64 | C:\Windows\SysWOW64 | shell:SystemX86
Templates | C:\ProgramData\Microsoft\Windows\Templates | shell:Common Templates
Templates | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Templates | shell:Templates
Temporary Internet Files | C:\Users\User-Name\AppData\Local\Microsoft\Windows\TemporaryInternet Files | shell:Cache
User Pinned (Закрепленные элементы) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned | shell:User Pinned
User-Name (файлы Вашей учетной записи) | C:\Users\User-Name | shell:UsersFilesFolder
User-Name (Ваш учетный профиль) | C:\Users\User-Name | shell:Profile
Windows (главная папка системы) | C:\Windows | shell:Windows
Автозагрузка | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup | shell:Common Startup
Автозагрузка | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup | shell:Startup
Администрирование | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Administrative Tools
Администрирование | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Common Administrative Tools
Библиотеки | Библиотеки | shell:Libraries
Библиотеки | Библиотеки | shell:UsersLibrariesFolder
Видео | Библиотеки\Видео | shell:VideosLibrary
Временная папка для записи | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Burn\Burn | shell:CD Burning
Все элементы панели управления | Панель управления\Все элементы панели управления | shell:ControlPanelFolder
Главное меню | C:\ProgramData\Microsoft\Windows\Start Menu | shell:Common Start Menu
Главное меню | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu | shell:Start Menu
Документы | Библиотеки\Документы | shell:DocumentsLibrary
Домашняя группа | Домашняя группа | shell:HomeGroupFolder
Загрузки | C:\Users\User-Name\Downloads | shell:downloads
Згрузки | C:\Users\Public\Downloads | shell:CommonDownloads
Игры | Игры | shell:Games
Избранное | C:\Users\User-Name\Favorites | shell:Favorites
Изображения | C:\Users\Public\Pictures | shell:CommonPictures
Изображения | C:\Users\User-Name\Pictures | shell:My Pictures
Изображения | Библиотеки\Изображения | shell:PicturesLibrary
Компьютер | Компьютер | shell:MyComputerFolder
Контакты | C:\Users\User-Name\Contacts | shell:Contacts
Конфликты | Панель управления\Все элементы панели управления\Центрсинхронизации\Конфликты | shell:ConflictFolder
Корзина | Корзина | shell:RecycleBinFolder
Мои видеозаписи | C:\Users\User-Name\Videos | shell:CommonVideo
Мои видеозаписи | C:\Users\User-Name\Videos | shell:My Video
Мои документы | C:\Users\User-Name\Documents | shell:Personal
Моя Музыка | C:\Users\Public\Music | shell:CommonMusic
Моя музыка | C:\Users\User-Name\Music | shell:My Music
Музыка | Библиотеки\Музыка | shell:MusicLibrary
Настройка синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Настройка синхронизации | shell:SyncSetupFolder
Недавние документы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Recent | shell:Recent
Образцы видео | C:\Users\Public\Videos\Sample Videos | shell:SampleVideos
Образцы изображений | C:\Users\Public\Pictures\Sample Pictures | shell:SamplePictures
Образцы музыки | C:\Users\Public\Music\Sample Music | shell:SampleMusic
Общие | C:\Users\Public | shell:Public
Папка с рингтонами Windows 7 | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Ringtones | shell:Ringtones
Поиск Windows | search-ms: | shell:SearchHomeFolder
Поиски (информация о поисках) | C:\Users\User-Name\Searches | shell:Searches
Получение программ | Панель управления\Все элементы панели управления\Получение программ | shell:AddNewProgramsFolder
Пользователи | C:\Users | shell:UserProfiles
Принтеры | Все элементы панели управления\Принтеры | shell:PrintersFolder
Программы | C:\ProgramData\Microsoft\Windows\Start Menu\Programs | shell:Common Programs
Программы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu\Programs | shell:Programs
Программы и компоненты | Панель управления\Все элементы панели управления\Программы и компоненты | shell:ChangeRemoveProgramsFolder
Рабочий стол | C:\Users\Public\Desktop | shell:Common Desktop
Рабочий стол | C:\Users\User-Name\Desktop | shell:desktop
Результаты синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Результаты синхронизации | shell:SyncResultsFolder
Сетевые подключения | Панель управления\Все элементы панели управления\Сетевые подключения | shell:ConnectionsFolder
Сеть | Сеть | shell:NetworkPlacesFolder
Сохраненные игры | C:\Users\User-Name\Saved Games | shell:SavedGames
Ссылки | C:\Users\User-Name\Links | shell:Links
Установленные обновления | Программы и компоненты\Установленные обновления | shell:AppUpdatesFolder
Центр синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации | shell:SyncCenterFolder

16. Добавление элементов в контекстное меню "Отправить".

При попытке открыть более 15 элементов сразу используя меню, вызываемое правой кнопкой мыши в Проводнике, пункт меню Открыть пропадет. Если Вам необходимо открыть большее количество элементов одновременно, то Вы можете сделать это добавив нужную Вам программу в контекстное меню "Отправить".
Чтобы добавить свою программу в контекстное меню "Отправить". Сделайте следующее:

1) Откройте папку C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo , где UserName - Ваше имя пользователя.
Также Вы можете открыть данную папку так:
1.1) В адресной строке Проводника введите команду shell:SendTo и нажмите Enter.
1.2) Нажмите Win+R, введите команду shell:SendTo и нажмите Enter.
2) Создайте в открывшейся папке ярлык для необходимой Вам программы:
2.1) Используйте меню, вызываемое правой кнопкой мыши. Создать -> Ярлык -> Укажите расположение программы -> Введите имя ярлыка
2.2) Удерживая нажатой клавишу Alt скопируйте Вашу программу в вышеуказанную папку и переименуйте ярлык.

17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

Скопируйте необходимый Вам ярлык в папку C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Windows\Network Shortcuts
где Имя пользователя - это имя Вашей учетной записи (Например: Администратор).

18. Замена элементов в диалоговом окне открытия/сохранения файлов.

Вы можете заменить стандартные папки из диалогового окна открытия/сохранения файлов на указанные Вами.

1) Откройте меню Пуск
2) В строке поиска введите gpedit.msc
3) Откройте папку Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Проводник Windows.\Общее диалоговое окно открытия файлов
4) Сделайте двойной щелчок мышью на Элементы, отображаемые в панели мест
5) Установите переключатель на значение Включить
6) Введите в текстовых полях напротив Элементов, пути к папкам и нажмите ОК.
Для добавления папки Рабочий стол необходимо ввести: shell:desktop


1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново. Чтобы выключить гибернацию, запустите командную строку с правами администратора и выполните: powercfg /h off Чтобы включить: powercfg /h on
Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

Отключаем ее:
1. Создайте пустой текстовый файл,
2. Скопируйте в него powercfg -h off,
3. При сохранении изменить расширение "TXT" на "CMD",
4. Запустите его как обычную программу,
5. Перезагрузка.

Также Вы можете запустить командную строку с правами администратора (Нажать Win+R, ввести Cmd и нажать Ok) и выполнить в ней данную команду:
powercfg /h off

Назад на страницу раздела Тонкие настройки.


2. Как скрыть значок "Центр действий" в трее возле часов?

1) Пройдите Пуск\Панель управления\Значки области уведомлений
2) Выберите значки которые хотите скрыть и нажмите Ok

Назад на страницу раздела Тонкие настройки.


3. Как убрать текст под значком ярлыка или файла?

1) Щелкните правой кнопкой мыши на иконке.
2) Кликните Переименовать.
3) Удерживая клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
Если вы захотите переименовать несколько ярлыков, то, когда вы будете переименовывать следующий, вам потребуется нажать Alt и ввести 255 дважды. Так для третьего значка вам потребуется ввести ALT+255, ALT+255, ALT+255.

Назад на страницу раздела Тонкие настройки.


4. Создаем (восстанавливаем) панель быстрого запуска (Quick Launch).

1) Правой кнопкой по панели задач ->Панели(Toolbars )-->Создать панель инструментов(New Toolbar)-->
2) Выберите папку: %appdata%\Microsoft\Internet Explorer\Quick Launch
3) Нажмите кнопку выбора папки “Select Folder”.
4) Правой кнопкой на панели задач -> снять галку "Закрепить панель задач";
5) Правой кнопкой мыши на появившемся "quick launch"--->убираем галки с "Показывать подписи" и "Показывать заголовок"
6) Перетаскиваем в левую сторону и закрепляем обратно панель --->Все!

Назад на страницу раздела Тонкие настройки.


5. Удаление или разблокирование для замены любого файла защищённого Windows.

1. Качаем и устанавливаем программу Unlocker
2. Копируем файл(ы) в буфер обмена, для дальнейшей замены.
3. С помощью программы Unlocker, удаляем заменяемый(е) файл(ы).
4. После удаления файла(ов), вставляем заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления) и перезагружаем компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, переходим к папке C:\Windows\rescache и с помощью этой же программы Unlocker удаляем её содержимое. Перезагружаемся.

Для 64-битных систем аналогом является программа LockHunter 64-bit.

Назад на страницу раздела Тонкие настройки.


6. Убираем лишние надписи на рабочем столе.

Открываете с помощью Restorator или PE Explorer файлы C:\Windows\System32\ru-RU\user32.dll.mui и C:\Windows\System32\en-US\user32.dll.mui и в строковой таблице удаляем строчки с 715 по 718 включительно и строки 737 и 738 , для того чтобы лишних надписей на рабочем столе не было.

715 %wsWindows %ws
716 %ws Сборка %ws
717 Пробная копия.
718 Только для тестов.

737 Ваша копия Windows не является подлинной
738 Тестовый режим

Назад на страницу раздела Тонкие настройки.


7. Смена названия операционной системы из Максимальная на Ultimate.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

Назад на страницу раздела Тонкие настройки.


8. Использование всей доступной оперативной памяти.

8. Использование всей оперативной памяти в 32-битных Windows.

Данная программа добавляет второе ядро для загрузки операционной системы: ntkr128g.exe

1) Скачать здесь автоскрипт от deepxw.
2) 3апустить ReadyFor4GB.exe
3) Нажать на кнопку Check, затем на кнопку Apply.
4) Перезагрузить компьютер и вам станут доступны все 4 ГБ оперативки на вашей установленной ОС Windows 7 (x86), или если у вас установлено более >4ГБ, то ваш объем Оперативной памяти также станет доступен в полном объеме без ограничений...

Примечание: Файлы обязательно запускать как администратор, запускайте этот скрипт строго в операционной системе Windows 7 x86 (32-Bit) для которой вам нужно снять ограничение.

Статья (на английском), объясняющая принцип работы данной программы: http://www.geoffchappell.com/viewer.htm?doc=notes/windows/license/memory.htm

Назад на страницу раздела Тонкие настройки.


9. Изменение папки открываемой по умолчанию в Проводнике.

Настраиваем нажатие на кнопку Проводник (Windows Explorer), чтобы оно приводило в указанную Вами папку, вместо Libraries.

1) Нажмите правой кнопкой мыши на значок Проводника в Панели задач.
2) Нажмите правой кнопкой мыши на Проводник
3) Нажмите левой кнопкой мыши на Свойства
4) Измените поле Объект (Target) на %SystemRoot%\explorer.exe /n, /e, С:\My Folder
где C:\My Folder - путь к Вашей папке.
Для запуска папки Компьютер измените на значение: %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Пуск, то вам потребуется изменить поле Объект в свойствах ярлыка Проводник в папке Стандартные (Accessories) из меню Пуск.
Комбинация клавиш Win+E откроет Проводник в «Компьютере»

Назад на страницу раздела Тонкие настройки.


10. Добавление или прямой запуск папки Все задачи (для разработчиков и тестеров), и других системных папок.

10. Добавление или прямой запуск папки Все задачи (для разработчиков и тестеров).

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

Назад на страницу раздела Тонкие настройки.


11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

Назад на страницу раздела Тонкие настройки.


12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:
1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:
shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
2) Нажимаете ПКМ -> Создать -> Библиотека
3) Переименовываете её. Например: Обои для рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки,в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Скачать данную программу можно здесь или здесь

Назад на страницу раздела Тонкие настройки.


13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.

Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

Для установки необходимы права локального администратора.

1) Скачайте архив MouseRate.zip и распакуйте его в папку.
2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
5) Откройте папку HIDUSBF
6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
8) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Если у Вас появится сообщение о неподписанных драйверах - не волнуйтесь, все нормально. Подпишем его программой Driver Signature Enforcement Overrider, о которой упоминалось в совете Как добавить подпись к драйверам? из раздела Установка. На время её работы UAC(Контроль учетных записей пользователей) в Windows должен быть отключен.

1) Запустите файл dseo13b.exe из папки Driver Signature Enforcement Overrider и выберите там "Enable Test Mode".
2) Перезапустите компьютер.
3) После перезапуска снова откройте файл dseo13b.exe и выберите "Sign a system file".
4) В окне пропишите: "C:\Windows\System32\Drivers\HIDUSBF.sys". Если вы сделали это правильно, то вы увидите сообщение: "Система была подписана успешно" ("The system file has been signed succesfully")
5) Снова перезапустите компьютер.
6) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
7) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Назад на страницу раздела Тонкие настройки.


14. Перемещение системных папок и изменение их путей.

Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящимися в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей продеайте следующее:

1) Создайте новую папку, желательно с аналогичным перемещаемой папке наименованием.
2) Откройте в Windows Explorer: Рабочий стол\Ваш Профиль (Например: Рабочий стол\Администратор)
3) Щелкните правой кнопкой мыши на название папки, которую Вы собираетесь переместить (Например: Мои Документы) и выберите Свойства.
4) Откройте вкладку Расположение
5) Нажмите кнопку Переместить и укажите путь к созданной Вами новой папке
6) Далее система спросит Вас: Переместить все файлы из старого расположения в новое? (Рекомендуемый ответ - Да)
7) Соглашаетесь с новыми параметрами применяя их и выходите.
8) Перезагружаете Компьютер.

Назад на страницу раздела Тонкие настройки.


15. Запуск команд Windows Shell, используя названия и {GUID} объектов.

Microsoft Windows Shell - интерпретатор команд операционной системы (ОС), обеспечивающий интерфейс для взаимодействия пользователя с функциями системы. Позволяет получить доступ к диалоговым окнам, к файловой системе, запускать программы и изменять системные настройки.
Для быстрого перехода к компонентам Windows используется команда shell.
GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Использование GUID гарантирует, что две версии одного компонента могут иметь одно и то же имя, но быть отличимыми по GUID. Microsoft применяет GUID в качестве идентификаторов для большого количества своих объектов. Зная GUID Вы сможете открыть многие компоненты Windows: элементы Панели управления, системные папки, различные программы и настройки.

Для запуска любого из объектов Windows, используя {GUID}, применяется команда:
Shell:::{GUID}
где {GUID} - идентификатор {GUID} нужного Вам объекта. Например, для запуска Панели управления наберите команду:
Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Вы можете поискать нужные Вам {GUID} в разделе реестра HKEY_CLASSES_ROOT\CLSID или воспользоваться таблицей №1.

Таблица №1.

Русское название элемента | Английское название элемента | Команда
Flip 3D (Win+Tab) | Flip 3D (Win+Tab) | Shell:::{3080F90E-D7AD-11D9-BD98-0000947B0257}
Fusion Cache | Fusion Cache | Shell:::{1D2680C9-0E2A-469d-B787-065558BC7D43}
Internet Explorer | Internet Explorer | Shell:::{871C5380-42A0-1069-A2EA-08002B30309D}
Microsoft Outlook | Microsoft Outlook | Shell:::{2559a1f5-21d7-11d4-bdaf-00c04f60b9f0}
Windows CardSpace | Windows CardSpace | Shell:::{78CB147A-98EA-4AA6-B0DF-C8681F69341C}
Windows SideShow | Windows SideShow | Shell:::{E95A4861-D57A-4be1-AD0F-35267E261739}
Автозапуск | AutoPlay | Shell:::{9C60DE1E-E5FC-40f4-A487-460851A8D915}
Автономные файлы | Offline Files | Shell:::{D24F75AA-4F2B-4D07-A3C4-469B3D9030C4}
Администрирование | Administrative Tools | Shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Архивация и восстановление | Backup and Restore | Shell:::{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}
Библиотеки | Libraries | Shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Биометрические устройства | Biometric Devices | Shell:::{0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}
Брандмауэр Windows | Windows Firewall | Shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423}
Восстановление | Recovery | Shell:::{9FE63AFD-59CF-4419-9775-ABCC3849F861}
Восстановление системы | System Restore | Shell:::{3f6bc534-dfa1-4ab4-ae54-ef25a74e0107}
Все задачи | All Tasks | Shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Все элементы панели управления | All Control Panel Items | Shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Выполнить | Run | Shell:::{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}
Гаджеты рабочего стола | Desktop Gadgets | Shell:::{37efd44d-ef8d-41b1-940d-96973a50e9e0}
Дата и Время | Date and Time | Shell:::{E2E7934B-DCE5-43C4-9576-7FE4F75E7480}
Датчик расположения и другие датчики | Location and Other Sensors | Shell:::{E9950154-C418-419e-A90A-20C5287AE24B}
Диспетчер устройств | Device Manager | Shell:::{74246bfc-4c96-11d0-abef-0020af6b0b7a}
Диспетчер учетных данных | Credential Manager | Shell:::{1206F5F1-0569-412C-8FEC-3204630DFB70}
Домашняя группа | HomeGroup | Shell:::{67CA7650-96E6-4FDD-BB43-A8E774F73A57}
Домашняя группа - папка | HomeGroup folder | Shell:::{6785BFAC-9D2D-4be5-B7E2-59937E8FB80A}
Защитник Windows | Windows Defender | Shell:::{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}
Звук | Sound | Shell:::{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}
Значки области уведомлений | Notification Area Icons | Shell:::{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}
Игровые устройства | Game Controllers | Shell:::{259EF4B1-E6C9-4176-B574-481532C9BCE8}
Игры | Games | Shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
Избранное | Favorites | Shell:::{323CA680-C24D-4099-B94D-446DD2D7249E}
Инфракрасная связь | Infrared | Shell:::{A0275511-0E86-4ECA-97C2-ECD8F1221D08}
Карта сети | Network Map | Shell:::{E7DE9B1A-7533-4556-9484-B26FB486475E}
Компоненты Windows | Windows Features | Shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Компьютер | Computer | Shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина | Recycle Bin | Shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Мои Документы | My Documents | Shell:::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Настройка доступа программ и умолчаний | Set Program access and Windows defaults | Shell:::{2559a1f7-21d7-11d4-bdaf-00c04f60b9f0}
Недавние места | Recent Places | Shell:::{22877a6d-37a1-461a-91b0-dbda5aaebc99}
Общие | Public | Shell:::{4336a54d-038b-4685-ab02-99bb52d3fb8b}
Панель управления (заданного Вами вида) | Control Panel | Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Панель управления (Категория) | Control Panel (Category) | Shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Параметры индексирования | Indexing Options | Shell:::{87D66A43-7B11-4A28-9811-C86EE395ACF7}
Параметры папок | Folder Options | Shell:::{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}
Параметры планшетного компьютера | Tablet PC Settings | Shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}
Параметры шрифта | Font settings | Shell:::{93412589-74D4-4E4E-AD0E-E0CB621440FD}
Переносные устройства | Portable Devices | Shell:::{35786D3C-B075-49b9-88DD-029876E11C01}
Перо и сенсорные устройства | Pen and Touch | Shell:::{F82DF8F7-8B9F-442E-A48C-818EA735FF9B}
Персонализация | Personalization | Shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | Shell:::{241D7C96-F8BF-4F85-B01F-E2B043341A4B}
Поиск Windows | Search | Shell:::{2559a1f0-21d7-11d4-bdaf-00c04f60b9f0}
Получение программ | Get Programs | Shell:::{15eae92e-f17a-4431-9f28-805e482dafd4}
Принтеры | Printers | Shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Приступая к работе | Getting Started | Shell:::{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}
Программы и компоненты | Programms and Features | Shell:::{7b81be6a-ce2b-4676-a29e-eb907a5126c5}
Программы по умолчанию | Default Programs | Shell:::{17cd9488-1228-4b2f-88ce-4298e93e0966}
Рабочий стол | Desktop | Shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}
Распознавание речи | Speech Recognition | Shell:::{58E3C745-D971-4081-9034-86E34B30836A}
Расположение по умолчанию | Default Location | Shell:::{00C6D95F-329C-409a-81D7-C46C66EA7F33}
Родительский контроль | Parental Controls | Shell:::{96AE8D84-A250-4520-95A5-A47A7E3C548B}
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | Shell:::{0DF44EAA-FF21-4412-828E-260A8728E7F1}
Свойства речи | Text to Speech | Shell:::{D17D1D6D-CC3F-4815-8FE3-607E7D5D10B3}
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | Shell:::{A304259D-52B8-4526-8B1A-A1D6CECC8243}
Свойства: Интернет | Internet Properties | Shell:::{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}
Свойства: Клавиатура | Keyboard Properties | Shell:::{725BE8F7-668E-4C7B-8F90-46BDB0936430}
Свойства: Мышь | Mouse Properties | Shell:::{6C8EEC18-8D75-41B2-A177-8831D59D2D50}
Сетевые подключения | Network Connections | Shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сетевые подключения в Области уведомления | Network Connections in Notification area | Shell:::{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}
Сеть | Network | Shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Система | System | Shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE}
Сканеры и камеры | Scanners and Cameras | Shell:::{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}
Соседние пользователи | People Near Me | Shell:::{5224F545-A443-4859-BA23-7B5A95BDC8EF}
Справка и Поддержка | Windows Help and Support | Shell:::{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}
Счетчики и средства производительности | Performance Information and Tools | Shell:::{78F3955E-3B90-4184-BD14-5397C15F1EFC}
Телефон и модем | Phone and Modem | Shell:::{40419485-C444-4567-851A-2DD7BFA1684D}
Управление беспроводными сетями | Manage Wireless networks | Shell:::{1FA9085F-25A2-489B-85D4-86326EEDCD87}
Управление цветом | Color Management | Shell:::{B2C761C6-29BC-4f19-9251-E6195265BAF1}
Установленные обновления | Installed Updates | Shell:::{d450a8a1-9568-45c7-9c0e-b4f9fb4537bd}
Устранение неполадок | Troubleshooting | Shell:::{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}
Устройства Bluetooth | Bluetooth Devices | Shell:::{28803F59-3A75-4058-995F-4EE5503B023C}
Устройства и принтеры | Devices and Printers | Shell:::{A8A91A66-3A7D-4424-8D24-04E180695C7A}
Учетные записи пользователей | User Accounts | Shell:::{60632754-c523-4b62-b45c-4172da012619}
Центр мобильности Windows | Windows Mobility Center | Shell:::{5ea4f148-308c-46d7-98a9-49041b1dd468}
Центр обновления Windows | Windows Update | Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
Центр поддержки | Action Center | Shell:::{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}
Центр синхронизации | Sync Center | Shell:::{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}
Центр специальных возможностей | Ease of Access Center | Shell:::{D555645E-D4F8-4c29-A827-D93C859C4F2A}
Центр управления сетями и общим доступом | Network and Sharing Center | Shell:::{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}
Шифрование диска BitLocker | BitLocker Drive Encryption | Shell:::{D9EF8727-CAC2-4e60-809E-86F80A666C91}
Экран (размер текста) | Display (size of text) | Shell:::{C555438B-3C23-4769-A71F-B6D3D9B6053A}
Электропитание | Power Options | Shell:::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Язык и региональные стандарты | Region and Language | Shell:::{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

Для некоторых системных папок, Вы можете создать их копии, в любом, необходимом для Вас месте. Такие папки не будут занимать место на диске, а будут служить символическими ссылками на оригинальные. Для создания такой папки-ссылки:

1) Создайте в любом нужном Вам месте новую папку (Щелчок ПКМ -> Создать -> Папку)
2) Переименуйте её следующим образом:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Принцип запуска команд Shell, используя имя объектов, намного легче. Данный способ не требует от Вас знания большого количества цифр и букв, и позволяет снизить величину ошибок при наборе команды. Его основное применение - открытие системных папок.

Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет в проводнике будет открыта папка: C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Для запуска любого из объектов Windows, используя его имя, применяется команда:
Shell:Имя объекта
Вы можете найти нужные Вам имена объектов в разделах ветки реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FolderDescriptions или воспользоваться таблицей №2.

Таблица №2.

Имя программы или папки | Адрес папки | Команда
32-разрядный Internet Explorer | C:\Program Files\Internet Explorer или C:\Program Files (x86)\Internet Explorer | shell:InternetFolder
Common Files (в 32-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommon
Common Files (в 64-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommonX64
Common Files (в 64-битной Windows 7) | C:\Program Files (x86)\Common Files | shell:ProgramFilesCommonX86
Cookies | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies | shell:Cookies
Credentials | C:\Users\User-Name\AppData\Roaming\Microsoft\Credentials | shell:CredentialManager
Crypto | C:\Users\User-Name\AppData\Roaming\Microsoft\Crypto | shell:CryptoKeys
DeviceMetadataStore | C:\ProgramData\Microsoft\Windows\DeviceMetadataStore | shell:Device Metadata Store
Documents | C:\Users\Public\Documents | shell:Common Documents
Fonts (шрифты) | C:\Windows\Fonts | shell:Fonts
Gadgets | C:\Program Files\Windows Sidebar\Gadgets | shell:default Gadgets
Gadgets | C:\Users\User-Name\AppData\Local\Microsoft\WindowsSidebar\Gadgets | shell:Gadgets
GameExplorer | C:\ProgramData\Microsoft\Windows\GameExplorer | shell:PublicGameTasks
GameExplorer (Обозреватель игр) | C:\Users\User-Name\AppData\Local\Microsoft\Windows\GameExplorer | shell:GameTasks
History | C:\Users\User-Name\AppData\Local\Microsoft\Windows\History | shell:History
ImplicitAppShortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts | shell:ImplicitAppShortcuts
Local | C:\Users\User-Name\AppData\Local | shell:Local AppData
LocalLow | C:\Users\User-Name\AppData\LocalLow | shell:LocalAppDataLow
Low | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies\Low | shell:Cookies\Low
Network Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\NetworkShortcuts | shell:NetHood
Printer Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\PrinterShortcuts | shell:PrintHood
Program Files | C:\Program Files | shell:ProgramFiles
Program Files (x86) (в 64-битной Windows 7) | C:\Program Files (x86) | shell:ProgramFilesX86
Program Files (в 64-битной Windows 7) | C:\Program Files | shell:ProgramFilesX64
ProgramData | C:\ProgramData | shell:Common AppData
Protect | C:\Users\User-Name\AppData\Roaming\Microsoft\Protect | shell:dpapiKeys
Quick Launch (Быстрый запуск) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch | shell:Quick Launch
Resources (содержит темы Windows) | C:\Windows\Resources | shell:ResourceDir
Ringtones | C:\ProgramData\Microsoft\Windows\Ringtones | shell:CommonRingtones
Roaming | C:\Users\User-Name\AppData\Roaming | shell:AppData
SendTo (элементы контекстного меню Отправить) | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\SendTo | shell:SendTo
System32 | C:\Windows\System32 | shell:System
SystemCertificates | C:\Users\User-Name\AppData\Roaming\Microsoft\SystemCertificates | shell:SystemCertificates
SysWOW64 | C:\Windows\SysWOW64 | shell:SystemX86
Templates | C:\ProgramData\Microsoft\Windows\Templates | shell:Common Templates
Templates | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Templates | shell:Templates
Temporary Internet Files | C:\Users\User-Name\AppData\Local\Microsoft\Windows\TemporaryInternet Files | shell:Cache
User Pinned (Закрепленные элементы) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned | shell:User Pinned
User-Name (файлы Вашей учетной записи) | C:\Users\User-Name | shell:UsersFilesFolder
User-Name (Ваш учетный профиль) | C:\Users\User-Name | shell:Profile
Windows (главная папка системы) | C:\Windows | shell:Windows
Автозагрузка | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup | shell:Common Startup
Автозагрузка | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup | shell:Startup
Администрирование | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Administrative Tools
Администрирование | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Common Administrative Tools
Библиотеки | Библиотеки | shell:Libraries
Библиотеки | Библиотеки | shell:UsersLibrariesFolder
Видео | Библиотеки\Видео | shell:VideosLibrary
Временная папка для записи | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Burn\Burn | shell:CD Burning
Все элементы панели управления | Панель управления\Все элементы панели управления | shell:ControlPanelFolder
Главное меню | C:\ProgramData\Microsoft\Windows\Start Menu | shell:Common Start Menu
Главное меню | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu | shell:Start Menu
Документы | Библиотеки\Документы | shell:DocumentsLibrary
Домашняя группа | Домашняя группа | shell:HomeGroupFolder
Загрузки | C:\Users\User-Name\Downloads | shell:downloads
Згрузки | C:\Users\Public\Downloads | shell:CommonDownloads
Игры | Игры | shell:Games
Избранное | C:\Users\User-Name\Favorites | shell:Favorites
Изображения | C:\Users\Public\Pictures | shell:CommonPictures
Изображения | C:\Users\User-Name\Pictures | shell:My Pictures
Изображения | Библиотеки\Изображения | shell:PicturesLibrary
Компьютер | Компьютер | shell:MyComputerFolder
Контакты | C:\Users\User-Name\Contacts | shell:Contacts
Конфликты | Панель управления\Все элементы панели управления\Центрсинхронизации\Конфликты | shell:ConflictFolder
Корзина | Корзина | shell:RecycleBinFolder
Мои видеозаписи | C:\Users\User-Name\Videos | shell:CommonVideo
Мои видеозаписи | C:\Users\User-Name\Videos | shell:My Video
Мои документы | C:\Users\User-Name\Documents | shell:Personal
Моя Музыка | C:\Users\Public\Music | shell:CommonMusic
Моя музыка | C:\Users\User-Name\Music | shell:My Music
Музыка | Библиотеки\Музыка | shell:MusicLibrary
Настройка синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Настройка синхронизации | shell:SyncSetupFolder
Недавние документы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Recent | shell:Recent
Образцы видео | C:\Users\Public\Videos\Sample Videos | shell:SampleVideos
Образцы изображений | C:\Users\Public\Pictures\Sample Pictures | shell:SamplePictures
Образцы музыки | C:\Users\Public\Music\Sample Music | shell:SampleMusic
Общие | C:\Users\Public | shell:Public
Папка с рингтонами Windows 7 | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Ringtones | shell:Ringtones
Поиск Windows | search-ms: | shell:SearchHomeFolder
Поиски (информация о поисках) | C:\Users\User-Name\Searches | shell:Searches
Получение программ | Панель управления\Все элементы панели управления\Получение программ | shell:AddNewProgramsFolder
Пользователи | C:\Users | shell:UserProfiles
Принтеры | Все элементы панели управления\Принтеры | shell:PrintersFolder
Программы | C:\ProgramData\Microsoft\Windows\Start Menu\Programs | shell:Common Programs
Программы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu\Programs | shell:Programs
Программы и компоненты | Панель управления\Все элементы панели управления\Программы и компоненты | shell:ChangeRemoveProgramsFolder
Рабочий стол | C:\Users\Public\Desktop | shell:Common Desktop
Рабочий стол | C:\Users\User-Name\Desktop | shell:desktop
Результаты синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Результаты синхронизации | shell:SyncResultsFolder
Сетевые подключения | Панель управления\Все элементы панели управления\Сетевые подключения | shell:ConnectionsFolder
Сеть | Сеть | shell:NetworkPlacesFolder
Сохраненные игры | C:\Users\User-Name\Saved Games | shell:SavedGames
Ссылки | C:\Users\User-Name\Links | shell:Links
Установленные обновления | Программы и компоненты\Установленные обновления | shell:AppUpdatesFolder
Центр синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации | shell:SyncCenterFolder

Назад на страницу раздела Тонкие настройки.


16. Добавление элементов в контекстное меню "Отправить".

При попытке открыть более 15 элементов сразу используя меню, вызываемое правой кнопкой мыши в Проводнике, пункт меню Открыть пропадет. Если Вам необходимо открыть большее количество элементов одновременно, то Вы можете сделать это добавив нужную Вам программу в контекстное меню "Отправить".
Чтобы добавить свою программу в контекстное меню "Отправить". Сделайте следующее:

1) Откройте папку C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo , где UserName - Ваше имя пользователя.
Также Вы можете открыть данную папку так:
1.1) В адресной строке Проводника введите команду shell:SendTo и нажмите Enter.
1.2) Нажмите Win+R, введите команду shell:SendTo и нажмите Enter.
2) Создайте в открывшейся папке ярлык для необходимой Вам программы:
2.1) Используйте меню, вызываемое правой кнопкой мыши. Создать -> Ярлык -> Укажите расположение программы -> Введите имя ярлыка
2.2) Удерживая нажатой клавишу Alt скопируйте Вашу программу в вышеуказанную папку и переименуйте ярлык.

Назад на страницу раздела Тонкие настройки.


17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

Скопируйте необходимый Вам ярлык в папку C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Windows\Network Shortcuts
где Имя пользователя - это имя Вашей учетной записи (Например: Администратор).

Назад на страницу раздела Тонкие настройки.


18. Замена элементов в диалоговом окне открытия/сохранения файлов.

Вы можете заменить стандартные папки из диалогового окна открытия/сохранения файлов на указанные Вами.

1) Откройте меню Пуск
2) В строке поиска введите gpedit.msc
3) Откройте папку Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Проводник Windows.\Общее диалоговое окно открытия файлов
4) Сделайте двойной щелчок мышью на Элементы, отображаемые в панели мест
5) Установите переключатель на значение Включить
6) Введите в текстовых полях напротив Элементов, пути к папкам и нажмите ОК.
Для добавления папки Рабочий стол необходимо ввести: shell:desktop

Назад на страницу раздела Тонкие настройки.


Виртуализация

1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

VHD (Virtual Hard Disk) - это формат файлов, используемых виртуальными машинами для эмуляции жесткого диска. Вы сможете создать себе виртуальный диск и использовать его для хранения виртуальных операционных систем, программ и других файлов в одном файле-образе, который можно открыть различными программами виртуализации или виртуальными машинами. Виртуальные жесткие диски позволяют нескольким операционным системам одновременно находиться на одном компьютере.

Вариант 1. Работа с виртуальными дисками используя графический интерфейс.

Создание виртуального жесткого диска.

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
3) Откроется оснастка "Управление дисками". В панели меню выберите пункт Действие и нажмите на Создать виртуальный жесткий диск

Рисунок 1 из 13

4) В открывшемся окне укажите:

Рисунок 2 из 13

4.1) Имя файла и его расположение. Вы можете как написать это вручную, так и нажав на кнопку Обзор и воспользовавшись диалоговым окном Просмотр файлов виртуального диска
4.2) Размер виртуального диска. Возле текстового поля, в которое нужно ввести размер диска, присутствует раскрывающийся список, где можно выбрать размер жесткого диска. Доступные значения – мегабайты, гигабайты и терабайты. Создайте размер не меньше 20 ГБ.
4.3) Тип виртуального диска. Динамически расширяемый дисковый образ обеспечивает объем пространства, необходимый для хранения данных.
Размер VHD-файла в момент создания диска небольшой, но увеличивается по мере добавления данных на диск. Распределение данных осуществляется в блоках. При удалении данных с виртуального жесткого диска размер VHD-файла автоматически не уменьшается. Фиксированный размер создает VHD-файл, размер которого задается при создании виртуального жесткого диска. Размер VHD-файла остается постоянным независимо от объема хранимых данных.
5) Нажмите на кнопку «ОК».

Чтобы диспетчер локальных дисков смог получить доступ к созданному Вами виртуальному диску его необходимо инициализировать и создать на нем простой том. Для этого также используется оснастка "Управление дисками".

Инициализация виртуального жесткого диска.

1) Найдите Ваш виртуальный диск и щелкните на нем правой кнопкой мыши
2) Нажмите на пункт Инициализировать диск

Рисунок 3 из 13

3) Выберите стиль разделов - MBR и нажмите OK

Рисунок 4 из 13

Создание простого тома на виртуальном жестком диске.

После того как Вы проинициализировали Ваш виртуальный диск, на нем необходимо создать простой том.

1) Найдите Ваш виртуальный диск и щелкните на нераспределенной области справа от него
2) Нажмите на пункт Создать простой том

Рисунок 5 из 13

3) В первом диалоге Мастера создания простого тома нажмите на кнопку Далее
4) В диалоге указания размера тома, укажите размер будущего тома в мегабайтах и нажмите на кнопку Далее

Рисунок 6 из 13

5) В диалоге Назначение буквы диска или пути укажите букву для будущего диска и нажмите на кнопку Далее

Рисунок 7 из 13

6) В диалоге Форматирование раздела укажите нужную файловую систему, размер кластера, название диска и установите флажок возле опции Быстрое форматирование - для того, чтобы диск был сразу отформатирован. После чего нажмите на кнопку Далее

Рисунок 8 из 13

7) Для принятия всех настроенных параметров в диалоге Завершение мастера создания простого тома нажмите на кнопку Готово.
8) Виртуальный диск появится в таблице дисков. В оснастке управления дисками, значок виртуального диска визуально отличается от значков физических дисков. В проводнике Windows виртуальные диски выглядят так же, как и физические.

Рисунок 9 из 13

Присоединение виртуального жесткого диска.

Если у Вас уже имеется созданный виртуальный жесткий диск, то Вы также можете присоединить его в оснастке "Управление дисками".

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
3) В панели меню выберите пункт Действие и нажмите на Присоединить виртуальный жесткий диск.

Рисунок 10 из 13

4) Укажите расположение для виртуального жесткого диска на компьютере и нажмите OK Указать расположение Вы можете либо введя значение вручную, либо нажав на кнопку Обзор, и используя диалоговое окно Просмотр файлов виртуального диска. Если Вам не нужно записывать данные на диск, то в этом диалоге можно установить флажок Только для чтения.

Рисунок 11 из 13

Отсоединение (удаление) виртуального жесткого диска.

1) Найдите виртуальный диск, который хотите отсоединить, нажмите на нем правой кнопкой мыши
2) Нажмите на пункт Отсоединить виртуальный жесткий диск

Рисунок 12 из 13

3) Если Вы желаете отсоединить виртуальный диск без удаления его из системы, то нажмите OK. Для полного удаления диска из системы, отметьте Удалить виртуальный диск после удаления диска и после этого нажмите OK.

Рисунок 13 из 13

Вариант 2. Работа с виртуальными дисками используя программу Diskpart в командной строке.

Создание виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для создания виртуального диска воспользуйтесь командой Create Vdisk. Синтаксис команды следующий:
Create Vdisk File=<"имя_файла"> Maximum= [Type={Fixed|Expandable}] [Source=<"имя_файла">]
Где:

File=<"имя_файла"> - Указание полного пути и имени файла виртуального диска.
Maximum=<n> - Максимальное дисковое пространство, предоставляемое виртуальным диском, заданное в мегабайтах (МБ).
[Type={Fixed|Expandable}] - Используется для указания формата виртуального диска. Существует два значения для данного параметра:
Fixed создает файл виртуального диска фиксированного размера;
Expandable создает динамически расширяемый образ виртуального диска.
[Source=<"имя_файла">] - Путь к существующему файлу виртуального диска для предварительного заполнения нового файла виртуального диска. При использовании параметра Source данные из исходного файла виртуального диска копируются блок за блоком в создаваемый файл виртуального диска. Если Вы при копировании динамического диска не укажете параметр Type=Expandable, то копия будет создана максимального размера выделенного для исходного диска, независимо от его текущего размера.

Примеры использования команды:

Create Vdisk File="E:\VHD\Virtual_disk_1.vhd" Maximum=512 Type=Expandable
Create Vdisk File="E:\VHD\Virtual_disk_2.vhd" Source="E:\VHD\Virtual_disk_1.vhd"

Рисунок 1 из 3

Присоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk. Синтаксис команды следующий:
Select Vdisk File=<"имя_файла">
Пример использования команды:
Select Vdisk File="E:\VHD\Virtual_disk_1.vhd"
4) Для присоединения выбранного виртуального диска воспользуйтесь командой Attach Vdisk. Синтаксис команды следующий:
Attach Vdisk [Readonly] { [SD=<строка sddl>] | [Usefilesd] }
[Readonly] - Присоединяет виртуальный диск в режиме только для чтения. Любая операция записи приведет к возникновению ошибки ввода-вывода устройства.
[Usefilesd] - Указывает, что для виртуального диска следует использовать дескриптор безопасности самого виртуального файла. Если параметр не указан, то у диска не будет явно заданного дескриптора безопасности, если не был также задан параметр SD=(строка SDDL).
[SD=<строка sddl>] - Задает дескриптор безопасности в формате SDDL. По умолчанию дескриптор безопасности обеспечивает доступ, аналогичный любому физическому диску. Дополнительные сведения о формате строки SDDL см. в справке по команде Create Vdisk.

Примеры использования команды:

Attach Vdisk
Attach Vdisk Readonly
Attach Vdisk Usefilesd

Рисунок 2 из 3

Отсоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk.
4) Для отсоединения выбранного виртуального диска воспользуйтесь командой Detach Vdisk.

Рисунок 3 из 3

2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

Для работы нам потребуются программа DISM, входящая в состав Windows 7, либо включенная в WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

Вариант 1

1) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
2) Запускаете утилиту WinImage, открываете в ней VHD-образ. В открывшемся диалоге щелкаете ОК. Выделяете справа все файлы и щелкаете на выделенном правой кнопкой. Выбираете Extract, затем щелкаете Browse и выбираете папку VHD. Чуть ниже выбираете Extract with pathname. Ждете завершения процесса распаковки. Если появится ошибка, просто нажимаете продолжить.

Рисунок 1 из 5

3) Распакуйте образ дистрибутива(ваш ISO), с помощью программы архиватора 7zip в папку C:\DVD
4) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
5) Запустите коммандную строку от имени администратора (Win+R -> cmd -> Ok)
6) Распакуйте lp.cab в папку C:\Lip\uLip выполнив в консоли команду:
expand C:\Lip\lp.cab -f:* C:\Lip\uLip
7) При помощи GimageX узнаете индекс Ultimate

Рисунок 2 из 5

8) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

Рисунок 3 из 5

9) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

Рисунок 4 из 5

10) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

Рисунок 5 из 5

11) Перезагрузите компьютер.
Примечание: Комманды DISM Вы можете также выполнять в командной строке ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
12) Запустите коммандную строку от имени администратора (Win+R -> cmd -> Ok)
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:
dism /Mount-Wim /WimFile:C:\mWim\install.wim /index:1 /MountDir:C:\Mount
14) Интегрируете LIP в install.wim
dism /image:C:\Mount\ /Add-Package /PackagePath:C:\Lip\lp.cab /ScratchDir:C:\Temp
15) Применяете все настройки для русского языка командой:
dism /image:C:\Mount /Set-AllIntl:ru-RU
16) Копируете все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer)
17) Демонтируете install.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount
dism /Mount-Wim /WimFile:C:\mWim\boot.wim /index:1 /MountDir:C:\Mount
19) Добавляете в boot.wim русский язык:
xcopy C:\Lip\uLip\setup\* C:\Mount\ /cheryki
20) Добавляете в boot.wim файлы лицензий:
xcopy C:\Lip\uLip\sources\license\* C:\Mount\sources\license\ /cheryki
21) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
22) Демонтируете boot.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
23) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
24) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

1) Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
3) Указываете местонахождение VHD-образа, жмете ОК

Рисунок 1 из 2

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

Рисунок 2 из 2

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на USB флеш-накопитель (флешку) или DVD.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

3. Установка и загрузка Windows 7 из VHD-файла.

Вариант 1

Первое, что потребуется - это сам VHD-образ. Второе - необходимо подготовить логический диск. Желательно выделить для установки чистый диск с размером 15-25Гб. Третье, это утилита WinImage.

1) Запускаете утилиту WinImage.
2) Открываете в Winimage Ваш VHD-образ.
3) В открывшемся диалоге нажимаете ОК.
4) Выделяете справа все файлы
5) Нажимаете на выделенном правой кнопкой мыши и выбираете Extract
6) Нажимаете Browse и выбираете предварительно подготовленный диск.
7) Ниже выбираете Extract with pathname. Ждете завершения процесса распаковки.
8) После завершения распаковки скачиваете утилиту EasyBCD.
9) В окне приложения нажимаете Add/Remove Entries
10) В поле Add entries выбираете имя для Вашей новой ОС (к примеру, Windows 7 - VHD)
11) Указываете тип (Windows Vista/7)
12) Выбираете диск, на который Вы извлекли содержимое образа.
13) Нажимаете Add entry, а затем вверху нажимаете Save. В списке ОС теперь должно быть два пункта.
14) Заходите в раздел Change Settings
15) Выбираете в качестве ОС, загружаемой по умолчанию, Windows 7 - VHD.
16) Нажимаете Save settings и перезагружаете компьютер.

Вариант 2 как основная система.

1) Создаем папку VHD на любом разделе диска. Открываем VHD-образ утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) Выбираем Micosoft Diagnostics and Recovery Toolset -> Explorer и удаляем все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
4) Переносим все файлы из папки VHD на диск C:/. Папка VHD-> выделяем все файлы-> щелкаем правой кнопкой-> параметр move to-> выбираем диск С:\
5) Удаляем папку VHD.
6) Перезагружаемся снова в ERD. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
7) Радуемся установленной Windows 7.

Вариант 3 как вторая система.

Способ 1. Автоматически.

1) Открываем VHD-образ утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем любой логический диск (необязательно форматированный, у меня например там фильмы лежат). Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) После выбора языка раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
4) После перезагрузки нам становиться доступен выбор из двух ОС. Нас интересует вторая Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Выбираем её и ждем пока закончится настройка системы. В процессе, компьютер будет два раза перезагружен, незабываем после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Всё, VHD-образ установлен.
5) Если загружаетесь через Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено) , то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все).Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc).Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкаем правой кнопкой на диске, выбираем Change Drive Letter and Paths, нажимаем Add, выбираем любую букву для диска, ОК, диск доступен.

Способ 2. В ручную без Winimage, при помощи программы Bcedit.

Для данного способа используйте программу bcedit, входящую в состав средств Windows или средств Восстановления.

1) Запустите командную строку от имени администратора в Windows или в командной строке средств Восстановления, или в Erd Commander (при запуске необходимо выбрать текущую систему). Все дальнейшие команды вводите в командной строке.
2) При помощи указанной команды, скопируйте существующую запись текущей системы с новым названием:
bcdedit /copy {current} /d "Windows 7 Virtual"
3) Дожидаетесь сообщения «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
Указанный в данном сообщении буквенно-цифровой код, подставляйте в команды, указанные ниже вместо {ID}:
4) Укажите раздел, на котором расположены файлы загрузки (device) и раздел, на котором расположены системные файлы операционной системы (osdevice). Так как у нас виртуальный диск, то значения параметров device и osdevice будут равны.
bcdedit /set {ID} device vhd=X:\DIR\filename.vhd
bcdedit /set {ID} osdevice vhd= X:\DIR\filename.vhd
где X:\DIR\filename.vhd – полный путь к файлу VHD и указание имени файла.
5) Для форсирования автоматического определения в Windows диска через соответствующий уровень абстракции — Hardware Abstraction Layer (разрешать ли операционной системе ускоренное автоматическое определение версии HAL и файла ядра при загрузке), выполните следующую команду:
bcdedit /set {ID} detecthal on
6)Установите добавленную систему на последнее место в списке загрузок
bcdedit /displayorder {ID} /addlast
7) Перезагрузите компьютер

Если посмотреть на диски, присутствующие в системе, будет видно, что помимо виртуального диска на 16 Гб (обведен оранжевым), с которого, собственно, загружена Windows 7, также присутствуют второй раздел виртуального диска на 200 Мб под системные файлы и реальный(!) жесткий диск, установленный на компьютере. Если открыть диск, где ранее располагался vhd-файл, то можно обнаружить, что его размер увеличился до тех самых 16Гб, причем размер этот теперь строго ограничен.

Некоторые сайты также советуют внести в листинг menu.lst(должен появится при загрузке компьютера) следующие изменения:
title Windows 7 Virtual
root (hd0,0)
chainloader /bootmgr

4. Установка Windows 7 на виртуальный диск в VHD-файл.

Установив систему на виртуальный диск, в один VHD-файл, Вы получаете такие преимущества по сравнению с обычной системой:
- сможете сделать копию операционной системы просто скопировав VHD-файл
- сможете тестироть бета версии программ, не беспокоясь за систему
- сможете изучать систему, экспериментировать с реестром, не боясь её испортить.

1) Вставьте установочный диск Windows 7 в привод, загрузитесь с него
2) Доходите до шага мастера установки, где Вас просят выбрать или создать тот раздел диска, на который будет установлена Windows 7.
3) Нажмите комбинацию клавиш "Shift+F10".
Это сочетание клавиш предоставит доступ к командной строке. Напечатайте в ней Diskpart и нажмите Enter.
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Введите в DISKPART следующую команду:
create vdisk file="E:\VHD\win7.vhd" type=expandable maximum=30000
Она означает - создать файл win7.vhd расширяемого типа, максимальный размер ограничить 30 Гигабайтами. Замените E: на имя диска, на котором вы хотите хранить создаваемый файл.

4) Смонтируйте VHD-файл, чтобы он был доступен программе установки:
select vdisk file="E:\win7.vhd" attach vdisk
5) После успешного выполнения всех операций, набираете команду exit для выхода из утилиты diskpart, и еще раз команду exit – уже в приглашении CMD.EXE для закрытия командной строки.

Рисунок 1 из 2

6) Вы снова окажетесь в окне Выберите раздел для установки.
7) Нажмите кнопку Обновить, расположенную под списком дисков и Вы увидите Ваш новый диск
8) Так как на нем ещё нет разделов, то будет написано Незанятое место на диске...
9) Выберите его и нажмите Настройка диска
10) Щелкните на кнопке "Создать", укажите объем создаваемого радела и щелкните на кнопке "Применить".
11) Ещё раз убедитесь, что Вы выбрали созданный Вами виртуальный диск и нажмите Далее, игнорируя предупреждение: Невозможно установить Windows на диск...

Рисунок 2 из 2

Процесс установки Windows 7 на раздел VHD-диска продолжится так, как будто это обычный логический раздел жесткого диска. При этом будет не только установлена новая ОС, но и подменен загрузчик на "физическом" системном разделе для успешного старта с VHD. При установке Windows 7 на "чистую" систему, мастер установки автоматически создаст на диске системный раздел в 100МБ, на котором помещается загрузчик, а уже для самой системы создаст отдельный раздел.

5. Конвертирование тома жесткого диска в VHD-файл.

Для создания VHD-файлов из томов жесткого диска, Вам необходимо воспользоваться утилитой Disk2vhd. Она позволяет создать VHD-образ прямо с запущенной операционной системы. Для своей работы, программа использует Модуль теневого копирования тома (Volume Snapshot), являющийся функцией используемой операционной системой для создания последовательных снимков томов на определенный момент времени. Таким образом, Вы сможете создать VHD-файл прямо на том же разделе, который в него упаковываете. При создании VHD-файла, программа включает в него только системный том и исключает разделы с данными.

Созданный утилитой виртуальный диск может быть подключен к виртуальной машине как IDE-диск. Не используйтейте VHD-файл, для загрузки через менеджер загрузки Windows 7 на реальной машине. Windows специальным образом подписывает жесткие диски, и присваивает VHD-диску новый уникальный идентификатор. При попытке загрузки с VHD система выдаст ошибку об отсутствии загрузочного диска или просто перезагрузится без уведомления пользователя. Но при использовании данного VHD-образа в Virtual PC, система отлично стартует и работает.

Для работы с Вашим VHD-файлом Вы также можете использовать оснастку Управление дисками (diskmgmt.msc).
Eсли снимаете образ системного диска, и у вас есть раздел восстановления (System Reserved), не забудьте включить его в VHD-образ, так как без него система не загрузится. Для создания VHD-файла сделайте следующее:

1) Скачайте программу Disk2vhd
2) Разархивируйте скачанный архив и запустите Disk2vhd
3) В поле под VHD File name укажите путь и имя создаваемого Вами VHD-файла.
4) Установите флажки напротив томов жесткого диска, которые необходимо включить в создаваемый Вами VHD-файл.
5) Нажмите Create

Для создания скриптов утилита поддерживает командную строку:
disk2vhd <[drive: [drive:]...]|[*]> <vhdfile>
Укажите какие тома необходиво включить в VHD-файл или используйте * для конвертирования всех томов.
disk2vhd c: e:\Your-PC.vhd
disk2vhd * e:\Your-PC.vhd

6. Конвертирование DVD-образа Windows 7 в VHD-файл.

Для конвертирования DVD-образа Windows 7 в VHD-файл, Вам потребуются Набор автоматической установки Windows (AIK) для Windows 7 (Размер скачиваемого файла 1,25 ГБ и инструмент командной строки WIM2VHD

WIM2VHD - это сценарий Windows Scripting Host, предназначенный для использования в командной строке и позволяющий создать аппаратно-независимый VHD-файл из инсталляционного диска Windows 7, при инициализации которого система минует стадию начальной загрузки и распаковки файлов и будет готова к определению оборудования компьютера, на котором она запущена.

Суть метода заключается в преобразовании файла install.wim в VHD-файл.

1) Установите Набор автоматической установки Windows (AIK) для Windows 7
2) Поместите скаченный файл WIM2VHD.WSF в папку C:\Program Files\Windows AIK\Tools\x86\, если используете 32-разрядную систему, или в C:\Program Files\Windows AIK\Tools\amd64\, если 64-разрядную.
3) Запустите командную строку с правами администратора, для чего нажмите "Пуск", в поле поиска введите cmd.exe и нажмите CTRL+ENTER.
4) Перейдите в папку со скриптом используя команду CD . Например:

Для 32-битной Windows:
С:\>cd /d "C:\Program Files\Windows AIK\Tools\x86\"
Для 64-битной Windows:
С:\>cd /d "C:\Program Files\Windows AIK\Tools\amd64\"
Измените пути на соответствующие Вашей системе.

5) Запустите скрипт wim2vhd. Для этого, введите в командной строке следующее:
cscript wim2vhd.wsf /wim:h:\sources\install.wim /sku:ultimate /vhd:e:\vhd\win7.vhd
Командная строка расшифровывается так:
Взять файл h:\sources\install.wim, и редакцию ultimate преобразовать в e:\vhd\win7.vhd

6) Дождитесь окончания операции.

Рисунок 1 из 1

7) Для подключения полученного VHD-файла к имеющемуся загрузчику Windows 7, используйте команду:
bcdedit /copy {current} /d "Windows 7 Virtual"
Команда дублирует загрузочную запись текущей запущенной Windows 7. Вместо "Windows 7 Virtual" Вы можете написать любое значение.

8) Bcdedit выведет на экран {GUID} только что созданной записи-дубликата - скопируйте его в буфер обмена и используйте для внесения VHD-файла в опции загрузки:
bcdedit /set {ваш GUID} device vhd=[c:]\win7.vhd
bcdedit /set {ваш GUID} osdevice vhd=[c:]\win7.vhd
bcdedit /set {ваш GUID} detecthal on

Для информации: Работа скрипта WIM2VHD базируется на использовании утилиты imagex.exe из WAIK. Другие примеры использования скрипта WIM2VHD описаны здесь.

7. Включение Aero Glass в Windows на Virtual PC.

1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Нажмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

В итоге, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

8. Установка Windows 7 в виртуальную машину VirtualBox.
VirtualBox - специальная программа для создания в памяти ПК виртуальных компьютеров. Каждый виртуальный компьютер может содержать произвольный набор виртуальных устройств и отдельную операционную систему. Область применения виртуальных компьютеров очень широка - от выполнения функций по тестированию ПО до создания целых сетей, которые легко масштабировать, распределять нагрузку и защищать. VirtualBox распространяется бесплатно, с открытым исходным кодом.

1) Скачайте последнюю версию программы VirtualBox с оффициального сайта: http://www.virtualbox.org/wiki/Downloads
2) Установите ее на свой компьютер.

2.1) Запустите установщик; В первом окне нажмите Next
2.2) Выберите пункт I accept the terms in the License Agreement и нажмите Next.
2.3) Нажмите Next, затем снова Next
2.4) Нажмите на кнопку Yes. Внимание: На следующем шаге после нажатия кнопки Install произойдет разрыв связи с сетью (как локальной, так и Интернет)
2.5) Нажмите Install для продолжения установки
2.6) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
2.7) В последнем окне оставьте флажок, чтобы приступить к созданию виртуальной машины сразу или уберите флажок для создания виртуальной машины позднее. Нажмите кнопку Finish. Если Вы убрали флажок, то для запуска программы воспользуйтесь значком на рабочем столе.

3) В главном окне программы нажмите на кнопке Создать. Откроется Мастер создания новой виртуальной машины. Нажмите кнопку Далее.
4) Введите имя виртуальной машины, в разделе Тип ОС установите значения:
Операционная система: Microsoft Windows
Версия: Windows 7.
Нажмите кнопку Далее.

Рисунок 1 из 9

5) Введите размер оперативной памяти, выделяемый для виртуальной машины.
Внимание: Память будет выделяться из физической памяти установленной в Вашем компьютере. Не устанавливайте память ниже 512 Мегабайт и выше 50% от размера установленной физической памяти. Нажмите кнопку Далее.
6) Выберите загрузочный виртуальный жесткий диск. Установите переключатель в значение: Создать новый жесткий диск. Нажмите кнопку Далее.

Рисунок 2 из 9

7) Откроется Мастер создания нового виртуального диска. Нажмите кнопку Далее.
8) Выберите тип виртуального жесткого диска. Динамический образ изначально займет немного места, и будет расширяться постепенно. Фиксированный образ сразу создаст диск указанного размера - это может занять продолжительное время. Нажмите кнопку Далее.

Рисунок 3 из 9

9) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\.VirtualBox.
Выберите размер виртуального жесткого диска. (По умолчанию 20 Гигабайт). Нажмите кнопку Далее.

Рисунок 4 из 9

10) Нажмите на кнопку Готово и Вы вернетесь в предыдущее окно, где будут указаны параметры создаваемой Вами виртуальной машины. Нажмите на кнопку Готово в окне Итог, и Вы создадите новую виртуальную машину.

Виртуальная машина для установки на нее Windows 7 создана.

Рисунок 5 из 9

11) Перед началом установки Windows 7 на Вашу виртуальную машину ее необходимо настроить. Для настройки Вашей виртуальной машины нажмите на кнопку Свойства.
12) В разделе настроек из списка слева выберите Дисплей. Установите размер видеопамяти, доступной для виртуальной машины не менее 26 Мегабайт. Поставьте флажки для элементов настроек Включить 3D-ускорение и Включить 2D-ускорение видео.

Рисунок 6 из 9

13) В разделе настроек из списка слева выберите Носители.
14) В дереве настроек Носители информации выберите значок DVD диска.
Если у Вас установочный диск Windows 7 записан на DVD-диск, то вставьте его в DVD-привод и в графе Атрибуты напротив элемента Привод выберите его из ниспадаюшего списка. Также установите флажок для Разрешить прямой доступ.
Если у Вас установочный диск Windows 7 имеется в виде ISO-образа, то в графе Атрибуты нажмите на значок папки, чтобы открыть Менеджер виртуальных носителей
15) В окне Менеджер виртуальных носителей нажмите кнопку Добавить. Выберите файл образа и нажмите Открыть. Нажмите на кнопку Выбрать

Рисунок 7 из 9

16) Ваш образ добавится дереве настроек Носители информации, следующим за файлом виртуального жесткого диска. Нажмите кнопку OK.

Рисунок 8 из 9

17) Вы окажетесь в основном окне программы. Нажмите на кнопку Старт
18) Если появятся информационные окна, то нажмите в них на кнопку OK
19) Щелкните кнопкой мыши внутри экрана виртуальной машины, и в информационном окне нажмите на кнопку Захватить
20) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
21) После завершения установки Windows 7 на виртуальную машину, VirtualBox сразу запустит Вам Windows 7 внутри виртуальной машины.

22) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Control.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Дополнения гостевой ОС. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Устройства -> Установить Дополнения гостевой ОС

Рисунок 9 из 9

23) Во всплывшем окне Автозапуск нажмите VBoxWindowsAdditions.exe и установите программу.
24) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Машина -> Закрыть -> Выключить машину.
25) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Старт.

9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.
Microsoft Virtual PC - это мощная программа, которая позволяет эмулировать на одном компьютере работу сразу нескольких виртуальных машин. Каждая из таких машин может находиться под управлением своей собственной операционной системы (Windows любой версии, Netware, Linux, Solaris и т.д.), выполнять уникальную задачу, иметь собственную конфигурацию и т.д.

1) Скачайте последнюю версию программы Virtual PC с оффициального сайта:
http://www.microsoft.com/downloads/details.aspx?familyid=28c97d22-6eb8-4a09-a7f7-f6c7a1f000b5&displaylang=en
2) Установите программу. Внимание программа установки без предупреждения выключит соединение с сетью (как локальной, так и Интернет).
3) Скачайте и установите обновление KB958162.msp для Virtual PC
4) Запустите программу. Нажмите кнопку Пуск -> Все программы -> Microsoft Virtual PC
5) В окне с надписью: "You are not running on a supported operating system" нажмите ОК.
6) В окне New Virtual Machine Wizard нажмите кнопку Next. Данное окно Вы также можете запустить нажав кнопку New в Virtual PC Console или в меню File выбрать New Virtual Machine Wizard.

Рисунок 1 из 7

7) Установите переключатель на Create a Virtual Machine. Нажмите кнопку Next.

Рисунок 2 из 7

8) Выберите имя и расположение для файла Вашей виртуальной машины. По умолчанию имя файла New Virtual Machine, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\Documents\My Virtual Machines. Нажмите кнопку Next.
9) Выберите тип операционной системы. В связи с отсутствием пункта Windows 7 в Virtual PC, выберите Windows Vista или Other. Нажмите кнопку Next.

Рисунок 3 из 7

10) Установите переключатель на Adjusting the RAM. Выберите необходимое Вам количество оперативной памяти выделяемое виртуальной машине, не менее 512 Мегабайт. Нажмите кнопку Next.

Рисунок 4 из 7

11) Установите переключатель на A new virtual hard disk, чтобы создать новый виртуальный образ. Нажмите кнопку Next.
12) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, к котрой добавлено Hard Disk, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке:
C:\Users\UserName\Documents\My Virtual Machines\ИмяВиртуальнойМашины\
Укажите величину создаваемого вами виртуального жесткого диска в мегабайтах. Рекомендую указать 20480 Мб (20 Гб). Для информации: 1 Гб = 1024 Мб. Нажмите кнопку Next.

Рисунок 5 из 7

13) Нажмите кнопку Finish, для создания виртуальной машины. Вы снова окажетесь в окне Virtual PC Console.
14) Выберите созданную Вами виртуальную машину и нажмите кнопку Start
15) Виртуальная машина начнет свою работу и остановится с сообщением: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device, поскольку отсутствует инсталляционный диск с Windows 7. Выберите команду CD>Capture CD Image и укажите образ ISO с Windows 7.

Рисунок 6 из 7

16) Перезагрузите виртуальную машину, выбрав команду Action -> Ctrl+Alt+Del или нажав Правый Alt+DEL в окне виртуальной машины.
17) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
18) После завершения установки Windows 7 на виртуальную машину, Microsoft Virtual PC сразу запустит Вам Windows 7 внутри виртуальной машины.
19) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Alt.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Virtual Machine Additions. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Action –> Install or Update Virtual Machine Additions и нажмите Continue.

Рисунок 7 из 7

20) Во всплывшем окне Автозапуск нажмите Setup.exe и установите программу.
21) Нажмите Yes по окончанию установки Virtual Machine Additions и виртуальная машина перезагрузится.
22) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Action -> Close -> Turn Off и нажмите OK.
23) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Start.

10. Установка Windows 7 в виртуальную машину VMware Workstation.
VMware Workstation — популярная программа для виртуализации систем. VMware Workstation является массивным решением для разработчиков программного обеспечения и системных админов, создающих и тестирующих полно-комплексные сетевые приложения класса серверов, работающие в разнообразных средах.

1) Заходите на страницу оффициального сайта для скачивания программы: http://downloads.vmware.com/d/
2) Нажимаете на ссылку VMware Workstation
3) На открывшейся странице выбираете для скачивания VMware Workstation X.X.X for Windows (где X.X.X - номер версии)
4) Щелкаете на кнопке Download рядом с Workstation for Windows 32-bit and 64-bit with VMware Tools.
5) Нажимаете на кнопку Register и заполняете регистрационную форму и нажимаете Continue
6) Внизу EULA соглашения нажимаете Yes и оказываетесь на странице загрузки. Программа бесплатна для полнофункционального использования 30 дней. По истечении данного срока Вам необходимо её зарегистрировать.
7) Скачиваете Workstation for Windows 32-bit and 64-bit Main installation file with Tools. В отличие от других виртуальных машин, программа установки VMware Workstation имеет размер более 500 Мегабайт.
8) Установите программу. Перезапустите компьютер, для этого в последнем окне программы нажмите Restart Now или нажмите Restart Later и перезапустите вручную позже.
9) Запустите программу. Установите переключатель на Yes, I accept the terms in the license agreement и нажмите OK
10) В главном окне программы нажмите на значок New Vitual Machine.

Рисунок 1 из 6

11) Установите переключатель на Typical (recommended). Нажмите кнопку Next.

Рисунок 2 из 6

12) Установите переключатель на Installer disk image file (iso). Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Next.

Рисунок 3 из 6

13) Укажите свой инсталяционный код Windows 7, имя пользователя и пароль и нажмите кнопку Next. Если Вы решили ввести эти данные позже, то после нажатия кнопки Next, нажмите на кнопку Yes.
14) Выберите имя и расположение для файла Вашей виртуальной машины. Нажмите кнопку Next.

Рисунок 4 из 6

15) Задайте размер Вашего виртуального жесткого диска в гигабайтах.

Рисунок 5 из 6

16) Нажмите кнопку Finish, для создания виртуальной машины.
17) В окне VMware Workstation Activation нажмите Enter Serial Number, чтобы ввести имеющийся у Вас серийный номер. Если у Вас нет серийного номера, то Вы можете получить серийный номер на 30 дней для полнофункционального тестирования программы: https://www.vmware.com/tryvmware/?p=workstation&lp=default
18) После введения пробного номера во всплывшем окне Register your version of VMware Workstation now! нажмите кнопку Register
19) В главном окне программы перейдите на вкладку с названием Вашей виртуальной машины (по умолчанию Windows 7) и нажмите ссылку Power on this virtual machine.

Рисунок 6 из 6

20) В отличие от других виртуальных машин установка Windows 7 начнется сама и большую часть установки VMware Workstation выполнит автоматически, Ваше участие в процессе установки Windows 7 почти не потребуется.
21) После завершения установки Windows 7 на виртуальную машину, VMware Workstation сразу запустит Вам Windows 7 внутри виртуальной машины.
22) Сразу после запуска VMware Workstation самостоятельно установит Вам дополнительные инструменты VMware Tools, а также в случае наличия у Вас подключения к Интернет самостоятельно установит все необходимые драйвера.
23) Используйте комбинацию клавиш Ctrl+G для разблокировки одновременного использования мыши как в виртуальной системе, так и в основной.
24) Чтобы выключить виртуальную машину, завершите работу в виртуальной Windows 7 как в обычной Windows. Пуск -> Завершение работы.
25) Чтобы запустить установленную Windows 7 в основном окне программы в колонке слева выберите наименование Вашей операционной системы. В открывшейся вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) нажмите ссылку Power on this virtual machine.

11. Создание общей папки для виртуальной и основной Windows в VirtualBox.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VirtualBox и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Устройства -> Общие папки

Рисунок 1 из 4

2) Нажмите на клавиатуре кнопку Insert, либо нажмите на значок папки с плюсом.

Рисунок 2 из 4

3) Установите флажок для параметра Создать постоянную папку.
4) В ниспадающем меню рядом с текстом Путь к папке выберите пункт Другой....
5) Укажите путь к Вашей папке и нажмите на каждую кнопку ОК.

Рисунок 3 из 4

6) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> VBOXSVR -> Ваша папка

Рисунок 4 из 4

12. Создание общей папки для виртуальной и основной Windows в Microsoft Virtual PC.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину Microsoft Virtual PC и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Edit -> Settings или нажмите сочетание клавиш: правый Alt+E

Рисунок 1 из 4

2) Выберите в списке Shared Folders и нажмите кнопку Share Folder...

Рисунок 2 из 4

3) Установите флажок на Share Every Time, укажите Вашу общую папку и установите букву диска в виде которго будет отображаться папка в виртуальной Windows, затем нажмите OK.

Рисунок 3 из 4

4) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Компьютер -> Отключенное сетевое устройство (назначенная вами буква диска)

Рисунок 4 из 4

13. Создание общей папки для виртуальной и основной Windows в VMware Workstation.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VMware Workstation и хостовой (реальной) Windows 7, сделайте следующее:

1) В вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) перейдите на вкладку Options.
2) Сделайте двойной щелчок на папке Shared Folders

Рисунок 1 из 4

3) Установите переключатель на Always enabled.

Рисунок 2 из 4

4) Нажмите кнопку Add..., а затем кнопку Next.
5) Нажмите кнопку Browse. Укажите путь к Вашей общей папке в хостовой (реальной) Windows 7 и ее имя в виртуальной Windows, затем нажмите OK.

Рисунок 3 из 4

6) Нажмите кнопку Next, а затем кнопку Finish. Выйдите из опций нажав на OK.
7) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> vmware-host -> Shared Folders -> Ваша папка

Рисунок 4 из 4


1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

VHD (Virtual Hard Disk) - это формат файлов, используемых виртуальными машинами для эмуляции жесткого диска. Вы сможете создать себе виртуальный диск и использовать его для хранения виртуальных операционных систем, программ и других файлов в одном файле-образе, который можно открыть различными программами виртуализации или виртуальными машинами. Виртуальные жесткие диски позволяют нескольким операционным системам одновременно находиться на одном компьютере.

Вариант 1. Работа с виртуальными дисками используя графический интерфейс.

Создание виртуального жесткого диска.

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
3) Откроется оснастка "Управление дисками". В панели меню выберите пункт Действие и нажмите на Создать виртуальный жесткий диск

4) В открывшемся окне укажите:

4.1) Имя файла и его расположение. Вы можете как написать это вручную, так и нажав на кнопку Обзор и воспользовавшись диалоговым окном Просмотр файлов виртуального диска
4.2) Размер виртуального диска. Возле текстового поля, в которое нужно ввести размер диска, присутствует раскрывающийся список, где можно выбрать размер жесткого диска. Доступные значения – мегабайты, гигабайты и терабайты. Создайте размер не меньше 20 ГБ.
4.3) Тип виртуального диска. Динамически расширяемый дисковый образ обеспечивает объем пространства, необходимый для хранения данных.
Размер VHD-файла в момент создания диска небольшой, но увеличивается по мере добавления данных на диск. Распределение данных осуществляется в блоках. При удалении данных с виртуального жесткого диска размер VHD-файла автоматически не уменьшается. Фиксированный размер создает VHD-файл, размер которого задается при создании виртуального жесткого диска. Размер VHD-файла остается постоянным независимо от объема хранимых данных.
5) Нажмите на кнопку «ОК».

Чтобы диспетчер локальных дисков смог получить доступ к созданному Вами виртуальному диску его необходимо инициализировать и создать на нем простой том. Для этого также используется оснастка "Управление дисками".

Инициализация виртуального жесткого диска.

1) Найдите Ваш виртуальный диск и щелкните на нем правой кнопкой мыши
2) Нажмите на пункт Инициализировать диск

3) Выберите стиль разделов - MBR и нажмите OK

Создание простого тома на виртуальном жестком диске.

После того как Вы проинициализировали Ваш виртуальный диск, на нем необходимо создать простой том.

1) Найдите Ваш виртуальный диск и щелкните на нераспределенной области справа от него
2) Нажмите на пункт Создать простой том

3) В первом диалоге Мастера создания простого тома нажмите на кнопку Далее
4) В диалоге указания размера тома, укажите размер будущего тома в мегабайтах и нажмите на кнопку Далее

5) В диалоге Назначение буквы диска или пути укажите букву для будущего диска и нажмите на кнопку Далее

6) В диалоге Форматирование раздела укажите нужную файловую систему, размер кластера, название диска и установите флажок возле опции Быстрое форматирование - для того, чтобы диск был сразу отформатирован. После чего нажмите на кнопку Далее

7) Для принятия всех настроенных параметров в диалоге Завершение мастера создания простого тома нажмите на кнопку Готово.
8) Виртуальный диск появится в таблице дисков. В оснастке управления дисками, значок виртуального диска визуально отличается от значков физических дисков. В проводнике Windows виртуальные диски выглядят так же, как и физические.

Присоединение виртуального жесткого диска.

Если у Вас уже имеется созданный виртуальный жесткий диск, то Вы также можете присоединить его в оснастке "Управление дисками".

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
3) В панели меню выберите пункт Действие и нажмите на Присоединить виртуальный жесткий диск.

4) Укажите расположение для виртуального жесткого диска на компьютере и нажмите OK Указать расположение Вы можете либо введя значение вручную, либо нажав на кнопку Обзор, и используя диалоговое окно Просмотр файлов виртуального диска. Если Вам не нужно записывать данные на диск, то в этом диалоге можно установить флажок Только для чтения.

Отсоединение (удаление) виртуального жесткого диска.

1) Найдите виртуальный диск, который хотите отсоединить, нажмите на нем правой кнопкой мыши
2) Нажмите на пункт Отсоединить виртуальный жесткий диск

3) Если Вы желаете отсоединить виртуальный диск без удаления его из системы, то нажмите OK. Для полного удаления диска из системы, отметьте Удалить виртуальный диск после удаления диска и после этого нажмите OK.

Вариант 2. Работа с виртуальными дисками используя программу Diskpart в командной строке.

Создание виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для создания виртуального диска воспользуйтесь командой Create Vdisk. Синтаксис команды следующий:
Create Vdisk File=<"имя_файла"> Maximum= [Type={Fixed|Expandable}] [Source=<"имя_файла">]
Где:

File=<"имя_файла"> - Указание полного пути и имени файла виртуального диска.
Maximum=<n> - Максимальное дисковое пространство, предоставляемое виртуальным диском, заданное в мегабайтах (МБ).
[Type={Fixed|Expandable}] - Используется для указания формата виртуального диска. Существует два значения для данного параметра:
Fixed создает файл виртуального диска фиксированного размера;
Expandable создает динамически расширяемый образ виртуального диска.
[Source=<"имя_файла">] - Путь к существующему файлу виртуального диска для предварительного заполнения нового файла виртуального диска. При использовании параметра Source данные из исходного файла виртуального диска копируются блок за блоком в создаваемый файл виртуального диска. Если Вы при копировании динамического диска не укажете параметр Type=Expandable, то копия будет создана максимального размера выделенного для исходного диска, независимо от его текущего размера.

Примеры использования команды:

Create Vdisk File="E:\VHD\Virtual_disk_1.vhd" Maximum=512 Type=Expandable
Create Vdisk File="E:\VHD\Virtual_disk_2.vhd" Source="E:\VHD\Virtual_disk_1.vhd"

Присоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk. Синтаксис команды следующий:
Select Vdisk File=<"имя_файла">
Пример использования команды:
Select Vdisk File="E:\VHD\Virtual_disk_1.vhd"
4) Для присоединения выбранного виртуального диска воспользуйтесь командой Attach Vdisk. Синтаксис команды следующий:
Attach Vdisk [Readonly] { [SD=<строка sddl>] | [Usefilesd] }
[Readonly] - Присоединяет виртуальный диск в режиме только для чтения. Любая операция записи приведет к возникновению ошибки ввода-вывода устройства.
[Usefilesd] - Указывает, что для виртуального диска следует использовать дескриптор безопасности самого виртуального файла. Если параметр не указан, то у диска не будет явно заданного дескриптора безопасности, если не был также задан параметр SD=(строка SDDL).
[SD=<строка sddl>] - Задает дескриптор безопасности в формате SDDL. По умолчанию дескриптор безопасности обеспечивает доступ, аналогичный любому физическому диску. Дополнительные сведения о формате строки SDDL см. в справке по команде Create Vdisk.

Примеры использования команды:

Attach Vdisk
Attach Vdisk Readonly
Attach Vdisk Usefilesd

Отсоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk.
4) Для отсоединения выбранного виртуального диска воспользуйтесь командой Detach Vdisk.

Назад на страницу раздела Виртуализация.


2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

Для работы нам потребуются программа DISM, входящая в состав Windows 7, либо включенная в WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

Вариант 1

1) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
2) Запускаете утилиту WinImage, открываете в ней VHD-образ. В открывшемся диалоге щелкаете ОК. Выделяете справа все файлы и щелкаете на выделенном правой кнопкой. Выбираете Extract, затем щелкаете Browse и выбираете папку VHD. Чуть ниже выбираете Extract with pathname. Ждете завершения процесса распаковки. Если появится ошибка, просто нажимаете продолжить.

3) Распакуйте образ дистрибутива(ваш ISO), с помощью программы архиватора 7zip в папку C:\DVD
4) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
5) Запустите коммандную строку от имени администратора (Win+R -> cmd -> Ok)
6) Распакуйте lp.cab в папку C:\Lip\uLip выполнив в консоли команду:
expand C:\Lip\lp.cab -f:* C:\Lip\uLip
7) При помощи GimageX узнаете индекс Ultimate

8) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

9) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

10) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

11) Перезагрузите компьютер.
Примечание: Комманды DISM Вы можете также выполнять в командной строке ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
12) Запустите коммандную строку от имени администратора (Win+R -> cmd -> Ok)
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:
dism /Mount-Wim /WimFile:C:\mWim\install.wim /index:1 /MountDir:C:\Mount
14) Интегрируете LIP в install.wim
dism /image:C:\Mount\ /Add-Package /PackagePath:C:\Lip\lp.cab /ScratchDir:C:\Temp
15) Применяете все настройки для русского языка командой:
dism /image:C:\Mount /Set-AllIntl:ru-RU
16) Копируете все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer)
17) Демонтируете install.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount
dism /Mount-Wim /WimFile:C:\mWim\boot.wim /index:1 /MountDir:C:\Mount
19) Добавляете в boot.wim русский язык:
xcopy C:\Lip\uLip\setup\* C:\Mount\ /cheryki
20) Добавляете в boot.wim файлы лицензий:
xcopy C:\Lip\uLip\sources\license\* C:\Mount\sources\license\ /cheryki
21) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
22) Демонтируете boot.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
23) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
24) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

1) Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
3) Указываете местонахождение VHD-образа, жмете ОК

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на USB флеш-накопитель (флешку) или DVD.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Назад на страницу раздела Виртуализация.


3. Установка и загрузка Windows 7 из VHD-файла.

Вариант 1

Первое, что потребуется - это сам VHD-образ. Второе - необходимо подготовить логический диск. Желательно выделить для установки чистый диск с размером 15-25Гб. Третье, это утилита WinImage.

1) Запускаете утилиту WinImage.
2) Открываете в Winimage Ваш VHD-образ.
3) В открывшемся диалоге нажимаете ОК.
4) Выделяете справа все файлы
5) Нажимаете на выделенном правой кнопкой мыши и выбираете Extract
6) Нажимаете Browse и выбираете предварительно подготовленный диск.
7) Ниже выбираете Extract with pathname. Ждете завершения процесса распаковки.
8) После завершения распаковки скачиваете утилиту EasyBCD.
9) В окне приложения нажимаете Add/Remove Entries
10) В поле Add entries выбираете имя для Вашей новой ОС (к примеру, Windows 7 - VHD)
11) Указываете тип (Windows Vista/7)
12) Выбираете диск, на который Вы извлекли содержимое образа.
13) Нажимаете Add entry, а затем вверху нажимаете Save. В списке ОС теперь должно быть два пункта.
14) Заходите в раздел Change Settings
15) Выбираете в качестве ОС, загружаемой по умолчанию, Windows 7 - VHD.
16) Нажимаете Save settings и перезагружаете компьютер.

Вариант 2 как основная система.

1) Создаем папку VHD на любом разделе диска. Открываем VHD-образ утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) Выбираем Micosoft Diagnostics and Recovery Toolset -> Explorer и удаляем все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
4) Переносим все файлы из папки VHD на диск C:/. Папка VHD-> выделяем все файлы-> щелкаем правой кнопкой-> параметр move to-> выбираем диск С:\
5) Удаляем папку VHD.
6) Перезагружаемся снова в ERD. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
7) Радуемся установленной Windows 7.

Вариант 3 как вторая система.

Способ 1. Автоматически.

1) Открываем VHD-образ утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем любой логический диск (необязательно форматированный, у меня например там фильмы лежат). Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) После выбора языка раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
4) После перезагрузки нам становиться доступен выбор из двух ОС. Нас интересует вторая Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Выбираем её и ждем пока закончится настройка системы. В процессе, компьютер будет два раза перезагружен, незабываем после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Всё, VHD-образ установлен.
5) Если загружаетесь через Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено) , то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все).Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc).Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкаем правой кнопкой на диске, выбираем Change Drive Letter and Paths, нажимаем Add, выбираем любую букву для диска, ОК, диск доступен.

Способ 2. В ручную без Winimage, при помощи программы Bcedit.

Для данного способа используйте программу bcedit, входящую в состав средств Windows или средств Восстановления.

1) Запустите командную строку от имени администратора в Windows или в командной строке средств Восстановления, или в Erd Commander (при запуске необходимо выбрать текущую систему). Все дальнейшие команды вводите в командной строке.
2) При помощи указанной команды, скопируйте существующую запись текущей системы с новым названием:
bcdedit /copy {current} /d "Windows 7 Virtual"
3) Дожидаетесь сообщения «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
Указанный в данном сообщении буквенно-цифровой код, подставляйте в команды, указанные ниже вместо {ID}:
4) Укажите раздел, на котором расположены файлы загрузки (device) и раздел, на котором расположены системные файлы операционной системы (osdevice). Так как у нас виртуальный диск, то значения параметров device и osdevice будут равны.
bcdedit /set {ID} device vhd=X:\DIR\filename.vhd
bcdedit /set {ID} osdevice vhd= X:\DIR\filename.vhd
где X:\DIR\filename.vhd – полный путь к файлу VHD и указание имени файла.
5) Для форсирования автоматического определения в Windows диска через соответствующий уровень абстракции — Hardware Abstraction Layer (разрешать ли операционной системе ускоренное автоматическое определение версии HAL и файла ядра при загрузке), выполните следующую команду:
bcdedit /set {ID} detecthal on
6)Установите добавленную систему на последнее место в списке загрузок
bcdedit /displayorder {ID} /addlast
7) Перезагрузите компьютер

Если посмотреть на диски, присутствующие в системе, будет видно, что помимо виртуального диска на 16 Гб (обведен оранжевым), с которого, собственно, загружена Windows 7, также присутствуют второй раздел виртуального диска на 200 Мб под системные файлы и реальный(!) жесткий диск, установленный на компьютере. Если открыть диск, где ранее располагался vhd-файл, то можно обнаружить, что его размер увеличился до тех самых 16Гб, причем размер этот теперь строго ограничен.

Некоторые сайты также советуют внести в листинг menu.lst(должен появится при загрузке компьютера) следующие изменения:
title Windows 7 Virtual
root (hd0,0)
chainloader /bootmgr

Назад на страницу раздела Виртуализация.


4. Установка Windows 7 на виртуальный диск в VHD-файл.

Установив систему на виртуальный диск, в один VHD-файл, Вы получаете такие преимущества по сравнению с обычной системой:
- сможете сделать копию операционной системы просто скопировав VHD-файл
- сможете тестироть бета версии программ, не беспокоясь за систему
- сможете изучать систему, экспериментировать с реестром, не боясь её испортить.

1) Вставьте установочный диск Windows 7 в привод, загрузитесь с него
2) Доходите до шага мастера установки, где Вас просят выбрать или создать тот раздел диска, на который будет установлена Windows 7.
3) Нажмите комбинацию клавиш "Shift+F10".
Это сочетание клавиш предоставит доступ к командной строке. Напечатайте в ней Diskpart и нажмите Enter.
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Введите в DISKPART следующую команду:
create vdisk file="E:\VHD\win7.vhd" type=expandable maximum=30000
Она означает - создать файл win7.vhd расширяемого типа, максимальный размер ограничить 30 Гигабайтами. Замените E: на имя диска, на котором вы хотите хранить создаваемый файл.

4) Смонтируйте VHD-файл, чтобы он был доступен программе установки:
select vdisk file="E:\win7.vhd" attach vdisk
5) После успешного выполнения всех операций, набираете команду exit для выхода из утилиты diskpart, и еще раз команду exit – уже в приглашении CMD.EXE для закрытия командной строки.

6) Вы снова окажетесь в окне Выберите раздел для установки.
7) Нажмите кнопку Обновить, расположенную под списком дисков и Вы увидите Ваш новый диск
8) Так как на нем ещё нет разделов, то будет написано Незанятое место на диске...
9) Выберите его и нажмите Настройка диска
10) Щелкните на кнопке "Создать", укажите объем создаваемого радела и щелкните на кнопке "Применить".
11) Ещё раз убедитесь, что Вы выбрали созданный Вами виртуальный диск и нажмите Далее, игнорируя предупреждение: Невозможно установить Windows на диск...

Процесс установки Windows 7 на раздел VHD-диска продолжится так, как будто это обычный логический раздел жесткого диска. При этом будет не только установлена новая ОС, но и подменен загрузчик на "физическом" системном разделе для успешного старта с VHD. При установке Windows 7 на "чистую" систему, мастер установки автоматически создаст на диске системный раздел в 100МБ, на котором помещается загрузчик, а уже для самой системы создаст отдельный раздел.

Назад на страницу раздела Виртуализация.


5. Конвертирование тома жесткого диска в VHD-файл.

Для создания VHD-файлов из томов жесткого диска, Вам необходимо воспользоваться утилитой Disk2vhd. Она позволяет создать VHD-образ прямо с запущенной операционной системы. Для своей работы, программа использует Модуль теневого копирования тома (Volume Snapshot), являющийся функцией используемой операционной системой для создания последовательных снимков томов на определенный момент времени. Таким образом, Вы сможете создать VHD-файл прямо на том же разделе, который в него упаковываете. При создании VHD-файла, программа включает в него только системный том и исключает разделы с данными.

Созданный утилитой виртуальный диск может быть подключен к виртуальной машине как IDE-диск. Не используйтейте VHD-файл, для загрузки через менеджер загрузки Windows 7 на реальной машине. Windows специальным образом подписывает жесткие диски, и присваивает VHD-диску новый уникальный идентификатор. При попытке загрузки с VHD система выдаст ошибку об отсутствии загрузочного диска или просто перезагрузится без уведомления пользователя. Но при использовании данного VHD-образа в Virtual PC, система отлично стартует и работает.

Для работы с Вашим VHD-файлом Вы также можете использовать оснастку Управление дисками (diskmgmt.msc).
Eсли снимаете образ системного диска, и у вас есть раздел восстановления (System Reserved), не забудьте включить его в VHD-образ, так как без него система не загрузится. Для создания VHD-файла сделайте следующее:

1) Скачайте программу Disk2vhd
2) Разархивируйте скачанный архив и запустите Disk2vhd
3) В поле под VHD File name укажите путь и имя создаваемого Вами VHD-файла.
4) Установите флажки напротив томов жесткого диска, которые необходимо включить в создаваемый Вами VHD-файл.
5) Нажмите Create

Для создания скриптов утилита поддерживает командную строку:
disk2vhd <[drive: [drive:]...]|[*]> <vhdfile>
Укажите какие тома необходиво включить в VHD-файл или используйте * для конвертирования всех томов.
disk2vhd c: e:\Your-PC.vhd
disk2vhd * e:\Your-PC.vhd

Назад на страницу раздела Виртуализация.


6. Конвертирование DVD-образа Windows 7 в VHD-файл.

Для конвертирования DVD-образа Windows 7 в VHD-файл, Вам потребуются Набор автоматической установки Windows (AIK) для Windows 7 (Размер скачиваемого файла 1,25 ГБ и инструмент командной строки WIM2VHD

WIM2VHD - это сценарий Windows Scripting Host, предназначенный для использования в командной строке и позволяющий создать аппаратно-независимый VHD-файл из инсталляционного диска Windows 7, при инициализации которого система минует стадию начальной загрузки и распаковки файлов и будет готова к определению оборудования компьютера, на котором она запущена.

Суть метода заключается в преобразовании файла install.wim в VHD-файл.

1) Установите Набор автоматической установки Windows (AIK) для Windows 7
2) Поместите скаченный файл WIM2VHD.WSF в папку C:\Program Files\Windows AIK\Tools\x86\, если используете 32-разрядную систему, или в C:\Program Files\Windows AIK\Tools\amd64\, если 64-разрядную.
3) Запустите командную строку с правами администратора, для чего нажмите "Пуск", в поле поиска введите cmd.exe и нажмите CTRL+ENTER.
4) Перейдите в папку со скриптом используя команду CD . Например:

Для 32-битной Windows:
С:\>cd /d "C:\Program Files\Windows AIK\Tools\x86\"
Для 64-битной Windows:
С:\>cd /d "C:\Program Files\Windows AIK\Tools\amd64\"
Измените пути на соответствующие Вашей системе.

5) Запустите скрипт wim2vhd. Для этого, введите в командной строке следующее:
cscript wim2vhd.wsf /wim:h:\sources\install.wim /sku:ultimate /vhd:e:\vhd\win7.vhd
Командная строка расшифровывается так:
Взять файл h:\sources\install.wim, и редакцию ultimate преобразовать в e:\vhd\win7.vhd

6) Дождитесь окончания операции.

7) Для подключения полученного VHD-файла к имеющемуся загрузчику Windows 7, используйте команду:
bcdedit /copy {current} /d "Windows 7 Virtual"
Команда дублирует загрузочную запись текущей запущенной Windows 7. Вместо "Windows 7 Virtual" Вы можете написать любое значение.

8) Bcdedit выведет на экран {GUID} только что созданной записи-дубликата - скопируйте его в буфер обмена и используйте для внесения VHD-файла в опции загрузки:
bcdedit /set {ваш GUID} device vhd=[c:]\win7.vhd
bcdedit /set {ваш GUID} osdevice vhd=[c:]\win7.vhd
bcdedit /set {ваш GUID} detecthal on

Для информации: Работа скрипта WIM2VHD базируется на использовании утилиты imagex.exe из WAIK. Другие примеры использования скрипта WIM2VHD описаны здесь.

Назад на страницу раздела Виртуализация.


7. Включение Aero Glass в Windows на Virtual PC.

1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Нажмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

В итоге, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

Назад на страницу раздела Виртуализация.


8. Установка Windows 7 в виртуальную машину VirtualBox.

VirtualBox - специальная программа для создания в памяти ПК виртуальных компьютеров. Каждый виртуальный компьютер может содержать произвольный набор виртуальных устройств и отдельную операционную систему. Область применения виртуальных компьютеров очень широка - от выполнения функций по тестированию ПО до создания целых сетей, которые легко масштабировать, распределять нагрузку и защищать. VirtualBox распространяется бесплатно, с открытым исходным кодом.

1) Скачайте последнюю версию программы VirtualBox с оффициального сайта: http://www.virtualbox.org/wiki/Downloads
2) Установите ее на свой компьютер.

2.1) Запустите установщик; В первом окне нажмите Next
2.2) Выберите пункт I accept the terms in the License Agreement и нажмите Next.
2.3) Нажмите Next, затем снова Next
2.4) Нажмите на кнопку Yes. Внимание: На следующем шаге после нажатия кнопки Install произойдет разрыв связи с сетью (как локальной, так и Интернет)
2.5) Нажмите Install для продолжения установки
2.6) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
2.7) В последнем окне оставьте флажок, чтобы приступить к созданию виртуальной машины сразу или уберите флажок для создания виртуальной машины позднее. Нажмите кнопку Finish. Если Вы убрали флажок, то для запуска программы воспользуйтесь значком на рабочем столе.

3) В главном окне программы нажмите на кнопке Создать. Откроется Мастер создания новой виртуальной машины. Нажмите кнопку Далее.
4) Введите имя виртуальной машины, в разделе Тип ОС установите значения:
Операционная система: Microsoft Windows
Версия: Windows 7.
Нажмите кнопку Далее.

5) Введите размер оперативной памяти, выделяемый для виртуальной машины.
Внимание: Память будет выделяться из физической памяти установленной в Вашем компьютере. Не устанавливайте память ниже 512 Мегабайт и выше 50% от размера установленной физической памяти. Нажмите кнопку Далее.
6) Выберите загрузочный виртуальный жесткий диск. Установите переключатель в значение: Создать новый жесткий диск. Нажмите кнопку Далее.

7) Откроется Мастер создания нового виртуального диска. Нажмите кнопку Далее.
8) Выберите тип виртуального жесткого диска. Динамический образ изначально займет немного места, и будет расширяться постепенно. Фиксированный образ сразу создаст диск указанного размера - это может занять продолжительное время. Нажмите кнопку Далее.

9) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\.VirtualBox.
Выберите размер виртуального жесткого диска. (По умолчанию 20 Гигабайт). Нажмите кнопку Далее.

10) Нажмите на кнопку Готово и Вы вернетесь в предыдущее окно, где будут указаны параметры создаваемой Вами виртуальной машины. Нажмите на кнопку Готово в окне Итог, и Вы создадите новую виртуальную машину.

Виртуальная машина для установки на нее Windows 7 создана.

11) Перед началом установки Windows 7 на Вашу виртуальную машину ее необходимо настроить. Для настройки Вашей виртуальной машины нажмите на кнопку Свойства.
12) В разделе настроек из списка слева выберите Дисплей. Установите размер видеопамяти, доступной для виртуальной машины не менее 26 Мегабайт. Поставьте флажки для элементов настроек Включить 3D-ускорение и Включить 2D-ускорение видео.

13) В разделе настроек из списка слева выберите Носители.
14) В дереве настроек Носители информации выберите значок DVD диска.
Если у Вас установочный диск Windows 7 записан на DVD-диск, то вставьте его в DVD-привод и в графе Атрибуты напротив элемента Привод выберите его из ниспадаюшего списка. Также установите флажок для Разрешить прямой доступ.
Если у Вас установочный диск Windows 7 имеется в виде ISO-образа, то в графе Атрибуты нажмите на значок папки, чтобы открыть Менеджер виртуальных носителей
15) В окне Менеджер виртуальных носителей нажмите кнопку Добавить. Выберите файл образа и нажмите Открыть. Нажмите на кнопку Выбрать

16) Ваш образ добавится дереве настроек Носители информации, следующим за файлом виртуального жесткого диска. Нажмите кнопку OK.

17) Вы окажетесь в основном окне программы. Нажмите на кнопку Старт
18) Если появятся информационные окна, то нажмите в них на кнопку OK
19) Щелкните кнопкой мыши внутри экрана виртуальной машины, и в информационном окне нажмите на кнопку Захватить
20) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
21) После завершения установки Windows 7 на виртуальную машину, VirtualBox сразу запустит Вам Windows 7 внутри виртуальной машины.

22) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Control.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Дополнения гостевой ОС. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Устройства -> Установить Дополнения гостевой ОС

23) Во всплывшем окне Автозапуск нажмите VBoxWindowsAdditions.exe и установите программу.
24) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Машина -> Закрыть -> Выключить машину.
25) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Старт.

Назад на страницу раздела Виртуализация.


9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.

Microsoft Virtual PC - это мощная программа, которая позволяет эмулировать на одном компьютере работу сразу нескольких виртуальных машин. Каждая из таких машин может находиться под управлением своей собственной операционной системы (Windows любой версии, Netware, Linux, Solaris и т.д.), выполнять уникальную задачу, иметь собственную конфигурацию и т.д.

1) Скачайте последнюю версию программы Virtual PC с оффициального сайта:
http://www.microsoft.com/downloads/details.aspx?familyid=28c97d22-6eb8-4a09-a7f7-f6c7a1f000b5&displaylang=en
2) Установите программу. Внимание программа установки без предупреждения выключит соединение с сетью (как локальной, так и Интернет).
3) Скачайте и установите обновление KB958162.msp для Virtual PC
4) Запустите программу. Нажмите кнопку Пуск -> Все программы -> Microsoft Virtual PC
5) В окне с надписью: "You are not running on a supported operating system" нажмите ОК.
6) В окне New Virtual Machine Wizard нажмите кнопку Next. Данное окно Вы также можете запустить нажав кнопку New в Virtual PC Console или в меню File выбрать New Virtual Machine Wizard.

7) Установите переключатель на Create a Virtual Machine. Нажмите кнопку Next.

8) Выберите имя и расположение для файла Вашей виртуальной машины. По умолчанию имя файла New Virtual Machine, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\Documents\My Virtual Machines. Нажмите кнопку Next.
9) Выберите тип операционной системы. В связи с отсутствием пункта Windows 7 в Virtual PC, выберите Windows Vista или Other. Нажмите кнопку Next.

10) Установите переключатель на Adjusting the RAM. Выберите необходимое Вам количество оперативной памяти выделяемое виртуальной машине, не менее 512 Мегабайт. Нажмите кнопку Next.

11) Установите переключатель на A new virtual hard disk, чтобы создать новый виртуальный образ. Нажмите кнопку Next.
12) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, к котрой добавлено Hard Disk, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке:
C:\Users\UserName\Documents\My Virtual Machines\ИмяВиртуальнойМашины\
Укажите величину создаваемого вами виртуального жесткого диска в мегабайтах. Рекомендую указать 20480 Мб (20 Гб). Для информации: 1 Гб = 1024 Мб. Нажмите кнопку Next.

13) Нажмите кнопку Finish, для создания виртуальной машины. Вы снова окажетесь в окне Virtual PC Console.
14) Выберите созданную Вами виртуальную машину и нажмите кнопку Start
15) Виртуальная машина начнет свою работу и остановится с сообщением: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device, поскольку отсутствует инсталляционный диск с Windows 7. Выберите команду CD>Capture CD Image и укажите образ ISO с Windows 7.

16) Перезагрузите виртуальную машину, выбрав команду Action -> Ctrl+Alt+Del или нажав Правый Alt+DEL в окне виртуальной машины.
17) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
18) После завершения установки Windows 7 на виртуальную машину, Microsoft Virtual PC сразу запустит Вам Windows 7 внутри виртуальной машины.
19) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Alt.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Virtual Machine Additions. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Action –> Install or Update Virtual Machine Additions и нажмите Continue.

20) Во всплывшем окне Автозапуск нажмите Setup.exe и установите программу.
21) Нажмите Yes по окончанию установки Virtual Machine Additions и виртуальная машина перезагрузится.
22) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Action -> Close -> Turn Off и нажмите OK.
23) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Start.

Назад на страницу раздела Виртуализация.


10. Установка Windows 7 в виртуальную машину VMware Workstation.

VMware Workstation — популярная программа для виртуализации систем. VMware Workstation является массивным решением для разработчиков программного обеспечения и системных админов, создающих и тестирующих полно-комплексные сетевые приложения класса серверов, работающие в разнообразных средах.

1) Заходите на страницу оффициального сайта для скачивания программы: http://downloads.vmware.com/d/
2) Нажимаете на ссылку VMware Workstation
3) На открывшейся странице выбираете для скачивания VMware Workstation X.X.X for Windows (где X.X.X - номер версии)
4) Щелкаете на кнопке Download рядом с Workstation for Windows 32-bit and 64-bit with VMware Tools.
5) Нажимаете на кнопку Register и заполняете регистрационную форму и нажимаете Continue
6) Внизу EULA соглашения нажимаете Yes и оказываетесь на странице загрузки. Программа бесплатна для полнофункционального использования 30 дней. По истечении данного срока Вам необходимо её зарегистрировать.
7) Скачиваете Workstation for Windows 32-bit and 64-bit Main installation file with Tools. В отличие от других виртуальных машин, программа установки VMware Workstation имеет размер более 500 Мегабайт.
8) Установите программу. Перезапустите компьютер, для этого в последнем окне программы нажмите Restart Now или нажмите Restart Later и перезапустите вручную позже.
9) Запустите программу. Установите переключатель на Yes, I accept the terms in the license agreement и нажмите OK
10) В главном окне программы нажмите на значок New Vitual Machine.

11) Установите переключатель на Typical (recommended). Нажмите кнопку Next.

12) Установите переключатель на Installer disk image file (iso). Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Next.

13) Укажите свой инсталяционный код Windows 7, имя пользователя и пароль и нажмите кнопку Next. Если Вы решили ввести эти данные позже, то после нажатия кнопки Next, нажмите на кнопку Yes.
14) Выберите имя и расположение для файла Вашей виртуальной машины. Нажмите кнопку Next.

15) Задайте размер Вашего виртуального жесткого диска в гигабайтах.

16) Нажмите кнопку Finish, для создания виртуальной машины.
17) В окне VMware Workstation Activation нажмите Enter Serial Number, чтобы ввести имеющийся у Вас серийный номер. Если у Вас нет серийного номера, то Вы можете получить серийный номер на 30 дней для полнофункционального тестирования программы: https://www.vmware.com/tryvmware/?p=workstation&lp=default
18) После введения пробного номера во всплывшем окне Register your version of VMware Workstation now! нажмите кнопку Register
19) В главном окне программы перейдите на вкладку с названием Вашей виртуальной машины (по умолчанию Windows 7) и нажмите ссылку Power on this virtual machine.

20) В отличие от других виртуальных машин установка Windows 7 начнется сама и большую часть установки VMware Workstation выполнит автоматически, Ваше участие в процессе установки Windows 7 почти не потребуется.
21) После завершения установки Windows 7 на виртуальную машину, VMware Workstation сразу запустит Вам Windows 7 внутри виртуальной машины.
22) Сразу после запуска VMware Workstation самостоятельно установит Вам дополнительные инструменты VMware Tools, а также в случае наличия у Вас подключения к Интернет самостоятельно установит все необходимые драйвера.
23) Используйте комбинацию клавиш Ctrl+G для разблокировки одновременного использования мыши как в виртуальной системе, так и в основной.
24) Чтобы выключить виртуальную машину, завершите работу в виртуальной Windows 7 как в обычной Windows. Пуск -> Завершение работы.
25) Чтобы запустить установленную Windows 7 в основном окне программы в колонке слева выберите наименование Вашей операционной системы. В открывшейся вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) нажмите ссылку Power on this virtual machine.

Назад на страницу раздела Виртуализация.


11. Создание общей папки для виртуальной и основной Windows в VirtualBox.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VirtualBox и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Устройства -> Общие папки

2) Нажмите на клавиатуре кнопку Insert, либо нажмите на значок папки с плюсом.

3) Установите флажок для параметра Создать постоянную папку.
4) В ниспадающем меню рядом с текстом Путь к папке выберите пункт Другой....
5) Укажите путь к Вашей папке и нажмите на каждую кнопку ОК.

6) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> VBOXSVR -> Ваша папка

Назад на страницу раздела Виртуализация.


12. Создание общей папки для виртуальной и основной Windows в Microsoft Virtual PC.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину Microsoft Virtual PC и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Edit -> Settings или нажмите сочетание клавиш: правый Alt+E

2) Выберите в списке Shared Folders и нажмите кнопку Share Folder...

3) Установите флажок на Share Every Time, укажите Вашу общую папку и установите букву диска в виде которго будет отображаться папка в виртуальной Windows, затем нажмите OK.

4) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Компьютер -> Отключенное сетевое устройство (назначенная вами буква диска)

Назад на страницу раздела Виртуализация.


13. Создание общей папки для виртуальной и основной Windows в VMware Workstation.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VMware Workstation и хостовой (реальной) Windows 7, сделайте следующее:

1) В вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) перейдите на вкладку Options.
2) Сделайте двойной щелчок на папке Shared Folders

3) Установите переключатель на Always enabled.

4) Нажмите кнопку Add..., а затем кнопку Next.
5) Нажмите кнопку Browse. Укажите путь к Вашей общей папке в хостовой (реальной) Windows 7 и ее имя в виртуальной Windows, затем нажмите OK.

6) Нажмите кнопку Next, а затем кнопку Finish. Выйдите из опций нажав на OK.
7) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> vmware-host -> Shared Folders -> Ваша папка

Назад на страницу раздела Виртуализация.


Твики Реестра

Твики Реестра - Добавление

1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@="\"%1\" /X:\"%1_unpacked\""
В итоге, при распаковке WindowsXP-KB922582-x86-RUS.exe, на выходе получаем папку WindowsXP-KB922582-x86-RUS.exe_unpacked с извлечёнными файлами. Минус один - команда Unpack HotFix встраивается в контекстное меню всех екзешников, а не только файлов от MS.

Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix]
[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@=-

Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

2. Как задать полный доступ к файлу или папке?

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"

3. Автоматическое VPN подключение к интернет при запуске Windows (реестр).

1. Создайте ваше VPN подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:
"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск только для текущего пользователя) или
"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск для всех пользователей)
В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
2. В качестве значения созданного параметра внесите строку вида:
rasdial "имя_вашего соединения" <логин> <пароль> (Например: rasdial "VPN connection" nz15vl 1234)
3. Закройте реестр и перезагрузите компьютер.

4. Добавляем пункт "Открыть в блокноте" в контекстное меню файлов.

Для того, чтобы добавить в контекстное меню файлов пункт "Открыть в Блокноте" текст кода сохраните в текстовый файл, присвойте ему расширение *.reg, запустите и согласитесь с добавлением данных в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте]
@=""

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте\command]
@="notepad.exe %1"

5. Как добавить дополнительные функции в папку Компьютер?

Администрирование

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]

Корзина

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{645FF040-5081-101B-9F08-00AA002F954E}]

Панель управления

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\Controls]
@="{21EC2020-3AEA-1069-A2DD-08002B30309D}"

Принтеры и факсы

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}]

Учетные записи пользователей

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{7A9D77BD-5403-11d2-8785-2E0420524153}]
В итоге получаем:

6. Добавляем произвольную команду в контекстное меню рабочего стола.

Для этого создаем файл fix.txt
Открываем блокнот и копируем туда это содержимое, сохраняем и меняем разширение на .reg
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name]
@="Свойства папки"
"Icon"="imageres.dll,200"
"Position"="Top"

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name\command]
@="control folders"
Сохраняем файл и выполняем его.
В параметре "Icon"="imageres.dll,200" цифра 200 отвечает за номер иконки. Вы можете указать свою.
Таким образом можно добавить практически любую команду (управление учетными записями Control userpasswords).

7. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.
1) Скачиваете утилиту Reg2inf (необходим Framework 2 или 3)
2) Помешаете её в System32
3) Добавление в реестр добавляется следующее:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\command]
@="Reg2Inf.exe \"%1\" \"%1.inf\" /RepVars"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Application]
@="Reg2Inf"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Topic]
@="System"
В итоге, в контекстное меню reg файлов добавляется команда reg2inf и, к примеру, файл test.reg конвертируется в test.reg.inf

8. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".
Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\Shell]

[HKEY_CLASSES_ROOT\*\Shell\astext]
@="Как текст..."

[HKEY_CLASSES_ROOT\*\Shell\astext\command]
@="notepad.exe \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\Expand]
@="Распаковать .cab"

[HKEY_CLASSES_ROOT\*\Shell\Expand\command]
@="expand -r \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\MakeCab]
@="Запаковать в .cab"

[HKEY_CLASSES_ROOT\*\Shell\MakeCab\command]
@="makecab /D CompressionType=LZX /D CompressionMemory=21 \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\UpperCase]
@="Имя в ВЕРХНИЙ РЕГИСТР"

[HKEY_CLASSES_ROOT\*\Shell\UpperCase\command]
@="FILECASE /U \"%1\""

[HKEY_CLASSES_ROOT\Directory\shell\CabPack]
@="Запаковать папку в .cab"

[HKEY_CLASSES_ROOT\Directory\shell\CabPack\command]
@="cabs.cmd %L"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs]
@="Создать список файлов папки"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs\command]
@="dirs.cmd %L"

9. Добавление пункта "Удалить содержимое папки" в контекстное меню.

Как добавить в контекстное меню папки команду для удаления содержимого папки без удаления самой папки? Вы можете создать себе пункт Удалить содержимое папки в контекстном меню и Вам достаточно будет его только выбрать. Вам не придется открывать папку, выделять все файлы и нажимать на клавишу Delete.

Вариант 1.

1) Запустите редактор реестра: Win+R -> regedit -> Ok
2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
3) Создайте в ней раздел DeleteFolderContent
4) Создайте в нем строковый(String) параметр MUIVerb со строкой Удалить содержимое папки.
5) В разделе DeleteFolderContent создайте подраздел command
6) Измените значение параметра (По умолчанию) раздела command на следующее:
cmd /c "cd /d %1 && del /s /f /q *.*"

Вариант 2.

1) Запустите редактор реестра: Win+R -> regedit -> Ok
2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
3) Создайте в ней раздел Удалить содержимое папки
4) В разделе Удалить содержимое папки создайте подраздел command
6) Измените значение параметра (По умолчанию) раздела command на следующее:
cmd /c "cd /d %1 && del /s /f /q *.*"

Вариант 3.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell\DeleteFolderContent]
@="Удалить содержимое папки"

[HKEY_CLASSES_ROOT\Directory\shell\DeleteFolderContent\command]
@="cmd /c \"cd /d %1 && del /s /f /q *.*\" "
Вы можете скачать готовые reg-файлы: DeleteFolderContent.zip

10. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

По какой-то неизвестной причине, разработчики Microsoft решили не включать в контекстное меню Проводника пункты Копировать в папку (Copy To) и Переместить в папку (Move To). Используя их, можно легко и быстро скопировать или переместить файл или папку. Для этого, достаточно выбрать желаемое место их размещения в соответствующем диалоговом окне. Для того, чтобы добавить эти команды в контекстное меню, достаточно создать, соответствующие им параметры в реестре.

Вариант 1

1) Запустите Редактор Реестра (нажмите копку «Пуск» (Start), введите regedit в строке «Найти программы и файлы» и нажмите Enter).
2) Откройте ветку реестра HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers
3) Создайте в ней раздел со следующим именем (включая фигурные скобки):
Для добавления в контекстное меню пункта Копировать в папку
{C2FBB630-2971-11D1-A18C-00C04FD75D13}
Для добавления в контекстное меню пункта Переместить в папку
{C2FBB631-2971-11D1-A18C-00C04FD75D13}
4) Нажмите Enter
5) Перезагрузите Проводник Windows (Windows Explorer) или перезайдите в систему, и данные пункты появятся в контекстном меню.

Вариант 2

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\{C2FBB630-2971-11D1-A18C-00C04FD75D13}]
@=""

[HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\{C2FBB631-2971-11D1-A18C-00C04FD75D13}]
@=""

11. Включение скрытых настроек электропитания.

Чтобы настроить в Windows 7 параметры электропитания, необходимо открыть Панель управления\Система и безопасность\Электропитание. Там можно выбрать нужный план электропитания и при необходимости более детально настроить параметры, перейдя в Настройка плана электропитания -> Изменить дополнительные параметры питания.
Однако более детально настроить параметры электропитания помогает консольная утилита Powercfg. Но работать в командной строке, разбираясь с каждым параметром может занять продолжительное время. Для того чтобы функции предоставляемые powercfg стали доступны Вам в графической оболочке, необходимо внести некоторые изменения в ветке реестра:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings
В данной ветке содержатся разделы, отвечающие за определенную группу настроек.
Например, раздел 0012ee47-9041-4b5d-9b77-535fba8b1442 относится к настройкам управления питанием жесткого диска, а 54533251-82be-4824-96c1-47b60b740d00 к настройкам управления питанием процессора.
В свою очередь, в каждом из данных разделов есть подразделы, отвечаяющие за какую-либо настройку электропитания. Описание каждой из настроек указано в значении параметра Description, а её отображение в графической оболочке в значении параметра Attributes. По умолчанию, многие настройки имеют значение параметра Attributes равное «1», для того, чтобы необходимая Вам настройка был виден в графической оболочке, необходимо заменить его на «0». Доступные для отображения настройки, на ноутбуке и стационарном компьютере могут отличаться, в связи с особенностью их систем электропитания.

Для отображения политики простоя устройств, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\4faab71a-92e5-4726-b531-224559672d19]
"Attributes"=dword:00000000
Для отображения скрытых параметров по настройке работы жесткого диска, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\dab60367-53fe-4fbc-825e-521d069d2456]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\0b2d69d7-a2a1-449c-9680-f91c70521c60]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\80e3c60e-bb94-4ad8-bbe0-0d3195efc663]
"Attributes"=dword:00000000
Для отображения скрытых параметров по настройке кнопок питания, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\4f971e89-eebd-4455-a8de-9e59040e7347\833a6b62-dfa4-46d1-82f8-e09e34d029d6]
"Attributes"=dword:00000000
Для отображения скрытых параметров по настройке управления питания процессора, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\3b04d4fd-1cc7-4f23-ab1c-d1337819c4bb]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\5d76a2ca-e8c0-402f-a133-2158492d58ad]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\a55612aa-f624-42c6-a443-7397d064c04f]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\ea062031-0e34-4ff1-9b6d-eb1059334028]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\0cc5b647-c1df-4637-891a-dec35c318583]
"Attributes"=dword:00000000
Импортированное значение реестра позволяет увидеть только малую часть параметров, доступных для настройки управлением процессора. Всего их более 30.

Для отображения скрытых параметров по настройке спящего режима, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\25DFA149-5DD1-4736-B5AB-E8A37B5B8187]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\d4c1d4c8-d5cc-43d3-b83e-fc51215cb04d]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\abfc2519-3608-4c2a-94ea-171b0ed546ab]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\A4B195F5-8225-47D8-8012-9D41369786E2]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0]
"Attributes"=dword:00000000
Для отображения скрытых параметров по настройке экрана, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\A9CEB8DA-CD46-44FB-A98B-02AF69DE4623]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\FBD9AA66-9553-4097-BA44-ED6E9D65EAB8]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\90959d22-d6a1-49b9-af93-bce885ad335b]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\EED904DF-B142-4183-B10B-5A1197A37864]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\82DBCF2D-CD67-40C5-BFDC-9F1A5CCD4663]
"Attributes"=dword:00000000
Также к этому разделу относится настройка параметров графического адаптера, но доступность конкретных настроек будет определяется драйвером.

У себя в системе я обнаружил 54 скрытых настройки электропитания. Для включения сразу всех скрытых настроек электропитания: экспортируйте всю ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings в reg-файл. Отредактируйте полученный reg-файл: оставьте в нем только наименование веток реестра и их параметры Attributes и присвойте им значения «0». Также Вы можете скачать и применить, готовый reg-файл PowerSettings.reg

12. Добавление своего ярлыка папки или программы в папку Компьютер.

Если Вы часто пользуйтесь какой-либо программой, то помимо добавления её значка на Рабочий стол, Вы также можете добавить его в папку Компьютер. Поскольку скопировать напрямую или создать ярлык в данной папке нельзя, то предлагаю Вам решение, как это возможно осуществить.

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}]
@="Имя программы"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\DefaultIcon]
@="Путь к иконке программы"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell\Open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell\Open\Command]
@="Путь к файлу программы"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{GUID}]
2) Скачайте программу Microsoft Exchange Server GUID Generator
3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
4) Установите переключатель на значение Registry Format
5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
7) Вставьте вместо {GUID}, сгенерированный программой GUID.
Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {FF4A6226-C00B-409e-88A6-6C401C52BD98}
Внимание! Для добавления при указывании пути к иконе и файлу объекта слэш должен быть двойным.
8) Например, если путь к программе: C:\MyProgram\MyProgram.exe, то необходимо указать его как: C:\\MyProgram\\MyProgram.exe
Так как, чаще всего икона программы встроена в саму программу, то значения "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" могут совпадать.
9) При добавлении ярлыка папки измените "Путь к иконке для ярлыка" на %SystemRoot%\\system32\\SHELL32.dll,4
А значение "Путь к папке или файлу программы" на explorer /n, /e, C:\\ВашаПапка
10) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
11) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
12) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Пример reg-файла для добавления программы WinDjView в папку Компьютер:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
@="WinDjView"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\DefaultIcon]
@="C:\\Program Files\\WinDjView\\WinDjView.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open\Command]
@="C:\\Program Files\\WinDjView\\WinDjView.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
Пример reg-файла для добавления папки Downloads в папку Компьютер:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
@="Downloads"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\DefaultIcon]
@="%SystemRoot%\\system32\\SHELL32.dll,4"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open\Command]
@="explorer /n, /e, C:\\My Folder\\Downloads"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
В итоге Вы получите тот же самый эффект, что был упомянут в совете 5 раздела "Твики Реестра - Добавление".

Твики Реестра - Изменение

1. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
2) Введите команду
unregmp2.exe /SwapTo:64
(команда чувствительна к регистру)
3) Откройте редактор реестра: Win+R --> regedit
4) Перейдите к ветке
HKLM\Software\Microsoft\Windows\CurrentVersion\App Paths\wmplayer.exe\
и кликните два раза по значению Path
5) Измените
"%ProgramFiles(x86)%\Windows Media Player"
на
"%ProgramFiles%\Windows Media Player"
6) Закройте реестр и наслаждайтесь Windows Media Player х64

Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

2. Ускорение выключения компьютера.

Измените задержку перед выключением компьютера в реестре в разделе:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WaitToKillServiceTimeout" - отвечает за задержку перед выключением.
По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки)

3. Отмена автозапуска для носителей и устройств.

1) Пуск -> выполнить -> regedit
2) открыть ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) В этом разделе создать ключ(Параметр DWORD) NoDriveTypeAutoRun

Допустимые значения ключа:

0x1 - отключить автозапуск на приводах неизвестных типов
0x4 - отключить автозапуск сьемных устройств
0x8 - отключить автозапуск НЕсьемных устройств
0x10 - отключить автозапуск сетевых дисков
0x20 - отключить автозапуск CD-приводов
0x40 - отключить автозапуск RAM-дисков
0x80 - отключить автозапуск на приводах неизвестных типов
0xFF - отключить автозапуск вообще всех дисков.

4. Смена фона в экране авторизации.

1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background

2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
4) Поместите сюда свой файл
5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg
backgroundDefault.jpg - в случае нестандартного расширения монитора

Размер изображений не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

5. Ускорение анимации всплывающего меню в меню Пуск и появления окна предварительного просмотра в панели задач.

Если Вы желаете изменить время задержки до показа всплывающего меню в меню Пуск, проделайте следующее:

1)Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
3) Создайте в нем(или измените) параметр MenuShowDelay
4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
6) Выберите желательное значение от 1 до 4000, означающее задержку в милисекундах, до показа всплывающего меню в меню Пуск.
7) Закройте regedit и перезагрузите систему.

6. Изменение состояния встроенного динамика персонального компьютера.

1) Запустите редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Sound
3) Измените значение параметра Beep на "No" чтобы отключить и на "Yes" чтобы включить.

7. Переназначение гнезд звуковой карты Realtek используя реестр.
На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

1) Установите драйвера звуковой карты
2) Запустите редактор реестра (Win+К -> regedit -> Ok)
3) Пройдите к папке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\
4) Откройте папку Drv6013_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

Рисунок 1 из 2

Имя(вставлять без кавычек):

"Pin01" = Заднее зеленое гнездо
"Pin02" = Заднее черное гнездо
"Pin03" = Заднее коричневое гнездо
"Pin04" = Заднее серое гнездо
"Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
"Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

"Pin06" = Переднее розовое гнездо
"Pin08" = Переднее зеленое гнездо

Значение(вставлять без кавычек):

"00 00 00 00" = Линейный вход
"01 00 00 00" = Микрофон
"02 00 00 00" = Наушники
"04 00 00 00" = Передние динамики
"05 00 00 00" = Тыловые динамики
"06 00 00 00" = Центральный канал/Сабвуфер
"07 00 00 00" = Боковые динамики

Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

Drv6013_DevType_0888_SS10438357 - на версию вашего драйвера
(имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
Pin04 - на любое значение из списка Имя
hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\Drv6013_DevType_0888_SS10438357]
"Pin04"=hex:02,00,00,00

Рисунок 2 из 2

8. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
3) Измените значение параметра MessageDuration.

9. Настройка диалога переключения между окнами ("Alt"+"Tab").

1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Для создания твика, воспользуйтесь инструкцией:

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Параметры, отвечающие за количество отображаемых столбцов и строк

Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"Columns"=dword:00000005
"Rows"=dword:00000003
Параметры, отвечающие за отступы в диалоге переключения между окнами

Упомянутые ниже параметры указываются в пикселях.

TopMarginPx - величина верхнего поля, добавляемого в диалог
SideMarginPx - величина бокового поля, добавляемого в диалог
BottomMarginPx - величина нижнего поля, добавляемого в диалог
MinWidthPx - минимальная возможная ширина диалога AltTab
ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"TopMarginPx"=dword:00000027
"SideMarginPx"=dword:00000005
"BottomMarginPx"=dword:00000003
"MinWidthPx"=dword:00000050
"ThumbSpacingXPx"=dword:00000006
"ThumbSpacingYPx"=dword:00000015
Параметры, отвечающие за значки эскизов окон

Упомянутые ниже параметры указываются в пикселях.

OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"OverlayIconDYPx"=dword:00000008
"OverlayIconDXPx"=dword:00000008
"OverlayIconPx"=dword:00000030
Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

Упомянутые ниже параметры указываются в пикселях.
MaxThumbSizePx - максимальный размер эскизов окон
MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
TextButtomPx - высота заголовка диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"MinThumbSizePcent"=dword:00000010
"MaxThumbSizePx"=dword:00000085
"TextButtomPx"=dword:00000010
Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

StartAlpha - начальная прозрачность диалога переключения между окнами
FinalAlpha - конечная прозрачность диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"FadeOut_ms"=dword:00000100
"FadeIn_ms"=dword:00000100
"StartAlpha"=dword:00000002
"FinalAlpha"=dword:00000004
Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

10. Настройка параметров всплывающих эскизов окон в панели задач.

Изменив несколько настроек в реестре Вы сможете придать своим всплывающим эскизам окон больше эффективности в работе.

1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Создайте в нем(или измените) параметры:

ExtendedUIHoverTime - Задержка до появления всплывающего эскиза окна на экране, после наведения курсора мыши на иконку в панели задач.
ThumbnailLivePreviewHoverTime - Задержка до появления окна программы, после наведения курсора мыши на всплывший эскиз окна.

4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
6) В графе Система исчисления установите значение параметра на Десятичная.
7) Введите необходимое Вам значение. Значение 1000 = 1 секунде.

8) Откройте в реестре раздел: HKEY_CLASSES_ROOT\SystemFileAssociations\image
9) Сделайте двойной щелчок на параметре Treatment - Данный параметр изменяет вид бордюра всплывающего эскиза окна.
10) Выберите необходимое Вам значение:

0 - Без бордюра
1 - Бордюр с тенью
2 - Фоторамка (по умолчанию)
3 - Видеорамка

11) Закройте regedit и перезагрузите систему.

11. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

Когда Вы наводите курсор на крайнюю кнопку, находящуюся за часами на панели задач (обычно правый нижний угол экрана), система показывает Вам рабочий стол. При желании Вы можете ускорить или замедлить данный процесс.

1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Измените значение параметра DesktopLivePreviewHoverTime. Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
4) В графе Система исчисления установите значение параметра на Десятичная.
5) Введите необходимое Вам значение. Значение 1000 = 1 секунде.
6) Закройте regedit, перезайдите в систему или перезагрузите систему.

12. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

Как известно, при выделении более 15 файлов команды контекстного меню, такие как "Открыть/Печать/Редактировать" становятся недоступны.
Для отмены данного ограничения проделайте следующее:

1)Запустите редактор реестра ( Win+R -> regedit -> OK)
2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
3) Создайте в ней параметр MultipleInvokePromptMinimum типа DWORD.
4) Установите значение данного параметра равным 16.

Для уменьшения количества файлов на которых действует ограничение применения команд, введите значение от 1 до 15.
При выделении файлов выше выбранного Вами значения команды в контекстном меню применяться не будут. При указании значения 0 произойдет полное отключение команд, включая команду "Открыть".

13. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

1) Откройте Редактор групповой локальной политики (Win+R -> gpedit.msc - Ok)
2) Перейдите в раздел Конфигурация пользователя\Административные шаблоны\Панель управления.
3) Выберите команду Скрыть указанные элементы панели управления
4) Установите переключатель в значение Включить.
5) Нажмите на кнопку Показать.
6) Добавьте новую запись: Microsoft.DevicesAndPrinters и нажмите Ok.
7) Запустите редактор реестра (Win+R -> regedit.exe -> Ok).
8) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
9) Создайте в ней новый раздел {2227a280-3aea-1069-a2de-08002b30309d}.
10) Присвойте параметру По умолчанию значение - Принтеры (Printers).

Данную папку Вы сможете увидеть в Панели управления в контекстном меню Пуск, если у Вас установлено значение "Отображать как меню" или при просмотре полного списка всех элементов при её открытии.

Твики Реестра - Удаление

1. Как убрать цифру при пересоздании адаптера сети в Диспетчере устройств?

Вариант 1

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" установите значение адаптера сети на 0.
3) Создайте драйвер сетевого адаптера

Вариант 2

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" удалите ваш сетевой адаптер.
3) Создайте драйвер сетевого адаптера.

2. Как отключить проверку подписи для загруженных программ?

Избавляет от этого:

1) В Панель управления -> Свойства браузера-> вкладка Дополнительно -> снять галочку "Проверка подписи для загруженных программ" и поставить галочку "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
2) Создайте и примените reg-файл следующего содержания.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"DefaultFileTypeRisk"=dword:00006152

;Отключить предупреждение при открытии файлов, загруженных из Интернета
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
"HideZoneInfoOnProperties"=dword:00000001
"SaveZoneInformation"=dword:00000002

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000095

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".zip;.rar;.nfo;.txt;.exe;.bat;.com;.cmd;.reg;.msi;.htm;.html;.gif;.bmp;.jpg;.avi;.mpg;.mpeg;.mov;.mp3;.m3u;.wav;"

3. Как удалить (вернуть) стрелки с ярлыков Windows?

Готовые файлы для убирания стрелок вы можете скачать по ссылке:
Shortcut_Arrows.zip
1) Распакуйте и откройте папку нужного вам варианта
2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat или Remove_Shortcut_Arrow.reg
3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat или Restore_Shortcut_Arrow.reg

Вариант 1

Для удаления стрелок с ярлыков:

1) Запустите диалоговое окно "Выполнить" (Win + R)
2) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %WINDIR%\system32\shell32.dll,50 /f
Для восстановления стрелок на ярлыках:
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f
Или в ручную удалите данную ветку.

Вариант 2

Для удаления стрелок с ярлыков:

1) Создайте пустой файл иконки назовите его Blank.ico
2) Скопируйте его в папку C:\Windows
3) Запустите диалоговое окно "Выполнить" (Win + R)
4) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %SystemRoot%\Blank.ico,0 /f
Для восстановления стрелок на ярлыках:

1) Удалите файл Blank.ico из папки C:\Windows
2) Запустите диалоговое окно "Выполнить" (Win + R)
3) Скопируйте код указанный ниже и нажмите OK
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f
Или в ручную удалите данную ветку.

Побочным эффектом при использовании данного варианта является, появление черных квадратиков вместо стрелочек, если в папке Windows у Вас будет отсутствовать файл Blank.ico.

Вариант 3

1) Скопируйте текст в блокнот.
2) Сохраните как Remove_Shortcut_Arrow.reg (для удаления) или Restore_Shortcut_Arrow.reg (для восстановления).
3) Выполните файл, чтобы его содержание было внесено в реестр.
4) Обратите внимание на знак минуса в команде "IsShortCut"=-. Вокруг него нет кавычек. Эта команда удаляет значение IsShortCut и сам ключ IsShortCut. Если вы введёте команду "IsShortCut"="-", то тогда ключ удалён не будет, а его значение поменяется на минус. "IsNotShortCut"="" создаёт ключ и присваивает ему нулевое значение.

Файл .reg для удаления стрелок с ярлыков
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=-
"IsNotShortCut"=""
Файл .reg для восстановления стрелок на ярлыках
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=""
"IsNotShortCut"=-
Побочным эффектом при использовании данного варианта является, исчезновение пункта "Закрепить программу в панели задач". Если Вам необходимо будет закрепить какую-либо программу в Панели задач, то воспользуйтесь reg-файлом для восстановления стрелок на ярлыках, закрепите программу, а затем снова воспользуйтесь reg-файлом для удаления стрелок с ярлыков.

4. Как отключить или переназначить клавишу Caps Lock?

Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

Клавиша Caps Lock будет выполнять действие клавиши Ctrl
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,1d,00,3a,00,00,00,00,00
Клавиша Caps Lock будет выполнять действие клавиши Shift

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,2a,00,3a,00,00,00,00,00
Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,3A,00,46,00,00,00,00,00
Отключает клавишу Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,00,00,00,00
Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=-

5. Удаление просроченных элементов в области уведомления панели задач.

1. Запустите редактор реестра: Win+R --> regedit
2. Перейдите в следующий раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
3. Удалите параметры "IconStreams" и "PastIconsStream"
4. Запустите диспетчер задач Ctrl+Shift+Esc
5. Остановите процесс explorer.exe
6. File --> New Task (Run...) --> explorer --> ОК.
7. Установите необходимые параметры отображения области уведомления панели задач.

6. Удаление папок из Рабочего стола в Проводнике.

Если вы хотите, удалить папки из Рабочего стола в Проводнике.

Вариант 1

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
3) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
5) Удалите следующие ветки:
Favorites(Избранное)             = {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки)            = {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа)       = {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Документы)    = {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер)              = {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть)                    = {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) = {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина)             = {645FF040-5081-101B-9F08-00AA002F954E}

Вариант 2

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
Для удаления Favorites(Избранное), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a9400100
Для восстановления Favorites(Избранное) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a0900100
Для удаления Libraries(Библиотеки), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b090010d
Для восстановления Libraries(Библиотеки) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b080010d
Для удаления Homegroup(Домашняя группа), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Homegroup(Домашняя группа) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Computer(Компьютер), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Computer(Компьютер) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Network(Сеть), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0940064
Для восстановления Network(Сеть) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0040064
Для удаления Recycle Bin(Корзина), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:70,01,00,20
Для восстановления Recycle Bin(Корзина) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:40,01,00,20

7. Очистка устаревших значков из диалога выбора значков и уведомлений.

После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

8. Очистка истории расположений фонов рабочего стола в Windows 7.

В окне настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев Рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

1. Фоны рабочего стола Windows;
2. Библиотека изображений;
3. Самые популярные фотографии;
4. Сплошные цвета.

Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

9. Удаление папки Общие Документы и пользовательского профиля Общие.

Для спокойного удаления папки Общие Документы и пользовательского профиля Общие указанные ниже действия рекомендуется выполнять на чистой установленной системе. Если же у Вас система уже установлена, и на ней уже установлены программы, то прежде чем выполнять инструкции ниже скопируйте все папки из C:\Users\Public\* в C:\Users\ВашПрофиль\*

Вариант 1.

1) В командной строке(Пуск->Выполнить) наберите REGEDIT
2) Найдите ветку HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\
3) Затем нажмите правой кнопкой мыши на правой панели и выберите Создать -> Параметр "DWORD".
4) Дайте этому параметру имя NoSharedDocuments и присвойте ему значение 1
5) Перезагрузите компьютер

Вариант 2.

1) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
2) Удалите следующую ветку: {59031a47-3f72-44a7-89c5-5595fe6b30ee}
3) Пройдите к ветке реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\DelegateFolders\
4) Удалите следующую ветку(если есть): {59031a47-3f72-44a7-89c5-5595fe6b30ee}

Вариант 3.

1) Откройте Панель управления\Все элементы панели управления\Система(или Пуск -> Компьютер -> Свойства)
2) Откройте Дополнительные параметры системы
3) Пройдите на вкладку Имя Компьютера и нажмите Идентификация...
4) Выберите пункт Компьютер предназначен для домашнего использования.
5) Нажмите Далее, затем Готово, затем Ок
6) Перезагрузите компьютер

После того, как воспользуйтесь решением одного из вариантов проделайте следующие действия:

1) В ветке реестра: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders замените значения с C:\Users\Public\ на C:\Users\ВашПрофиль\

2) В ветке реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders замените значения с %PUBLIC%\ на %USERPROFILE%\

3) Удалите папки (если они остались):

Диск С: -> Пользователи -> Общие (C:\Users\Public\)
Библиотеки -> Документы -> Общие Документы

Внимание: Если не хотите,чтобы у Вас на рабочем столе появились дублирующиеся иконки файлов, не устанавливайте значение параметра Common Desktop, идентичное рабочему столу Вашего профиля. Например, вместо C:\Users\ВашПрофиль\Desktop укажите C:\Users\ВашПрофиль\Public\Desktop, а вместо %USERPROFILE%\Desktop укажите %USERPROFILE%\Public\Desktop.

10. Отключение суффикса "-Ярлык" при создании новых ярлыков.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
3) В правой части окна, дважды щелкните на параметр реестра "link".
4) Измените значение на 00 00 00 00.
5) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"link"=hex:00,00,00,00

11. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) В правой части окна, дважды щелкните на параметр реестра "ShowInfoTip".
4) Измените значение на 0.
5) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"ShowInfoTip"=dword:00000000

12. Запрет запуска контекстного меню Проводника при нажатии правой кнопкой мыши.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в NoViewContextMenu
5) Измените значение на 1.
6) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:
Windows Registry Editor Version 5.00

[HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoViewContextMenu"=dword:00000001

13. Удаление пункта меню Файл из Проводника.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в NoFileMenu
5) Измените значение на 1.
6) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:
Windows Registry Editor Version 5.00

[HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoFileMenu"=dword:00000001
Данный пункт будет также удален из всех мест, использующих оболочку Windows

14. Запрещение запуска программ.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в RestrictRun
5) Измените значение на 1.
6) Перезагрузите компьютер.
7) Создайте подраздел с аналогичным именем RestrictRun
8) Создайте в разделе (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun) список разрешенных к запуску программ для текущего пользователя.
8.1) Создайте строковые(String) параметры
8.2) Укажите названия для создаваемый строковых параметров, начиная с 1 и далее
8.3) Установите в значениях параметров пути к Вашим приложениям и их имена. Файлы должны указываться с расширением. Например:

1 REG_SZ regedit.exe
2 REG_SZ calc.exe
3 REG_SZ Iexplore.exe

Не забудьте указать файл regedit.exe, чтобы Вы могли зайти в него и отменить установленные Вами ограничения!
Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0 или удалить его.

Если Вы забыли указать regedit.exe в списке или не создали подраздел RestrictRun, чтобы запретить запуск всех программ. Для отмены запрета проделайте следующее:

1) Перезапустите компьютер.
2) До начала запуска Windows нажмите на клавишу F8 и выберите пункт Безопасный режим с поддержкой командной строки
3) В командной строке введите regedit и нажмите Enter.
4) Пройдите в ветку HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
5) Удалите ключ RestrictRun или установите его значение на 0.


1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@="\"%1\" /X:\"%1_unpacked\""
В итоге, при распаковке WindowsXP-KB922582-x86-RUS.exe, на выходе получаем папку WindowsXP-KB922582-x86-RUS.exe_unpacked с извлечёнными файлами. Минус один - команда Unpack HotFix встраивается в контекстное меню всех екзешников, а не только файлов от MS.

Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix]
[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@=-
Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


2. Как задать полный доступ к файлу или папке?

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


3. Автоматическое VPN подключение к интернет при запуске Windows (реестр).

1. Создайте ваше VPN подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:
"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск только для текущего пользователя) или
"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск для всех пользователей)
В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
2. В качестве значения созданного параметра внесите строку вида:
rasdial "имя_вашего соединения" <логин> <пароль> (Например: rasdial "VPN connection" nz15vl 1234)
3. Закройте реестр и перезагрузите компьютер.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


4. Добавляем пункт "Открыть в блокноте" в контекстное меню файлов.

Для того, чтобы добавить в контекстное меню файлов пункт "Открыть в Блокноте" текст кода сохраните в текстовый файл, присвойте ему расширение *.reg, запустите и согласитесь с добавлением данных в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте]
@=""

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте\command]
@="notepad.exe %1"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


5. Как добавить дополнительные функции в папку Компьютер?

Администрирование

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]

Корзина

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{645FF040-5081-101B-9F08-00AA002F954E}]

Панель управления

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\Controls]
@="{21EC2020-3AEA-1069-A2DD-08002B30309D}"

Принтеры и факсы

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}]

Учетные записи пользователей

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{7A9D77BD-5403-11d2-8785-2E0420524153}]
В итоге получаем:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


6. Добавляем произвольную команду в контекстное меню рабочего стола.

Для этого создаем файл fix.txt
Открываем блокнот и копируем туда это содержимое, сохраняем и меняем разширение на .reg
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name]
@="Свойства папки"
"Icon"="imageres.dll,200"
"Position"="Top"

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name\command]
@="control folders"
Сохраняем файл и выполняем его.
В параметре "Icon"="imageres.dll,200" цифра 200 отвечает за номер иконки. Вы можете указать свою.
Таким образом можно добавить практически любую команду (управление учетными записями Control userpasswords).

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


7. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.

1) Скачиваете утилиту Reg2inf (необходим Framework 2 или 3)
2) Помешаете её в System32
3) Добавление в реестр добавляется следующее:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\command]
@="Reg2Inf.exe \"%1\" \"%1.inf\" /RepVars"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Application]
@="Reg2Inf"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Topic]
@="System"
В итоге, в контекстное меню reg файлов добавляется команда reg2inf и, к примеру, файл test.reg конвертируется в test.reg.inf

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


8. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".

Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\Shell]

[HKEY_CLASSES_ROOT\*\Shell\astext]
@="Как текст..."

[HKEY_CLASSES_ROOT\*\Shell\astext\command]
@="notepad.exe \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\Expand]
@="Распаковать .cab"

[HKEY_CLASSES_ROOT\*\Shell\Expand\command]
@="expand -r \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\MakeCab]
@="Запаковать в .cab"

[HKEY_CLASSES_ROOT\*\Shell\MakeCab\command]
@="makecab /D CompressionType=LZX /D CompressionMemory=21 \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\UpperCase]
@="Имя в ВЕРХНИЙ РЕГИСТР"

[HKEY_CLASSES_ROOT\*\Shell\UpperCase\command]
@="FILECASE /U \"%1\""

[HKEY_CLASSES_ROOT\Directory\shell\CabPack]
@="Запаковать папку в .cab"

[HKEY_CLASSES_ROOT\Directory\shell\CabPack\command]
@="cabs.cmd %L"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs]
@="Создать список файлов папки"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs\command]
@="dirs.cmd %L"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


9. Добавление пункта "Удалить содержимое папки" в контекстное меню.

Как добавить в контекстное меню папки команду для удаления содержимого папки без удаления самой папки? Вы можете создать себе пункт Удалить содержимое папки в контекстном меню и Вам достаточно будет его только выбрать. Вам не придется открывать папку, выделять все файлы и нажимать на клавишу Delete.

Вариант 1.

1) Запустите редактор реестра: Win+R -> regedit -> Ok
2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
3) Создайте в ней раздел DeleteFolderContent
4) Создайте в нем строковый(String) параметр MUIVerb со строкой Удалить содержимое папки.
5) В разделе DeleteFolderContent создайте подраздел command
6) Измените значение параметра (По умолчанию) раздела command на следующее:
cmd /c "cd /d %1 && del /s /f /q *.*"

Вариант 2.

1) Запустите редактор реестра: Win+R -> regedit -> Ok
2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
3) Создайте в ней раздел Удалить содержимое папки
4) В разделе Удалить содержимое папки создайте подраздел command
6) Измените значение параметра (По умолчанию) раздела command на следующее:
cmd /c "cd /d %1 && del /s /f /q *.*"

Вариант 3.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell\DeleteFolderContent]
@="Удалить содержимое папки"

[HKEY_CLASSES_ROOT\Directory\shell\DeleteFolderContent\command]
@="cmd /c \"cd /d %1 && del /s /f /q *.*\" "
Вы можете скачать готовые reg-файлы: DeleteFolderContent.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


10. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

По какой-то неизвестной причине, разработчики Microsoft решили не включать в контекстное меню Проводника пункты Копировать в папку (Copy To) и Переместить в папку (Move To). Используя их, можно легко и быстро скопировать или переместить файл или папку. Для этого, достаточно выбрать желаемое место их размещения в соответствующем диалоговом окне. Для того, чтобы добавить эти команды в контекстное меню, достаточно создать, соответствующие им параметры в реестре.

Вариант 1

1) Запустите Редактор Реестра (нажмите копку «Пуск» (Start), введите regedit в строке «Найти программы и файлы» и нажмите Enter).
2) Откройте ветку реестра HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers
3) Создайте в ней раздел со следующим именем (включая фигурные скобки):
Для добавления в контекстное меню пункта Копировать в папку
{C2FBB630-2971-11D1-A18C-00C04FD75D13}
Для добавления в контекстное меню пункта Переместить в папку
{C2FBB631-2971-11D1-A18C-00C04FD75D13}
4) Нажмите Enter
5) Перезагрузите Проводник Windows (Windows Explorer) или перезайдите в систему, и данные пункты появятся в контекстном меню.

Вариант 2

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\{C2FBB630-2971-11D1-A18C-00C04FD75D13}]
@=""

[HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\{C2FBB631-2971-11D1-A18C-00C04FD75D13}]
@=""

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


11. Включение скрытых настроек электропитания.

Чтобы настроить в Windows 7 параметры электропитания, необходимо открыть Панель управления\Система и безопасность\Электропитание. Там можно выбрать нужный план электропитания и при необходимости более детально настроить параметры, перейдя в Настройка плана электропитания -> Изменить дополнительные параметры питания.
Однако более детально настроить параметры электропитания помогает консольная утилита Powercfg. Но работать в командной строке, разбираясь с каждым параметром может занять продолжительное время. Для того чтобы функции предоставляемые powercfg стали доступны Вам в графической оболочке, необходимо внести некоторые изменения в ветке реестра:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings
В данной ветке содержатся разделы, отвечающие за определенную группу настроек.
Например, раздел 0012ee47-9041-4b5d-9b77-535fba8b1442 относится к настройкам управления питанием жесткого диска, а 54533251-82be-4824-96c1-47b60b740d00 к настройкам управления питанием процессора.
В свою очередь, в каждом из данных разделов есть подразделы, отвечаяющие за какую-либо настройку электропитания. Описание каждой из настроек указано в значении параметра Description, а её отображение в графической оболочке в значении параметра Attributes. По умолчанию, многие настройки имеют значение параметра Attributes равное «1», для того, чтобы необходимая Вам настройка был виден в графической оболочке, необходимо заменить его на «0». Доступные для отображения настройки, на ноутбуке и стационарном компьютере могут отличаться, в связи с особенностью их систем электропитания.

Для отображения политики простоя устройств, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\4faab71a-92e5-4726-b531-224559672d19]
"Attributes"=dword:00000000
Для отображения скрытых параметров по настройке работы жесткого диска, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\dab60367-53fe-4fbc-825e-521d069d2456]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\0b2d69d7-a2a1-449c-9680-f91c70521c60]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\80e3c60e-bb94-4ad8-bbe0-0d3195efc663]
"Attributes"=dword:00000000
Для отображения скрытых параметров по настройке кнопок питания, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\4f971e89-eebd-4455-a8de-9e59040e7347\833a6b62-dfa4-46d1-82f8-e09e34d029d6]
"Attributes"=dword:00000000
Для отображения скрытых параметров по настройке управления питания процессора, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\3b04d4fd-1cc7-4f23-ab1c-d1337819c4bb]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\5d76a2ca-e8c0-402f-a133-2158492d58ad]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\a55612aa-f624-42c6-a443-7397d064c04f]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\ea062031-0e34-4ff1-9b6d-eb1059334028]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\0cc5b647-c1df-4637-891a-dec35c318583]
"Attributes"=dword:00000000
Импортированное значение реестра позволяет увидеть только малую часть параметров, доступных для настройки управлением процессора. Всего их более 30.

Для отображения скрытых параметров по настройке спящего режима, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\25DFA149-5DD1-4736-B5AB-E8A37B5B8187]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\d4c1d4c8-d5cc-43d3-b83e-fc51215cb04d]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\abfc2519-3608-4c2a-94ea-171b0ed546ab]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\A4B195F5-8225-47D8-8012-9D41369786E2]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0]
"Attributes"=dword:00000000
Для отображения скрытых параметров по настройке экрана, необходимо импортировать в реестр:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\A9CEB8DA-CD46-44FB-A98B-02AF69DE4623]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\FBD9AA66-9553-4097-BA44-ED6E9D65EAB8]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\90959d22-d6a1-49b9-af93-bce885ad335b]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\EED904DF-B142-4183-B10B-5A1197A37864]
"Attributes"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\82DBCF2D-CD67-40C5-BFDC-9F1A5CCD4663]
"Attributes"=dword:00000000
Также к этому разделу относится настройка параметров графического адаптера, но доступность конкретных настроек будет определяется драйвером.

У себя в системе я обнаружил 54 скрытых настройки электропитания. Для включения сразу всех скрытых настроек электропитания: экспортируйте всю ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings в reg-файл. Отредактируйте полученный reg-файл: оставьте в нем только наименование веток реестра и их параметры Attributes и присвойте им значения «0». Также Вы можете скачать и применить, готовый reg-файл PowerSettings.reg

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


2. Добавление ярлыка часто используемой папки или программы в папку Компьютер.

12. Добавление своего ярлыка папки или программы в папку Компьютер.

Если Вы часто пользуйтесь какой-либо программой, то помимо добавления её значка на Рабочий стол, Вы также можете добавить его в папку Компьютер. Поскольку скопировать напрямую или создать ярлык в данной папке нельзя, то предлагаю Вам решение, как это возможно осуществить.

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}]
@="Наименование папки или программы"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\DefaultIcon]
@="Путь к иконке для ярлыка"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell\Open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{GUID}\Shell\Open\Command]
@="Путь к папке или файлу программы"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{GUID}]
2) Скачайте программу Microsoft Exchange Server GUID Generator
3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
4) Установите переключатель на значение Registry Format
5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
7) Вставьте вместо {GUID}, сгенерированный программой GUID.
Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {FF4A6226-C00B-409e-88A6-6C401C52BD98}
Внимание! Для добавления при указывании пути к иконе и файлу объекта слэш должен быть двойным.
8) Например, если путь к программе: C:\MyProgram\MyProgram.exe, то необходимо указать его как: C:\\MyProgram\\MyProgram.exe
Так как, чаще всего икона программы встроена в саму программу, то значения "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" могут совпадать.
9) При добавлении ярлыка папки измените "Путь к иконке для ярлыка" на %SystemRoot%\\system32\\SHELL32.dll,4
А значение "Путь к папке или файлу программы" на explorer /n, /e, C:\\ВашаПапка
10) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
11) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
12) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Пример reg-файла для добавления программы WinDjView в папку Компьютер:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
@="WinDjView"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\DefaultIcon]
@="C:\\Program Files\\WinDjView\\WinDjView.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open\Command]
@="C:\\Program Files\\WinDjView\\WinDjView.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
Пример reg-файла для добавления папки Downloads в папку Компьютер:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
@="Downloads"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\DefaultIcon]
@="%SystemRoot%\\system32\\SHELL32.dll,4"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{FF4A6226-C00B-409e-88A6-6C401C52BD98}\Shell\Open\Command]
@="explorer /n, /e, C:\\My Folder\\Downloads"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{FF4A6226-C00B-409e-88A6-6C401C52BD98}]
В итоге Вы получите тот же самый эффект, что был упомянут в совете 5 раздела "Твики Реестра - Добавление".

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


1. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
2) Введите команду
unregmp2.exe /SwapTo:64
(команда чувствительна к регистру)
3) Откройте редактор реестра: Win+R --> regedit
4) Перейдите к ветке
HKLM\Software\Microsoft\Windows\CurrentVersion\App Paths\wmplayer.exe\
и кликните два раза по значению Path
5) Измените
"%ProgramFiles(x86)%\Windows Media Player"
на
"%ProgramFiles%\Windows Media Player"
6) Закройте реестр и наслаждайтесь Windows Media Player х64

Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


2. Ускорение выключения компьютера.

Измените задержку перед выключением компьютера в реестре в разделе:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WaitToKillServiceTimeout" - отвечает за задержку перед выключением.
По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки)

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


3. Отмена автозапуска для носителей и устройств.

1) Пуск -> выполнить -> regedit
2) открыть ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) В этом разделе создать ключ(Параметр DWORD) NoDriveTypeAutoRun

Допустимые значения ключа:

0x1 - отключить автозапуск на приводах неизвестных типов
0x4 - отключить автозапуск сьемных устройств
0x8 - отключить автозапуск НЕсьемных устройств
0x10 - отключить автозапуск сетевых дисков
0x20 - отключить автозапуск CD-приводов
0x40 - отключить автозапуск RAM-дисков
0x80 - отключить автозапуск на приводах неизвестных типов
0xFF - отключить автозапуск вообще всех дисков.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


4. Смена фона в экране авторизации.

1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background

2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
4) Поместите сюда свой файл
5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg
backgroundDefault.jpg - в случае нестандартного расширения монитора

Размер изображений не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


5. Ускорение анимации всплывающего меню в меню Пуск.

Если Вы желаете изменить время задержки до показа всплывающего меню в меню Пуск, проделайте следующее:

1)Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
3) Создайте в нем(или измените) параметр MenuShowDelay
4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
6) Выберите желательное значение от 1 до 4000, означающее задержку в милисекундах, до показа всплывающего меню в меню Пуск.
7) Закройте regedit и перезагрузите систему.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


6. Изменение состояния встроенного динамика персонального компьютера.

1) Запустите редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Sound
3) Измените значение параметра Beep на "No" чтобы отключить и на "Yes" чтобы включить.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


7. Переназначение гнезд звуковой карты Realtek используя реестр.

На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

1) Установите драйвера звуковой карты
2) Запустите редактор реестра (Win+К -> regedit -> Ok)
3) Пройдите к папке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\
4) Откройте папку Drv6013_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

Имя(вставлять без кавычек):

"Pin01" = Заднее зеленое гнездо
"Pin02" = Заднее черное гнездо
"Pin03" = Заднее коричневое гнездо
"Pin04" = Заднее серое гнездо
"Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
"Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

"Pin06" = Переднее розовое гнездо
"Pin08" = Переднее зеленое гнездо

Значение(вставлять без кавычек):

"00 00 00 00" = Линейный вход
"01 00 00 00" = Микрофон
"02 00 00 00" = Наушники
"04 00 00 00" = Передние динамики
"05 00 00 00" = Тыловые динамики
"06 00 00 00" = Центральный канал/Сабвуфер
"07 00 00 00" = Боковые динамики

Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

Drv6013_DevType_0888_SS10438357 - на версию вашего драйвера
(имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
Pin04 - на любое значение из списка Имя
hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\Drv6013_DevType_0888_SS10438357]
"Pin04"=hex:02,00,00,00

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


8. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
3) Измените значение параметра MessageDuration.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


9. Настройка диалога переключения между окнами ("Alt"+"Tab").

1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Для создания твика, воспользуйтесь инструкцией:

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Параметры, отвечающие за количество отображаемых столбцов и строк

Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"Columns"=dword:00000005
"Rows"=dword:00000003
Параметры, отвечающие за отступы в диалоге переключения между окнами

Упомянутые ниже параметры указываются в пикселях.

TopMarginPx - величина верхнего поля, добавляемого в диалог
SideMarginPx - величина бокового поля, добавляемого в диалог
BottomMarginPx - величина нижнего поля, добавляемого в диалог
MinWidthPx - минимальная возможная ширина диалога AltTab
ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"TopMarginPx"=dword:00000027
"SideMarginPx"=dword:00000005
"BottomMarginPx"=dword:00000003
"MinWidthPx"=dword:00000050
"ThumbSpacingXPx"=dword:00000006
"ThumbSpacingYPx"=dword:00000015
Параметры, отвечающие за значки эскизов окон

Упомянутые ниже параметры указываются в пикселях.

OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"OverlayIconDYPx"=dword:00000008
"OverlayIconDXPx"=dword:00000008
"OverlayIconPx"=dword:00000030
Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

Упомянутые ниже параметры указываются в пикселях.
MaxThumbSizePx - максимальный размер эскизов окон
MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
TextButtomPx - высота заголовка диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"MinThumbSizePcent"=dword:00000010
"MaxThumbSizePx"=dword:00000085
"TextButtomPx"=dword:00000010
Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

StartAlpha - начальная прозрачность диалога переключения между окнами
FinalAlpha - конечная прозрачность диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"FadeOut_ms"=dword:00000100
"FadeIn_ms"=dword:00000100
"StartAlpha"=dword:00000002
"FinalAlpha"=dword:00000004
Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


10. Настройка параметров всплывающих эскизов окон в панели задач.

Изменив несколько настроек в реестре Вы сможете придать своим всплывающим эскизам окон больше эффективности в работе.

1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Создайте в нем(или измените) параметры:

ExtendedUIHoverTime - Задержка до появления всплывающего эскиза окна на экране, после наведения курсора мыши на иконку в панели задач.
ThumbnailLivePreviewHoverTime - Задержка до появления окна программы, после наведения курсора мыши на всплывший эскиз окна.

4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
6) В графе Система исчисления установите значение параметра на Десятичная.
7) Введите необходимое Вам значение. Значение 1000 = 1 секунде.

8) Откройте в реестре раздел: HKEY_CLASSES_ROOT\SystemFileAssociations\image
9) Сделайте двойной щелчок на параметре Treatment - Данный параметр изменяет вид бордюра всплывающего эскиза окна.
10) Выберите необходимое Вам значение:

0 - Без бордюра
1 - Бордюр с тенью
2 - Фоторамка (по умолчанию)
3 - Видеорамка

11) Закройте regedit и перезагрузите систему.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


11. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

Когда Вы наводите курсор на крайнюю кнопку, находящуюся за часами на панели задач (обычно правый нижний угол экрана), система показывает Вам рабочий стол. При желании Вы можете ускорить или замедлить данный процесс.

1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Измените значение параметра DesktopLivePreviewHoverTime. Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
4) В графе Система исчисления установите значение параметра на Десятичная.
5) Введите необходимое Вам значение. Значение 1000 = 1 секунде.
6) Закройте regedit, перезайдите в систему или перезагрузите систему.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


12. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

Как известно, при выделении более 15 файлов команды контекстного меню, такие как "Открыть/Печать/Редактировать" становятся недоступны.
Для отмены данного ограничения проделайте следующее:

1)Запустите редактор реестра ( Win+R -> regedit -> OK)
2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
3) Создайте в ней параметр MultipleInvokePromptMinimum типа DWORD.
4) Установите значение данного параметра равным 16.

Для уменьшения количества файлов на которых действует ограничение применения команд, введите значение от 1 до 15.
При выделении файлов выше выбранного Вами значения команды в контекстном меню применяться не будут. При указании значения 0 произойдет полное отключение команд, включая команду "Открыть".

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


13. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

1) Откройте Редактор групповой локальной политики (Win+R -> gpedit.msc - Ok)
2) Перейдите в раздел Конфигурация пользователя\Административные шаблоны\Панель управления.
3) Выберите команду Скрыть указанные элементы панели управления
4) Установите переключатель в значение Включить.
5) Нажмите на кнопку Показать.
6) Добавьте новую запись: Microsoft.DevicesAndPrinters и нажмите Ok.
7) Запустите редактор реестра (Win+R -> regedit.exe -> Ok).
8) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
9) Создайте в ней новый раздел {2227a280-3aea-1069-a2de-08002b30309d}.
10) Присвойте параметру По умолчанию значение - Принтеры (Printers).

Данную папку Вы сможете увидеть в Панели управления в контекстном меню Пуск, если у Вас установлено значение "Отображать как меню" или при просмотре полного списка всех элементов при её открытии.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


1. Как убрать цифру при пересоздании адаптера сети в Диспетчере устройств?

Вариант 1

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" установите значение адаптера сети на 0.
3) Создайте драйвер сетевого адаптера

Вариант 2

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" удалите ваш сетевой адаптер.
3) Создайте драйвер сетевого адаптера.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


2. Как отключить проверку подписи для загруженных программ?

Избавляет от этого:

1) В Панель управления -> Свойства браузера-> вкладка Дополнительно -> снять галочку "Проверка подписи для загруженных программ" и поставить галочку "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
2) Создайте и примените reg-файл следующего содержания.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"DefaultFileTypeRisk"=dword:00006152

;Отключить предупреждение при открытии файлов, загруженных из Интернета
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
"HideZoneInfoOnProperties"=dword:00000001
"SaveZoneInformation"=dword:00000002

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000095

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".zip;.rar;.nfo;.txt;.exe;.bat;.com;.cmd;.reg;.msi;.htm;.html;.gif;.bmp;.jpg;.avi;.mpg;.mpeg;.mov;.mp3;.m3u;.wav;"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


3. Как удалить (вернуть) стрелки с ярлыков Windows?

Готовые файлы для убирания стрелок вы можете скачать по ссылке:
Shortcut_Arrows.zip
1) Распакуйте и откройте папку нужного вам варианта
2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat или Remove_Shortcut_Arrow.reg
3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat или Restore_Shortcut_Arrow.reg

Вариант 1

Для удаления стрелок с ярлыков:

1) Запустите диалоговое окно "Выполнить" (Win + R)
2) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %WINDIR%\system32\shell32.dll,50 /f
Для восстановления стрелок на ярлыках:
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f
Или в ручную удалите данную ветку.

Вариант 2

Для удаления стрелок с ярлыков:

1) Создайте пустой файл иконки назовите его Blank.ico
2) Скопируйте его в папку C:\Windows
3) Запустите диалоговое окно "Выполнить" (Win + R)
4) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %SystemRoot%\Blank.ico,0 /f
Для восстановления стрелок на ярлыках:

1) Удалите файл Blank.ico из папки C:\Windows
2) Запустите диалоговое окно "Выполнить" (Win + R)
3) Скопируйте код указанный ниже и нажмите OK
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f
Или в ручную удалите данную ветку.

Побочным эффектом при использовании данного варианта является, появление черных квадратиков вместо стрелочек, если в папке Windows у Вас будет отсутствовать файл Blank.ico.

Вариант 3

1) Скопируйте текст в блокнот.
2) Сохраните как Remove_Shortcut_Arrow.reg (для удаления) или Restore_Shortcut_Arrow.reg (для восстановления).
3) Выполните файл, чтобы его содержание было внесено в реестр.
4) Обратите внимание на знак минуса в команде "IsShortCut"=-. Вокруг него нет кавычек. Эта команда удаляет значение IsShortCut и сам ключ IsShortCut. Если вы введёте команду "IsShortCut"="-", то тогда ключ удалён не будет, а его значение поменяется на минус. "IsNotShortCut"="" создаёт ключ и присваивает ему нулевое значение.

Файл .reg для удаления стрелок с ярлыков
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=-
"IsNotShortCut"=""
Файл .reg для восстановления стрелок на ярлыках
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=""
"IsNotShortCut"=-
Побочным эффектом при использовании данного варианта является, исчезновение пункта "Закрепить программу в панели задач". Если Вам необходимо будет закрепить какую-либо программу в Панели задач, то воспользуйтесь reg-файлом для восстановления стрелок на ярлыках, закрепите программу, а затем снова воспользуйтесь reg-файлом для удаления стрелок с ярлыков.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


4. Как отключить или переназначить клавишу Caps Lock?

Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

Клавиша Caps Lock будет выполнять действие клавиши Ctrl
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,1d,00,3a,00,00,00,00,00
Клавиша Caps Lock будет выполнять действие клавиши Shift

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,2a,00,3a,00,00,00,00,00
Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,3A,00,46,00,00,00,00,00
Отключает клавишу Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,00,00,00,00
Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=-

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


5. Удаление просроченных элементов в области уведомления панели задач.

1. Запустите редактор реестра: Win+R --> regedit
2. Перейдите в следующий раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
3. Удалите параметры "IconStreams" и "PastIconsStream"
4. Запустите диспетчер задач Ctrl+Shift+Esc
5. Остановите процесс explorer.exe
6. File --> New Task (Run...) --> explorer --> ОК.
7. Установите необходимые параметры отображения области уведомления панели задач.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


6. Удаление папок из Рабочего стола в Проводнике.

Если вы хотите, удалить папки из Рабочего стола в Проводнике.

Вариант 1

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
3) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
5) Удалите следующие ветки:
Favorites(Избранное)             = {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки)            = {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа)       = {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Документы)    = {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер)              = {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть)                    = {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) = {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина)             = {645FF040-5081-101B-9F08-00AA002F954E}

Вариант 2

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
Для удаления Favorites(Избранное), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a9400100
Для восстановления Favorites(Избранное) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a0900100
Для удаления Libraries(Библиотеки), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b090010d
Для восстановления Libraries(Библиотеки) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b080010d
Для удаления Homegroup(Домашняя группа), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Homegroup(Домашняя группа) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Computer(Компьютер), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Computer(Компьютер) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Network(Сеть), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0940064
Для восстановления Network(Сеть) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0040064
Для удаления Recycle Bin(Корзина), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:70,01,00,20
Для восстановления Recycle Bin(Корзина) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:40,01,00,20

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


7. Очистка устаревших значков из диалога выбора значков и уведомлений.

После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


8. Очистка истории расположений фонов рабочего стола в Windows 7.

В окне настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев Рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

1. Фоны рабочего стола Windows;
2. Библиотека изображений;
3. Самые популярные фотографии;
4. Сплошные цвета.

Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


9. Удаление папки Общие Документы и пользовательского профиля Общие.

Для спокойного удаления папки Общие Документы и пользовательского профиля Общие указанные ниже действия рекомендуется выполнять на чистой установленной системе. Если же у Вас система уже установлена, и на ней уже установлены программы, то прежде чем выполнять инструкции ниже скопируйте все папки из C:\Users\Public\* в C:\Users\ВашПрофиль\*

Вариант 1.

1) В командной строке(Пуск->Выполнить) наберите REGEDIT
2) Найдите ветку HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\
3) Затем нажмите правой кнопкой мыши на правой панели и выберите Создать -> Параметр "DWORD".
4) Дайте этому параметру имя NoSharedDocuments и присвойте ему значение 1
5) Перезагрузите компьютер

Вариант 2.

1) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
2) Удалите следующую ветку: {59031a47-3f72-44a7-89c5-5595fe6b30ee}
3) Пройдите к ветке реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\DelegateFolders\
4) Удалите следующую ветку(если есть): {59031a47-3f72-44a7-89c5-5595fe6b30ee}

Вариант 3.

1) Откройте Панель управления\Все элементы панели управления\Система(или Пуск -> Компьютер -> Свойства)
2) Откройте Дополнительные параметры системы
3) Пройдите на вкладку Имя Компьютера и нажмите Идентификация...
4) Выберите пункт Компьютер предназначен для домашнего использования.
5) Нажмите Далее, затем Готово, затем Ок
6) Перезагрузите компьютер

После того, как воспользуйтесь решением одного из вариантов проделайте следующие действия:

1) В ветке реестра: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders замените значения с C:\Users\Public\ на C:\Users\ВашПрофиль\

2) В ветке реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders замените значения с %PUBLIC%\ на %USERPROFILE%\

3) Удалите папки (если они остались):

Диск С: -> Пользователи -> Общие (C:\Users\Public\)
Библиотеки -> Документы -> Общие Документы

Внимание: Если не хотите,чтобы у Вас на рабочем столе появились дублирующиеся иконки файлов, не устанавливайте значение параметра Common Desktop, идентичное рабочему столу Вашего профиля. Например, вместо C:\Users\ВашПрофиль\Desktop укажите C:\Users\ВашПрофиль\Public\Desktop, а вместо %USERPROFILE%\Desktop укажите %USERPROFILE%\Public\Desktop.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


10. Отключение суффикса "-Ярлык" при создании новых ярлыков.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
3) В правой части окна, дважды щелкните на параметр реестра "link".
4) Измените значение на 00 00 00 00.
5) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"link"=hex:00,00,00,00

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


11. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) В правой части окна, дважды щелкните на параметр реестра "ShowInfoTip".
4) Измените значение на 0.
5) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"ShowInfoTip"=dword:00000000

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


12. Запрет запуска контекстного меню Проводника при нажатии правой кнопкой мыши.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в NoViewContextMenu
5) Измените значение на 1.
6) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:
Windows Registry Editor Version 5.00

[HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoViewContextMenu"=dword:00000001

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


13. Удаление пункта меню Файл из Проводника.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в NoFileMenu
5) Измените значение на 1.
6) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:
Windows Registry Editor Version 5.00

[HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoFileMenu"=dword:00000001
Данный пункт будет также удален из всех мест, использующих оболочку Windows.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


14. Запрещение запуска программ.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в RestrictRun
5) Измените значение на 1.
6) Перезагрузите компьютер.
7) Создайте подраздел с аналогичным именем RestrictRun
8) Создайте в разделе (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun) список разрешенных к запуску программ для текущего пользователя.
8.1) Создайте строковые(String) параметры
8.2) Укажите названия для создаваемый строковых параметров, начиная с 1 и далее
8.3) Установите в значениях параметров пути к Вашим приложениям и их имена. Файлы должны указываться с расширением. Например:

1 REG_SZ regedit.exe
2 REG_SZ calc.exe
3 REG_SZ Iexplore.exe

Не забудьте указать файл regedit.exe, чтобы Вы могли зайти в него и отменить установленные Вами ограничения!
Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0 или удалить его.

Если Вы забыли указать regedit.exe в списке или не создали подраздел RestrictRun, чтобы запретить запуск всех программ. Для отмены запрета проделайте следующее:

1) Перезапустите компьютер.
2) До начала запуска Windows нажмите на клавишу F8 и выберите пункт Безопасный режим с поддержкой командной строки
3) В командной строке введите regedit и нажмите Enter.
4) Пройдите в ветку HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
5) Удалите ключ RestrictRun или установите его значение на 0.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


Устранение неполадок

Устранение неполадок - Интерфейс и загрузка.

1. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

Вероятно, аэро - отключено.
Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху).
Или C:\Windows\Resources\Themes выбрать aero.

2. Решение проблемы с анимацией DWM (Desktop Window Manager).

1) Нажимаете "Пуск" на панели задач
2) Нажимаете правой кнопкой на Компьютер
3) Выбираете Свойства -> Дополнительные параметры системы
4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

3. Принудительное включение Windows Aero (только для Standard Administrator).

1) Нажмите Win+R и введите regedit
2) Установите следующие значения в регистре:
HKCU\Software\Microsoft\Windows\DWM\Composition равный 1 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy равынй 2 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend равный 1 (32-bit DWORD)
Готовый reg-файл enableaero.reg
3) Перезапустите DWM из command prompt, запущенного с правами администратора:
net stop UxSms
net start UxSms

4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
Для очистки кэша эскизов сделайте следующее.

1) Нажмите комбинацию клавишь WinKey+R, в поле Открыть напишите cleanmgr и нажмите OK
2) Выберите диск C: и после оценки объема отметьте "Эскизы" и нажмите OK
3) В папке %USERPROFILE%\AppData\Local\ стереть файл IconCache.db

Еще можно попробовать увеличить размер этого кеша, создав в реестре в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] новый параметр Max Cached Icons типа строки (REG_SZ) и занеся в него 4096 (а если такой параметр уже был, увеличить его вдвое).

5. Причины перехода цветовой схемы на упрощенный стиль.

Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter
или
1.2) Нажмите Win+R и введите команду в диалоговом окне Выполнить
msdt.exe -ep WindowsHelp -id AeroDiagnostic
2) Нажмите Далее

6. Выбор настроек во время установки для предотвращения замены русских букв знаками вопросов.

На начальном этапе установки выводится окно, содержащее три строчки.
Первая строчка - язык, на котором работает система (английский US или русский RU). При возможности выберите русский.
Вторая строчка - месторасположение компьютера, для выбора страны (от Афганистана и до Ямайки). Выберите страну - Russian Federation.
Третья строчка - язык раскладки клавиатуры по умолчанию. При выборе во второй строчке страны (РФ), здесь автоматически устанавливается русский. Вы можете выбрать здесь любой используемый Вами язык раскладки клавиатуры.

7. Замена кодовой страницы для решения проблемы с отображением русских букв.
1) Замените в реестре в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage С "1252"="c_1252.nls" на "1252"="c_1251.nls"
2) В папке \WINDOWS\system32\ найдите файлы С_1251 и С_1252. С_1251 куда-нибудь копируем и переименовываем в С_1252.
3) Оригинальный С_1252 переименовываем или удаляем (потребуется изменить права доступа). Возвращаем новую версию 1252 на место. В итоге файл С_1252, должен быть переименованной копией С_1251
4) Пуск-Панель управления-Язык и региональные установки-Дополнительно. Выбрать в пункте Текущий язык программ не поддерживающий Юникод: Русский (Россия)
5) Перезагружаемся.

8. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

Если при попытке выходе из спящего/ждущего режима Вы попадаете в черный экран или в BSOD (синий экран смерти) Вы можете попробовать несколько способов. Первым делом, скачайте и установите более новые версии драйверов для Вашей видеокарты, чем те что у Вас есть.

Вариант 1. Изменение настроек BIOS:

1) Во времени загрузки зайдите в BIOS (для этого нажмите клавишу Delete после начала загрузки компьютера)
2) В BIOS пройдите на вкладку Power
3) Попробуйте изменить значение параметра Suspend Mode (Auto, S1 (POS) Only, S3 Only) названия может отличаться, ищите похожие со значениями S1, S3.
4) Также попробуйте включить\отключить ACPI 2.0 Support -> Enabled\Disabled

Вариант 2. Запрет вывода из спящего режима используя USB мышь или USB клавиатуру.

Некоторые USB-устройства неправильно поддерживают спящий режим Windows. Два основных устройства с помощью которых Вы можете выйти из спящего режима - это клавиатура и мышь. Одно из них может блокировать Вам выход, в таком случае ему надо просто запретить это делать. Внимание: Не запрещайте одновременно клавиатуре и мыши, иначе Вы не сможете выйти из него.

1) Запустите Диспетчер устройств. Для этого пройдите в Пуск -> Выполнить (или Win+R) -> devmgmt.msc -> OK
2) В Диспетчере устройств разверните узел Мыши и иные указывающие устройства или Клавиатуры
3) Щелкните правой кнопкой на USB-мышь или USB-клавиатуру и выберите пункт Свойства.
4) Откройте вкладку Управление электропитанием.
5) Снимите флажок Разрешить устройству вывод компьютера из спящего режима и нажмите кнопку ОК.

Вариант 3. Отключение спящего/ждущего режима.

1) Пройдите в Пуск -> Выполнить (Win+R) -> powercfg.cpl -> OK
2) Выберите слева пункт Настройка перехода в спящий режим
3) Присвойте обоим параметрам: Отключать дисплей и Переводить компьютер в спящий режим, значение - Никогда.
Также можно отключить и функцию сна. Выберите пункт "Изменить дополнительные параметры питания". Найдите в окне режим Сон, разверните Сон после и установите значение находящихся там параметров на Никогда
Если несмотря на проделанное выше, компьютер по прежнему продолжает отлючаться, то Вам необходимо выполнить ещё некоторые действия:
4) Скачайте reg-файл PowerSettings.reg и примените его.
5) Откройте вкладку Сон
6) Установите следующие значения параметрам, открыв их вкладки:
6.1) Сон после - значение равным 0, оно идентично значению Никогда
6.2) Разрешить политику требуемую системой - значение Да (это предотвратит автоматический переход в ждущий режим)
6.3) Разрешить таймеры пробуждения - Включить (позволит автоматически выводить компьютер из спящего режима при помощи заданных событий)
7) Если у Вас одно из устройств USB например мышь, а второе клавиатура PS/2, то Вы можете отключать USB порт на время работы спящего режима.
Откройте вкладку Параметры USB в ней вкладку Параметр временного отключения USB- порта и установите значение в Разрешено.
8) Нажмите OK

10. Восстановление загрузки Windows 7 без установочного диска.

Вариант 1. Автоматически - при помощи среды восстановления Windows RE в Windows 7.

Во время установки Windows 7 на жестком диске автоматически создается служебный раздел, обеспечивающий доступ в среду восстановления Windows RE (Recovery Environment). Используя данный служебный раздел, Вы можете:

- загрузиться в среду восстановления с жесткого диска
- создать компакт-диск, содержащий среду восстановления

1) Выполните загрузку в среду восстановления с жесткого диска или диска восстановления системы.
Для того чтобы войти в меню Дополнительные варианты загрузки, нажмите F8 после включения компьютера (но до загрузки операционной системы).
2) Выберите первый пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter.
3) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи.
4) Введите пароль администратора. После ввода пароля вы увидите окно с вариантами восстановления.
5) Выберите пункт Восстановление запуска(Startup repair), также иногда может помочь пункт Восстановление системы (System Restore), позволяющий вернуться к точке, созданной до возникновения проблемы.

Вариант 2. Восстановление вручную, с созданием мультизагрузочного меню.

Здесь главное - это добраться до командной строки для введения дальнейших команд.

1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2) Создайте папку Boot
3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
4) Запустите среду необходимую для работы:
5) Загрузитесь в Windows, установленную на другой диск или в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
6) Запустите командную строку.
В Windows: Win+R -> cmd -> Ok.
В среде восстановления: Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt)

Далее все команды вводимые в командную строку будут одинаковы как в Windows, так и в среде восстановления.

1) Windows 7 использует усовершенствованный метод загрузки - хранилище данных конфигурации загрузки. Это хранилище содержит все сведения обо всех операционных системах, установленных на компьютере. Следовательно,загрузчики более ранних операционных систем Windows, не могут быть использованы для ее запуска. Итак, для восстановления, загрузочного сектор Windows 7, перезаписываем загрузочный сектор на всех разделах:
X:\boot\bootsect.exe /nt60 all
где Х - буква диска, на котором содержится программа Bootsect.exe
2) Если у Вас вторая система Windows XP, то Вам необходимо выполнить ещё ряд действий:

Создайте в хранилище загрузки Windows 7 - хранилище для загрузки Windows XP.
Bcdedit /create {ntldr} /d "Microsoft Windows XP"
Если же система откажется это делать, значит данное хранилище уже создано, поэтому необходимо его только переименовать:
Bcdedit /set {ntldr} description "Microsoft Windows XP"
Далее укажите загрузчику Windows 7 устройство расположения файлов загрузки Windows XP:
Bcdedit /set {ntldr} device partition=C:
Затем укажите загрузчику Windows 7 путь к загрузчику Windows XP:
Bcdedit /set {ntldr} path \ntldr
После добавьте строчку о выборе Windows XP в меню загрузки и расположив ее под остальными:
Bcdedit /displayorder {ntldr} /addlast
Также для работы с загрузчиками, Вы можете воспользоваться программой EasyBCD, позволяющей выполнять указанные выше действия, используя графический интерфейс.

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Вариант 3. Восстановление вручную, при помощи bootrec.exe.

1) Загрузитесь в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
2) Выберите операционную систему, которую необходимо восстановить, и нажмите "Next"("Далее").
3) В окне Опции системы восстановления (System Recovery Options) выберите пункт Командная строка (Command Prompt).
4) Откроется окно интерпретатора командной строки cmd.exe, где следует ввести:
Bootrec.exe /FixMbr
Параметр /FixMbr записывает в системный раздел основную загрузочную запись, совместимую с Windows 7. Этот параметр не перезаписывает существующую таблицу разделов. Данный параметр следует использовать для устранения проблем, связанных с повреждением основной загрузочной записи, или если необходимо удалить из основной загрузочной записи нестандартный код.
Bootrec.exe /FixBoot
Параметр /FixBoot записывает в системный раздел новый загрузочный сектор с использованием загрузочного сектора, совместимого с Windows 7. Этот параметр следует использовать, если выполняется хотя бы одно из перечисленных ниже условий.

- Загрузочный сектор Windows 7 был заменен нестандартным загрузочным сектором
- Загрузочный сектор поврежден
- После установки Windows 7 на компьютер была установлена более ранняя версия операционной системы Windows. В данном случае для запуска компьютера вместо диспетчера загрузки Windows (Bootmgr.exe) используется загрузчик Windows NT (NTLDR).
Bootrec.exe /RebuildBcd
Параметр /RebuildBcd выполняет поиск установленных операционных систем, совместимых с Windows 7, на всех дисках. Кроме того, этот параметр позволяет выбрать установленные системы, которые необходимо добавить в хранилище данных конфигурации загрузки. Этот параметр следует использовать в том случае, если необходимо выполнить полную перестройку данных конфигурации загрузки.

Если Вы не запомнили необходимого Вам значения Вы можете просто ввести:
Bootrec.exe
и утилита выведет справку по доступным ключам командной строки.

11. Восстановление стандартного анимированного экрана загрузки Windows 7.

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, после неудачно внесенных различного рода изменений в загрузчик ОС. Предлагаю Вам простые и действенные решения:

Вариант 1

Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК. Не забываем о разрешении экрана (17" -1280*1024)

Вариант 2

1. Откройте командную строку от имени администратора: Пуск -> Выполнить (или Win+R) -> cmd -> Ok
2. В открытом окне консоли введите команду:
bcdedit /set {current} locale en-US
Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Закройте окно командной строки.
4. Перезагрузите Ваш компьютер.

Вариант 3

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить (или Win+R)
2) В открытом окне консоли введите команду: msconfig и нажмите OK
3) Перейдите на вкладку "Загрузка" и проверьте не установлен ли флажок напротив значения "Без GUI". Если флажок установлен - снимите его.
4) Закройте окно Конфигурации системы.
5) Перезагрузите компьютер

12. Как получить полный доступ к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

ERD Commander для x86 или x64

13. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

14. Исправление невозможности запуска службы Центра обеспечения безопасности.

1) Отключены компоненты от которых зависит данная служба.

1.1) Откройте: Администрирование -> Службы
1.2) Проверьте включены ли следующие службы:

- Инструментарий управления Windows
- Удаленный вызов процедур (RPC)
- Модуль запуска процессов DCOM-сервера
- Сопоставитель конечных точек RPC

2) Востановите начальные параметры в реестре, используя значения с компьютера, на котором данная служба работает.

2.1) Загрузите и примените готовый reg-файл. wscsvc.zip

Устранение неполадок - Рабочий стол, Проводник, Панель задач.

1. Исправление исчезновения панели быстрого запуска после перезагрузки.

Если Вы создаете панель быстрого запуска, но после перезагрузки она исчезает, то попробуйте любое из предложенных ниже решений.

1) Попробуйте создать панель быстрого запуска со значением отличающимся от Вашего:

%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
%appdata%\Microsoft\Internet Explorer\Quick Launch
C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

2) Установите ползунок контроля учетных записей (UAC) в предпоследнее значение.

3) Создайте и добавьте в реестр следующий reg-файл:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoSaveSettings"=dword:00000000
"QuickLaunch"=dword:00000001
4) Откройте C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer
Добавьте на вкладке Свойства -> Безопасность пользователя Все и задайте ему полный доступ.

5) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду control userpasswords2 и нажмите Enter. Поставьте флажок на "Требовать ввод имени пользователя и пароля"

6) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
Измените параметр политики Отображение панели быстрый запуск на панели задач на значение Включить.

7) Закройте Языковую панель и установите вместо неё Punto Switcher.

2. Исправление сбоев в Проводнике и Windows Installer (msiexec.exe).

Вариант 1

Запустите командную строку от имени Администратора (Пуск->Все программы->Стандартные->Командная строка) и скопируйте следущую строчку:
reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\Disabled Sessions /va /f

Вариант 2

1) В меню Выполнить введите "gpedit.msc" перейдите по адресу:
Конфигурация компьютера->Административные шаблоны->Система->Управление связью через Интернет->Параметры связи через Интернет.
2) Щелкните на строчку "Отключить программу по улучшению качества программного обеспечения Windows"
3) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

3. Восстановление пункта "Выполнить" в меню "Пуск".

Если у Вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает Вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

4. Как убрать появляющуюся в меню "Пуск" полоску справа, которая пропадает при следующем открытии.

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
2) Перелогиниваетесь или перезапускаете компьютер
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
6) Радуетесь!
Для тех у кого изначально русская, выкладываю данный файл отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

Также Вы можете скачать и запустить от имени Администратора готовый патч: MenuFix_Rus_x86_x64_Final.rar
После его применения понадобиться перезагрузить компьютер.

5. Как восстановить ассоциацию с файлами *.cpl?

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкаете ПКМ на любом файле *.cpl
2) Выбираете Свойства -> Приложение -> Изменить
3) Заходим в папку C:\Windows\System32 и выбираем там control.exe
4) Жмем Ок

6. Исправление вылета проводника при нажатии правой клавиши на файле.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Скачайте небольшую утилиту ShellExView: с оффициального сайта или с зеркала.
2) После установки и запуска программы, найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

7. Восстановление исчезнувшей языковой панели.

Исчезновение языковой панели, чаще всего происходит после использования чистильщика или оптимизатора системы.
Перед использованием одного из предложенных вариантов, сделайте следующее:

1) Откройте редактор реестра (Win+R -> regedit -> OK )
2) Проверьте, не добавлен ли запрет на запуск языковой панели в следующую папку реестра:
HKEY_CURRENT_USER\Control Panel\don't load
3) Проверьте, присутствует ли в реестре ветки:

Region and Language

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

Keyboard

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{725BE8F7-668E-4C7B-8F90-46BDB0936430}

4) Проверьте значение параметров, в ветке реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Low Rights\ElevationPolicy\{85fc331e-bb64-4c53-ba25-3d8a956c02fd}

– значение REG_SZ-параметра AppName должно быть ctfmon.exe
– значение REG_SZ-параметра AppPath должно быть С:\Windows\system32.

где C: - буква диска на который у Вас установлена Windows

Вариант 1

1) Идете в Панель управления - Язык и региональные стандарты
2) Делаете все по пунктам на скриншотах.

Рисунок 1 из 2

Установите переключатель на значение Закреплена в панели задач и отметьте флажок Отображать текстовые метки на языковой панели и нажмите OK
3) Щелкаете правой кнопкой на панели задач, выбираете Свойства.
4) В пункте Область уведомлений щелкаем кнопку Настроить

Рисунок 2 из 2

5) В открывшемся окне поставьте флажок напротив "Всегда показывать все значки и уведомления на панели задач" и нажмите OK

Вариант 2

В контекстном меню панели задач уберите флажок со значения Закрепить панель задач, расширьте границы для всех панелей, а затем снова поставьте флажок напротив Закрепить панель задач.

Вариант 3

Найдите файл ctfmon.exe и добавьте его в Атозагрузку или создайте reg-файл со следующим содержанием:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
"CTFMon"="C:\Windows\system32\ctfmon.exe"

Вариант 4

1) Откройте Языки и службы текстового ввода
Так:

1.1.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
1.1.2) Ввести: RunDll32.exe shell32.dll,Control_RunDLL C:\Windows\system32\input.dll
1.1.3) Нажать OK

Или так:

1.2.1) Открыть Панель управления\Часы, язык и регион
1.2.2) Нажать на ссылку Смена раскладки клавиатуры или других способов ввода
1.2.3) Нажать на кнопку Изменить клавиатуру
2) На вкладке Общие удалите все раскладки клавиатуры кроме Английский
3) На вкладке Языковая панель снимите все флажки и установите переключатель в значение Скрыта
4) Выгрузите вручную библиотеки.
4.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
4.2) Выполните поочередно комманды:
Regsvr32.exe /u Msctf.dll
Regsvr32.exe /u Msctf.dll.mui

5) Перезагрузите компьютер.
6) Откройте Языки и службы текстового ввода
7) На вкладке Общие добавьте нужные Вам раскладки клавиатуры
8) На вкладке Языковая панель установите переключатель в значение Закреплена в панели задач и установите флажок напротив пункта Отображать текстовые метки на языковой панели.
9) Нажмите OK.

Как альтернативный вариант можете установить программу Punto Switcher, она добавляет собственную языковую панель и функцию автоматического переключения раскладки при неправильном её выборе.

8. Как исправить, если папки "Недавние места" и "Недавние документы" пустые?

1) Щелкните правой кнопкой мыши на кнопке Пуск и нажмите на Свойства
2) Установите флажки напротив пунктов:
"Хранить и отображать список недавно открывшихся программ в меню "Пуск"
"Хранить и отображать список недавно открывшихся элементов в меню "Пуск" и на панели задач"
3) Нажмите OK.

9. Удаление появившейся на Рабочем столе папки "Недавние места".

1) Удалите папку C:\Users\Default\AppData\Roaming\Microsoft\Windows\Recent
2) Перезагрузите компьютер или перезапустите систему
3) Зайдите в C:\Users\Default\AppData\Roaming\Microsoft\Windows\
4) Если Windows 7 не восстановил папку Recent заново, создайте её самостоятельно.

10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"
Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.JS]
@="JSFile"

11. Гаджеты или их настройки отказываются запускаться.

Для нормального функционирования гаджетов не отключайте UAC системы полностью. Выставьте минимальный уровень.
В случае если вы хотите восстановить работоспособность гаджетов при отключенном UAC, понимая уязвимость такого решения, вы можете применить твик реестра, указанный ниже. После перезагрузки гаджеты будут работать.
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings"
"AllowElevatedProcess"=dword:00000001

12. Восстановление пункта "Закрепить программу в панели задач".

Если у вас пропал пункт "Закрепить программу в панели задач":
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=""
"IsNotShortCut"=-

13. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235
Изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236
[LocalizedFileNames]
Sample Pictures.lnk=@%SystemRoot%\system32\shell32.dll,-21805
Музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21790
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\imageres.dll,-108
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-237
[LocalizedFileNames]
Sample Music.lnk=@%SystemRoot%\system32\shell32.dll,-21806
Видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21791
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\imageres.dll,-189
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-238
[LocalizedFileNames]
Sample Videos.lnk=@%SystemRoot%\system32\shell32.dll,-21807
Поиски
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-9031
IconResource=%SystemRoot%\system32\imageres.dll,-18
[LocalizedFileNames]
Indexed Locations.search-ms=@shell32.dll,-32811
Everywhere.search-ms=@shell32.dll,-32814
Shared By Me.search-ms=@shell32.dll,-32802
Recent Music.search-ms=@shell32.dll,-32803
Recent Documents.search-ms=@shell32.dll,-32804
Recent Pictures and Videos.search-ms=@shell32.dll,-32806
Recent E-mail.search-ms=@shell32.dll,-32807
Recently Changed.search-ms=@shell32.dll,-3281
Загрузка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21798
IconResource=%SystemRoot%\system32\imageres.dll,-184
Избранное
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21796
IconResource=%SystemRoot%\system32\imageres.dll,-115
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-173
Контакты
[.ShellClassInfo]
LocalizedResourceName=@%CommonProgramFiles%\system\wab32res.dll,-10100
InfoTip=@%CommonProgramFiles%\system\wab32res.dll,-10200
IconResource=%SystemRoot%\system32\imageres.dll,-181
Рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
Ссылки
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21810
IconResource=%SystemRoot%\system32\imageres.dll,-185
DefaultDropEffect=4
[LocalizedFileNames]
Public.lnk=@shell32.dll,-21816
Searches.lnk=@shell32.dll,-9031
Recently Changed.lnk=@shell32.dll,-32813
Music.lnk=@shell32.dll,-21790
Pictures.lnk=@shell32.dll,-21779
Documents.lnk=@shell32.dll,-21770
Сохраненные игры
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21814
IconResource=%SystemRoot%\system32\imageres.dll,-186
Общий рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799
Общие документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21801
IconResource=%SystemRoot%\system32\shell32.dll,-235
Общая музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21803
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\shell32.dll,-237
Общие изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21802
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\shell32.dll,-236
Общее видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21804
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\shell32.dll,-238

14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

Если при создании, копировании или перемещении на рабочий стол любого документа/ярлыка/папки, после обновления экрана или перезагрузки компьютера, у Вас появляются их дубликаты (точная копия, без (2) в названии), то это означает, что Ваш собственный рабочий стол и общий рабочий стол прописаны в реестре в одной папке. Данная проблема решается указанием для них отдельных отличающихся между собою папок.

1) Запустите Редактор реестра. Для этого в строке поиска в меню Пуск введите regedit и нажмите Enter
2) Откройте раздел: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
3) Измените значение параметра Common Desktop на одно из предложенных ниже:

C:\Users\Public\Desktop - значение Windows по умолчанию
C:\Users\ВашПрофиль\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
5) Измените значение параметра Common Desktop на одно из предложенных ниже:

%Public%\Desktop - значение Windows по умолчанию
%USERPROFILE%\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

15. Восстановление поиска в Проводнике и в меню Пуск.

1) Используя Реестр (Win+R -> regedit)
1.1) Откройте ветку реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
1.2) В случае обнаружения параметра NoFind, удалите его.

2) Используя Панель управления
2.1) Откройте Панель управления\Программы\Программы и компоненты
2.2) Запустите "Включение и отключение компонентов Windows" (или Win+R -> OptionalFeatures.exe)
2.3) Проверьте, включен ли у Вас компонент Windows Search (Поиск Windows).

Устранение неполадок - Устройства и BSOD.

1. При использовании сторонних плееров для видео, выкидывает в BSOD.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

2. В папке "Компьютер" не отображаются DVD-дисководы.

Уберите флажок в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

3. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

4. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажимаете комбинацию клавиш Win+Pause
2) Щелкаете ссылку Дополнительные параметры системы
3) Переходите на вкладку Дополнительно
4) Нажимаете кнопку Параметры в Загрузка и восстановление

Рисунок 1 из 2

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Рисунок 2 из 2

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) Загрузите и установите Debugging Tools for Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
Путь к папке указан после параметра set dbgpath=
4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)
kdfe.cmd "%systemroot%\Minidump\Mini1110307-01.dmp"
6) Дождитесь завершениия анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачиваете утилиту BlueScreenView.
2) Устанавливаете BlueScreenView.
3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
4) Запускаете BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

Порой, получив какую-либо ошибку синего экрана смерти, вы задумываетесь из-за чего же она произошла. Для этого случая, скачайте подборку с разъяснениями значений часто встречающихся ошибок и способами устранения многих из них.
Скачать: BSOD.rar

6. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в биосе:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled

7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

Попробуйте следующие варианты решений:

1) Попробуйте установить другую сборку или версию Windows 7.
2) Сбросьте настройки BIOS в стандартные и установите Windows заново.
3) Обнулите на материнской плате CMOS: либо переустановив и вернув перемычку, либо нажав на кнопку сброса на материнской плате.
4) Установите в списке загрузок с жестких дисков в BIOS, приоритет загрузки Вашего диска с Windows 7 на первое место.
5) Подключите диск выделенный для Windows 7, как Primary Master.

8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.
Если на Вашей мультимедиа или офисной клавиатуре перестали работать дополнительные клавиши расширяющие её функциональность, то сделайте следующее.
Во-первых, проверьте установлено ли у Вас программное обеспечение с диска идущего в комплекте к клавиатуре или с оффициального сайта.
Если же оно установлено, то одной из наиболее часто встречающихся причин может быть остановка службы Доступ к HID-устройствам.

1) Зайдите в Панель управления\Система и безопасность\Администрирование и запустите Службы или
Нажмите кнопку Пуск, щелкните в поле Начать поиск, введите services.msc и нажмите клавишу Enter.
2) Проверьте указано ли в колонке Состояние, напротив службы Доступ к HID-устройствам значение: Работает
Если данная служба отключена и не работает, сделайте следующее:
3) Нажмите на ней правой кнопкой мыши и в появившемся меню выберите Свойства
4) Для запуска службы нажмите на кнопку Запустить
5) Также Вы можете установить Тип запуска: Автоматически, и система будет автоматически запускать данную службу при старте Windows.
6) Перейдите на вкладку Восстановление и установите действия выполняющиеся при первом или втором сбое, а также при последующих сбоях на значение Перезапуск службы и нажмите OK.

9. Исправление появившихся красных крестиков на значках локальных дисков.

1) Откройте Панель Управления -> Диспетчер Устройств
1.1) Проверьте включены ли все IDE ATA/ATAPI контроллеры
1.2) Проверьте включены ли все Дисковые устройства
2) Если есть общий доступ, попробуйте его отключить
Щелкните ПКМ на диске -> Общий доступ -> Расширенная настройка общего доступа... -> Расширенная настройка...
3) Почистите кэш иконок: для этого в папке %USERPROFILE%\AppData\Local\ удалите файл IconCache.db
4) Воспользуйтесь специальными утилитами для оптимизации работы компьютера. Например:
4.1.) TuneUp Utilities

4.1.1) В колонке Customize Windows нажимаете All functions и выбираете Change Windows appearance
4.1.2) В меню слева в списке группы Icons выбираете Repair
4.1.3) Нажмите на кнопку Reload Icons, а после на кнопку Repair Icon Cache

4.2) Windows 7 Manager

4.2.1) В меню слева во вкладке Information выберите Repair Center
4.2.2) В меню слева в Repair Center нажмите Icon Repair
4.2.3) В разделе Rebuild Icon Cache нажмите Rebuild

10. Восстановление автозапуска для всех типов приводов и устройств.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveTypeAutoRun"=-

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"=dword:00000001

11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.
На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Скачать исправление KB977178 : для x86 или для x64

Устранение неполадок - Локальная сеть и Интернет.

1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженый уровень UAC.

2. Если гаджет погоды пишет service unavailable for your region.

Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
А панель настройки гаджетов может стать недоступной.

Вариант 1

Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:
207.68.172.246 www.msnweather.com
198.78.215.126 blst.msn.com
65.55.228.63 weather.msn.com
65.55.17.39 weather.service.msn.com

Вариант 2

Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget

3. В Windows Update при попытке обновления появляется error 80072ee7.

Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
3. Дважды щелкните папку Windows, а затем - папку System32.
4. Дважды щелкните папку драйверы, а затем - папку и т. д..
5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

4. Решение проблемы с punkbuster на Windows 7.

Вариант 1

Решение проблемы вылетов игр (COD 5 и battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136). Лечится так:
1. обновляем punkbuster - качаем это запускаем и добавляем туда игру, pb которой нужно обновить и жмем check for updates. в конце появится сообщение об окончании.
2. находим на диске с windows два файла: PnkBstrA.exe и PnkBstrB.exe оба лежат в C:\Windows\SysWOW64 (для х64) и C:\Windows\System32 (для х86) (PnkBstrB.exe еще есть в папке с игрой C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb (думаю аналогично и в cod5). У этих файлов в свойствах выставить совместимость с XP и Vista.

Вариант 2

1. в %WINDIR%\system32\ файлам PnkBstrA.exe, PnkBstrB.exe поставить совместимость с Вистой и Права администратора.
2.На рабочем столе создать батник с следующим содержанием :
:start

sc config PnkBstrA type= own type= interact

sc config PnkBstrB type= own type= interact

timeout 60

goto start
3. Запускать батник перед запуском игр.
4. Играть

5. Как исправить высокий пинг в Windows 7?

1. Пуск - Выполнить - regedit
2. Ищем там HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3. Ищем там интерфейс по которому у вас работает интернет, если не в курсе то делаем следующий шаг во всех
4. Создаем DWORD-параметр, называем его TcpAckFrequency, открываем Изменить, ставим значение переключателя на шестнадцатиричное, и пишем значение 1
5. Идем в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
Если такого пункта в реестре нет, а его скорее всего нет, то делаем следующие шаги:
Открываем - Пуск - Панель управления - Программы и Компоненты-(слева)Включение и отключение компонентов Windows.
Там находим пункт - Сервер очереди сообщений Майкрософт (MSMQ), и ставим галочку напротив него и все галочки внутри в выпадающем списке компонентов. Перегружаемся, идем в реестр и видим там нужную нам запись.

6. В месте указанном в пункте 5 ищем TCPNoDelay, если нету создаем DWORD параметр с таким названием. значение 1.

6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Internet Explorer не удается загрузить / из help
Не удается открыть этот узел Интернета. Узел не доступен или не найден. Повторите попытку позднее.

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.xml]
@="xmlfile"
"Content Type"="text/xml"
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.xml\OpenWithList]

[HKEY_CLASSES_ROOT\.xml\OpenWithList\winword.exe]
@=""

[HKEY_CLASSES_ROOT\.xml\PersistentHandler]
@="{7E9D8D44-6926-426F-AA2B-217A819A5CCE}"

7. Отключение запроса пароля при использовании папки общего доступа.
Даже если Вы не устанавливали пароль для папки общего доступа, система может у Вас его запросить.

Для отключения данного запроса сделайте следующее:

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
3) В графе Общий доступ с парольной защитой установите переключатель на значение Отключить общий доступ с парольной защитой.


1. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

Вероятно, аэро - отключено.
Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху).
Или C:\Windows\Resources\Themes выбрать aero.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


2. Решение проблемы с анимацией DWM (Desktop Window Manager).

1) Нажимаете "Пуск" на панели задач
2) Нажимаете правой кнопкой на Компьютер
3) Выбираете Свойства -> Дополнительные параметры системы
4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


3. Принудительное включение Windows Aero (только для Standard Administrator).

1) Нажмите Win+R и введите regedit
2) Установите следующие значения в регистре:
HKCU\Software\Microsoft\Windows\DWM\Composition равный 1 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy равынй 2 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend равный 1 (32-bit DWORD)
Готовый reg-файл enableaero.reg
3) Перезапустите "Диспетчер сеансов диспетчера окон рабочего стола" из command prompt, запущенного с правами администратора:
net stop UxSms
net start UxSms

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
Для очистки кэша эскизов сделайте следующее.

1) Нажмите комбинацию клавишь WinKey+R, в поле Открыть напишите cleanmgr и нажмите OK
2) Выберите диск C: и после оценки объема отметьте "Эскизы" и нажмите OK
3) В папке %USERPROFILE%\AppData\Local\ стереть файл IconCache.db

Еще можно попробовать увеличить размер этого кеша, создав в реестре в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] новый параметр Max Cached Icons типа строки (REG_SZ) и занеся в него 4096 (а если такой параметр уже был, увеличить его вдвое).

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


5. Причины перехода цветовой схемы на упрощенный стиль.

Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter
или
1.2) Нажмите Win+R и введите команду в диалоговом окне Выполнить
msdt.exe -ep WindowsHelp -id AeroDiagnostic
2) Нажмите Далее

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


6. Выбор настроек во время установки для предотвращения замены русских букв знаками вопросов.

На начальном этапе установки выводится окно, содержащее три строчки.
Первая строчка - язык, на котором работает система (английский US или русский RU). При возможности выберите русский.
Вторая строчка - месторасположение компьютера, для выбора страны (от Афганистана и до Ямайки). Выберите страну - Russian Federation.
Третья строчка - язык раскладки клавиатуры по умолчанию. При выборе во второй строчке страны (РФ), здесь автоматически устанавливается русский. Вы можете выбрать здесь любой используемый Вами язык раскладки клавиатуры.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


7. Замена кодовой страницы для решения проблемы с отображением русских букв.

1) Замените в реестре в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage С "1252"="c_1252.nls" на "1252"="c_1251.nls"
2) В папке \WINDOWS\system32\ найдите файлы С_1251 и С_1252. С_1251 куда-нибудь копируем и переименовываем в С_1252.
3) Оригинальный С_1252 переименовываем или удаляем (потребуется изменить права доступа). Возвращаем новую версию 1252 на место. В итоге файл С_1252, должен быть переименованной копией С_1251
4) Пуск-Панель управления-Язык и региональные установки-Дополнительно. Выбрать в пункте Текущий язык программ не поддерживающий Юникод: Русский (Россия)
5) Перезагружаемся.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


8. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

Если при попытке выходе из спящего/ждущего режима Вы попадаете в черный экран или в BSOD (синий экран смерти) Вы можете попробовать несколько способов. Первым делом, скачайте и установите более новые версии драйверов для Вашей видеокарты, чем те что у Вас есть.

Вариант 1. Изменение настроек BIOS:

1) Во времени загрузки зайдите в BIOS (для этого нажмите клавишу Delete после начала загрузки компьютера)
2) В BIOS пройдите на вкладку Power
3) Попробуйте изменить значение параметра Suspend Mode (Auto, S1 (POS) Only, S3 Only) названия может отличаться, ищите похожие со значениями S1, S3.
4) Также попробуйте включить\отключить ACPI 2.0 Support -> Enabled\Disabled

Вариант 2. Запрет вывода из спящего режима используя USB мышь или USB клавиатуру.

Некоторые USB-устройства неправильно поддерживают спящий режим Windows. Два основных устройства с помощью которых Вы можете выйти из спящего режима - это клавиатура и мышь. Одно из них может блокировать Вам выход, в таком случае ему надо просто запретить это делать. Внимание: Не запрещайте одновременно клавиатуре и мыши, иначе Вы не сможете выйти из него.

1) Запустите Диспетчер устройств. Для этого пройдите в Пуск -> Выполнить (или Win+R) -> devmgmt.msc -> OK
2) В Диспетчере устройств разверните узел Мыши и иные указывающие устройства или Клавиатуры
3) Щелкните правой кнопкой на USB-мышь или USB-клавиатуру и выберите пункт Свойства.
4) Откройте вкладку Управление электропитанием.
5) Снимите флажок Разрешить устройству вывод компьютера из спящего режима и нажмите кнопку ОК.

Вариант 3. Отключение спящего/ждущего режима.

1) Пройдите в Пуск -> Выполнить (Win+R) -> powercfg.cpl -> OK
2) Выберите слева пункт Настройка перехода в спящий режим
3) Присвойте обоим параметрам: Отключать дисплей и Переводить компьютер в спящий режим, значение - Никогда.
Также можно отключить и функцию сна. Выберите пункт "Изменить дополнительные параметры питания". Найдите в окне режим Сон, разверните Сон после и установите значение находящихся там параметров на Никогда
Если несмотря на проделанное выше, компьютер по прежнему продолжает отлючаться, то Вам необходимо выполнить ещё некоторые действия:
4) Скачайте reg-файл PowerSettings.reg и примените его.
5) Откройте вкладку Сон
6) Установите следующие значения параметрам, открыв их вкладки:
6.1) Сон после - значение равным 0, оно идентично значению Никогда
6.2) Разрешить политику требуемую системой - значение Да (это предотвратит автоматический переход в ждущий режим)
6.3) Разрешить таймеры пробуждения - Включить (позволит автоматически выводить компьютер из спящего режима при помощи заданных событий)
7) Если у Вас одно из устройств USB например мышь, а второе клавиатура PS/2, то Вы можете отключать USB порт на время работы спящего режима.
Откройте вкладку Параметры USB в ней вкладку Параметр временного отключения USB- порта и установите значение в Разрешено.
8) Нажмите OK

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


10. Восстановление загрузки Windows 7 без установочного диска.

Вариант 1. Автоматически - при помощи среды восстановления Windows RE в Windows 7.

Во время установки Windows 7 на жестком диске автоматически создается служебный раздел, обеспечивающий доступ в среду восстановления Windows RE (Recovery Environment). Используя данный служебный раздел, Вы можете:

- загрузиться в среду восстановления с жесткого диска
- создать компакт-диск, содержащий среду восстановления

1) Выполните загрузку в среду восстановления с жесткого диска или диска восстановления системы.
Для того чтобы войти в меню Дополнительные варианты загрузки, нажмите F8 после включения компьютера (но до загрузки операционной системы).
2) Выберите первый пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter.
3) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи.
4) Введите пароль администратора. После ввода пароля вы увидите окно с вариантами восстановления.
5) Выберите пункт Восстановление запуска(Startup repair), также иногда может помочь пункт Восстановление системы (System Restore), позволяющий вернуться к точке, созданной до возникновения проблемы.

Вариант 2. Восстановление вручную, с созданием мультизагрузочного меню.

Здесь главное - это добраться до командной строки для введения дальнейших команд.

1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2) Создайте папку Boot
3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
4) Запустите среду необходимую для работы:
5) Загрузитесь в Windows, установленную на другой диск или в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
6) Запустите командную строку.
В Windows: Win+R -> cmd -> Ok.
В среде восстановления: Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt)

Далее все команды вводимые в командную строку будут одинаковы как в Windows, так и в среде восстановления.

1) Windows 7 использует усовершенствованный метод загрузки - хранилище данных конфигурации загрузки. Это хранилище содержит все сведения обо всех операционных системах, установленных на компьютере. Следовательно,загрузчики более ранних операционных систем Windows, не могут быть использованы для ее запуска. Итак, для восстановления, загрузочного сектор Windows 7, перезаписываем загрузочный сектор на всех разделах:
X:\boot\bootsect.exe /nt60 all
где Х - буква диска, на котором содержится программа Bootsect.exe
2) Если у Вас вторая система Windows XP, то Вам необходимо выполнить ещё ряд действий:

Создайте в хранилище загрузки Windows 7 - хранилище для загрузки Windows XP.
Bcdedit /create {ntldr} /d "Microsoft Windows XP"
Если же система откажется это делать, значит данное хранилище уже создано, поэтому необходимо его только переименовать:
Bcdedit /set {ntldr} description "Microsoft Windows XP"
Далее укажите загрузчику Windows 7 устройство расположения файлов загрузки Windows XP:
Bcdedit /set {ntldr} device partition=C:
Затем укажите загрузчику Windows 7 путь к загрузчику Windows XP:
Bcdedit /set {ntldr} path \ntldr
После добавьте строчку о выборе Windows XP в меню загрузки и расположив ее под остальными:
Bcdedit /displayorder {ntldr} /addlast
Также для работы с загрузчиками, Вы можете воспользоваться программой EasyBCD, позволяющей выполнять указанные выше действия, используя графический интерфейс.

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Вариант 3. Восстановление вручную, при помощи bootrec.exe.

1) Загрузитесь в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
2) Выберите операционную систему, которую необходимо восстановить, и нажмите "Next"("Далее").
3) В окне Опции системы восстановления (System Recovery Options) выберите пункт Командная строка (Command Prompt).
4) Откроется окно интерпретатора командной строки cmd.exe, где следует ввести:
Bootrec.exe /FixMbr
Параметр /FixMbr записывает в системный раздел основную загрузочную запись, совместимую с Windows 7. Этот параметр не перезаписывает существующую таблицу разделов. Данный параметр следует использовать для устранения проблем, связанных с повреждением основной загрузочной записи, или если необходимо удалить из основной загрузочной записи нестандартный код.
Bootrec.exe /FixBoot
Параметр /FixBoot записывает в системный раздел новый загрузочный сектор с использованием загрузочного сектора, совместимого с Windows 7. Этот параметр следует использовать, если выполняется хотя бы одно из перечисленных ниже условий.

- Загрузочный сектор Windows 7 был заменен нестандартным загрузочным сектором
- Загрузочный сектор поврежден
- После установки Windows 7 на компьютер была установлена более ранняя версия операционной системы Windows. В данном случае для запуска компьютера вместо диспетчера загрузки Windows (Bootmgr.exe) используется загрузчик Windows NT (NTLDR).
Bootrec.exe /RebuildBcd
Параметр /RebuildBcd выполняет поиск установленных операционных систем, совместимых с Windows 7, на всех дисках. Кроме того, этот параметр позволяет выбрать установленные системы, которые необходимо добавить в хранилище данных конфигурации загрузки. Этот параметр следует использовать в том случае, если необходимо выполнить полную перестройку данных конфигурации загрузки.

Если Вы не запомнили необходимого Вам значения Вы можете просто ввести:
Bootrec.exe
и утилита выведет справку по доступным ключам командной строки.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


11. Восстановление стандартного анимированного экрана загрузки Windows 7.

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, после неудачно внесенных различного рода изменений в загрузчик ОС. Предлагаю Вам простые и действенные решения:

Вариант 1

Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК. Не забываем о разрешении экрана (17" -1280*1024)

Вариант 2

1. Откройте командную строку от имени администратора: Пуск -> Выполнить (или Win+R) -> cmd -> Ok
2. В открытом окне консоли введите команду:
bcdedit /set {current} locale en-US
Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Закройте окно командной строки.
4. Перезагрузите Ваш компьютер.

Вариант 3

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить (или Win+R)
2) В открытом окне консоли введите команду: msconfig и нажмите OK
3) Перейдите на вкладку "Загрузка" и проверьте не установлен ли флажок напротив значения "Без GUI". Если флажок установлен - снимите его.
4) Закройте окно Конфигурации системы.
5) Перезагрузите компьютер

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


12. Как получить полный доступ к NTFS-томам, системному реестру, параметрам настройки и драйверам...

12. Как получить полный доступ к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

ERD Commander для x86 или x64

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


13. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


14. Исправление невозможности запуска службы Центра обеспечения безопасности.

1) Отключены компоненты от которых зависит данная служба.

1.1) Откройте: Администрирование -> Службы
1.2) Проверьте включены ли следующие службы:

- Инструментарий управления Windows
- Удаленный вызов процедур (RPC)
- Модуль запуска процессов DCOM-сервера
- Сопоставитель конечных точек RPC

2) Востановите начальные параметры в реестре, используя значения с компьютера, на котором данная служба работает.

2.1) Загрузите и примените готовый reg-файл. wscsvc.zip

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Интерфейс и загрузка.


1. Исправление исчезновения панели быстрого запуска после перезагрузки.

Если Вы создаете панель быстрого запуска, но после перезагрузки она исчезает, то попробуйте любое из предложенных ниже решений.

1) Попробуйте создать панель быстрого запуска со значением отличающимся от Вашего:

%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
%appdata%\Microsoft\Internet Explorer\Quick Launch
C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

2) Установите ползунок контроля учетных записей (UAC) в предпоследнее значение.

3) Создайте и добавьте в реестр следующий reg-файл:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoSaveSettings"=dword:00000000
"QuickLaunch"=dword:00000001
4) Откройте C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer
Добавьте на вкладке Свойства -> Безопасность пользователя Все и задайте ему полный доступ.

5) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду control userpasswords2 и нажмите Enter. Поставьте флажок на "Требовать ввод имени пользователя и пароля"

6) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
Измените параметр политики Отображение панели быстрый запуск на панели задач на значение Включить.

7) Закройте Языковую панель и установите вместо неё Punto Switcher.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


2. Исправление сбоев в Explorer и Windows Installer (msiexec.exe).

2. Исправление сбоев в Проводнике и Windows Installer (msiexec.exe).

Вариант 1

Запустите командную строку от имени Администратора (Пуск->Все программы->Стандартные->Командная строка) и скопируйте следущую строчку:
reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\Disabled Sessions /va /f

Вариант 2

1) В меню Выполнить введите "gpedit.msc" перейдите по адресу:
Конфигурация компьютера->Административные шаблоны->Система->Управление связью через Интернет->Параметры связи через Интернет.
2) Щелкните на строчку "Отключить программу по улучшению качества программного обеспечения Windows"
3) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


3. Восстановление пункта "Выполнить" в меню "Пуск".

Если у Вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает Вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


4. Как убрать появляющуюся в меню "Пуск" полоску справа, которая пропадает при следующем открытии.

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
2) Перелогиниваетесь или перезапускаете компьютер
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
6) Радуетесь!
Для тех у кого изначально русская, выкладываю данный файл отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

Также Вы можете скачать и запустить от имени Администратора готовый патч: MenuFix_Rus_x86_x64_Final.rar
После его применения понадобиться перезагрузить компьютер.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


5. Как восстановить ассоциацию с файлами *.cpl?

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкаете ПКМ на любом файле *.cpl
2) Выбираете Свойства -> Приложение -> Изменить
3) Заходим в папку C:\Windows\System32 и выбираем там control.exe
4) Жмем Ок

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


6. Исправление вылета проводника при нажатии правой клавиши на файле.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Скачайте небольшую утилиту ShellExView: с оффициального сайта или с зеркала.
2) После установки и запуска программы, найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


7. Восстановление исчезнувшей языковой панели.

Исчезновение языковой панели, чаще всего происходит после использования чистильщика или оптимизатора системы.
Перед использованием одного из предложенных вариантов, сделайте следующее:

1) Откройте редактор реестра (Win+R -> regedit -> OK )
2) Проверьте, не добавлен ли запрет на запуск языковой панели в следующую папку реестра:
HKEY_CURRENT_USER\Control Panel\don't load
3) Проверьте, присутствует ли в реестре ветки:

Region and Language

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

Keyboard

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{725BE8F7-668E-4C7B-8F90-46BDB0936430}

4) Проверьте значение параметров, в ветке реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Low Rights\ElevationPolicy\{85fc331e-bb64-4c53-ba25-3d8a956c02fd}

– значение REG_SZ-параметра AppName должно быть ctfmon.exe
– значение REG_SZ-параметра AppPath должно быть С:\Windows\system32.

где C: - буква диска на который у Вас установлена Windows

Вариант 1

1) Идете в Панель управления - Язык и региональные стандарты
2) Делаете все по пунктам на скриншотах.

Установите переключатель на значение Закреплена в панели задач и отметьте флажок Отображать текстовые метки на языковой панели и нажмите OK
3) Щелкаете правой кнопкой на панели задач, выбираете Свойства.
4) В пункте Область уведомлений щелкаем кнопку Настроить

5) В открывшемся окне поставьте флажок напротив "Всегда показывать все значки и уведомления на панели задач" и нажмите OK

Вариант 2

В контекстном меню панели задач уберите флажок со значения Закрепить панель задач, расширьте границы для всех панелей, а затем снова поставьте флажок напротив Закрепить панель задач.

Вариант 3

Найдите файл ctfmon.exe и добавьте его в Атозагрузку или создайте reg-файл со следующим содержанием:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
"CTFMon"="C:\Windows\system32\ctfmon.exe"

Вариант 4

1) Откройте Языки и службы текстового ввода
Так:

1.1.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
1.1.2) Ввести: RunDll32.exe shell32.dll,Control_RunDLL C:\Windows\system32\input.dll
1.1.3) Нажать OK

Или так:

1.2.1) Открыть Панель управления\Часы, язык и регион
1.2.2) Нажать на ссылку Смена раскладки клавиатуры или других способов ввода
1.2.3) Нажать на кнопку Изменить клавиатуру
2) На вкладке Общие удалите все раскладки клавиатуры кроме Английский
3) На вкладке Языковая панель снимите все флажки и установите переключатель в значение Скрыта
4) Выгрузите вручную библиотеки.
4.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
4.2) Выполните поочередно комманды:
Regsvr32.exe /u Msctf.dll
Regsvr32.exe /u Msctf.dll.mui

5) Перезагрузите компьютер.
6) Откройте Языки и службы текстового ввода
7) На вкладке Общие добавьте нужные Вам раскладки клавиатуры
8) На вкладке Языковая панель установите переключатель в значение Закреплена в панели задач и установите флажок напротив пункта Отображать текстовые метки на языковой панели.
9) Нажмите OK.

Как альтернативный вариант можете установить программу Punto Switcher, она добавляет собственную языковую панель и функцию автоматического переключения раскладки при неправильном её выборе.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


8. Как исправить, если папки "Недавние места" и "Недавние документы" пустые?

1) Щелкните правой кнопкой мыши на кнопке Пуск и нажмите на Свойства
2) Установите флажки напротив пунктов:
"Хранить и отображать список недавно открывшихся программ в меню "Пуск"
"Хранить и отображать список недавно открывшихся элементов в меню "Пуск" и на панели задач"
3) Нажмите OK.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


9. Удаление появившейся на Рабочем столе папки "Недавние места".

1) Удалите папку C:\Users\Default\AppData\Roaming\Microsoft\Windows\Recent
2) Перезагрузите компьютер или перезапустите систему
3) Зайдите в C:\Users\Default\AppData\Roaming\Microsoft\Windows\
4) Если Windows 7 не восстановил папку Recent заново, создайте её самостоятельно.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"

Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.JS]
@="JSFile"

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


11. Гаджеты или их настройки отказываются запускаться.

Для нормального функционирования гаджетов не отключайте UAC системы полностью. Выставьте минимальный уровень.
В случае если вы хотите восстановить работоспособность гаджетов при отключенном UAC, понимая уязвимость такого решения, вы можете применить твик реестра, указанный ниже. После перезагрузки гаджеты будут работать.
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings"
"AllowElevatedProcess"=dword:00000001

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


12. Восстановление пункта "Закрепить программу в панели задач".

Если у вас пропал пункт "Закрепить программу в панели задач":
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=""
"IsNotShortCut"=-

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


13. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235
Изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236
[LocalizedFileNames]
Sample Pictures.lnk=@%SystemRoot%\system32\shell32.dll,-21805
Музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21790
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\imageres.dll,-108
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-237
[LocalizedFileNames]
Sample Music.lnk=@%SystemRoot%\system32\shell32.dll,-21806
Видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21791
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\imageres.dll,-189
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-238
[LocalizedFileNames]
Sample Videos.lnk=@%SystemRoot%\system32\shell32.dll,-21807
Поиски
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-9031
IconResource=%SystemRoot%\system32\imageres.dll,-18
[LocalizedFileNames]
Indexed Locations.search-ms=@shell32.dll,-32811
Everywhere.search-ms=@shell32.dll,-32814
Shared By Me.search-ms=@shell32.dll,-32802
Recent Music.search-ms=@shell32.dll,-32803
Recent Documents.search-ms=@shell32.dll,-32804
Recent Pictures and Videos.search-ms=@shell32.dll,-32806
Recent E-mail.search-ms=@shell32.dll,-32807
Recently Changed.search-ms=@shell32.dll,-3281
Загрузка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21798
IconResource=%SystemRoot%\system32\imageres.dll,-184
Избранное
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21796
IconResource=%SystemRoot%\system32\imageres.dll,-115
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-173
Контакты
[.ShellClassInfo]
LocalizedResourceName=@%CommonProgramFiles%\system\wab32res.dll,-10100
InfoTip=@%CommonProgramFiles%\system\wab32res.dll,-10200
IconResource=%SystemRoot%\system32\imageres.dll,-181
Рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
Ссылки
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21810
IconResource=%SystemRoot%\system32\imageres.dll,-185
DefaultDropEffect=4
[LocalizedFileNames]
Public.lnk=@shell32.dll,-21816
Searches.lnk=@shell32.dll,-9031
Recently Changed.lnk=@shell32.dll,-32813
Music.lnk=@shell32.dll,-21790
Pictures.lnk=@shell32.dll,-21779
Documents.lnk=@shell32.dll,-21770
Сохраненные игры
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21814
IconResource=%SystemRoot%\system32\imageres.dll,-186
Общий рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799
Общие документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21801
IconResource=%SystemRoot%\system32\shell32.dll,-235
Общая музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21803
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\shell32.dll,-237
Общие изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21802
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\shell32.dll,-236
Общее видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21804
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\shell32.dll,-238

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

Если при создании, копировании или перемещении на рабочий стол любого документа/ярлыка/папки, после обновления экрана или перезагрузки компьютера, у Вас появляются их дубликаты (точная копия, без (2) в названии), то это означает, что Ваш собственный рабочий стол и общий рабочий стол прописаны в реестре в одной папке. Данная проблема решается указанием для них отдельных отличающихся между собою папок.

1) Запустите Редактор реестра. Для этого в строке поиска в меню Пуск введите regedit и нажмите Enter
2) Откройте раздел: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
3) Измените значение параметра Common Desktop на одно из предложенных ниже:

C:\Users\Public\Desktop - значение Windows по умолчанию
C:\Users\ВашПрофиль\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
5) Измените значение параметра Common Desktop на одно из предложенных ниже:

%Public%\Desktop - значение Windows по умолчанию
%USERPROFILE%\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


15. Восстановление поиска в Проводнике и в меню Пуск.

1) Используя Реестр (Win+R -> regedit)
1.1) Откройте ветку реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
1.2) В случае обнаружения параметра NoFind, удалите его.

2) Используя Панель управления
2.1) Откройте Панель управления\Программы\Программы и компоненты
2.2) Запустите "Включение и отключение компонентов Windows" (или Win+R -> OptionalFeatures.exe)
2.3) Проверьте, включен ли у Вас компонент Windows Search (Поиск Windows).

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


1. При использовании сторонних плееров для видео выкидывает синий экран.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


2. В папке "Компьютер" не отображаются DVD-дисководы.

Уберите флажок в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


3. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


4. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажимаете комбинацию клавиш Win+Pause
2) Щелкаете ссылку Дополнительные параметры системы
3) Переходите на вкладку Дополнительно
4) Нажимаете кнопку Параметры в Загрузка и восстановление

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) Загрузите и установите Debugging Tools for Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
Путь к папке указан после параметра set dbgpath=
4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)
kdfe.cmd "%systemroot%\Minidump\Mini1110307-01.dmp"
6) Дождитесь завершениия анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачиваете утилиту BlueScreenView.
2) Устанавливаете BlueScreenView.
3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
4) Запускаете BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

Порой, получив какую-либо ошибку синего экрана смерти, вы задумываетесь из-за чего же она произошла. Для этого случая, скачайте подборку с разъяснениями значений часто встречающихся ошибок и способами устранения многих из них.
Скачать: BSOD.rar

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


6. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в биосе:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

Попробуйте следующие варианты решений:

1) Попробуйте установить другую сборку или версию Windows 7.
2) Сбросьте настройки BIOS в стандартные и установите Windows заново.
3) Обнулите на материнской плате CMOS: либо переустановив и вернув перемычку, либо нажав на кнопку сброса на материнской плате.
4) Установите в списке загрузок с жестких дисков в BIOS, приоритет загрузки Вашего диска с Windows 7 на первое место.
5) Подключите диск выделенный для Windows 7, как Primary Master.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.

Если на Вашей мультимедиа или офисной клавиатуре перестали работать дополнительные клавиши расширяющие её функциональность, то сделайте следующее.
Во-первых, проверьте установлено ли у Вас программное обеспечение с диска идущего в комплекте к клавиатуре или с оффициального сайта.
Если же оно установлено, то одной из наиболее часто встречающихся причин может быть остановка службы Доступ к HID-устройствам.

1) Зайдите в Панель управления\Система и безопасность\Администрирование и запустите Службы или
Нажмите кнопку Пуск, щелкните в поле Начать поиск, введите services.msc и нажмите клавишу Enter.
2) Проверьте указано ли в колонке Состояние, напротив службы Доступ к HID-устройствам значение: Работает
Если данная служба отключена и не работает, сделайте следующее:
3) Нажмите на ней правой кнопкой мыши и в появившемся меню выберите Свойства
4) Для запуска службы нажмите на кнопку Запустить
5) Также Вы можете установить Тип запуска: Автоматически, и система будет автоматически запускать данную службу при старте Windows.
6) Перейдите на вкладку Восстановление и установите действия выполняющиеся при первом или втором сбое, а также при последующих сбоях на значение Перезапуск службы и нажмите OK.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


9. Исправление появившихся красных крестиков на значках локальных дисков.

1) Откройте Панель Управления -> Диспетчер Устройств
1.1) Проверьте включены ли все IDE ATA/ATAPI контроллеры
1.2) Проверьте включены ли все Дисковые устройства
2) Если есть общий доступ, попробуйте его отключить
Щелкните ПКМ на диске -> Общий доступ -> Расширенная настройка общего доступа... -> Расширенная настройка...
3) Почистите кэш иконок: для этого в папке %USERPROFILE%\AppData\Local\ удалите файл IconCache.db
4) Воспользуйтесь специальными утилитами для оптимизации работы компьютера. Например:
4.1.) TuneUp Utilities

4.1.1) В колонке Customize Windows нажимаете All functions и выбираете Change Windows appearance
4.1.2) В меню слева в списке группы Icons выбираете Repair
4.1.3) Нажмите на кнопку Reload Icons, а после на кнопку Repair Icon Cache

4.2) Windows 7 Manager

4.2.1) В меню слева во вкладке Information выберите Repair Center
4.2.2) В меню слева в Repair Center нажмите Icon Repair
4.2.3) В разделе Rebuild Icon Cache нажмите Rebuild

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


10. Восстановление автозапуска для всех типов приводов и устройств.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveTypeAutoRun"=-

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"=dword:00000001

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.

На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Скачать исправление KB977178 : для x86 или для x64

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженый уровень UAC.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


2. Если гаджет погоды пишет service unavailable for your region.

Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
А панель настройки гаджетов может стать недоступной.

Вариант 1

Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:
207.68.172.246 www.msnweather.com
198.78.215.126 blst.msn.com
65.55.228.63 weather.msn.com
65.55.17.39 weather.service.msn.com

Вариант 2

Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


3. В Windows Update при попытке обновления появляется error 80072ee7.

Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
3. Дважды щелкните папку Windows, а затем - папку System32.
4. Дважды щелкните папку драйверы, а затем - папку и т. д..
5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


4. Решение проблемы с punkbuster на Windows 7.

Вариант 1

Решение проблемы вылетов игр (COD 5 и battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136). Лечится так:
1. обновляем punkbuster - качаем это запускаем и добавляем туда игру, pb которой нужно обновить и жмем check for updates. в конце появится сообщение об окончании.
2. находим на диске с windows два файла: PnkBstrA.exe и PnkBstrB.exe оба лежат в C:\Windows\SysWOW64 (для х64) и C:\Windows\System32 (для х86) (PnkBstrB.exe еще есть в папке с игрой C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb (думаю аналогично и в cod5). У этих файлов в свойствах выставить совместимость с XP и Vista.

Вариант 2

1. в %WINDIR%\system32\ файлам PnkBstrA.exe, PnkBstrB.exe поставить совместимость с Вистой и Права администратора.
2.На рабочем столе создать батник с следующим содержанием :

:start

sc config PnkBstrA type= own type= interact

sc config PnkBstrB type= own type= interact

timeout 60

goto start
3. Запускать батник перед запуском игр.
4. Играть

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


5. Как исправить высокий пинг в Windows 7?

1. Пуск - Выполнить - regedit
2. Ищем там HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3. Ищем там интерфейс по которому у вас работает интернет, если не в курсе то делаем следующий шаг во всех
4. Создаем DWORD-параметр, называем его TcpAckFrequency, открываем Изменить, ставим значение переключателя на шестнадцатиричное, и пишем значение 1
5. Идем в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
Если такого пункта в реестре нет, а его скорее всего нет, то делаем следующие шаги:
Открываем - Пуск - Панель управления - Программы и Компоненты-(слева)Включение и отключение компонентов Windows.
Там находим пункт - Сервер очереди сообщений Майкрософт (MSMQ), и ставим галочку напротив него и все галочки внутри в выпадающем списке компонентов. Перегружаемся, идем в реестр и видим там нужную нам запись.

6. В месте указанном в пункте 5 ищем TCPNoDelay, если нету создаем DWORD параметр с таким названием. значение 1.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Internet Explorer не удается загрузить / из help
Не удается открыть этот узел Интернета. Узел не доступен или не найден. Повторите попытку позднее.

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.xml]
@="xmlfile"
"Content Type"="text/xml"
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.xml\OpenWithList]

[HKEY_CLASSES_ROOT\.xml\OpenWithList\winword.exe]
@=""

[HKEY_CLASSES_ROOT\.xml\PersistentHandler]
@="{7E9D8D44-6926-426F-AA2B-217A819A5CCE}"

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


7. Отключение запроса пароля при использовании папки общего доступа.

Даже если Вы не устанавливали пароль для папки общего доступа, система может у Вас его запросить.

Для отключения данного запроса сделайте следующее:

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
3) В графе Общий доступ с парольной защитой установите переключатель на значение Отключить общий доступ с парольной защитой.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


Разное

1. Где можно скачать последнюю версию DirectX?
Оффициальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

Оффициальный сайт DirectX
Полная версия: directx_feb2010_redist.exe
Web версия: dxwebsetup.exe

2. Как открыть файлы с расширением .hlp?

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Оффициальная ссылка: здесь

3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

Диалоговое окно Выполнить используется в Windows для открытия программы, папки или документа. Оно позволяет создать задание для запуска с правами администратора. Самые известные команды выполняемые в окне Выполнить это cmd (Командная строка) и regedit (Редактор реестра). Зная точное названия команды Вы можете запустить любое системное приложения или оснастку Windows.
Диалоговое меню Выполнить запускается либо Пуск -> Выполнить, либо нажатием клавиатуре Win+R.
Для выполнения команды введите её название и нажмите Enter.

Русское название элемента | Английское название элемента | Команда
Ftp-протокол (командная строка) | Ftp-protocol (command prompt) | ftp
Iexpress Wizard (не переведена) | Iexpress Wizard | iexpress
Internet Explorer | Internet Explorer | iexplore
Paint | Paint | mspaint
Windows Firewall | Брандмауэр Windows | firewall.cpl
Wordpad | Wordpad | write
Администратор источников данных ODBC | ODBC Data Source Administrator | odbcad32
Администрирование | Administrative Tools | control admintools
Архивация и восстановление | Backup and Restore | sdclt
Блокнот | Notepad | notepad
Включение и отключение компонентов Windows | Turn Windows features on or off | OptionalFeatures.exe
Восстановление системы | System Restore | rstrui
Выйти из системы | Log Out Of Windows | logoff
Дата и Время | Date and Time | timedate.cpl
Дефрагментация диска | Disk Defragmenter | dfrgui
Диспетчер авторизации | Authorization Manager | azman.msc
Диспетчер задач Windows | Windows Task Manager | taskmgr
Диспетчер проверки драйверов | Driver Verifier Manager | verifier
Диспетчер устройств | Device Manager | devmgmt.msc
Диспетчер устройств | Device Manager | hdwwiz.cpl
Дополнительные часы | Additional Clocks | control timedate.cpl,,1
Завершение работы Windows | Shuts Down Windows | shutdown /s
Записки | Sticky Note | StikyNot
Защита БД учетных записей Windows | Securing the Windows Account Database | syskey
Звук | Sound | mmsys.cpl
Звуки (звуковая схема) | Sounds (sound theme) | control mmsys.cpl,,2
Звукозапись | Sound Recorder | soundrecorder
Игровые устройства | Game Controllers | joy.cpl
Инициализация оборудования безопасности для TPM | Initialize the TMP security hardware | TpmInit
Калибровка цветов экрана | Display Color Calibration | dccw
Калькулятор | Calculator | calc
Командная строка | Command Prompt | cmd
Компоненты Windows | Windows Features | OptionalFeatures
Консоль управления(MMC) | Microsoft Management Console | mmc
Конфигурация системы | System Configuration | msconfig
Локальная политика безопастности | Local Security Policy | secpol.msc
Локальные пользователи и группы | Local Users and Groups | lusrmgr.msc
Мастер загрузки изображений Windows | Windows Picture Acquisition Wizard | wiaacmgr
Мастер создания общих ресурсов | Create A Shared Folder Wizard | shrpubw
Мастер установки драйверов устройств | Driver Package Installer | dpinst
Мастер установки оборудования | Add Hardware Wizard | hdwwiz
Микшер громкости | Sound Volume | sndvol
Монитор ресурсов | Resource Monitor | resmon
Настройка доступа программ и умолчаний | Set Program Access and Computer Defaults | control appwiz.cpl,,3
Настройка Контроля Учетных Записей | User Account Control Settings | UserAccountControlSettings
Ножницы | Snipping Tool | snippingtool
Общие папки | Shared Folders | fsmgmt.msc
Очистка диска | Disk Cleanup Utility | cleanmgr
Панель управления | Control Panel | control
Папка "Fonts" | Fonts Folder | fonts
Папка "Загрузки" | "Downloads" Folder | Downloads
Параметры папок | Folder Options | control folders
Перезагрузка | Restart Windows | shutdown /r
Перенос принтеров | Printer Migration | PrintBrmUi
Перо и сенсорные устройства | Pen and Touch | TabletPC.cpl
Персонализация | Personalization | control desktop
Планировщик заданий | Task Sheduler | control schedtasks
Подключение к удаленному рабочему столу | Remote Desktop Connection | mstsc
Получение программ | Get Programs | control appwiz.cpl,,1
Проверка диска | Check Disk Utility | chkdsk
Проверка и восстановление системных файлов | System File Checker (Scan and Repair) | sfc /scannow
Проверка подписи файла | File Signature Verification | sigverif
Проводник | Windows Explorer | explorer
Программа DiskPart | Disk Partition Manager | diskpart
Программы и компоненты | Programms and Features | appwiz.cpl
Просмотр событий | Event Viewer | eventvwr.msc
Разрешение экрана | Screen Resolution | desk.cpl
Редактор личных знаков | Private Character Editor | eudcedit
Редактор локальной групповой политики | Local Group Policy Editor | gpedit.msc
Редактор реестра | Registry Editor | regedit
Редактор реестра | Registry Editor | regedt32
Редактор титульных страниц факсов | Fax Cover Sheet Editor | fxscover
Результирующая политика | Resultant Set of Policy | rsop.msc
Сведения о системе | System Information | msinfo32
Свойства системы | System Properties | sysdm.cpl
Свойства системы: Дополнительно | System Properties: Advanced | SystemPropertiesAdvanced
Свойства системы: Защита системы | System Properties: System Protection | SystemPropertiesProtection
Свойства системы: Оборудование | System Properties: Hardware | SystemPropertiesHardware
Свойства системы: Удаленный доступ | System Properties: Remote | SystemPropertiesRemote
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | iscsicpl
Свойства: Интернет | Internet Properties | inetcpl.cpl
Свойства: Клавиатура | Keyboard Properties | control keyboard
Свойства: Мышь | Mouse Properties | control mouse
Свойства: Мышь | Mouse Properties | main.cpl
Свойства: Мышь: Параметры указателя | Mouse Properties: Pointer Options | control main.cpl,,2
Свойства: Мышь: Указатели (схема) | Mouse Properties: Pointers | control main.cpl,,1
Сертификаты | Sertificates | certmgr.msc
Сетевые подключения | Network Connections | control netconnections
Сетевые подключения | Network Connections | ncpa.cpl
Системный монитор | Performance Monitor | perfmon
Служба индексирования | Indexing Service | ciadv.msc
Службы компонентов | Component Services | dcomcnfg
Службы компонентов | Component Services | comexp.msc
Совместимость программы | Program Compatibility | msdt.exe -id PCWDiagnostic
Создать диск восстановления системы | Create a system repair disk | recdisc
Соседние пользователи | People Near Me | collab.cpl
Сохранение имен пользователей и паролей | Stored User Names and Passwords | credwiz
Средство диагностики DirectX | Direct X Troubleshooter | dxdiag
Средство диагностики службы технической поддержки | Microsoft Support Diagnostic Tool | msdt
Средство калибровки дигитайзера | Ditilizer Calibration Tool | tabcal
Средство настройки текста ClearType | ClearType Text Tuner | cttune
Средство просмотра XPS | XPS Viewer | xpsrchvw
Стредство записи действий по воспроизведению неполадок | Problem Steps Recorder | psr
Таблица символов | Character Map | charmap
Телефон и модем | Phone and Modem | telephon.cpl
Удаленный помощник Windows | Windows Remote Assistance | msra
Управление дисками | Disk Management | diskmgmt.msc
Управление компьютером | Computer Management | compmgmt.msc
Управление печатью | Print Management | printmanagement.msc
Управление цветом | Color Management | colorcpl
Установка или удаление языков интерфейса | Install or uninstall display languages | lpksetup
Устройства и принтеры | Devices and Printers | control printers
Учетные записи пользователей | User Accounts | Netplwiz
Цвет и внешний вид окна | Window Color and Appearance | control color
Центр мобильности Windows | Windows Mobility Center | mblctr
Центр поддержки | Action Center | wscui.cpl
Центр синхронизации | Sync Center | mobsync
Центр специальных возможностей | Ease of Access Center | utilman
Шифрующая файловая система (EFS) | Encryption File System | rekeywiz
Шрифты (добавление или удаление) | Fonts | control fonts
Экран (размер текста) | Display (size of text) | dpiscaling
Экранная клавиатура | On-Screen Keyboard | osk
Экранная лупа | Magnifier | magnify
Экранный диктор | Microsoft Narrator | narrator
Электропитание | Power Options | powercfg.cpl
Электропитание: Дополнительные параметры | Power Options: Advanced Settings | control powercfg.cpl,,1
Элемент управления WMI | Windows Management Infrastructure | wmimgmt.msc
Язык и региональные стандарты | Region and Language | intl.cpl
Язык и региональные стандарты: Дополнительно | Region and Language: Administrative | control intl.cpl,,3
Язык и региональные стандарты: Языки и клавиатуры | Region and Language: Keyboards and Languages | control intl.cpl,,2

Если какой-либо из элементов списка не запускается, то скорее всего это означает что он неустановлен. Многие из компонентов Windows можно установить в Пуск -> Панель Управления -> Програмы и Компоненты -> Включение и отключение компонентов Windows

4. Список клавиатурных сокращений.

Основные:

Win+Up - Развернуть окно
Win+Down - Восстановить / Минимизировать окно
Win+Left - Прикрепить окно к левому краю экрана
Win+Right - Прикрепить окно к правому краю экрана
Win+Shift+Left - Переключиться на левый монитор
Win+Shift+Right - Переключиться на правый монитор
Win+Home - Минимизировать / Восстановить все неактивные окна
Win+Break(или Pause) - Запустить элемент Система из Панели Управления (пункт Свойства при нажатии правой кнопкой мыши на Компьютер в меню Пуск)
Win+Space - Показать рабочий стол
Win+B - Переход в область уведомлений(трей)
Win+D - Свернуть окна или восстановить все окна
Win+E - Запустить Проводник(Explorer)
Win+F - Запустить встроенный диалог поиска Windows
Win+Ctrl+F - Запустить Поиск по компьютеру из домена
Win+F1 - Запустить встроенный диалог Windows: Справка и Поддержка
Win+G - Отобразить гаджеты поверх всех окон
Win+L - Блокировка рабочей станции(текущего сеанса пользователя)
Win+M - Минимизировать все окна
Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
Win+R - Запустить диалоговое окно Выполнить
Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
Win+U - Запустить Центр специальных возможностей (Ease of Access Center)
Win+X - Запустить Mobility Center
Win+цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
Win + "+" - Увеличить масштаб
Win + "-" - Уменьшить масштаб
Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

В Проводнике (Explorer):
Alt+P - Показать / Скрыть Область предпросмотра

Панель задач:
Shift + щелчок на иконке - Открыть новое окно приложения
Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
Shift + щелчок правой кнопкой на иконке - Показать меню приложения
Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / cвернуть все / Закрыть все
Ctrl + щелчок по группе икнонок - Развернуть все окна группы

5. Перезагрузка компьютера в безопасный режим без использования клавиатуры.

Для того, чтобы перезагрузиться в Безопасный режим достаточно во время загрузки нажать клавишу F8 и выбрать пункт Safe Mode. А чтобы вернуться обратно в Нормальный режим достаточно всего лишь перезагрузить компьютер (не нажимая F8) и система вернется в своё стандартное состояние.
Но на некоторых материнских платах клавиша F8 используется для выбора физического устройства, с которого должен начать загрузку компьютер.
В этом случае необходимо выбрать жесткий диск, на котором установлена операционная система. После нажатия клавиши Enter необходимо сразу же снова нажимать клавишу F8 до тех пор, пока на экране не появится меню выбора вариантов загрузки ОС Windows. Вы должны успеть сделать это довольно быстро, а иначе начнется обычная загрузка Windows.
Если же нет желания играть на скорость, есть более легкий вариант решения:

1) Откройте Конфигурация системы (Пуск -> Выполнить -> msconfig -> Ok или Win+R -> msconfig -> Ok)
2) Перейдите на вкладку Загрузка
3) Поставьте галочку напротив значения Безопасный режим в разделе Параметры загрузки
4) Нажмите Ok и перезагрузите компьютер.
5) Чтобы вернуться обратно в Нормальный режим: находясь в Безопасном режиме уберите данную галочку и перезагрузите компьютер.

6. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

7. Автоматическое переключение русской и английской раскладок клавиатуры.
Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

8. Удаление Windows 7 без форматирования раздела и без потери данных.
Для удаления Windows 7 описанным здесь способом вам потребуются:

а) ERD Commander;
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду
E:\boot\bootsect.exe /nt60 ALL C: /force
Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
2) Как в обычном Explorer, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

По инструкции ниже создаете свой образ ERD Commander:

1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

Рисунок 1 из 3

3) Щелкаете Ок, затем несколько раз кнопку Далее
4) На вкладке Выбор программных средств снова нажимаете Далее
5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

Рисунок 2 из 3

6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на USB флеш-накопитель (флешку) и нажимаете Далее.

Рисунок 3 из 3

На USB флеш-накопитель (флешку) образ записывается через программу UltraISO так:
1) Открывате образ в UltraISO.
2) Выбираете Самозагрузка -> Записать образ жесткого диска...
3) Нажимаете Записать

11) Перезагружаемся в ERD Commander.
12) Would you like to initialize network connectivity in the background?
Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
13) Would you like to remap the drive letters to match the mappings from the target operating system?
Для сопоставления букв дисков целевой операционной системе выбираете выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
14) Select a keyboard input method
Выбираете нужную раскладку, нажимаете Next
15) В окне для выбора операционной системы:

Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
16) Нажимаете Next.

10. Активация Windows 7 по телефону.

1) Пуск - правой кнопкой мыши по Компьютер - Свойства.
2) Изменить ключ продукта
3) Вводим ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
4) Жмем Активировать.
5) Ждем. Затем выбираем Другие способы активации - Активация по телефону. Выбираете свой регион.
6) Звоним по бесплатному номеру (можно через Скайп) .
7) Девушка робот начнет перечислять варианты активации.
8) Жмем 1(активировать продукт майкрософт).
9) На вопрос на скольких компьютерах установлен продукт, нажимаем 1.
10) Затем вас попросят ввести код. Вводите, в ответ другая девушка-робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
11) Вносим цифры в окно активации.
12) Жмем Далее. Интернет, может быть отключен (без разницы). Windows 7 активирована.

11. Как быстро переключиться с одного монитора на другой или с монитора на проектор?
Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

12. Как быстро открыть ещё одну копию приложения?
Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

13. Как разместить любое окно Windows поверх других?

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
PUSHD %TEMP% 2>Nul RD /S/Q "%TEMP%" POPD PUSHD %WinDir%\TEMP 2>Nul RD /S/Q "%WinDir%\TEMP" POPD
2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами командного файла c:\tempdirclean.cmd
7) Нажмите Ок, затем снова Ок
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите командный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

15. Где в Windows 7 храняться значки (иконки)?

Если Вы хотите использовать одну из иконок (значков) Windows 7, то большую их часть Вы можете найти в следующих файлах:

C:\Windows\System32\shell32.dll
C:\Windows\System32\imageres.dll

Для извлечения необходимой Вам иконки:

1) Откройте один из предложенных файлов, с помощью программы Restorator.
2) В панели Дерево ресурсов откройте папку Иконка
3) Выберите любую из понравившихся Вам иконок.
4) В панели Дерево ресурсов щелкните правой кнопкой мыши на данном ресурсе и выберите Извлечь... > Извлечь как "имя_ресурса.ico"
5) Выберите папку для извлечения и нажмите Сохранить

Вы также можете извлечь все иконки сразу, для этого:
6) В панели Дерево ресурсов щелкните правой кнопкой мыши на папке Иконка и выберите Извлечь... > Извлечь все как тип "Иконка"
7) Выберите папку для извлечения и нажмите OK

16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

Многие используя в Windows функцию Форматировать, замечали пункт Создание загрузочного диска MS-DOS. Он используется для создания загрузочного диска MS-DOS на определенных типах устройств, для других же типов устройств он заблокирован.
Выясняя откуда Windows берет образ MS-DOS для записи, я узнал что он содержится в файле diskcopy.dll. Но тут появился другой вопрос, а как его оттуда извлечь? Предлагаю Вам несколько способов его извлечения.

Способ 1 Использование редакторов ресурсов.

Открываете файл diskcopy.dll любым редактором ресурсов и извлекаете(сохраняете) ресурс 1 из папки BINFILE как diskcopy.img

Способ 2 Программа Disk Extract

1) Указываете в поле File(s) to search and extract byte sequence (wildcards *.* accepted) - файл для поиска и извлечения необходимого количества байтов: C:\Windows\System32\diskcopy.dll
2) Указываете в поле Byte sequence to find - с какого байта искать: EB3C90
3) Указываете в поле Bytes to copy - сколько байт скопировать: 1474560
4) Указываете в поле Save as - куда и под каким именем сохранить (например так): D:\Temp\diskcopy\diskcopy.img
5) Нажимаете на кнопку Play
6) В появившемся окне Confirm нажимаете Yes

Способ 3 Программа GETBTDSK со скриптом

Запускаете файл GETBTDSK.bat и получаете в итоге готовый файл diskcopy.img
Некоторые антивирусные программы могут воспринять попытку её обращения к системному файлу как разновидность вируса, поэтому для работы скрипта либо изолируйте файл GETBTDSK.EXE, или папку где он находится из поиска антивирусной программой, либо воспользуйтесь первым способом.

Хорошо, образ мы извлекли и у нас есть готовый файл diskcopy.img. Что же дальше, спросите Вы. А дальше, Вы можете:

1) Распаковать полученный файл с помощью программы архиватора 7zip и дальше работать с файлами по-своему усмотрению.

2) Записать загрузочный MS-DOS образ diskcopy.img на USB флеш-накопитель (флешку).

1. Открываете файл diskcopy.img в программе UltraISO
2. Выбираете Самозагрузка -> Записать образ жесткого диска...
3. Метод записи оставляете USB-HDD+
4. Нажимаете Записать

Чтобы не искать в интернете эти программы, Вы можете скачать архив с ними: msdosboot.zip

17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

Скачивая какой-либо продукт Microsoft в интернете, помимо его названия Вы можете увидеть дополнительные обозначения в наименовании. Если Вам интересно, что означает "CTP", "Escrow", "LDR", "RC", "RTM" и тому подобное - предлагаю Вам, расшифровку особо часто встречающихся из них.

BBT - Basic Block Tools или Binary Profile Feedback Optimization framework
BBT - пакет инструментов оптимизации, помогающий уменьшить требования к рабочему набору Win32 приложения. Для этого применяется дополнительный статический анализ и эвристика кода. Также в результате мониторинга потока выполнения программы происходит интеграция профиля данных. Для дополнительной компрессии страниц памяти, BBT реорганизовывает статистические данные и секции ресурсов.
BBT - cпециальный анализатор, оптимизирующий величину кода, путем игнорирования не используемой части, и архивации оставшейся.
Другое значение BBT - это “Black Box Testing”, тестирование "чёрного ящика" или что-то в этом духе.

BVT - Build Verification Test
Небольшой набор тестов, проверяющих уровень качества сборки, на этапе её создания. Например, BVT для Блокнота может выглядеть как: "Запустить, напечатать текст, сохранить, выйти". Если сборка не проходит данный тест, то воизбежание дальнейших ошибок при тестировании, она отправляется на доработку. Порядок действий BVT редко меняется, а результаты - тщательно контролируются.

CPP - Customer Preview Program
Программа предварительного ознакомления.

CTP - Community Technology Preview
Предварительный технологический релиз для сообщества, впервые использован для сборки Vista build 5219, так называемый январьский CTP.

DNSRV - .NET (DotNet) Server
Раннее кодовое имя Windows Server 2003.

EBS - Essential Business Server
Серверное решение от Microsoft, имеет в своей основе ядро Windows Small Business Server 2008, ориентировано на рынок среднего бизнеса.

EDW - External Developer Workstation
Этот термин, использовался во времена разработки Windows Vista, для обозначения сборок выпущенных между RC и RTM сборками.

Escrow
Сборки, не имеющие серьёзных ошибок. Они, как правило, становятся в итоге Релиз-кандидатами или RTM (после того, как сборка подписана к выпуску).

Exit Criteria
Набор тестов, проверяющих наиболее важные аспекты корректной работы основных функций приложения. Как выглядит тот или иной тест, определяется командой-разработчиком функции, результаты прохождения теста долдны точно совпадать с ожидаемыми. Полное прохождение таких тестов ознаменует переход к следующему этапу разработки.

FBL - Feature build lab
Группа разработки какого-либо функционала.

FVT - Feature Verification Tests
Тоже самое, что и BVT, только для конкретной функции.

GA - General Availability
Означает, что програмное обеспечение доступно на основном рынке через Интернет или на каком-либо физическом носителе.

GDR - General Distribution Release
Используется для обновлений и хотфиксов, содержащих только заплатки критических ошибок и исправления, влияющие на стабильность.

HSBS - Home and Small Business Server

IDS - Internal Developer Server

IDW - Internal Developer Workstation

IDX - Internal Developer Client/Server

LCTP - Limited Community Technology Preview
Ограниченный предварительный технологический релиз.

LDR - Limited Distribution Release
Используется для обновлений и хотфиксов, содержащих “прочие” исправления, как правило, для ошибок, возникающих у весьма специфической группы пользователей.

MMS - Mid-Market Server
Раннее название Essential Business Server.

QFE - Quick Fix Engineering
Аналогично LDR.

QHSV - Q Home Server
Раннее название Windows Home Server.

RC - Release Candidate
Качество сборки на данной стадии разработки наиболее близко к стабильному, критические ошибки уже исправлены, однако, в ходе текущего тестирования могут быть найдены новые ошибки.

RDP - Rapid Deployment Program

RTM - Release To Manufacturing
Стабильная сборка, прошедшая все стадии тестирования, в которой исправлены все найденные ошибки, и готовая к применению.

RTW - Release To Web
Это RTM, предназначенный для распространения через Интернет.

SBS - Small Business Server

Self host
Сброки, прошедшие тесты Exit Criteria tests, готовые к более глубокому тестированию.

Self test
Сборки, прошедшие BVT и FVT тесты.

Self toast
Сборки, не прошедшие BVT.
Sign-off
Подписание, означает, что функция/продукт готова к продаже.

TAP - Technology Adoption Program
Программа технологического утверждения, в ходе которого собираются отзывы тестеров, в качестве которых могут выступать и заказчики компании.

TP - Technical Preview

VBL - Virtual Build Lab
Термин обозначает группу разработчиков объединенных в виртуальную лабораторию.

WHS - Windows Home Server

WSSG - Windows Server Solutions Group

WSUS - Windows Server Update Services

18. Как удалить установленное обновление?
Если Вы установили обновление в Windows, для добавления дополнительной функции, а оно Вам не понравилось, то Вы можете спокойно его удалить.
Для удаления любого обновления сделайте следующее:

1) Откройте Панель управления\Программы
2) Нажмите на ссылку Просмотр установленных обновлений
3) Нажмите правой кнопкой на любом обновлении, которое желаете удалить и щелкните на появившемся слове Удалить.
4) В случае необходимости, перезагрузите компьютер.

19. Создание значков управления состоянием компьютера.

Для быстрого изменения состояния системы, Вы можете создать на рабочем столе ярлыки, позволяющие изменить его одним нажатием мыши.

Для создания ярлыков выполните следующие действия:
1) Нажмите правую клавишу мыши на рабочем столе, выберите пункт меню Создать -> Ярлык
2) В поле Укажите расположение объекта введите необходимую команду для создания ярлыка и нажмите OK.

Блокировка компьютера
rundll32.exe User32.dll,LockWorkStation
Выход из системы
Shutdown.exe /l
Завершение работы
Shutdown.exe -s -t 00
Перезагрузка
Shutdown.exe -r -t 00
Сон
rundll32.exe powrprof.dll,SetSuspendState Sleep

20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

Текст из окна сообщения Windows выделить для копирования невозможно, так как он заблокирован. Но Вы можете скопировать данный текст в буфер обмена.
Для того чтобы это нажмите комбинацию клавиш Ctrl+C, а затем вставьте текст из буфера в любой текстовый редактор используя комбинацию клавиш Ctrl+V. Окно, текст которого нужно скопировать, должно быть активным.
Например, попробуйте закрыть окно оснастки Службы при открытом окне свойств отдельной службы, и Вы увидите одно из таких сообщений Windows.


1. Где можно скачать последнюю версию DirectX?

Оффициальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

Оффициальный сайт DirectX
Полная версия: directx_feb2010_redist.exe
Web версия: dxwebsetup.exe

Назад на страницу раздела Разное.


2. Как открыть файлы с расширением .hlp?

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Оффициальная ссылка: здесь

Назад на страницу раздела Разное.


3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

Диалоговое окно Выполнить используется в Windows для открытия программы, папки или документа. Оно позволяет создать задание для запуска с правами администратора. Самые известные команды выполняемые в окне Выполнить это cmd (Командная строка) и regedit (Редактор реестра). Зная точное названия команды Вы можете запустить любое системное приложения или оснастку Windows.
Диалоговое меню Выполнить запускается либо Пуск -> Выполнить, либо нажатием клавиатуре Win+R.
Для выполнения команды введите её название и нажмите Enter.

Русское название элемента | Английское название элемента | Команда
Ftp-протокол (командная строка) | Ftp-protocol (command prompt) | ftp
Iexpress Wizard (не переведена) | Iexpress Wizard | iexpress
Internet Explorer | Internet Explorer | iexplore
Paint | Paint | mspaint
Windows Firewall | Брандмауэр Windows | firewall.cpl
Wordpad | Wordpad | write
Администратор источников данных ODBC | ODBC Data Source Administrator | odbcad32
Администрирование | Administrative Tools | control admintools
Архивация и восстановление | Backup and Restore | sdclt
Блокнот | Notepad | notepad
Включение и отключение компонентов Windows | Turn Windows features on or off | OptionalFeatures.exe
Восстановление системы | System Restore | rstrui
Выйти из системы | Log Out Of Windows | logoff
Дата и Время | Date and Time | timedate.cpl
Дефрагментация диска | Disk Defragmenter | dfrgui
Диспетчер авторизации | Authorization Manager | azman.msc
Диспетчер задач Windows | Windows Task Manager | taskmgr
Диспетчер проверки драйверов | Driver Verifier Manager | verifier
Диспетчер устройств | Device Manager | devmgmt.msc
Диспетчер устройств | Device Manager | hdwwiz.cpl
Дополнительные часы | Additional Clocks | control timedate.cpl,,1
Завершение работы Windows | Shuts Down Windows | shutdown /s
Записки | Sticky Note | StikyNot
Защита БД учетных записей Windows | Securing the Windows Account Database | syskey
Звук | Sound | mmsys.cpl
Звуки (звуковая схема) | Sounds (sound theme) | control mmsys.cpl,,2
Звукозапись | Sound Recorder | soundrecorder
Игровые устройства | Game Controllers | joy.cpl
Инициализация оборудования безопасности для TPM | Initialize the TMP security hardware | TpmInit
Калибровка цветов экрана | Display Color Calibration | dccw
Калькулятор | Calculator | calc
Командная строка | Command Prompt | cmd
Компоненты Windows | Windows Features | OptionalFeatures
Консоль управления(MMC) | Microsoft Management Console | mmc
Конфигурация системы | System Configuration | msconfig
Локальная политика безопастности | Local Security Policy | secpol.msc
Локальные пользователи и группы | Local Users and Groups | lusrmgr.msc
Мастер загрузки изображений Windows | Windows Picture Acquisition Wizard | wiaacmgr
Мастер создания общих ресурсов | Create A Shared Folder Wizard | shrpubw
Мастер установки драйверов устройств | Driver Package Installer | dpinst
Мастер установки оборудования | Add Hardware Wizard | hdwwiz
Микшер громкости | Sound Volume | sndvol
Монитор ресурсов | Resource Monitor | resmon
Настройка доступа программ и умолчаний | Set Program Access and Computer Defaults | control appwiz.cpl,,3
Настройка Контроля Учетных Записей | User Account Control Settings | UserAccountControlSettings
Ножницы | Snipping Tool | snippingtool
Общие папки | Shared Folders | fsmgmt.msc
Очистка диска | Disk Cleanup Utility | cleanmgr
Панель управления | Control Panel | control
Папка "Fonts" | Fonts Folder | fonts
Папка "Загрузки" | "Downloads" Folder | Downloads
Параметры папок | Folder Options | control folders
Перезагрузка | Restart Windows | shutdown /r
Перенос принтеров | Printer Migration | PrintBrmUi
Перо и сенсорные устройства | Pen and Touch | TabletPC.cpl
Персонализация | Personalization | control desktop
Планировщик заданий | Task Sheduler | control schedtasks
Подключение к удаленному рабочему столу | Remote Desktop Connection | mstsc
Получение программ | Get Programs | control appwiz.cpl,,1
Проверка диска | Check Disk Utility | chkdsk
Проверка и восстановление системных файлов | System File Checker (Scan and Repair) | sfc /scannow
Проверка подписи файла | File Signature Verification | sigverif
Проводник | Windows Explorer | explorer
Программа DiskPart | Disk Partition Manager | diskpart
Программы и компоненты | Programms and Features | appwiz.cpl
Просмотр событий | Event Viewer | eventvwr.msc
Разрешение экрана | Screen Resolution | desk.cpl
Редактор личных знаков | Private Character Editor | eudcedit
Редактор локальной групповой политики | Local Group Policy Editor | gpedit.msc
Редактор реестра | Registry Editor | regedit
Редактор реестра | Registry Editor | regedt32
Редактор титульных страниц факсов | Fax Cover Sheet Editor | fxscover
Результирующая политика | Resultant Set of Policy | rsop.msc
Сведения о системе | System Information | msinfo32
Свойства системы | System Properties | sysdm.cpl
Свойства системы: Дополнительно | System Properties: Advanced | SystemPropertiesAdvanced
Свойства системы: Защита системы | System Properties: System Protection | SystemPropertiesProtection
Свойства системы: Оборудование | System Properties: Hardware | SystemPropertiesHardware
Свойства системы: Удаленный доступ | System Properties: Remote | SystemPropertiesRemote
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | iscsicpl
Свойства: Интернет | Internet Properties | inetcpl.cpl
Свойства: Клавиатура | Keyboard Properties | control keyboard
Свойства: Мышь | Mouse Properties | control mouse
Свойства: Мышь | Mouse Properties | main.cpl
Свойства: Мышь: Параметры указателя | Mouse Properties: Pointer Options | control main.cpl,,2
Свойства: Мышь: Указатели (схема) | Mouse Properties: Pointers | control main.cpl,,1
Сертификаты | Sertificates | certmgr.msc
Сетевые подключения | Network Connections | control netconnections
Сетевые подключения | Network Connections | ncpa.cpl
Системный монитор | Performance Monitor | perfmon
Служба индексирования | Indexing Service | ciadv.msc
Службы компонентов | Component Services | dcomcnfg
Службы компонентов | Component Services | comexp.msc
Совместимость программы | Program Compatibility | msdt.exe -id PCWDiagnostic
Создать диск восстановления системы | Create a system repair disk | recdisc
Соседние пользователи | People Near Me | collab.cpl
Сохранение имен пользователей и паролей | Stored User Names and Passwords | credwiz
Средство диагностики DirectX | Direct X Troubleshooter | dxdiag
Средство диагностики службы технической поддержки | Microsoft Support Diagnostic Tool | msdt
Средство калибровки дигитайзера | Ditilizer Calibration Tool | tabcal
Средство настройки текста ClearType | ClearType Text Tuner | cttune
Средство просмотра XPS | XPS Viewer | xpsrchvw
Стредство записи действий по воспроизведению неполадок | Problem Steps Recorder | psr
Таблица символов | Character Map | charmap
Телефон и модем | Phone and Modem | telephon.cpl
Удаленный помощник Windows | Windows Remote Assistance | msra
Управление дисками | Disk Management | diskmgmt.msc
Управление компьютером | Computer Management | compmgmt.msc
Управление печатью | Print Management | printmanagement.msc
Управление цветом | Color Management | colorcpl
Установка или удаление языков интерфейса | Install or uninstall display languages | lpksetup
Устройства и принтеры | Devices and Printers | control printers
Учетные записи пользователей | User Accounts | Netplwiz
Цвет и внешний вид окна | Window Color and Appearance | control color
Центр мобильности Windows | Windows Mobility Center | mblctr
Центр поддержки | Action Center | wscui.cpl
Центр синхронизации | Sync Center | mobsync
Центр специальных возможностей | Ease of Access Center | utilman
Шифрующая файловая система (EFS) | Encryption File System | rekeywiz
Шрифты (добавление или удаление) | Fonts | control fonts
Экран (размер текста) | Display (size of text) | dpiscaling
Экранная клавиатура | On-Screen Keyboard | osk
Экранная лупа | Magnifier | magnify
Экранный диктор | Microsoft Narrator | narrator
Электропитание | Power Options | powercfg.cpl
Электропитание: Дополнительные параметры | Power Options: Advanced Settings | control powercfg.cpl,,1
Элемент управления WMI | Windows Management Infrastructure | wmimgmt.msc
Язык и региональные стандарты | Region and Language | intl.cpl
Язык и региональные стандарты: Дополнительно | Region and Language: Administrative | control intl.cpl,,3
Язык и региональные стандарты: Языки и клавиатуры | Region and Language: Keyboards and Languages | control intl.cpl,,2

Если какой-либо из элементов списка не запускается, то скорее всего это означает что он неустановлен. Многие из компонентов Windows можно установить в Пуск -> Панель Управления -> Програмы и Компоненты -> Включение и отключение компонентов Windows

Назад на страницу раздела Разное.


4. Список клавиатурных сокращений.

Во многих статьях Вы можете увидеть текст наподобие: Win+R. Данное слово Win обозначает клавишу с логотипом Windows. Данная клавиша обычно находится на левой стороне клавиатуры, в нижней строке. Основные:

Win+Up - Развернуть окно
Win+Down - Восстановить / Минимизировать окно
Win+Left - Прикрепить окно к левому краю экрана
Win+Right - Прикрепить окно к правому краю экрана
Win+Shift+Left - Переключиться на левый монитор
Win+Shift+Right - Переключиться на правый монитор
Win+Home - Минимизировать / Восстановить все неактивные окна
Win+Break(или Pause) - Запустить элемент Система из Панели Управления (пункт Свойства при нажатии правой кнопкой мыши на Компьютер в меню Пуск)
Win+Space - Показать рабочий стол
Win+B - Переход в область уведомлений(трей)
Win+D - Свернуть окна или восстановить все окна
Win+E - Запустить Проводник(Explorer)
Win+F - Запустить встроенный диалог поиска Windows
Win+Ctrl+F - Запустить Поиск по компьютеру из домена
Win+F1 - Запустить встроенный диалог Windows: Справка и Поддержка
Win+G - Отобразить гаджеты поверх всех окон
Win+L - Блокировка рабочей станции(текущего сеанса пользователя)
Win+M - Минимизировать все окна
Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
Win+R - Запустить диалоговое окно Выполнить
Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
Win+U - Запустить Центр специальных возможностей (Ease of Access Center)
Win+X - Запустить Mobility Center
Win+цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
Win + "+" - Увеличить масштаб
Win + "-" - Уменьшить масштаб
Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

В Проводнике (Explorer):
Alt+P - Показать / Скрыть Область предпросмотра

Панель задач:
Shift + щелчок на иконке - Открыть новое окно приложения
Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
Shift + щелчок правой кнопкой на иконке - Показать меню приложения
Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / cвернуть все / Закрыть все
Ctrl + щелчок по группе икнонок - Развернуть все окна группы

Назад на страницу раздела Разное.


5. Перезагрузка компьютера в безопасный режим без использования клавиатуры.

Для того, чтобы перезагрузиться в Безопасный режим достаточно во время загрузки нажать клавишу F8 и выбрать пункт Safe Mode. А чтобы вернуться обратно в Нормальный режим достаточно всего лишь перезагрузить компьютер (не нажимая F8) и система вернется в своё стандартное состояние.
Но на некоторых материнских платах клавиша F8 используется для выбора физического устройства, с которого должен начать загрузку компьютер.
В этом случае необходимо выбрать жесткий диск, на котором установлена операционная система. После нажатия клавиши Enter необходимо сразу же снова нажимать клавишу F8 до тех пор, пока на экране не появится меню выбора вариантов загрузки ОС Windows. Вы должны успеть сделать это довольно быстро, а иначе начнется обычная загрузка Windows.
Если же нет желания играть на скорость, есть более легкий вариант решения:

1) Откройте Конфигурация системы (Пуск -> Выполнить -> msconfig -> Ok или Win+R -> msconfig -> Ok)
2) Перейдите на вкладку Загрузка
3) Поставьте галочку напротив значения Безопасный режим в разделе Параметры загрузки
4) Нажмите Ok и перезагрузите компьютер.
5) Чтобы вернуться обратно в Нормальный режим: находясь в Безопасном режиме уберите данную галочку и перезагрузите компьютер.

Назад на страницу раздела Разное.


6. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

Назад на страницу раздела Разное.


7. Автоматическое переключение русской и английской раскладок клавиатуры.

Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

Назад на страницу раздела Разное.


8. Удаление Windows 7 без форматирования раздела и без потери данных.

Для удаления Windows 7 описанным здесь способом вам потребуются:

а) ERD Commander;
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду
E:\boot\bootsect.exe /nt60 ALL C: /force
Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
2) Как в обычном Explorer, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

Назад на страницу раздела Разное.


9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

По инструкции ниже создаете свой образ ERD Commander:

1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

3) Щелкаете Ок, затем несколько раз кнопку Далее
4) На вкладке Выбор программных средств снова нажимаете Далее
5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на USB флеш-накопитель (флешку) и нажимаете Далее.

На USB флеш-накопитель (флешку) образ записывается через программу UltraISO так:
1) Открывате образ в UltraISO.
2) Выбираете Самозагрузка -> Записать образ жесткого диска...
3) Нажимаете Записать

11) Перезагружаемся в ERD Commander.
12) Would you like to initialize network connectivity in the background?
Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
13) Would you like to remap the drive letters to match the mappings from the target operating system?
Для сопоставления букв дисков целевой операционной системе выбираете выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
14) Select a keyboard input method
Выбираете нужную раскладку, нажимаете Next
15) В окне для выбора операционной системы:

Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
16) Нажимаете Next.

Назад на страницу раздела Разное.


10. Активация Windows 7 по телефону.

1) Пуск - правой кнопкой мыши по Компьютер - Свойства.
2) Изменить ключ продукта
3) Вводим ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
4) Жмем Активировать.
5) Ждем. Затем выбираем Другие способы активации - Активация по телефону. Выбираете свой регион.
6) Звоним по бесплатному номеру (можно через Скайп) .
7) Девушка робот начнет перечислять варианты активации.
8) Жмем 1(активировать продукт майкрософт).
9) На вопрос на скольких компьютерах установлен продукт, нажимаем 1.
10) Затем вас попросят ввести код. Вводите, в ответ другая девушка-робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
11) Вносим цифры в окно активации.
12) Жмем Далее. Интернет, может быть отключен (без разницы). Windows 7 активирована.

Назад на страницу раздела Разное.


11. Как быстро переключиться с одного монитора на другой или с монитора на проектор?

Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

Назад на страницу раздела Разное.


12. Как быстро открыть ещё одну копию приложения?

Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

Назад на страницу раздела Разное.


13. Как разместить любое окно Windows поверх других?

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

Назад на страницу раздела Разное.


14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
PUSHD %TEMP% 2>Nul RD /S/Q "%TEMP%" POPD PUSHD %WinDir%\TEMP 2>Nul RD /S/Q "%WinDir%\TEMP" POPD
2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами командного файла c:\tempdirclean.cmd
7) Нажмите Ок, затем снова Ок
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите командный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

Назад на страницу раздела Разное.


15. Где в Windows 7 храняться значки (иконки)?

Если Вы хотите использовать одну из иконок (значков) Windows 7, то большую их часть Вы можете найти в следующих файлах:

C:\Windows\System32\shell32.dll
C:\Windows\System32\imageres.dll

Для извлечения необходимой Вам иконки:

1) Откройте один из предложенных файлов, с помощью программы Restorator.
2) В панели Дерево ресурсов откройте папку Иконка
3) Выберите любую из понравившихся Вам иконок.
4) В панели Дерево ресурсов щелкните правой кнопкой мыши на данном ресурсе и выберите Извлечь... > Извлечь как "имя_ресурса.ico"
5) Выберите папку для извлечения и нажмите Сохранить

Вы также можете извлечь все иконки сразу, для этого:
6) В панели Дерево ресурсов щелкните правой кнопкой мыши на папке Иконка и выберите Извлечь... > Извлечь все как тип "Иконка"
7) Выберите папку для извлечения и нажмите OK

Назад на страницу раздела Разное.


16. Извлечение MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

Многие используя в Windows функцию Форматировать, замечали пункт Создание загрузочного диска MS-DOS. Он используется для создания загрузочного диска MS-DOS на определенных типах устройств, для других же типов устройств он заблокирован.
Выясняя откуда Windows берет образ MS-DOS для записи, я узнал что он содержится в файле diskcopy.dll. Но тут появился другой вопрос, а как его оттуда извлечь? Предлагаю Вам несколько способов его извлечения.

Способ 1 Использование редакторов ресурсов.

Открываете файл diskcopy.dll любым редактором ресурсов и извлекаете(сохраняете) ресурс 1 из папки BINFILE как diskcopy.img

Способ 2 Программа Disk Extract

1) Указываете в поле File(s) to search and extract byte sequence (wildcards *.* accepted) - файл для поиска и извлечения необходимого количества байтов: C:\Windows\System32\diskcopy.dll
2) Указываете в поле Byte sequence to find - с какого байта искать: EB3C90
3) Указываете в поле Bytes to copy - сколько байт скопировать: 1474560
4) Указываете в поле Save as - куда и под каким именем сохранить (например так): D:\Temp\diskcopy\diskcopy.img
5) Нажимаете на кнопку Play
6) В появившемся окне Confirm нажимаете Yes

Способ 3 Программа GETBTDSK со скриптом

Запускаете файл GETBTDSK.bat и получаете в итоге готовый файл diskcopy.img
Некоторые антивирусные программы могут воспринять попытку её обращения к системному файлу как разновидность вируса, поэтому для работы скрипта либо изолируйте файл GETBTDSK.EXE, или папку где он находится из поиска антивирусной программой, либо воспользуйтесь первым способом.

Хорошо, образ мы извлекли и у нас есть готовый файл diskcopy.img. Что же дальше, спросите Вы. А дальше, Вы можете:

1) Распаковать полученный файл с помощью программы архиватора 7zip и дальше работать с файлами по-своему усмотрению.

2) Записать загрузочный MS-DOS образ diskcopy.img на USB флеш-накопитель (флешку).

1. Открываете файл diskcopy.img в программе UltraISO
2. Выбираете Самозагрузка -> Записать образ жесткого диска...
3. Метод записи оставляете USB-HDD+
4. Нажимаете Записать

Чтобы не искать в интернете эти программы, Вы можете скачать архив с ними: msdosboot.zip

Назад на страницу раздела Разное.


17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

Скачивая какой-либо продукт Microsoft в интернете, помимо его названия Вы можете увидеть дополнительные обозначения в наименовании. Если Вам интересно, что означает "CTP", "Escrow", "LDR", "RC", "RTM" и тому подобное - предлагаю Вам, расшифровку особо часто встречающихся из них.

BBT - Basic Block Tools или Binary Profile Feedback Optimization framework
BBT - пакет инструментов оптимизации, помогающий уменьшить требования к рабочему набору Win32 приложения. Для этого применяется дополнительный статический анализ и эвристика кода. Также в результате мониторинга потока выполнения программы происходит интеграция профиля данных. Для дополнительной компрессии страниц памяти, BBT реорганизовывает статистические данные и секции ресурсов.
BBT - cпециальный анализатор, оптимизирующий величину кода, путем игнорирования не используемой части, и архивации оставшейся.
Другое значение BBT - это “Black Box Testing”, тестирование "чёрного ящика" или что-то в этом духе.

BVT - Build Verification Test
Небольшой набор тестов, проверяющих уровень качества сборки, на этапе её создания. Например, BVT для Блокнота может выглядеть как: "Запустить, напечатать текст, сохранить, выйти". Если сборка не проходит данный тест, то воизбежание дальнейших ошибок при тестировании, она отправляется на доработку. Порядок действий BVT редко меняется, а результаты - тщательно контролируются.

CPP - Customer Preview Program
Программа предварительного ознакомления.

CTP - Community Technology Preview
Предварительный технологический релиз для сообщества, впервые использован для сборки Vista build 5219, так называемый январьский CTP.

DNSRV - .NET (DotNet) Server
Раннее кодовое имя Windows Server 2003.

EBS - Essential Business Server
Серверное решение от Microsoft, имеет в своей основе ядро Windows Small Business Server 2008, ориентировано на рынок среднего бизнеса.

EDW - External Developer Workstation
Этот термин, использовался во времена разработки Windows Vista, для обозначения сборок выпущенных между RC и RTM сборками.

Escrow
Сборки, не имеющие серьёзных ошибок. Они, как правило, становятся в итоге Релиз-кандидатами или RTM (после того, как сборка подписана к выпуску).

Exit Criteria
Набор тестов, проверяющих наиболее важные аспекты корректной работы основных функций приложения. Как выглядит тот или иной тест, определяется командой-разработчиком функции, результаты прохождения теста долдны точно совпадать с ожидаемыми. Полное прохождение таких тестов ознаменует переход к следующему этапу разработки.

FBL - Feature build lab
Группа разработки какого-либо функционала.

FVT - Feature Verification Tests
Тоже самое, что и BVT, только для конкретной функции.

GA - General Availability
Означает, что програмное обеспечение доступно на основном рынке через Интернет или на каком-либо физическом носителе.

GDR - General Distribution Release
Используется для обновлений и хотфиксов, содержащих только заплатки критических ошибок и исправления, влияющие на стабильность.

HSBS - Home and Small Business Server

IDS - Internal Developer Server

IDW - Internal Developer Workstation

IDX - Internal Developer Client/Server

LCTP - Limited Community Technology Preview
Ограниченный предварительный технологический релиз.

LDR - Limited Distribution Release
Используется для обновлений и хотфиксов, содержащих “прочие” исправления, как правило, для ошибок, возникающих у весьма специфической группы пользователей.

MMS - Mid-Market Server
Раннее название Essential Business Server.

QFE - Quick Fix Engineering
Аналогично LDR.

QHSV - Q Home Server
Раннее название Windows Home Server.

RC - Release Candidate
Качество сборки на данной стадии разработки наиболее близко к стабильному, критические ошибки уже исправлены, однако, в ходе текущего тестирования могут быть найдены новые ошибки.

RDP - Rapid Deployment Program

RTM - Release To Manufacturing
Стабильная сборка, прошедшая все стадии тестирования, в которой исправлены все найденные ошибки, и готовая к применению.

RTW - Release To Web
Это RTM, предназначенный для распространения через Интернет.

SBS - Small Business Server

Self host
Сброки, прошедшие тесты Exit Criteria tests, готовые к более глубокому тестированию.

Self test
Сборки, прошедшие BVT и FVT тесты.

Self toast
Сборки, не прошедшие BVT.
Sign-off
Подписание, означает, что функция/продукт готова к продаже.

TAP - Technology Adoption Program
Программа технологического утверждения, в ходе которого собираются отзывы тестеров, в качестве которых могут выступать и заказчики компании.

TP - Technical Preview

VBL - Virtual Build Lab
Термин обозначает группу разработчиков объединенных в виртуальную лабораторию.

WHS - Windows Home Server

WSSG - Windows Server Solutions Group

WSUS - Windows Server Update Services

Назад на страницу раздела Разное.


18. Как удалить установленное обновление?

Если Вы установили обновление в Windows, для добавления дополнительной функции, а оно Вам не понравилось, то Вы можете спокойно его удалить.
Для удаления любого обновления сделайте следующее:

1) Откройте Панель управления\Программы
2) Нажмите на ссылку Просмотр установленных обновлений
3) Нажмите правой кнопкой на любом обновлении, которое желаете удалить и щелкните на появившемся слове Удалить.
4) В случае необходимости, перезагрузите компьютер.

Назад на страницу раздела Разное.


19. Создание значков управления состоянием компьютера.

Для быстрого изменения состояния системы Вы можете создать на рабочем столе ярлыки позволяющие изменить его одним мажатием мыши.

Для создания ярлыков выполните следующие действия:
1) Нажмите правую клавишу мыши на рабочем столе, выберите пункт меню Создать -> Ярлык
2) В поле Укажите расположение объекта введите необходимую команду для создания ярлыка и нажмите OK.

Блокировка компьютера
rundll32.exe User32.dll,LockWorkStation
Выход из системы
Shutdown.exe /l
Завершение работы
Shutdown.exe -s -t 00
Перезагрузка
Shutdown.exe -r -t 00
Сон
rundll32.exe powrprof.dll,SetSuspendState Sleep

Назад на страницу раздела Разное.


20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

Текст из окна сообщения Windows выделить для копирования невозможно, так как он заблокирован. Но Вы можете скопировать данный текст в буфер обмена.
Для того чтобы это нажмите комбинацию клавиш Ctrl+C, а затем вставьте текст из буфера в любой текстовый редактор используя комбинацию клавиш Ctrl+V. Окно, текст которого нужно скопировать, должно быть активным.
Например, попробуйте закрыть окно оснастки Службы при открытом окне свойств отдельной службы, и Вы увидите одно из таких сообщений Windows.

Назад на страницу раздела Разное.


История версий

Изменения в версии 2.08.

Исправлен порядок в Индексе.
Добавлено 4 новых совета.
Удален 1 совет.

Изменения в версии 2.05.

Переработана структура сборника.
Советы из раздела "Устранение неполадок" рассортированы на подразделы.
Советы из "Твики реестра - Восстановление" перемещены в подразделы "Устранение неполадок".
Для удобочитаемости переход к странице подраздела, заменен на переход к якорю внутри страницы раздела.
Некоторые советы переименованы и обновлены.
Информация об изображениях и ссылки на них изменены в соответствии с новой структурой сборника.
Добавлено 3 новых совета.

Изменения в версии 2.02.1.

Исправлена ошибка ссылок и нумерации нескольких советов в Содержании и Указателе.

Изменения в версии 2.02.

Добавлен эффект прокручивания изображений колесом мыши(курсор при прокручивании должен быть на изображении)
Некоторые советы обновлены.
Добавлено 12 новых советов.

Изменения в версии 1.90.

Удалено несколько советов.
Некоторые советы обновлены.
Добавлено 16 новых советов.
Исправлены незначительные ошибки.

Изменения в версии 1.77.

Многие советы обновлены и переписаны заново
Добавлен новый раздел Виртуализация, поэтому переработана структура сборника
Обновлены ссылки на некоторые программы
Произведен точный перерасчет количества советов.
Добавлено 28 новых советов

Изменения в версии 1.49.

Переработан индекс сборника, что позволяет осуществить более точный поиск, через вкладку Указатель или вкладку Поиск
Исправлены грамматические, орфографические и синтаксические ошибки
Обновлены несколько советов
Добавлено 9 советов

Изменения в версии 1.40.

Добавлен новый раздел Твики Реестра с подразделами, поэтому переработана структура сборника
Многие советы заменены или обновлены
Исправлена ошибка, при которой внешние ссылки указанные на отдельных страницах некоторых советов, открывались в самой справке. Теперь они открываются в новом окне интернет броузера.
Добавлен 1 совет

Изменения в версии 1.39.

Исправлены грамматические, орфографические и синтаксические ошибки
Добавлен 1 совет

Изменения в версии 1.38.

Обновлены ссылки на версии программ.
Исправлена ссылка на изображение в одном из советов
Добавлен 1 совет

Изменения в версии 1.37.8.

Исправлены грамматические, орфографические и синтаксические ошибки
Исправлены ссылки на некоторые страницы и изображения
Добавлен 1 совет

Изменения в версии 1.37.

Исправлены ошибки распознавания кодировки на некоторых страницах
Многие советы заменены или обновлены
Если в совете более одного изображения, то они сгруппированны в галерею
Добавлено 8 советов

Изменения в версии 1.29.

Добавлена функция превью для изображений(увеличение по клику) в общем списке и в страницах разделов
Добавлена История версий
Добавлено 4 совета

Изменения в версии 1.25.1.-1.25.3.

Исправлены грамматические и синтаксические ошибки

Изменения в версии 1.25.

Исправлены грамматические и синтаксические ошибки
Заменены некоторые ссылки
Добавлен 1 совет

Изменения в версии 1.24.

Переписан исходный код страниц
Улучшена (упрощена) навигация в сборнике
Советы сгруппированы по темам (разделам)
Спойлерам добавлен эффект слайда
Спойлеры оставлены только в общем списке и в списках разделов
Убраны спойлеры в отдельных страницах для каждого совета
Добавлены меняющиеся надписи на кнопках.
Исправлены старые и добавлены новые советы (14 штук)

Изменения в версии 1.10.

Исправлена невозможность выделения в общем списке после 49 совета
Исправлена невозможность выделения в 49 совете
Заменены ссылки на оригинальные скрипты
Добавлено принудительное определение кодировки как windows-1251
Добавлено 2 новых совета

Версия 1.08.

Первая версия